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Studio Software Update 9.0 – Release Notes 

Previous Studio Release: 8.6.x 
Supported Equipment PC: Z370, Q470 

Recommended PLC Versions (hardware dependent): 1088/2088 for AXP2.0 1008/2008 for PS600S 
Offline Studio Operating System: Windows 7; extensive testing specifically performed on Win 10 64 bit 

  

Summary: 

All included Studio applications have been validated for compatibility with previously created Akrometrix Studio 
file formats. Files created prior to Studio 8.0 will not be readily usable with the Automated Report Generator or 
Batch Interface Analysis feature. Important bug fixes and added features are listed below. This list does not include 
all resolved bugs and added features. Known issues are presented with workarounds where applicable. 

Update Procedure: 

PLC/HMI Update 

Studio 9.0 requires an update to the PLC for the AXP 2.0 and PS600S system including a PLC (PS600S system including 
an HMI screen seen in front of electrical cabinet instead of a CSL208 temperature controller). Owners of any other 
Akrometrix models may skip this step. AXP 2.0 owners will use PLC version 1088 and PS600S owners will use PLC version 
1008. HMI versions are the same for both systems. Further instructions for downloading PLC code and updating AXP 2.0 
and PS600S systems will be provided separately. 

Install Studio 9.0 
THIS INSTALLATION HAS EXTRA STEPS TO ENSURE A CLEAN UPDATE. Download and Unzip the Studio 9.0 Installer 
zip file onto the system PC. Unplug the Studio USB dongle. Manually uninstall all Akrometrix Studio applications via 
Windows “Add or Remove Programs”, then restart the computer. Install all applications for Studio 9.0 by launching the 
provided file “Akrometrix Studio 9.0 Installer x64.exe”, then plug the Studio USB dongle back in. A full system power cycle 
is recommended after completing both PLC and software updates. 

Key Feature Changes or Additions: 

Studio 9.0 is releasing without fully updated User Manuals for this version, to be provided at a later date. 

Batch Interface Analysis 

The popular Akrometrix Interface Analysis software has received a major overhaul that greatly increases the usability, 
scalability, and functionality of our surface matching solution. This solution was originally marketed as Interface Analysis 
2.0 and has since been more appropriately renamed to Batch Interface Analysis (IA). Customers who own Interface Analysis 
licenses may upgrade to Batch Interface Analysis for a fee. A separate software license is required to unlock Batch IA. 
Anyone pre-purchasing “Interface Analysis 2.0” will have access to Batch IA. Please contact your local Akrometrix 
representative to inquire about the Studio 9.0 feature, Batch IA. 

Metadata and Batch Processing 

Batch Interface Analysis now integrates into Surface Analysis and is no longer a separate application. Within Surface 
Analysis, Batch IA operates with a similar workflow to Batch Processing and Automated Report Generator. Large subsets 
of data can be processed and organized. File Metadata is utilized to organize, process, and output measurements in desired 
combinations. Users no longer need to take time in organizing files into specific folders and pointing to them individually. All 
data can be in a single folder and the software will intelligently organize for interface comparisons. 

Every Combination 

Classic Interface Analysis would combine multiple surfaces into statistical surfaces for comparison. While this feature is still 
available and useful, Batch IA takes analysis a step further by enabling comparison of every top and bottom surface. 
Furthermore, the software will pick out max and min of all available combinations based on the users chosen gauge or 
gauges. This allows the user to understand the best case and worst-case gaps across a large data set at different points in 
time and temperature. 
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- Includes previous capabilities within Interface Analysis, in a new, more usable format 

- Group and Layout Settings tabs function similar to Automated Report Generator 

- “Top” and “Bottom” Metadata assignments have been added to simplify the assignment of mating surfaces  

- Z Range can be customized by the user 

Manual Report Generator and Retirement of Legacy Report Generator 

A Manual Report option is now available under the Tools menu in Surface Analysis. This provides a manual click and drag 
style mode to replicate functionality of the legacy Report Generator software. For this reason, Report Generator has been 
removed from Studio Manager and is not part of the Studio 9.0 release. Studio 9.0 does not stop users from running the 
legacy Report Generator software, but this functionality should no longer be needed by most users. 

Image Based Part Tracking 

Part Tracking functions can now be performed based on Image models instead of only rectangular edges. This feature also 
introduces new filters for “Noise Reduction” and “Edge Detail Level”.  It may be more effective than edge-based models 
when sample and background are similar in color or when sample edges are not specifically rectangular in shape. Samples 
with surface features like PCBs, assemblies, or sockets are typical applications. In addition, an Ellipse edge shape is now 
available. 
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TTDFP2 Product Line 

Support for a new TTDFP2 product line has been added. DFP Surface Measurement improvements discussed below apply 
to this new product. See further product release details from Akrometrix on the new TTDFP2. 

TTSM-JS Product Line 

Support for a new TTSM-JS product line has been added. This product adds barcode, data matrix, and QR code scanning 
capabilities to the TTSM-J. See further product release details from Akrometrix on the new TTSM-JS. 

Z-Range Mask Histogram 

Usability of the Z-Range mask function has been improved with a new Histogram display. This visualization tool represents 
the spread of Z values within the data set. The user can set masking limits by left and right clicking on the histogram.  In 
addition, masking can now be done based on percentages of the Z-height range. Mask ranges or percentages adjust as 
the user clicks on the graph. 

 

New Gauges 

- Missing Pixel Count (MPC) – Displays a count of the total number of data pixels removed from the given data set 

- Average Brightness (AB) – Displays the average brightness across all acquisitions in terms of gray scale value from 0 
to 4095 for shadow moire measurements (12 bit) and from 0-255 for DFP measurements (8 bit). Higher values indicate 
a brighter image. 

- Vertical/Horizontal Edge Bow – Follows the current Bow gauge, which takes the highest bow value for all 4 edges of a 
sample and instead gives max bow values for vertical and horizontal edges separately as two different gauges 
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Studio 9.0 Features: 

- X, Y, Z values based on cursor location are now displayed in the bottom left of displacement windows 

- Surface Measurement: 

o The DFP calibration wizard now automatically saves volumetric calibration files when the calibration test 
passes. In addition, a ‘FailedCalibrationTest.akx_disp’ file is saved when the calibration fails, allowing better 
understanding of any setup issues. 

o Found tracked parts can now be saved directly from target images via the context menu 

o ROI Text labels now scale based on camera resolution, improving readability 

o Results window size increased for larger resolution monitors 

o Projector framerate in DFP Surface Measurement can now be adjusted between 2 and 20 frames per second. 
Lowering the allowable framerate enables longer camera exposure times for measuring unpainted samples. 

o Recipe Autosave now has the option to also save the Gauge Results table as a text file, as well as Layout 
image files for ROI, Phase, and Displacement images 

o Removed recipe saving from within Edit Recipe interface to resolve associated errors. Recipes can still be 
saved and loaded in the main Surface Measurement window via File->Recipe. 

o Text files output can now be generated per ROI and per measurement to include gauge and/or metadata 
information as specified by the user.  This option is found under Edit Recipe via Edit->Outputs. 

- Thermal Profiler: 

o Allowable thermal profile setpoint range has been extended to -100°C to 399°C. This does not reflect the 
temperature range of the tool but allows for use of larger error bands in profiling. Anyone attempting to heat the 
AXP 2.0 system beyond 300°C up to a newly supported max of 350°C should contact their local representative 
for further detailed instructions before exceeding 300°C. 

- Surface Analysis 

o Paste mask and partition functions are now placed at the mouse cursor location for ease of use 

o Multiple improvements made to File Finder functionality to improve usability 

o Multiple improvements made to chord functionality to improve usability 

o Multiple improvements made to Feature Detection functionality to improve usability 

o Automated Report Generator (ARG) 

▪ Added Cancel button during report creation 

▪ Now fully supports Shape Name gauge 

▪ Increased number of gauge table columns to 26 columns 

▪ Custom images can now be added and included within surface plots, called “Image Annotations” under 
Output Options in the Layout Settings tab 
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Key Bug Fixes: 

- Improved handling of “comma” when used as decimal symbol in some Windows language packages, notifying user of 
need to make adjustment in Windows 

- Profile Generator: 

o Deleting actions no longer shifts the scrollbar to the front of the profile  

- Surface Measurement: 

o Autosave no longer always saves layout pictures or 3D graphs (when RTA is active), even when neither is 
selected 

o Using paste shortcut in camera window when no region has been copied, no longer creates Unhandled 
Exception 

o Moving camera window no longer resets digital zoom 

o Removed MIL Error message found when editing the recipe or opening thermal profiler prior to taking an 
acquisition 

o DFP Alignment Grid no longer shows up incorrectly after running a profile 

o Removed copy/paste error on copying ROIs containing specific gauge names included 

o Non-integer exposure percentages now handled correctly in saving/loading recipes 

- Thermal Profiler: 

o Thermocouple #2 can no longer be set as the monitoring thermocouple when the top heater is disabled, as 
intended 

o DFP projector can no longer go into standby mode when a profile is running 

- Surface Analysis: 

o Eliminated issues causing hang up on batch edit of specific Metadata fields on phase image files 

o Masks that are only a single pixel in 1 dimension no longer cause an error and are allowed 

o Mask starting locations outside the image bounds are now correctly honored 

o Batch Processing 

▪ Batch analysis no longer enters bugged state when source folder is moved or deleted 

o Automated Report Generator 

▪ Eliminated errors seen when creating reports with files containing the Shape Name or PVP gauges 

▪ Edited metadata fields are now correctly refreshed in database after editing 

▪ Improved alignment of data points and x-axis tick marks in report gauge vs. temp. plots 

▪ Removed extraneous combo box in Grouping Parameters 

Known Issues 

- Within Part Tracking, User Defined names are not used when Part Tracking in a target image.  User Defined names for 
found parts can still be used normally when Part Tracking samples during Thermal Profiling. 

- Image based Part Tracking, added with this 9.0 release, will show an error when search settings are changed prior to 
uploading a source image.  This can be avoided by first uploading the source image for the image model first.  If the 
error is seen, hitting “continue” on the error message will allow the user to continue to use the software normally. 

- Within Manual Report Generator, added in this 9.0 release, the function “Duplicate All Tiles” under the “Edit” menu is 
not functional and causes an error.  This feature was not available in legacy Report Generator and will be fixed in a 
future release. 
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Versions (listed for reference): 

Studio Manager  9.0.17632 

SurfaceMeasurement 9.0.17632 

SurfaceAnalysis  9.0.17632 

ProfileGenerator 7.9.17632 

FileConverter  7.5.17632 

LicenseUtility  9.0.17632 

User Manuals Studio Studio 8.5 


