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1 Introduction 

1.1 Overview 

Surface Analysis is a program designed to analyze and display the results of 
shadow moiré and fringe projection measurements produced by Akrometrix warpage 
measurement systems. The program typically resides on the measurement system 
computer. If additional site licenses are purchased, Surface Analysis may also be 
installed as a stand-alone application on other computers, offloading analysis tasks from 
the measurement system. This manual is intended for use with Akrometrix Studio 9.0. 

The analysis of interferometric data from shadow moiré and fringe projection systems 
is a rich and complex subject. The main text of this manual emphasizes the operation of 
the Surface Analysis program. The principles of interferometric techniques and analysis 
will be discussed in Akrometrix Optical Techniques and Analyses 101 (AOTA101). 
This paper should be read first by users unfamiliar with these techniques. 

The output of the data acquisition program and thus the input of the Surface Analysis 
program is an Akrometrix-defined file with the extension *.akx_phase or *.akx_disp 
(displacement images). These files can contain measurement and reference data as well 
as some measurement parameters and conditions. Surface Analysis converts data from 
the *.akx_phase and *.akx_disp file into height data, and if required, Akrometrix gauges. 

The main analysis functions on shadow moiré acquired data in Surface Analysis are 
based on the phase image in the *.akx_phase file. A phase image is a two-dimensional 
grayscale image (computed from several intensity source images) containing a value at 
each pixel related to the surface height at that location. Many of the options available in 
the Surface Analysis program originate from two challenges in phase image analysis.  

• First, the phase data must be analyzed as a whole and errors due to poor 
quality data in one region of the surface can affect the results in other regions. 
The Smoothing, Partitioning, Amplitude Threshold, Unwrapping Parameters, 
and Masking functions allow bad data to be smoothed or excluded from 
analysis.  

• Second, the surface contour does not have an absolute frame of reference. 
The Rotation, Grating Compensation, and Reference/Relative functions allow 
the user to define the reference plane in a way most useful for understanding 
the experimental results. 

A second group of options control the display and output of experimental results. 
Surface Analysis provides a suite of display formats, which can each be further 
customized to the user’s preference. In addition, the displacement data can be exported 
in tabular form for plotting or further analysis by other software packages. 

Finally, several batch and report tools allow repetitive functions to be automated and 
large amounts of data to be summarized: 

• Batch Analysis allows the user to quickly analyze a set of related 
measurement data (e.g. the same sample at different temperatures) 
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• Batch Masking allows the user to quickly mask more than one phase or 
displacement image.  

• Batch Rotation allows the user to quickly rotate more than one phase or 
displacement image.  

• Batch Cropping allows the user to quickly crop multiple regions of interest 
from more than one phase or displacement image. 

• Batch Edit Metadata allows the user to edit metadata such as Pin1 location 
and Measured Side on a phase or displacement image. 

• Batch Convert allows the user to convert displacement files back into phase 
images 

• Batch Feature Detection allows the user to apply a custom mask based on 
detected features in a phase image 

• Batch Interface Analysis allows the user to analyze and produce large 
amounts of dual surface or gap plots 

• Create Report allows the user to quickly summarize and report on large 
quantities of single surface warpage data and plots 

• Manual Report recreates the legacy Report Generator application for use in 
creating simple 6-up image reports 

• File Finder allows the user to search for phase or displacement files in a given 
folder that meet certain metadata or filename criteria 

1.2 Warnings and Notes 

1.2.1 Warnings and Notes in this Manual 

Warnings and Notes are marked throughout the manual with these icons: 

 

Figure 1.1 Warning Icon 
 

Figure 1.2 Note Icon 

Warnings are specific health hazards for the operator or potential sources of system 
damage. Notes highlight system limitations or automatic responses that may require 
corrective action by the operator for successful operation. 

1.3 Technical Support 

Akrometrix 

2700 NE Expressway 

Building B, Suite 500 

Atlanta, GA 30345 

404-486-0880 

404-486-0890 (fax) 

support@akrometrix.com 

http://www.akrometrix.com 

mailto:support@akrometrix.com
http://www.akrometrix.com/
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When contacting Akrometrix, please provide the system serial number, the version 
numbers of the Akrometrix software being used, a description of the problem or question, 
and contact information for reply. If the question concerns a particular measurement or 
analysis, please provide electronic copies of the *.akx_phase or *.akx_disp files, final 
results, and a description of data acquisition and/or analysis conditions. If the problem 
concerns changes or failure in general system operation, please describe any events or 
system modifications that occurred immediately before the problem arose. 
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2 Loading Measurement Data 

2.1 Starting the Program 

The Surface Analysis program can be started in four different ways: 

A. Right click on the phase or displacement image in Surface Measurement and 
choose Open in Surface Analysis…. 

B. Double-click on a valid *.akx_phase or *.akx_disp file 

C. Launch the Surface Analysis executable file directly from its shortcut (e.g. via 
the Start menu)  

D. Click the Surface Analysis button listed on the Akrometrix Studio Manager 
bar on the left side of the screen. 

 

Note: Only one instance (copy) of the software can run 
at a time; subsequent calls to the program will activate 
the open instance. 

2.2 Loading Measurement Data  

Once the Surface Analysis program starts, a GUI (Graphical User Interface) frame 
will appear. The contents of the display frame depend on how the application was 
launched: 

A. If called from the measurement software via clicking on a phase image, the 
current phase or displacement window from the data acquisition program is 
shown. 

B. If an *.akx_phase or *akx_disp file was double-clicked, the phase or 
displacement image contained in the selected file is shown. 

C. If the EXE is launched from a shortcut or Studio Manager, no image is shown 
and the user needs to select a file to open. 

New measurement data files can be loaded into memory with the File→Open menu 
item. A standard Open dialog box appears, prompting the user to select a valid 
*.akx_phase or *akx_disp file. Multiple files can be opened at one time by highlighting 
multiple selections using the Shift or Control keys. Phase images and displacement 
images can also be dragged and dropped into the Surface Analysis program in order to 
open them. 

 

Note: Surface Analysis can be configured to analyze 
the image and display results immediately upon 
opening the *.akx_phase file, using the 
Tools→Options… menu item. See Section 4.2 

2.3 Working with the Phase Image 

An *.akx_phase file may contain a variety of information such as measurement data 
(phase images, intensity images, etc.), reference data, as well as measurement 
parameters and conditions. When the *.akx_phase file is loaded, all the information in the 
file is loaded in memory. For display purposes, only the phase image will be shown in the 
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GUI of the Surface Analysis program. Modification (Section 2.4.7) and Analysis 
(Section 4) on the measurement data will be mainly applied to the phase image and any 
associated reference data that exist. 

2.3.1 Resizing a Phase Image 

The phase image window may be resized by clicking and dragging on any edge or 
corner. The image in the window can be zoomed by using Ctrl+ or Ctrl- (Figure 2.1 and 
Figure 2.2). Each action doubles or halves the size of the phase image.  

 

Figure 2.1 Phase Image 100% Magnification 

 

Figure 2.2 Phase Image 200% Magnification 

2.3.2 Data Information 

When a phase image is displayed in Surface Analysis, the image size and 
magnification percentage are shown on the status bar located at the bottom of the image 
(Figure 2.1). 

2.3.3 Edit Metadata 

Metadata for an individual phase image can be changed by right clicking on a phase 
image and going to Edit Metadata. For further information on metadata see Section 
A.1.1 

 

Figure 2.3 Individual Edit Metadata Window 

2.3.4 Measurement Information 

In addition to the information described in Section 2.3.2, the measurement metadata 
can be displayed by right-clicking on the image and choosing Properties… (Figure 2.4).. 
In the Properties window, information about the intensity images, phase image, and 
grating can be found, along with many other metadata fields. 
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Figure 2.4 Displaying Measurement Metadata 

2.3.5 Assigning Physical Size 

Surface Analysis (and the TherMoiré measurement system in general) has no 
internal means of knowing the physical ROI (Region of Interest) size, but physical 
dimensions can be assigned by the user. Click the “Image Size” area on the status bar at 
the bottom left of the phase image. Select Assign Size… from the pull-up menu (Figure 
2.5). In the Physical Size window, assign the unit as inches or millimeters, then enter the 
Width and Height of the image and click OK. 

After physical dimensions have been assigned, the user can choose whether X and 
Y axes are displayed in pixels, inches or millimeters using the same pull-up menu on the 
status bar. The selected unit will appear on the X and Y axes of all graphs created after 
analysis.  

 

Figure 2.5 Assigning Physical Size for a Phase Image 

 

Note: Physical dimensions are required for 
Compensation (Section 4.4.2) and calculation of the 
gauges Bow, Twist, DTA, and ROC (See Akrometrix 
Optical Techniques and Analyses 101). 
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2.3.6 Showing Surface or Intensity Images 

Phase images have fringes across the whole field, hiding features on the sample 
surface. If the user wishes to make masks, partitions, or chords on the surface or intensity 
images, they can be shown by right-clicking on the phase image and selecting 
Advanced→View→Surface Image (or, alternatively, any one of the 4 intensity images). 
The image can also be quickly changed without the context menu by using the keyboard 
shortcuts P, U, S, and the numbers 1-4. The currently viewed image can be saved to disk 
in by selecting File→Save Image… or Ctrl+I. 

  

Figure 2.6 Phase and Surface Image Views 

  

Figure 2.7 Menu Command for Showing Surface or Intensity Images 

2.4 Working with Displacement Data 

When an *.akx_disp image is loaded in Surface Analysis, a different window type is 
created as shown in Figure 2.8. 
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Figure 2.8 Loaded Displacement Window 

This window shows the displacement data, average surface image, 3D graph, and 
gauge results on one tabbed interface. The interaction with this window happens via 
context menu, just as with the phase image window. There is now a File entry for saving 
the data in either its original format or as an image. The data can also be duplicated or 
closed from this menu item. Along the bottom is a status bar showing mouse cursor 
coordinates, overall dimensions, zoom setting, and gauge information. 

This window can be resized by clicking and dragging on any edge or corner. The data 
can be resized using Ctrl+ or Ctrl- or by scrolling the mouse wheel. Either option 
increases or decreases the size of the displayed data by 25%. 

Other functions present in the phase image window are rearranged in this window to 
accommodate new functionality. The organization is described in the following sections. 

2.4.1 File 

Save… Saves the data in *.akx_disp format 

Save Image… Allows display window to be saved in graphical format 
(*_3D.png or *_3D.jpg). 

Duplicate Makes a copy of the current displacement window in 
memory. 

Close Closes the displacement window. Prompts to save if any 
changes are detected. 

2.4.2 Display 

Zoom Allows a reset of the image zoom that has been changed 
by the mouse wheel. 

Z-Axis Allows the Z-Axis units to be changed between microns 
and mils as well as to change the Z-Axis scale. 
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XY Size Allows the X and Y data dimensions to be mapped to 
physical dimensions in either mm or inches. 

2.4.3 Transform 

Detect Features Allows the user to filter data based on pattern recognition 
for specific features. See Section 2.4.7. 

Mask Allows the data to be masked. Contains all the same 
functions as described for phase images in Section 3.2, 
with the addition of “Z-Range…”, which is unique to 
displacement data and described in Section 2.4.8, and 
“Via Phase Amplitude Threshold…”, which is described in 
Section 2.4.10. 

Smooth Allows the user to apply either a default smoothing 
function to the 3D data or a custom one. The default 
smooth can be repeated multiple times. See AOTA101 
for more information. 

Plane Rotation Allows the user to change the data rotation as in Section 
4.3. 

Fit Data… Opens a dialog where a polynomial fit can be calculated 
based on the data set. See Figure 5.2. Alternatively, if 
physical dimensions are assigned to the phase image, a 
spherical fit can be calculated. 

Subtract Displays the relative displacement data calculated by 
subtracting a selected 3D data from the current 3D data 
in a new window. See Section 4.4.2. 

Rotate Allows the data to be rotated about its Z-axis as in 
Section 3.7. 

Shift… Allows the data to be shifted in its plane as in Section 
3.8. 

Invert Inverts Z data 

2.4.4 Analysis 

Step Height Allows the user to define two ROIs and calculate the 
height difference between them. See Section 2.4.9. 

Partition Shows the same commands as under the 
Advanced→Partition menu for phase images, except for 
Array. See Section 3.4. 

Chord Shows the same commands under the 
Advanced→Chord menu for phase images. See 
Section 5.4. 
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Interface Analysis Brings up a list of open *.akx_disp images for showing 
surface on surface plots from Interface Analysis. See 
Section 6. 

SOFC Displays a window containing all Second Order Fit 
Coefficients used to calculate a 2nd order polynomial fit 
for the surface. As of Studio 8.5, this list also includes the 
coefficient of determination, denoted R^2 (R squared). 

2.4.5 Info 

Allows the user to edit metadata and access the properties window associated with 
the displacement image. In the Properties window, information about the intensity images, 
phase images (if any), and grating (if any) can be found, along with many other metadata 
fields. 

 

Figure 2.9 Info Menu on Displacement Image 

 

Figure 2.10 Edit Metadata Dialog on Individual Displacement Image 

2.4.6 Undo 

Allows the user to undo the most recent change. 

2.4.7 Feature Detection 

Feature Detection allows the user to create a custom mask by searching for certain 
regions in the displacement data. This function is modal. Selecting it from the Transform 
context menu brings up a feature ROI whose default shape is an ellipse (Figure 2.11) 
and the Feature Detection window (Figure 2.12). While the Feature Detection mode is 
active, tab switching in the displacement image window is disabled. This mode can be 
turned off by pressing Esc or selecting Cancel from the context menu.  
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Figure 2.11 Feature Detection Region 

 

Figure 2.12 Feature Detection Parameter 
Window 

The Feature Detection process consists of two steps: detection and masking. The 
parameter window and context menu are divided accordingly. During detection, a single 
ROI is set up with matching parameters and all features are found that fit that shape. 
During masking, the detected ROIs can be edited to create a final mask, which may then 
be burned or saved. Current Detection Parameters can be saved from the File menu and 
loaded again in another one-off displacement window or in batch processing. 

Switching between the Feature Detection steps is accomplished using the Detect 
and Clear buttons in the middle of the Parameter Window. Detect scans the image for 
instances of the feature in question, creating an ROI around each one that can be edited 
in Masking mode. Clear deletes all ROIs but the original one, returning to the detection 
step. 
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The two versions of the Feature Detection context menu are shown in Figure 2.13 
and Figure 2.14. They are mostly the same, but since the mask step can have multiple 
ROIs, there are more editing options. 

 

Figure 2.13 Feature Detection 
Context Menu - Detection 

 

Figure 2.14 Feature Detection 
Context Menu - Masking 

• Parameter Window opens the window or brings it to the front, depending on 
whether it is already open 

• Assign Feature assigns the Region source from the current selected area 

• Square Bounds equalizes the horizontal and vertical dimensions of the ROI 
as the shorter value of the two  

• Edit brings up the ROI Editing window described in Section 3.1.  

• Copy (Ctrl+C) copies the selected ROI into memory. 

• Paste (Ctrl+V) places an instance of the copied ROI at the cursor location. 

• Delete (Del) deletes a single ROI. 

• Cancel (Esc) exits out of Feature Detection without making any changes to 
the displacement image, although the Feature Detection settings will be 
remembered as long as the same instance of the *.akx_disp file is open.  

• Finished exits Feature Detection when the user is done, leaving applied 
masks in place. This menu item is always visible but only active at the end of 
the Feature Detection process. 

 

Note: Mask ROIs start out as copies of the Detection 
ROI but can be independently edited. Everything in 
Section 3.1 applies to Feature Detection ROIs. 

In the top half of the Feature Detection Parameter Window (Figure 2.12), detection 
parameters can be set based on the feature detection region (Figure 2.11). This is the 
initial ROI which appears when Feature Detection is opened. Its location and size can be 
edited like any other ROI. Shape Match and Height Match control the degree of accuracy 
in exact shape and size required to find matches. Higher numbers will typically result in 
more features found. Fill Holes fills all mask regions with fabricated data based on the 
neighboring edges. Note that this option does not affect the final output, only the input 
dataset for the detection process, so there will be no visual indication on the 3D data that 
anything has changed. For a typical solder ball detection application, having this checked 
will improve the number and accuracy of features found.  
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If previous detection has been performed and saved via the File menu, Feature Data 
may be used by loading in a feature detection file (*.akx_featuredetection). A preview of 
the displacement data to be found is shown in the center of the parameter window once 
the file is loaded. 

In the mask step, the user edits the ROIs on the displacement image and sets mask 
parameters in the Parameter Window. These include the choice of whether Feature or 
non-Feature data is masked. If Non-feature data is to be masked, then the found features 
can be replaced with a single value, the maximum, minimum, or the value of the center 
pixel in each region. This is particularly useful when finding solder ball peaks. Scale 
Regions increases or decreases their size when masking and Save Mask File converts 
the results into a mask file that can be applied to other files without going through the full 
feature detection process. Mask will apply the mask settings and Undo will allow new 
settings to be tried. Lastly, Feature Detection can be quit by selecting Finished from the 
displacement image context menu.  
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Figure 2.15 Feature Detection with Fill Holes – Solder Ball Peaks on BGA  
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Figure 2.16 Analyzed Data with Feature Detection: Mask Feature and Mask Non-Feature 

2.4.8 Z-Range Mask 

Z-Range Mask functionality serves as a high and low pass filter for displacement data 
by filtering based on Z-axis displacement values. Like Feature Detection, this is a modal 
function that deactivates tab changing. Once Z-Range… is selected from the Mask menu, 
the Z-range Mask Parameters window will appear (Figure 2.18) and the context menu 
will change to that for Z-Range Mask (Figure 2.17). This mode can be turned off by 
pressing Esc or selecting Cancel from the context menu.  

 

Figure 2.17 Z-Range Mask 
Context Menu 

 

Figure 2.18 Z-Range Mask 
Parameters Window - Absolute 

 

Figure 2.19 Z-Range Mask 
Parameters Window - Regions 

The Z-Range Context Menu has 6 options, listed below. 

Parameter Window Opens the Parameter window if it is closed and brings it to 
the front if it is opened. 
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Add Region  While Regions mode is active, allows the user to add a 
region. 

Reset Removes any regions and masks and returns the data to 
its unfiltered state. 

Update Applies any parameter changes to the data. 

Burn Mask  Applies current filtering settings to the displacement 
image and closes Z-Range Mask Mode. 

Cancel Closes Z-Range Mask mode without applying a mask. 
 

 

Note: Right-clicking on a single Region brings up a 
context menu dedicated to ROI editing. Regions are 
subject to the same ROI editing options described in 
Section 3.1. 

The Z-Range Mask Parameters Window File menu has three options. Load allows 
the current parameters to be saved as a Z-Range Mask File (*.akx_zRangeMask). Save 
creates a new Z-Range Mask file from the current settings. Finally, Save Map, which 
activates once a mask has been created, saves a *.akx_mask file from the current Z-
Range Mask. This turns the masked data based on Z-Range into a normal, location based 
mask. 

Next, the Z-Range Mode can be chosen between Absolute, Percent, or Regions 
(Figure 2.18). Absolute and Percent modes allow the data to be filtered based on 
absolute Z-values or as percentages of the total data range. In addition, Absolute or 
Percent modes show a histogram of the data distribution for easy visualization of where 
the majority of the data lies. A range can be entered either by left and right clicking on the 
histogram, or by entering specific Z values in the Min and Max Range fields. 

Regions Mode (Figure 2.19) allows data to be filtered based on values in selected 
regions. Once a region has been added via the context menu (Figure 2.17) it will be listed 
in the Regions table, which shows min, max, and average Z values for each added region. 
The Metric drop-down allows filtering based on the average or range of the regions.  

 

Note: When there are multiple regions, an overall 
average of all their z values will be used as the result 
data for Average, and the overall smallest and largest 
Min and Max values will be used for Range.  

The Mask Pixels selection, either Outside Range or Inside Range, chooses how the 
masked data relates to the range values. Data outside or inside the selected range will 
be masked out and can be adjusted by changing the Offset values of the maximum or 
minimum of the data.  

 

Note: In both Regions and Absolute mode, the 
maximum is the top number and the minimum the 
bottom.  
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The bottom of the Z-Range Parameters Window displays data relevant to the masking 
process and shows results. There is Pixels Masked display which shows the percentage 
of currently masked pixels and an Overall Data Range of the original image. View Original 
or View Discarded buttons show what the original data looked like and what portions of it 
are currently masked out. Finally, the Update button applies the selected Z-Range options 
to the displacement image. If the result is acceptable, Burn Mask in the context menu 
(Figure 2.17) will make the Z-Range selection permanent and exit the Z-Range mode. 
Example data filtered by two different Z-Range Masks is shown in Figure 2.20. 

 

Figure 2.20 Data with High and Low Z-Range Masks 

2.4.9 Step Height Calculation 

Clicking on Step Height→Add Step (Figure 2.21) will add a pair of boxes to the 
displacement view that can be moved around and resized. The step height difference is 
calculated as the difference in average heights between the two regions (1A-1B). The 
step height sign will vary depending on whether the A region is higher or lower than B 
and the result is shown at the bottom of the displacement window (See Figure 2.22 and 
Figure 2.23). Multiple step height pairs can be added. They can also be saved for loading 
onto other displacement windows or used as a gauge in batch processing. 
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Figure 2.21 Step Height Menu 

 

Figure 2.22 Step Height Calculation A>B 

 

Figure 2.23 Step Height Calculation A<B 

The step height pair mode can also be changed by right clicking on either of the boxes 
and going to Switch to S-P. S-P mode uses the 1P box for its LSF reference plane and 
is most useful when analyzing a calibration block with flat planes and known step heights 
between them. A-B mode uses the reference plane that is already applied to the surface. 
See Figure 2.24 and Figure 2.25 for an example. 
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Figure 2.24 A-B Mode 

 

Figure 2.25 S-P Mode 

2.4.10 Phase Amplitude Thresholding  

As of Studio 8.5, Surface Analysis can now mask displacement images by adjusting 
the Phase Amplitude Threshold (PAT) of an image and removing low quality data. Both 
phase and displacement files contain raw intensity data used to build the image, and this 
is used to determine the quality of the data in various regions. Data is then masked out 
based on quality.  

Unlike PAT for phase files, which is described in Section 3.4, data masked via 
displacement file PAT is unrecoverable after the file has been saved and closed. That 
data is removed in the same way that data from a burned mask is removed. 

In order to adjust the Phase Amplitude Threshold, right click on the displacement 
image and select Transform→Mask→Via Phase Amplitude Thresholding… in the 
menu. A window will come up with a slider that allows the user to adjust the PAT of the 
displacement file and see which areas will be masked. Once the user clicks OK and this 
mask is applied, only the Undo function can recover the masked data. 

 

Note: Dragging the slider quickly or large distances 
may cause some delay in recalculating mask areas. 
This is particularly true with large displacement images 
and/or slower computers. 

2.5 Saving Displacement Images 

A modified displacement image is NOT automatically saved to the hard drive. It can 
be saved using the File→Save… menu item. If the modified image is not saved, the user 
will be prompted again to save it when the displacement image window is closed or the 
program is shut down. 
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3 Modifying Measurement Data 

 

Note: Context menu paths described in this section 
and references to phase images will be different for 
*.akx_disp files. Behavior of the functions such as 
masks/partitions/etc. remains the same for 
displacement images. Reference Section 2.4, 
Working with Displacement Data for correct context 
menu paths. 

3.1 Setting the ROI 

The Mask and Partition functions in Surface Analysis create one or more graphically 
defined ROIs (Regions of Interest) on the phase image where these functions can be 
applied. ROIs can be different shapes such as rectangle, ellipse, triangle, etc. The default 
shape of an ROI is a rectangle. Choose a new shape by opening the Shape Selector 
window from the View→Shape Selector menu item. Choose the shape before selecting 
the Mask or Partition function (Figure 3.1). 

After activating the desired function (Mask or Partition), click and drag the mouse 
cursor from one corner of the desired ROI to the other. When an ROI region is selected, 
it can be repositioned by dragging anywhere within its region and resized by dragging on 
any of the eight “Handles” on the periphery. The shape, location, and size of the ROI can 
also be changed by using the ROI Edit Window (Figure 3.2). To access this window, 
right-click inside the ROI and choose Edit…. This window is useful for drawing a pre-
defined ROI. Size can be defined in either absolute (pixel) terms or fractional terms 
(relative to the phase image dimensions). In the case of Partition regions, Chords, and 
Step Heights, name of the ROI can also be edited. 

 

Figure 3.1 ROI Shape Selector 
 

Figure 3.2 Edit ROI Region Size and Position 

Other common functions for Masking and Partitioning can be called by right-clicking 
inside an ROI: 

Copy (Ctrl+C) creates a copy of the active ROI on the Windows Clipboard. It may be 
pasted (Ctrl+V) inside the original phase image or in a different phase image. 

Square Bounds equalizes the horizontal and vertical dimensions of the ROI as the 
shorter value of the two 

Delete deletes the active ROI(s) 

Delete All deletes all ROIs within the current phase image window 
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Note: Other functions in Surface Analysis, such as 
Feature Detection and Z-Range Mask, also use ROIs 
in their interfaces. These ROIs can be edited using the 
functionality described above. 

 

Note: Multiple ROIs, whether Mask, Partition, etc., can 
be selected by using Ctrl+Click. This allows the user to 
interact with multiple ROIs at once. 

3.2 Masking a Phase Image 

Masking excludes regions inside the phase image from the analysis. Regions that 
lack good phase data (e.g. holes, steps) can create errors in the analysis that extend 
beyond the bad phase region. When using a mask, there is no displacement information 
generated within the masked-out regions, and the remainder of the phase image can be 
analyzed without interference. 

 

Figure 3.3 Mask Menu 

3.2.1 Creating a Mask 

A mask file can be either a binary graphical image (*.png) containing only black and 
white colors or a *.akx_mask file representing the location, shape, and size of the regions 
added during a mask operation. In the case of an image mask, the white color represents 
valid data while the black color represents points or areas that need to be masked out. In 
most cases, the mask shapes shown in Figure 3.1 are sufficient. However, if the user 
needs to define an irregularly shaped mask, they can also be generated from an external 
graphical tool such as MS Paint®. The file format needs to be *.bmp or *.png in order to 
be loaded in Surface Analysis. 

A mask can be created and saved in Surface Analysis by the following steps: 
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1. To create a new mask, right-click in the selected phase image and choose 
Advanced→Mask→Add Region (or use the keyboard shortcut, Ctrl+M). 

2. To create the first ROI in the new mask, hold down the left mouse button; draw a 
rectangle on the phase image and then release. The ROI will appear as a 
transparent red shape. All the ROI commands described in Section 3.1 apply to 
the mask ROI. 

3. Additional mask ROIs can be added by repeating steps 1 and 2. Mask ROIs may 
overlap. 

4. When the mask is complete, it may be saved to a file (*.akx_mask or *.png) by 
right-clicking inside the phase image (but not inside an editable mask ROI) and 
choosing Advanced→Mask→Save….  

5. The mask can be turned on and off without deleting the mask from memory by 
right-clicking inside the phase image (but not inside an editable mask ROI) and 
choosing Advanced→Mask→Enabled. Alternating this command will turn the 
current mask(s) on and off. This is useful when evaluating masks between phase 
image and 3D surface plot during analysis. When the masking function is disabled, 
all mask ROIs are hidden. 

6. The mask can be locked by going to Advanced→Mask→Locked. This setting will 
prevent the user from interacting with any editable (red transparent) mask regions. 
It is selected by default when adding a Mask Array (see Section 3.2.5). 

3.2.2 Loading and Editing a Mask 

A previously created mask that was saved in the *.akx_mask, or *.png, formats can 
be recalled and applied to any phase image. To load the mask file, right-click inside the 
phase image, choose Advanced→Mask→Load… (or use the keyboard shortcut, 
Ctrl+Shift+M), and select the desired mask file. More than one mask file can be loaded 
on the same phase image. An image mask is shown in solid yellow color while a 
*.akx_mask file is shown as an editable transparent red region. 

 

Figure 3.4 Loaded Image Mask 
in Yellow 

 

Figure 3.5 Loaded Annotation 
Mask in Red 

 

Figure 3.6 Multiple Annotation 
Masks Selected using Ctrl 

modifier key 

A loaded image mask cannot be edited but can be turned on and off by toggling the 
Advanced→Mask→Enable function. To delete a loaded image mask, choose 
Advanced→Mask→Delete Map. To delete a loaded *.akx_mask mask, choose 
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Advanced→Mask→Delete Regions, or right click on the red region and a context menu, 
including Delete, appears (Figure 3.5). Multiple regions can be selected and interacted 
with by holding down the Ctrl key while clicking on regions (Figure 3.6). New mask ROIs 
may be added by right-clicking inside the phase image and choosing 
Advanced→Mask→Add Region.  

The modified mask, including both old and new components, can be saved by right-
clicking inside the phase image (but not inside an editable mask ROI) and choosing 
Advanced→Mask→Save…. 

 

Note: If a mask is loaded onto a phase image with 
different pixel dimensions than the one on which it was 
created, a dialog will appear, as shown in either Figure 
3.7 or Figure 3.8. 

In Figure 3.7, when loading a mismatched Annotation mask, Scale layout will use the 
fractional values from the mask relative to the original phase image dimensions. Preserve 
layout will load the regions using the raw pixel dimensions and coordinates. 

 

Figure 3.7 Load Annotation Mask Mismatched 
Size Dialog 

 

Figure 3.8 Load Image Mask Mismatched Size 
Dialog 

In Figure 3.8, when loading a mismatched Image mask, clicking Yes on the dialog 
will load the image mask regardless of the mismatch, scaling the masked regions to the 
aspect ratio of the current phase image. 

3.2.3 Copying and Pasting Masks 

All masks on a phase image can be copied by going to Advanced→Mask→Copy 
All. Alternatively, individual mask regions can be copied and pasted by right clicking on 
them and going to Copy. When a region is selected the shortcut Ctrl+C also works. 

Pasting a mask is similar. Once a mask region has been copied, right click on the 
target phase image and go to Paste Mask. When the target phase image has focus, the 
shortcut Ctrl+V also works for this function. 
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Figure 3.9 Paste Mask Option in Phase Image Context Menu 

 

Note: If a mask is pasted onto a phase image with 
different pixel dimensions than the one on which it was 
created, the mask will be scaled fractionally in location 
and size. 

3.2.4 Burning a Mask 

Burning a mask combines the current phase image with one or more mask ROIs 
created in memory or loaded from a file. The mask pattern will be permanently embedded 
in the phase image. This function prevents the future separation and loss of mask files 
used during analysis. 

A mask can be burned by: 

• right-clicking inside an editable mask ROI and choosing Burn 

• right-clicking inside the phase image (but not inside an editable mask ROI) and 
choosing Advanced→Mask→Burn All.  

The burned mask ROIs appear in gray as shown in Figure 3.10. 

 

Figure 3.10 Burned Mask Areas  
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3.2.5 Adding a Mask Array 

Instead of adding mask ROIs one by one, an array of mask ROIs (Figure 3.11) can 
be created using the Mask Array tool. This function is useful for automatically creating 
repetitive mask regions on a phase image.  

 

Figure 3.11 Example of a Mask Array 

1. To create a new array right click in the selected phase image and choose 
Advanced→Mask→Add Array… 

2. A checkerboard pattern representing where mask regions will be placed appears 
on the phase image. Also, a window with various array parameter options appears 
( Figure 3.12). Width and Height refer to the individual dimensions of each mask 
region. Pattern Origin is the distance of the center of the pattern from the center 
of the image. Spacing controls how much space exists between each mask 
region. Region Inset refers to how much of each pattern region is covered by the 
final mask (a larger inset reduces the size of each mask region). Finally, Selection 
Area controls whether the mask array is placed inside or outside the green 
bounding box. Each option affects all ROIs in the same way.  

 

Note: There is no way to edit one mask region at this 
stage. Once the mask array has been added, the 
shape and location of each region can be altered 
individually. 

3. Click the Update button to view changes made to the pattern on the phase image. 

 
Figure 3.12 Mask Array Pattern and Parameters Window 

 

Figure 3.13 Array Context Menu 
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4. The array pattern origin can be changed graphically by right clicking at the desired 
point on the phase image and selecting Assign pattern origin HERE (Figure 
3.13). 

5. To save the mask regions, use the green array bounding box to select the specific 
regions to be saved. The bounding box can be edited via the Array Context Menu 
to square its dimensions or edit its position and size (Figure 3.13). Note that only 
regions whose whole areas are enclosed by the green bounding box will be saved, 
as seen in Figure 3.14 and Figure 3.15. Click on Add Regions to add the selected 
regions. The program will lock these regions so that they cannot be edited. 
Interaction with the created array can occur just as with a normal mask (see 
Section 3.2.1). 

 

Figure 3.14 Mask Array Green Bounding Box 

 

Figure 3.15 Added Mask Array 

3.2.6 Expand Existing Mask 

As of Studio 8.5, the Expand Existing Mask feature gives the user the ability to extend 
burned mask regions. This is useful for eliminating bad data not quite covered by the 
original mask without having to draw new masks. It’s also useful for expanding linearly on 
areas that were initially covered by Phase Amplitude Thresholding. 

To expand all burned masks in an image, right click in the selected phase or 
displacement image and choose Advanced→Mask→Expand Existing Mask… 
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Figure 3.16 Before Expanding Existing Mask 

 

Figure 3.17 After Expanding Existing Mask 

 

Figure 3.18 Expand Existing Mask 

3.2.7 Mask Data Islands 

As of Studio 8.5, the Mask Data Islands function gives the user the ability to mask 
islands in the data based on their pixel size, removing regions smaller than a given 
threshold. This is most useful when working with *.akx_disp files, since unwrapping for 
phase images works on contiguous areas and ignores disconnected islands (see Section 
4.6). For *.akx_disp images, however, the ability to remove small islands of data as a 
group instead of manually can be very effective for noise reduction or selecting the correct 
area for measurement.  

To mask data islands, right click on the selected image and select 
Advanced→Mask→Mask Data Islands…. The user then enters a pixel size of the 
largest island to be masked. 

3.3 Cropping a Phase Image 

Cropping an image allows the user to extract and save a smaller portion of the current 
phase image. This is useful for defining a smaller region inside the original phase image 
or eliminating bad phase data at an image edge. 

 

Note: As of Studio 8.0, the crop function has been 
removed in favor of creating a partition file with only 
one region. Please see Section 3.5. 

3.4 Phase Amplitude Thresholding 

As of Studio 8.0, Surface Analysis now has the ability to adjust the phase amplitude 
threshold used to auto-mask a phase image after it has been saved by Surface 
Measurement. Previously, this value could only be changed by re-acquiring data during 
acquisition. This works by virtue of the fact that *.akx_phase files typically store the raw 



Surface Analysis User Manual 

Page 32 of 126 30-50SW-0001 Ver. 9.0 

intensity images used to build phase data. By resetting the phase amplitude value, areas 
of the image that were above the acquisition PAT can be recovered and data that should 
have been masked can be removed. 

In order to adjust the Phase Amplitude Threshold, right click on the phase image and 
select the Amplitude Threshold… menu option. A dialog will pop up asking the user 
whether or not they want to keep existing masked points. Clicking Yes will create a map 
of the already masked out points that will not be affected by any PAT adjustments. This 
is particularly useful if the user has already created a mask of data that had good phase 
amplitude but was simply not needed in the measurement. Saying No will recalculate 
mask on all areas of the image. 

As of Studio 8.5, displacement images can also be Phase Amplitude masked, but 
displacement data can only be removed, not recovered. See Section 2.4.10. 

 

Figure 3.19 Amplitude 
Threshold Menu Option 

 

Figure 3.20 PAT Keep Existing 
Masked Points? 

 

Figure 3.21 Phase Amplitude 
Thresholding Adjustment 

Window 

When the adjustment window pops up, move the slider to adjust mask calculation. 
The Min and Max values on this slider are pulled directly from the phase amplitude of the 
image.  

 

Figure 3.22 Phase Amplitude Thresholding 

Masked areas will increase and decrease, and be highlighted red on the phase 
image. To go back to the original PAT value, click the Set button. 
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Note: Dragging the slider quickly or large distances 
may cause some delay in recalculating mask areas. 
This is particularly true with large phase images and/or 
slower computers. 

In Batch Processing, the Phase Amplitude Threshold dialog has both absolute and 
relative threshold settings, as well as both 8-bit and 12-bit scales, depending on which 
type of image is being processed. 

 

Figure 3.23 Phase Amplitude Threshold Batch Dialog 

3.5 Partitioning a Phase Image 

Partitioning is a function where one or more ROIs are cropped from a phase image 
while leaving the original phase image intact. This function is useful for measuring multiple 
samples in a single run, and later extracting the individual samples from each phase 
image recorded. The same partition can be applied to multiple phase images using the 
Batch Cropping tool described in Section 7. 

 

Figure 3.24 Partition Menu 

3.5.1 Creating a Partition 

1. To create a new partition, right-click in the selected phase image and choose 
Advanced→Partition→Add Region… (or Ctrl+R). 
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2. To create the first domain in the new partition, draw a rectangle on the phase image 
with the mouse. 

3. A green ROI appears and all the ROI commands described in Section 3.1 apply 
to the partition ROI. By default, the regions will be named “Region 001”, “Region 
002”, etc, but the default can be changed by going to 
Advanced→Partition→Default ROI Prefix… Previously used ROI names will be 
saved in a list for recall later. 

 

Figure 3.25 Default ROI Prefix Dialog 

4. Right-clicking inside any ROI and choosing Edit… allows the region name to be 
changed as well as the shape, location, size, and Mode of the domain (Figure 
3.26). Click OK when complete.  

 

Note: The Mode selection determines whether the 
partition location and size are displayed in absolute 
pixels or fractions. The location is relative to the top left 
corner of the phase image. The size is relative to the 
full x and y dimension of the phase image. 

 

Figure 3.26 A Partition ROI Properties Window 
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5. Additional domains can be added to the partition (Figure 3.27) by repeating steps 
1 through 3. Domains may overlap. 

 

Figure 3.27 Multiple Domains on One Phase Image  

6. When the partition is complete, it can be saved to a file (*.akx_partition) by right-
clicking inside the phase image (but not inside a domain) and choosing 
Advanced→Partition→Save…. 

7. Even if it has not been saved, a partition may be used until it is cleared. It may be 
cleared by right-clicking inside the phase image (but not inside a domain) and 
choosing Advanced→Partition→Delete All. 

8. The partition can be locked by going to Advanced→Partition→Locked. This 
setting will prevent the user from interacting with any editable partition regions. It 
is selected by default when adding a Partition Array (see Section 3.5.5). 

9. The partition can be made visible or invisible by going to 
Advanced→Partition→Visible. 

3.5.2 Loading and Editing a Partition  

A previously created partition that was saved in a *.akx_partition file can be recalled 
and applied to any phase image. To load the partition file, right-click inside the phase 
image, choose Advanced→Partition→Load… (or use the keyboard shortcut, 
Ctrl+Shift+M), and select the desired partition file. 

Any domain in the partition may be modified or deleted by right-clicking inside the 
domain and using the ROI commands described in Section 3.1. It may also be edited 
graphically using the cursor. New domains may be added by right-clicking inside the 
phase image (but not inside a domain) and choosing Advanced→Partition→Add 
Region…. 
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The modified partition, including both old and new domains, may be saved by right-
clicking inside the phase image (but not inside a domain) and choosing 
Advanced→Partition→Save…. 

 

Note: If a partition is loaded onto a phase image with 
different pixel dimensions than the one on which it was 
created, a dialog will appear, as shown and discussed 
below. 

 

Figure 3.28 Load Partition Absolute Size Mismatch 

Scale layout will use the fractional values from the mask relative to the original phase 
image dimensions. Preserve layout will load the regions using the raw pixel dimensions 
and coordinates. If Preserve is chosen, a dialog will let the user know how many regions 
were discarded because they were entirely outside of the data bounds as well as how 
many regions extend outside of the data bounds. Only regions with their top left corner 
present in the target image pixel bounds will be loaded. 

 

Figure 3.29 Load Partition Preserve Layout Info 

3.5.3 Copying and Pasting Partition Regions 

A mask can be copied by going to Advanced→Partition→Copy All. Alternatively, 
individual partition regions can be copied and pasted by right clicking on them and going 
to Copy. When a region is selected the shortcut Ctrl+C also works here. 

Pasting a partition is similar. Once a partition region has been copied, right click on 
the target phase image, and go to Paste Partition Region. When the target phase image 
has focus, the shortcut Ctrl+V also works for this function. 
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Figure 3.30 Paste Partition Region Option in Phase Image Context Menu 

 

Note: If a partition is pasted onto a phase image with 
different pixel dimensions than the one on which it was 
created, the region will be scaled fractionally in location 
and size. 

3.5.4 Extracting Domains 

Partitions can be extracted from the original phase image, either to new windows 
(Figure 3.31) or to independent *.akx_phase files. To extract a domain as an independent 
phase image in its own window, right-click inside the domain and choose Extract, then 
choose between ‘to window’ and ‘to file…’ (Figure 3.32). To extract all domains when 
multiple exist, right-click inside any ROI and choose Extract All, and again choose to 
extract to windows or files. If ‘to windows’ is chosen, a new window will pop up for each 
ROI. 

When partitions are extracted to files, the default file name is the ROI name appended 
to the name of the parent file (Example: Sample_0001.akx_phase). This default can be 
changed in Advanced→Partition→Extraction Naming. The default file names can be 
edited when extracting individual partitions to files, but are used automatically when 
Extract All→’to files…’ is chosen. 

 

Figure 3.31 Extracted Domains from a Phase Image 
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Figure 3.32 Partition Context Menu - Extract 

3.5.5 Adding a Partition Array 

Instead of adding partition ROIs one by one, an array of partition ROIs (Figure 3.33) 
can be created using the Partition Array tool. This function is useful for automatically 
creating repetitive partition regions on a phase image. Common use cases include 
examining die level warpage on wafers and package level warpage on strips. 

 

Figure 3.33 Example of a Partition Array 

1. To create a new array right click in the selected phase image and choose 
Advanced→Partition→Add Array… 

2. A checkerboard pattern representing where partition regions will be placed 
appears on the phase image. Also, a window with various array parameter options 
appears (Figure 3.34). Width and Height refer to the individual dimensions of 
each partition region. The Pattern Origin is the distance of the center of the pattern 
from the center of the image. Spacing controls how much space exists between 
each partition region. Region Inset refers to how much of each pattern region is 
covered by the final partition (a larger inset reduces the size of each partition 
region). Finally, Selection Area controls whether the partition array is placed 
inside or outside the green bounding box. Each option affects all ROIs in the same 
way.  

 

Note: There is no way to edit one partition region at 
this stage. Once the partition array has been added, 
the shape, location, and name of each region can be 
altered individually. 

3. Partitions will be numbered by default and Naming Origin determines where the 
first partition originates. The Naming Scheme parameter allows for sequential or 
row-column style naming of the partitions. The Starting Value option allows the 
numbering to begin at arbitrary values. Finally, the numbering scheme can have a 
Prefix or Suffix added for additional naming flexibility. 
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4. Click Update to view the changed array inside the phase image. 

5. The array pattern origin can be changed graphically by right clicking at the desired 
point on the phase image and selecting Assign pattern origin HERE (Figure 
3.35). 

 

Figure 3.34 Partition Array Parameters 

 

Figure 3.35 Array Context 
Menu 

6. To save the partition regions, use the green array bounding box to select the 
specific regions to be saved. The bounding box can be edited via the Array Context 
Menu to square its dimensions or edit its position and size (Figure 3.35). Note that 
only regions whose whole areas are enclosed by the green bounding box will be 
saved, as seen in Figure 3.36 and Figure 3.37. Click on Add Regions to add the 
selected regions. The program will lock these regions so that they cannot be 
edited. Interaction with the created array can occur just as with a normal partition 
(see Section 3.5.1). 
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Figure 3.36 Green Array Bounding Box 

 

Figure 3.37 Added Partition Array 

3.5.6 Add Unmasked Extents Region 

The Add Unmasked Extents Region function creates a region that encompasses the 
furthest unmasked edges of an image, allowing the user to quickly extract images with 
unmasked data up to the edges. This is most useful for obtaining normalized and edge 
chords from images that required edge masking to cover bad data. Figure 3.38 shows 
an example image with an unmasked extents region already created. 

To create an unmasked extents region, right-click in the selected image and choose 
Advanced→Partition→Add Unmasked extents region. 

  

Figure 3.38 Unmasked Extents Region 

3.6 Smoothing a Phase Image 

The Smooth command applies a smoothing function to the active phase image to 
reduce noise in the data. This is useful for reducing analysis error due to fringe 
miscounting and increasing reproducibility in gauge values. Warpage gauge values, such 
as coplanarity, are frequently determined by a small number of data points, e.g. the 
highest and lowest displacement values. Therefore, they are extremely sensitive to 
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statistical outliers in the data set. Smoothing, by reducing statistical noise, can make 
these values more repeatable from measurement to measurement. 

To apply the smooth function, right-click inside the phase image and choose Smooth. 
This command can be repeated multiple times. For further information about the smooth 
function, refer to Akrometrix Optical Techniques and Analysis 101. 

 

Note: Smoothing may cause errors when applied to 
images where the fringes are very tightly spaced or at 
boundaries of mask ROIs. Therefore, it is not 
recommended to apply the smooth function on data 
acquired with the MP10 Surface Measurement 
system which produces a closely spaced fringe pattern 
on a phase image. 

3.7 Rotating a Phase Image 

Rotating a phase image is a feature useful when a sample does not have the desired 
orientation in the original phase image (e.g. a part has rotated on the sample support 
fixture during a temperature profile). 

 

Note: Phase image rotation is different from reference 
plane rotation that is discussed in Section 4.3. The 
former rotates a 2D image while the latter rotates a 3D 
surface. To choose the method of rotating a reference 
plane, right-click on the phase image and choose 
Rotation (Figure 3.40). 

To rotate a phase image, right-click on the image, choose Advanced→Rotate and 
select the desired rotation. 

 

Figure 3.39 Phase Image Rotation 

 

Figure 3.40 Reference Plane Rotation 

3.8 Shifting a Phase Image 

Shifting a phase image is a feature useful when a sample does not have the desired 
position in the original phase image (e.g. a part has shifted to one side of the sample 
support fixture during a temperature profile). 

To shift a phase image, right-click on the phase image, choose Advanced→Shift… 
and select the desired shift in either the X (left-right) or Y (up-down) direction. The image 
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will shift with respect to an origin that is defined as the top left of the phase image. Areas 
shifted from outside the boundaries of the phase image will be filled with mask (see 
Figure 3.41).  

  

Figure 3.41 Shifting a Phase Image 

3.9 Undoing a Phase Image Modification 

To undo phase image modification from masking, partitioning, smoothing, rotating or 
shifting, right-click and select Advanced→Undo; select the action to undo from the 
available list.  

There can be up to 99 actions on the undo list. The latest action will be shown at the 
top of the list. Clicking on the latest action will remove this single action and move the 
phase image back one state. Clicking on any item in the middle of the list will remove all 
the actions from the top to this item. 

3.10 Saving Phase Images 

A modified phase image is NOT automatically saved to the hard drive. It can be saved 
using the File→Save… menu item. If the modified image is not saved, the user will be 
prompted again to save it when the phase image window is closed or the program is shut 
down. 
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4 Analyzing Measurement Data 

Analysis is the mathematical conversion of the measurement data (e.g. phase image) 
into displacement data (the height of the surface at each image pixel in physical units). 
Surface Analysis is normally set to display displacement data graphically as soon as the 
analysis is complete. The graphical output options will be described in Section 4.6. This 
section describes how to initiate the analysis process and a key factor in the analysis, the 
choice of reference plane. 

4.1 Analysis 

There are three methods to trigger analysis of the measurement data 

A. To trigger analysis manually, right-click on the phase or displacement image to 
be analyzed and select Analyze. 

B. To trigger analysis automatically when a *.akx_phase file is opened, select the 
Tools→Options… menu item and check Analyze on Open. 

C. To analyze multiple measurement data in parallel, use the Batch Analysis 
function described in Section 7.2. 

 

Note: If no graphical display options are checked in the 
options window, there will be no visible indication that 
analysis has taken place in cases A and B above. 

4.2 The Options Window 

The settings on the options window (Figure 4.1) determine the reference plane and 
display options when the measurement data is analyzed. These settings will be applied 
to all the measurement data, either manually or automatically on opening. 

To open the options window, select the Tools→Options… menu item. All the settings 
are explained below: 

Units XY Displays the in-plane dimensions in English (inches) or metric 
units (millimeters).  

Units Z Displays the out-of-plane dimensions in English (mils, 1 mil = 
0.001 inches) or metric units (microns, or µm). 

Smooth Phase on 
Open 

Checking this box causes the phase image to be smoothed 
one time immediately after loaded. 

Analyze on Open Checking this box causes the measurement data to be 
analyzed immediately after loaded. 

Grating 
Compensation 

Checking this box applies compensation to all measurement 
data that contain compensation parameters (See Section 
4.4.2 for a discussion of grating compensation). It may be 
turned on or off for individual measurement data by right-
clicking on a phase image and choosing 
Advanced→Compensate. 
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Normalize 
Chords 

Checking this box causes all 2D chord plots to be displayed 
with the endpoints referenced to zero. 

Default Rotation Pull-down list sets the reference plane rotation to be applied 
during the analysis. See Section 4.3. 

Gauges – Surface Select which gauges (numerical values quantifying flatness) 
are Active. Activating a gauge means that it will be calculated 
and displayed in both the Displacement Window Gauges tab 
and at the bottom of any 3D graphs. A gauge on the list may 
be highlighted by clicking on it once. The up and down arrows 
move the highlighted gauge up and down the list, changing 
the order in which gauges are displayed.  

 

Note: The second check box currently has no effect, 
and its value is not retained. It will have a use in future 
updates. 

 

Gauges – Chord Select which gauges show up at the bottom of a Chord Graph. 
Order By also determines the order in which the selected 
gauges are displayed. 

Graphs Selects which graph formats (see Sections 5.1 through 5.4 ) 
are displayed after analysis. A graph on the list may be 
highlighted by clicking on it once. Checking a box means that 
graph will be displayed. The up and down arrows move the 
highlighted graph up and down the list, changing the order in 
which graphs are displayed. 

Configuration 
File 

Allows the user to load a non-default display format for 
graphs. The 3D configuration file has an extension of 
*.akx_3Dconfig and is used for 3D plots. See Section 5.1. 
The 2D configuration file has an extension of *.akx_2Dconfig 
and is used for any 2D chords. See Sections 5.3 and 5.4. 

Graph Size Sets the initial size for all graphical displays created during 
analysis. 

Gauge Display Gauge values listed at the bottom of the 3D or 2D display 
window may be arranged horizontally or vertically. 

Use Latest 3D 
View 

Applies the perspective of the most recently modified 3D 
surface plot to all subsequently spawned 3D surface plots. In 
other words, if the user changes the altitude or rotation from 
which the surface is viewed in one graph, new graphs will 
automatically be shown from the same viewpoint. The zoom 
factor of the most recent graph will also be inherited. 
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Fixed Z-Scale When checked, this allows the user to adjust the data scale 
for all 3D or 2D plots. When unchecked, each image is plotted 
on a scale set by its own data set. This option is also available 
in Batch Analysis (Tools→Batch Processing…→Analysis 
Tab). 

Batch Analysis Allows the user to load a *.akx_recipe file to change the 
default Batch Analysis settings. Also allows the default file 
format to be selected as well as whether the file full path is 
included in the batch results. 

Create Report Allows the user to load a *.akx_ReportSettings file to change 
the default Create Report settings. 

OK Any changes to the settings are saved and the window is 
closed. 

Cancel The window will close without changes to the settings. 

  

Figure 4.1 Options Window 
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Note: If no options are checked on the Graphs list, 
there will be no visible indication that analysis has 
taken place. 

4.3 Reference Plane – Rotation 

In order to display the displacement data, the user may define a coordinate system 
with a zero reference plane. This is especially useful when calculating gauges. To set the 
reference plane rotation to be used during analysis, select Tools→Options… and 
choose from the Default Rotation pull-down list.  

The rotation choice can also be made before analysis by right-clicking on the phase 
image and choosing Rotation or Transform→Plane Rotation on a displacement image, 
then selecting from the list. The selected option is checked. 

 

Note: The rotation option chosen in the options 
window will be applied to all the measurement data 
when loaded. The rotation option chosen from an 
individual phase or displacement image will only be 
applied to that particular data. 

Surface Analysis provides the user with several options for defining the zero 
reference plane: 

• None: The displacement data is not rotated and thus the reference plane is 
parallel to the grating. The zero value on the data does not correspond to any 
specific feature of the displacement surface. 

• LSF: The displacement data is rotated so that the zero reference plane is the 
best fit plane calculated from all displacement points. 

• LSF Low 0: LSF rotation option with the lowest displacement point set equal 
to zero (all others are positive displacement values). 

• LSF High 0: LSF rotation option with the highest displacement point set equal 
to zero (all others are negative displacement values). 

• Three Point: The displacement data is rotated so that the zero reference plane 
is defined by three corners (upper left, lower left, upper right). 

• Four Point: The displacement data is rotated so that the zero reference plane 
is the best fit plane calculated from all four corners. 

When analyzing a displacement image, the User Defined rotation option is also 
available. This allows the user to specify a region on the sample surface to fit a LSF plane 
to. This LSF plane is then used to rotate the entire surface. 
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Figure 4.2 User Defined Plane Rotation 

In Figure 4.2 the green box can be dragged around and resized to cover the area 
that represents the desired rotation. In the context menu, Rotate will perform the rotation. 
If the rotation is deemed acceptable, Accept will complete the operation and remove the 
green box. Revert will undo the rotation. In addition, the green box can be copied from 
one displacement window to another using the Copy/Paste commands. Lastly, the box 
size and location can be set from another *.akx_disp file as well as edited using the 
Square Bounds and Edit commands. 

The values of the individual data points change as a function of rotation (choice of 
reference plane), so gauges (e.g. coplanarity) and other calculated values are also a 
function of rotation. See Akrometrix Optical Techniques and Analyses 101 for further 
discussion. 

4.4 Reference Surface – Relative Displacement 

A relative displacement measurement is calculated by taking the difference between 
two absolute displacement measurements. It is useful for observing the change in sample 
warpage as a function of sample history, temperature change, sample to sample 
variation, etc. The user interface to produce relative plots depends on how the input 
displacement data is loaded. See Sections 4.4.1 and 4.4.2 below. 

4.4.1 Phase Relative 

When dealing with phase image derived displacement plots, there are two ways to 
produce relative plots. In the first, a baseline displacement surface is set to be the 
reference surface. Relative plots are then created from other phase images. In the second 
method, relative displacement surfaces are created with the displacement surface context 
menu. 
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To define a reference surface, right-click on a 3D graph analyzed from a phase image 
and check Use as Reference (Figure 4.3). This surface data can then act as a reference 
to all other displacement data. After identifying the reference surface, right-click on a 
second phase image of the same pixel dimensions. An additional menu item, Analyze 
Relative, appears on the list below Analyze (Figure 4.4). To obtain the relative 
displacement data, select Analyze Relative. The created relative surface is the current 
active surface minus the reference surface. 

 

Figure 4.3 Use As Reference 

 

Figure 4.4 Analyze Relative 

 

Figure 4.5 Mismatched Pixel 
Dimensions Error 

Otherwise, choose Analyze to obtain the absolute displacement data. The relative 
displacement display can be turned off by right-clicking on the reference surface image 
and unchecking Reference Surface. Subsequently, Analyze Relative will disappear 
from the phase image context menu. 

The second method for creating relative plots requires only interacting with the 
displacement context menu. Right click on the plot of interest and choose Show Relative 
To. A list of compatible surfaces is shown (Figure 4.6) 

 

Figure 4.6 Show Relative To 

 

Note: Relative plots produced from phase image 
displacement surfaces only compare data of the exact 
same pixel dimension. When using the Analyze 
Relative method, if the second phase image is of 
different pixel dimensions than the reference phase 
image, the user will be shown an error message 
(Figure 4.5). 
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4.4.2 Displacement Relative 

When dealing with displacement images (loaded as *.akx_disp) the interface is 
changed. In the context menu, Transform→Subtract shows a list of open surfaces. 
Surfaces of the same pixel dimension are shown with a green checkmark. Surfaces of 
different sizes up to 4x different are shown with a yellow caution symbol. Surfaces greater 
than 4x different are grayed out and cannot be subtracted. 

 

Figure 4.7 Displacement Relative Plot UI 

If the user selects a surface of different pixel dimensions, the larger dimensions (in 
either image) will be shrunk down to fit the smaller dimension. A warning tells the user 
the resulting surface size (Figure 4.8). 

 

Figure 4.8 Subtraction Mismatched Size Warning 

4.5 Reference Surface – Grating Compensation 

The non-planar surface of a grating can be compensated by a reference surface (see 
Akrometrix Optical Techniques and Analyses 101). To enable grating compensation 
during analysis, check the Enabled box under Grating Compensation in the options 
window. 

The compensation choice can also be made for individual phase images by right-
clicking on the phase image and checking Advanced→Compensation. To turn off 
compensation, repeat the process and uncheck the selection by clicking it again. 

 

Note: In the options window, the Grating 
Compensation option can be enabled or disabled 
regardless of whether the grating has been 
compensated or not. This option will be applied to all 
opened phase images that contain compensation data. 
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Note: The compensation option on an individual phase 
image will be grayed out if no compensation 
parameters can be found in the *.akx_phase file. 
Otherwise, this option is shown in black and can be 
checked or unchecked. The compensation option 
chosen for each phase image will only be applied to 
that particular image. 

 

Note: In order to apply grating compensation, physical 
dimensions have to be assigned to the phase image 
(see Section 2.3.5). The grating compensation 
calculation assumes that the ROI is centered with 
respect to the grating. The accuracy of the 
compensation will be reduced if the ROI is not 
centered, particularly if it lies outside the central 4” by 
4” area of the grating. 
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4.6 Unwrapping Parameters 

A procedure called “unwrapping” is a key part of the analysis of measured phase data 
(See Akrometrix Optical Techniques and Analyses 101). The unwrapping process 
starts in the geometric center of the image and converts phase data to displacement 
values. Because the flood-fill algorithm used is inherently sequential, it simply stops any 
time a mask value is reached. As a result, it was impossible in previous versions of 
Surface Analysis to see data that was entirely separated by mask from the center of the 
surface being analyzed. An example of such data is shown in Figure 4.3. Only the center 
is analyzed because of the mask, which stops the unwrapping process from continuing 
to the valid surrounding data. 

  

Figure 4.9 Isolated data 

As of Studio 8.2, Unwrapping Parameters functionality allows the user to control 
aspects of the otherwise automated unwrapping process, thereby mitigating these data 
isolation issues. Unwrapping Parameters as a category covers two specific, mutually 
exclusive functions, Start Point and Phase Bridging, which solve the issue of isolated data 
in different ways.  

4.6.1 Start Point 

Start Point allows the user to manually change the start location of the unwrapping 
process, which, by default, starts in the center of the image. If only one isolated island of 
data is of interest, changing the start point allows the user to start the analysis in that 
island. Figure 4.10 shows an example. Instead of starting in the center as in Figure 4.9, 
the same image is analyzed with the start point moved to a corner, and the previously 
inaccessible edges are now visible at the expense of the center. 

 

Figure 4.10 Analyzed Data with Altered Start Point 
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 The key steps in editing a Start Point are: 

1. Right click on the phase image and go to Advanced→Unwrapping 
Parameters→Edit. 

2. In the resulting menu, change the X and Y location of the start point and select OK. 

3. An orange dot will appear on the phase image, representing the new start point 
location. This can be toggled on and off using Advanced→Unwrapping 
Parameters→Start Point. 

4. Analyze the file using the new Start Point. 

4.6.2 Phase Bridging 

Phase Bridging is a more complex solution to the issue of isolated data. With phase 
bridging, the user draws a bridge from one data “island” to another, so that the analysis 
software can bridge the gap. Unlike Start Point, Phase Bridging can be used to show all 
of the data at once. Examples of phase bridging are shown in Figure 4.11 and Figure 
4.12. Note that in Figure 4.11 the data is all at a similar height, while Figure 4.12 contains 
a step height which makes it difficult to see the fine scale warpage. Phase data is still 
used to calculate exact height from areas, although the height difference itself is entered 
manually for each bridge. 

  

Figure 4.11 Phase-bridged Data at Similar Heights 

 

Figure 4.12 Phase-bridged Data with a Step 
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The key steps in creating a Phase Bridge are: 

1. Right click on the phase image and go to Advanced→Unwrapping 
Parameters→Add Bridge, or press Ctrl+B. 

2. Click on a start and end point in the phase image. Make sure to start in one data 
“island,” and end in another. 

3. As of Studio 8.3, Surface Analysis will then show a “Rotated” phase image where 
the data is shown relative to an LSF plane of the “A” phase region. This helps in 
determining where to place bridges and what height estimates to apply. Note that 
this is not the final data rotation as that is performed on the whole data set after 
unwrapping is complete. 

4. An orange arrow will appear on the phase image, representing the new phase 
bridge. This can be toggled on and off using Advanced→Unwrapping 
Parameters→Phase Bridging 

5. The user can add as many phase bridges as are necessary to connect all of the 
isolated data. 

6. Analyze the file using the new Phase Bridge(s). 

 

Note: Once a phase bridge has been added, 
unwrapping will begin from the beginning of the first 
phase bridge, and then start at the end of the bridge 
when that is complete, and so on across all phase 
bridges. This is why Start Point and Phase Bridging are 
mutually exclusive, and also why it is not possible to 
have multiple bridges leaving the same section of data. 
Bridges must move sequentially from section to 
section. 

The user has a variety of options when it comes to editing and adjusting phase 
bridges. The start and end points of an existing phase bridge may be altered at any time 
by clicking and dragging the white handles at either end. In addition, right-clicking on an 
existing phase bridge brings up a unique context menu whose options are explained 
below. 

Reverse Direction Switches the start and end points of the phase bridge 

Align  Aligns the phase bridge horizontally or vertically 

Delete (Del) Deletes the phase bridge 

Edit Brings up the Phase Bridge Edit Window shown in 
Figure 4.13. 
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Figure 4.13 Phase Bridge Edit Window 

The Edit Bridge window gives the user access to several powerful options for 
controlling phase bridges. These include: 

Name Change the name of the phase bridge. The default naming 
scheme for phase bridges is A-B, B-C, C-D, etc. 

Start Point Determines the coordinates of the start point of the phase 
bridge. 

End Point Determines the coordinates of the end point of the phase 
bridge. 

Include Region in 
LSF Calculation 

Selecting this option includes a given region when an 
LSF plane calculation is performed on the data (see 
Section 4.3). 

Mode Determines whether the coordinates of the start and end 
points are expressed in absolute or fractional mode. 

Height Estimate The user-entered height estimate is used by the program 
to determine the relative height of bridged sections. Since 
phase data is relative, the program doesn’t treat a 
connected section a different fringe order unless the user 
tells it to. The user height estimate determines the fringe 
order of the isolated section while the actual phase data 
is used for fine scale height within that fringe order. 
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Figure 4.14 Phase Bridge Step Height Example 

 

Note: Height estimates must fall within +/- 0.25 Fringe 
Values of the measurement (+/-64 microns with the 
100 LPI). Height Estimates incorrect by +/- 0.25 to 0.75 
Fringe Values will generate an error from the software 
stating an incorrect height estimate. Height 
approximations incorrect beyond this threshold would 
lead to incorrect data. This is illustrated in Figure 4.14 
using the same data set from Figure 4.12. 

4.6.3 Second Diff Quality Mapping 

Standard phase unwrapping occurs via a flood-fill algorithm that starts in the center 
of the image. This process can lead to unwrapping errors when phase quality is poor. The 
second differences quality mapping routine ranks the quality of the phase, pixel by pixel 
and follows a path that starts with the highest quality phase data and moves towards the 
lowest. It will preferentially follow an unwrapping path that avoids larger changes in slope. 
In cases with random noise in the phase, this can result in significantly reduced 
unwrapping artifacts. 

This function can be activated by right-clicking on a phase image and going to 
Advanced→Unwrapping Parameters→Second Diff Quality Mapping. When it is 
enabled, a Threshold must also be entered where higher values lead to more low quality 
phase pixels being removed. Typical values range between 900 – 1000. 
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Figure 4.15 Standard Flood Fill Algorithm 
Unwrapping with Artifacts 

 

Figure 4.16 Second Differences Unwrapping 
without Artifacts 

4.6.4 Unwrapping Parameter Files 

Once unwrapping parameters have been set, they can be copied or saved to be used 
in other files. From the Advanced>Unwrapping Parameters context menu, the user can: 

• Load existing *.akx_unwrap files. 

• Save any active unwrapping parameters as *.akx_unwrap files. 

• Copy any active unwrapping parameters. 

• Paste copied unwrapping parameters onto phase images. 

 

Note: In this context, “active unwrapping parameters” 
are those that are toggled on in the context menu and 
visible in orange on the phase image. 
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5 Displaying Results 

After analysis, the information is displayed in a choice of four graphical formats: 

• 3D Surface (Section 5.1) 

• 3D Contour (Section 5.2) 

• 2D Diagonal (Section 5.3) 

• 2D Chord (Section 5.4) 

The data displayed in each graph can be exported in numerical form (Section 5.5). 
In the meantime, gauges (single values representing the warpage) can be displayed at 
the bottom of the 3D graphs (Section 5.6). 

5.1 Graphical Output – 3D Surface Plot 

5.1.1 3D Display Window 

To display the 3D Surface plot after analysis, check the box next to 3D on the Graphs 
list in the options window (Section 4.2). After right-clicking and selecting Analyze on the 
phase image or Analysis→Generate Results on a displacement image, a new 3D 
display window is opened and the 3D height map represented in color is shown in the 
center of this window. Interaction with the 3D display when generated from a 
displacement image is similar to that of the original image. Further details on the 3D 
display window generated from a phase image are discussed in this Section 5.1.4. The 
name of the data file will be shown on the top and gauges selected in the options window 
will be displayed below the 3D image. The caption of the 3D display window can be 
renamed by right-clicking on its title bar and selecting Rename Window…. Additional 
information including cursor coordinate position, viewpoint and zoom ratio can be found 
in the status bar at the bottom left. See Figure 5.1. 

5.1.2 Key/Mouse Interactions with the Graph 

There are five interactions that can be done with the 3D graph: 

1. Coordinates of each individual data points are shown live in the status bar by 
hovering the cursor over the 3D image.  

2. Rotate adjusts the angle from which the surface is viewed. Press the left mouse 
button and drag the plot to the desired orientation in the display window. The 
current Rotation and Altitude parameters will be displayed in the status bar.  

3. Zoom adjusts the scale of the plot. Scroll the mouse wheel and change the plot to 
the desired scale in the display window. The current 3D graph magnification level 
will be displayed in the status bar. 

4. Pan adjusts the plot center point. Simultaneously press the Ctrl key and left click 
on the plot to set the center point. Subsequent rotate and zoom functions will rotate 
and zoom about this new point. 

5. Esc key brings the 3D graph back to its original size (zoom ratio of 100%) and 
center point. 
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Figure 5.1 3D Surface Plot 

5.1.3 Changing Viewpoint 

The viewpoint of a 3D graph can be set using four different approaches: 

• Use Latest 3D View box in the options window (Section 4.2) 

• Rotate and Pan operations (Section 5.1.2)  

• Copy View and Paste View in the 3D display command list (Section 5.1.4) 

• The display Configuration window (Section 5.1.5) 

5.1.4 Graph Command List 

Right-clicking on the display window will show a different context menu depending on 
whether it came from a phase image or a displacement file. The context menu for a 3D 
graph created from a phase image is described below. For 3D graphs originating from a 
displacement window, the context menu command list is the same as that on the 3D 
Graph tab in the multi-tabbed *.akx_disp window. See Section 2.4. 

File Allows saving of the current displacement data either 
numerically or as a picture. Also contains commands for 
exporting a legend, printing the picture and closing the 
window. 
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Smooth Applies a smoothing function to the 3D data and shows the 
smoothed surface in a new window. This command can be 
repeated multiple times. See AOTA101 for more 
information. 

Fit Data… Opens a dialog where a polynomial fit can be calculated 
based on the data set. See Figure 5.2. Alternatively, if 
physical dimensions are assigned to the phase image, a 
spherical fit can be calculated. 

Plot Chord(s) Plots pre-defined chords in a new window. 

Show Relative To Displays the relative displacement data calculated by 
subtracting a selected 3D data from the current 3D data in 
a new window.  

Use as Reference Sets the current 3D data to serve as the reference surface 

Invert Inverts Z data 

SOFC… Displays a window containing all Second Order Fit 
Coefficients used to calculate a 2nd order polynomial fit for 
the surface. As of Studio 8.5, this list also includes the 
coefficient of determination, denoted R^2 (R squared). 

Display Contains the copy, paste, and reset view commands for 
applying one 3D graph orientation and zoom to another. 
Also contains Z-Axis units, scale options, and a switch to 
show Pin 1 Location on plots. Lastly, graph configuration 
parameters are accessed here. See Section 5.1.5 

Properties… Opens a displacement object properties window with all 
saved parameters relating to the displacement object. 

 

Figure 5.2 Fit Data Dialog 

5.1.5 Display Configuration Window  

The display configuration window (Figure 5.3) gives the user the ability to customize 
the graph display format. The custom format can be saved and re-used, and set as the 
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default format for all 3D plots. To display the configuration window, right-click inside the 
graph window and select Configure…. 

In the configuration window, to load a previously saved display configuration, choose 
File→Open… (Ctrl+O). To save the current display configuration, choose File→Save…. 
(Ctrl+S). 

 

Note: The display configuration file (*.akx_3Dconfig) 
loaded from the display properties window is applied to 
the current display window (Figure 5.1). Configuration 
files loaded from the Options window (see Section 4.2, 
Figure 4.1) will be applied to all newly created display 
windows. 

 

Figure 5.3 Display Configuration Window 
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5.2 Graphical Output – 3D Contour Plot 

To display the 3D Contour plot after analysis, check the box next to ColorContour 
on the Graphs list in the options window. Most of the contour plot commands and features 
are identical to those described in Section 5.1 (Figure 5.4). 

 

Figure 5.4 Contour Plot 

5.3 Graphical Output – Default Chord Plots 

A chord is a 2D line across the surface of a part. A chord plot graphs the z-values 
along these lines. Surface Analysis can display a wide variety of plots for both default and 
custom chords. The most common default chords are Diagonals, Horizontal Centerline, 
Vertical Centerline, Top Bottom Edges, and Left Right Edges. These common chords are 
all available on the Graphs list in Tools>Options, and checking them there causes these 
chord plots to come up automatically when analyzing a phase image. 

 

Note: The diagonal plot (Figure 5.5) represents two 
cross-sections of the surface along diagonal lines 
connecting the corners. 

The plot window for any of these common chord plots, along with some other default 
chords, can also be opened by right-clicking on the 3D display window and selecting Plot 
Chord(s)→Chord Name. A full list of available default chords is below.  

• Diagonals 
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• Centerlines 

• Top Bottom Edges 

• Left Right Edges 

• All Edges 

• All Edges Centers Diags 

• Five Vertical 

• Five Horizontal 

• Horizontal Centerline 

• Vertical Centerline  

 

Note: All of the chords oriented horizontally are plotted 
from left to right and all vertical chords are plotted from 
top to bottom. 

 

Note: The caption of the 2D display window can be 
renamed by right-clicking on its title bar and selecting 
Rename Window…. 

 

Note: On the 3D Graph tab of a displacement file, 
Analysis→Plot Chord(s)→Chord Name will bring up 
a chord plot. 

\  

Figure 5.5 Diagonal Plot 

5.3.1 Display Command List 

Right-click inside the display window to show the command list. 
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Scale Y-Axis… Displays a window where the minimum and maximum values 
of the Y axis may be modified. Defaults are the min and max 
values of the data plus a software determined buffer. 

Save… Exports the data in numerical format (Section 5.5) 

Save Image… Allows display window to be saved in graphical format 
(*_dia.png). 

Normalized Causes all diagonal plots to be displayed with the endpoints 
for each diagonal set to zero. 

Reset View Resets the graph view after it has been zoomed. 

Print… Allows display window to be printed to any available system 
printer. 

Create Legend… Allows the legend to be saved as a separate picture file for 
reporting purposes. 

Configure… The 2D display properties window is very similar to the 3D 
version described in Section 5.1.5. 

5.4 Graphical Output – Custom Chord Plots 

In addition to the default chords described in Section 5.3, arbitrary chords or chord 
sets can be defined, where out-of-plane displacement data along any line(s) can be 
displayed. The following subsections will describe how to draw a generic chord or chord 
set. 

5.4.1 Creating a Chord 

Right-click inside a phase image and select Advanced→Chord→Add Chord… 
(Ctrl+K). Using the mouse, draw a line across the image, holding down the left mouse 
button at the start point and releasing it at the end point. 

 

Note: Chords can also be plotted on 2D displacement 
images (*.akx_disp files). The menus and functionality 
are the same, but the Chord Menu is found under 
Analysis→Chord. The rest of this section will use the 
terminology for phase images. 

Several preset chords can be added to the phase or displacement image using 
keyboard shortcuts. 

• Shift+T: Top Edge 

• Shift+B: Bottom Edge 

• Shift+L: Left Edge 

• Shift+R: Right Edge 

• Shift+D: Downward diagonal (upper left to lower right corner) 

• Shift+U: Upward diagonal (lower left to upper right corner) 

• Shift+H: Horizontal centerline 

• Shift+V: Vertical centerline 
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Note: Preset chords can be removed by hitting the 
keyboard shortcut a second time. They cannot be 
edited. 

5.4.2 Editing and Plotting Chords 

To reposition the endpoints of a chord, click on the chord. Square white handles will 
appear on either end of the chord, which can be moved with the cursor. 

Right-click on a chord to show the chord command options list: 

Edit… Allows the endpoint positions to be set to specific pixel values 
using text boxes. Also allows renaming of the chord. 

Plot Plots all selected chords in a new 2D display window. 

Plot Set Plots all chords appearing on the phase or displacement 
image (only available when more than one chord is shown on 
the image). 

Reverse Direction Reverses the direction of the data along the chord when 
plotted. Works on all selected chords. 

Align Aligns the chord horizontally or vertically. Works on all 
selected chords. 

Delete (Del) Deletes all selected chords. 

Delete All Deletes all chords. 

When Plot or Plot Set is chosen, calculation is performed and a display window 
appears. All display commands available for Diagonal plots are applicable here, including 
exporting the chord displacement data in numerical form (Section 5.3.1). 

5.4.3 Using a Chord Set 

One or more chords form a set, which can be saved, re-used, and plotted collectively. 
A set is started automatically when the first chord is drawn on the phase or displacement 
image. Additional chords added using Advanced→Chord→Add Chord become part of 
this set. 

A set can be saved by right-clicking on the phase image and choosing 
Advanced→Chord→Save… and a saved set can be loaded by choosing 
Advanced→Chord→Load…(Ctrl+Shift+K). A saved set has a filename ending in 
*.akx_chordset. These files can be loaded in batch analysis and report creation as well 
as on individual phase or displacement images. 

 

Note: If a loaded chord set was generated from a 
larger phase or displacement image than the current 
one, only the chords with both ends falling within the 
current image in that set will be loaded. 

A chord or set of chords can be made visible or invisible by going to 
Advanced→Chord→Visible. Advanced→Chord→Locked prevents moving or 
interacting with chords. 
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5.4.4 Saving a Chord Image 

After a chord or chord set is plotted, the graphical image can be saved by right-
clicking on the 2D image and choosing Save Image…. The image may be saved in PNG 
format with different suffixes as listed below: 

Chord Type File Suffix File Extension 

Diagonal _dia .png 

Horizontal Centerline _hzc .png 

Horizontal Edges _hze .png 

Vertical Centerline _vtc .png 

Vertical Edges _vte .png 

Arbitrary _crd .png 

5.5 Numerical Output 

Numerical data from all display windows can be exported from the context menu. For 
any 2D plot, this is done by right-clicking on the display window and selecting Save…. A 
standard Save window appears with multiple choices for the save format in the Save as 
type pull-down list at the bottom. 3D plots – Color Contour and 3D graph – have slightly 
different context menus and save options, as described in Section 5.1.4.  

Akx_disp Exports data in the Akrometrix akx_disp format (not available 
for chords) 

Dat files Exports data in tab-delimited text format 

Text files Exports data in space-delimited text format 

Dat and text files containing chord data will use the same prefixes as chord image 
files, as described in Section 5.4.4. 

5.6 Gauge Output 

Gauges can be selected in the Gauges list in the Options window and are displayed 
at the bottom of 3D Surface, Contour or Chord plots where appropriate. Gauge definitions 
are available in Akrometrix Optical Techniques and Analyses 101. 



Surface Analysis User Manual 

Page 66 of 126 30-50SW-0001 Ver. 9.0 

6 Interface Analysis 

Utilizing individual surface data captured separately, Interface Analysis (IA) is a 
feature designed to analyze and display mating surface measurements produced by 
Akrometrix warpage measurement systems. IA places 3D plots on top of each other in 
order to visualize and quantify the gaps that might exist across the interface. Gap pass-
fail warning maps can be generated which highlight interconnect areas that would 
possibly fail. IA functionality can be accessed in two different workflows: a one-off mode 
for quick comparison (see Section 6.3), and a batch function (Section 6.4) for many sets 
of surfaces over a temperature profile. 

6.1 Orientation and Registration using IA Metadata 

In order to properly orient the two surfaces being analyzed, the following metadata 
fields are introduced. 

1. Pin 1 Location: Which of the 4 corners of the measured surface is Pin 1 

2. Inner Surface: The attach side of a BGA or PCB in an interface stack of interest 

3. Outer Surface: The non-attach side (e.g. mold compound or top side) of a BGA, or 
the side opposite the attach location for a PCB in an interface stack of interest 

4. Top Part: A part that would physically be located on the top of an interface stack 
of interest during the temperature cycling process 

5. Bottom Part: A part that would physically be located on the bottom of an interface 
stack of interest during the temperature cycling process 

Defining the interface stack of interest is crucial to setting up Interface Analysis 
correctly. In a typical electronic package assembly, there are only single interface stacks 
of interest. The most common of these scenarios is a BGA device on a PCB as in Figure 
6.1. 

 

Figure 6.1 BGA on PCB Interface Stack 

There are other package assemblies where there might be multiple interface stacks 
which affect whether a specific surface is defined as inner vs outer or top vs bottom. In 
Figure 6.2 and Figure 6.3 below, the sandwiched substrate can be defined as both top 
or bottom, and inner or outer depending on which interface is being studied. 
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Figure 6.2 BGA's on both sides of a PCB 

 

Figure 6.3 PoP on a PCB 

If the top interface is studied in Figure 6.2, then the top surface of the PCB would be 
considered an inner surface. If the bottom interface were studied, then this same surface 
would be considered outer. Similarly, the surfaces on the sandwiched BGA in Figure 6.3 
could vary depending on the interface of interest. When studying the interface between 
BGA 1 and BGA 2 in Figure 6.3 the top side of BGA 1 is now considered an inner surface, 
along with the bottom side of BGA 2. 

Once the interface of interest has been determined, and the inner/outer and 
top/bottom assignment been made, the software can rotate and/or flip the data so that 
the pin 1 locations on each surface mate up. If the inner surface of a top part is being 
analyzed, the software flips the data, and then rotates it such that pin 1 matches up. If the 
outer surface of that same part is measured, the data is not flipped. Flipping or not flipping 
the data will occur according to the combinations shown in Table 6.1. After the data has 
been flipped, the software will rotate each surface such that pin 1 is in the same corner 
for both top and bottom surfaces. 

Table 6.1 Surface Type Flip vs No Flip 

 Inner Outer 

Top Flip Don’t Flip 

Bottom Don’t Flip Flip 

When data is gathered in Surface Measurement or analyzed in Surface Analysis, the 
Pin 1 Location, Measured Side, and Interface Location of the part surface can be 
specified. Together, this orientation metadata information is critical to Interface Analysis 
in analyzing and orienting the data sets. 

6.2 Offset Methods 

Another important option when analyzing the interface between two surfaces is how 
the surfaces are offset from one another. The measured gap will be greatly influenced by 
this offset method choice. Interface Analysis offers the following offset methods: 

6.2.1 Closest Point Touching 

The Top and Bottom surfaces are brought together with their LSF planes parallel until 
the first point touches. An example, utilizing the Maximum surfaces from Figure 6.25 and 
Figure 6.26 is shown below. 
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Figure 6.4 Example Diagonals of Closest Point Touching Offset Method 

6.2.2 Closest Point Offset 

This offset method is the same as Closest Point Touching but with a user defined 
value added to account for solder ball height or other attachment interface material. 

6.2.3 Center Gap Constrained 

A 10 x 10 pixel area in the center of the top surface is averaged. This average value 
is then offset by a user defined amount from a similarly calculated average value on the 
bottom surface. In the example below, the offset was chosen to be 0. 

 

Figure 6.5 Example Diagonals of Center Gap Constrained Offset Method 

6.2.4 Edge Gap Constrained 

An average edge value is calculated from all the edges on the top surface. This 
average value is then offset by a user defined amount from a similarly calculated average 
value on the bottom surface. In the example below, the offset chosen was 0. 
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Figure 6.6 Example Diagonals of Edge Gap Constrained Offset Method 

6.2.5 Datum Plane Fixed 

The Least Squares Fit High 0 and Low 0 planes for Bottom and Top surfaces are 
aligned and set to the same Z height in this offset method. 

 

Figure 6.7 Example Diagonals of Datum Plane Fixed Offset Method  

 

Note: Datum Plane Fixed is most useful in Batch IA 
when any significant shape change has occurred in 
either the Top or Bottom statistical group of surfaces. 
By using this method, even if the resulting average 
surface looks nothing like a real surface, the gap at any 
particular point will still be valid. 

6.2.6 Datum Plane Offset 

This offset method is the same as Datum Plane Fixed but with an additional user 
defined offset. 
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6.3 One-Off Interface Analysis 

Under the Analysis section of the displacement window context menu, Interface 
Analysis can be chosen among a list of other open displacement images. Image size 
mismatch is noted in parentheses next to each entry with a green check mark, yellow 
triangle, or red X denoting how reasonable the size agreement is. Displacement images 
not currently open can be opened by selecting the File… menu item at the bottom (Figure 
6.8) and browsing to the file on disk. 

 

Figure 6.8 Selecting a file for Interface Analysis - One-off 

 

Figure 6.9 IA One-Off Result Window 
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Once a file has been chosen, a result window pops up as in Figure 6.9. A Gap slider 
on the left side of the 3D plot allows the two surfaces to be moved towards and away from 
each other. This does not affect the gauge calculations in any way but is only used for 
visualization purposes. 

Alignment and rotation of the two surfaces is accomplished using the IA metadata 
fields, if present. If these metadata are not present, analysis will still proceed but no pin 1 
rotation will occur and the file from which Interface Analysis was initiated will be the bottom 
surface. A note will appear indicating that IA metadata parameters have not been set 
(Figure 6.10). 

 

Figure 6.10 Not all IA metadata parameters set 

 IA 3D plots can be saved and settings altered via a right click context menu (Figure 
6.11). The File menu allows the 3D plot to be saved. Under Display, the Surface Mode 
can be changed between Top/Bottom and Gap modes. Gap mode reduces the dual 
surface view down to just one showing the gap that exists between the two surfaces 
(Figure 6.12). 

 

Figure 6.11 IA 3D Plot Context Menu 

 

Figure 6.12 IA Gap mode plot 

The top and bottom surfaces can be altered, shown, and hidden within the Display 
menu. Additionally, lines and arrows denoting the currently selected chord locations and 
directions can be shown/hidden under the Chords menu item. A pink colored dot locating 
the Pin 1 corner can be shown/hidden, and views can be copied/pasted between open 
3D plots as well. Lastly, a PWF (pass/warning/fail) map can be enabled as either a third 
surface between the top and bottom surfaces (Figure 6.13) or overlaid on top of them 
(Figure 6.14). 
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Figure 6.13 PWF map between Top and Bottom 
surfaces 

 

Figure 6.14 PWF map in overlay mode 

The last main item in the context menu is Interface Analysis Settings (Figure 6.15). 
Here, physical dimensions can be added, and Z units changed between microns and mils. 
In addition, PWF limits can be assigned, and gauges chosen.  

 

Note: PWF limit assignments are always in microns, 
regardless of Z Unit selection. 

If the two surfaces’ pixels dimensions are mismatched, the smaller surface is grown 
by default, but the opposite can be selected as well. Lastly, the Surface Offset Method 
(Section 6.2) can be chosen. 

 

Figure 6.15 Interface Analysis Settings 

 

Figure 6.16 Interface Analysis Chord Context Menu 

The chord section context menu (Figure 6.16) allows different chord groups and 
modes to be selected. In addition, the currently displayed chordset can be saved, either 
as a picture or data file. 
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6.4 Batch Interface Analysis 

Found within the Tools menu, Batch Interface Analysis allows multiple pairs of files 
to be analyzed all at once. Multi-page reports can be created in similar ways to Batch 
Reporting (Section 8). Folders of displacement files (*.akx_disp) are added into a folder 
list via a right click context menu (Figure 6.17). 

 

Figure 6.17 Batch Interface Analysis Add Folder Context Menu 

Once a list of folders is added, a database is built of the file contents and Group 
Results are shown in two tables (Figure 6.18). The first table shows the state of the IA 
specific metadata for the input files in one of three categories, Bottoms, Tops, or 
Unspecified. Any displacement files that do not have all 3 IA metadata fields specified will 
be placed in the Unspecified category and will need to be updated to be included in the 
analysis. A right click context (Figure 6.18) menu allows metadata fields to be updated 
just as in Batch Reporting (Section 8.1.4). 

 

Figure 6.18 Batch Interface Analysis Group Results 

Grouping of the input files can then take place either by the Acquisition Index or 
Temperature Nominal metadata fields. Once the group results are satisfactory, the 
Analysis tab can be selected to choose analysis options. Under Data Processing, there 
are two main options, All Individual Combinations, or Statistical Surfaces. All Individual 
Combinations analyzes every single possible pair of surfaces within each group. 
Statistical Surfaces combine tops and bottoms in a given group into single surfaces to 
compare. The different surface types and how they are calculated are described in 
Section 6.4.1. If Mix Combinations is chosen, different statistical surfaces can be 
calculated for bottom vs. top, although this is not typically used. In addition, there is an 
option to save these surfaces as displacement files to examine them as single surfaces. 
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Options below this are the same as available in one-off IA (Section 6.3). Once they 
are chosen, the Analyze button on the bottom left must be pressed to produce results. A 
preview of the results is shown to the right. Results for either Statistical Surface pairings 
or Individual Combinations can be shown by selecting the surface type from the drop-
down box, typing in specific Top or Bottom surfaces indices, or clicking in the bottom 
table. A right click context menu is available on both 3D and Chord graphs with options 
that are largely similar to the context menu on a one-off IA result window (Figure 6.11). 
In addition, the chord graphs section can be hidden in this context menu (Figure 6.19). 

 

Figure 6.19 Batch IA Analysis Tab Results Preview 

Once all the input data has been analyzed, the report layout can be configured on the 
Layout Settings tab (Figure 6.20). There are 3 main options available, depending on what 
was chosen during the analysis, Statistical Surfaces, Individual Pairings Gauge Extrema, 
and Individual Pairings. If those options are not analyzed, the corresponding section will 
be greyed out on the Layout Settings tab. Statistical Surfaces are discussed in Section 
6.4.1. Individual Pairings shows all possible surface combinations. Individual Pairings 
Gauge Extrema shows specific pairs of data that exhibit the gauge extrema chosen. 
Options are Compatibility, Maximum Gap, or Average Gap. Page titles, subtitles, and 
image titles can all be entered using static text or metadata tags just as in Batch 
Reporting. Metadata tags are discussed further in Section A.1.1. 
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Below the 3 main surface options, are Data Graph options. These can be selected in 
either a Top/Bottom or Gap mode just as in One-off IA. Gauges can be added to graph 
footers using tags and Pin 1 indicator or image annotations added. A number next to the 
Data Graphs checkbox, in parentheses, indicates the total number of graphs that will be 
produced with the given Data Graphs selection. 

 

Figure 6.20 Batch IA Layout Settings Tab 

Report Order and Page Break options follow to the right along with Page Formatting 
and Z-Scaling selection. Report Order chooses what variables or traits are prioritized first 
when building the report and Page Break options determine how and when new pages 
are created. Finally, outputs can be selected in either PDF, video, or image format. The 
selected outputs are created by pressing the Generate button. 

6.4.1 Statistical Surfaces Output 

One of the output options in Batch Interface Analysis examines the possible gaps 
between two surfaces using what are known as statistical surfaces. These surfaces are 
mathematical representations of the real surfaces that are input into the program. All the 
Top input surfaces are rotated to a least squares fit low 0 reference plane (see 
Akrometrix Optical Techniques and Analyses 101 for a discussion of this fit plane) and 
all the Bottom surfaces are rotated to a LSF high 0 plane. Next, the following math 
operations are performed on the combined input surfaces at each pixel location in the 
surface matrix. 
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• Maximum 

Top Surface: The maximum value is pulled from the top sample set at each pixel 
location and used to create the Top Maximum surface. This surface represents the 
maximum value away from the LSF low 0 plane at each pixel location in the input 
surfaces. 

Bottom Surface: The maximum absolute value is pulled from the bottom sample set 
at each pixel location and used to create the Bottom Maximum surface. This surface 
represents the maximum value away from the LSF high 0 plane at each pixel location in 
the input surfaces. 

• Minimum 

Top Surface: The minimum value is pulled from the top sample set at each pixel 
location and used to create the Top Minimum surface. This surface represents the 
minimum value away from the LSF low 0 plane at each pixel location in the input surfaces. 

Bottom Surface: The minimum absolute value is pulled from the bottom sample set 
at each pixel location and used to create the Bottom Minimum surface. This surface 
represents the minimum value away from the LSF high 0 plane at each pixel location in 
the input surfaces. 

• Average 

Top Surface: An average value is calculated at each pixel location and used to create 
the Average surface. This surface represents the average value away from the LSF low 
0 plane at each pixel location in the input surfaces. 

Bottom Surface: An average value is calculated at each pixel location and used to 
create the Average surface. This surface represents the average value away from the 
LSF high 0 plane at each pixel location in the input surfaces. 

• Three Sigma 

Top Surface: The standard deviation of Z values is calculated at each pixel location 
in the Top input surfaces. 3 times this standard deviation is added to the Average Top 
surface in order to create the Three Sigma Top surface. This surface represents the 
maximum normally distributed Z values away from the LSF low 0 plane at each pixel 
location in the Top input surfaces. 

Bottom Surface: The standard deviation of Z values is calculated at each pixel 
location in the Bottom input surfaces. 3 times this standard deviation is then subtracted 
from the Average Bottom surface in order to create the Three Sigma Bottom surface. This 
surface represents the maximum normally distributed Z values away from the LSF high 0 
plane at each pixel location in the Bottom input surfaces. 

• Example 

As an example, the following 4 perfectly spherical surfaces were input into Interface 
Analysis to show the resulting Statistical Surfaces. One concave, and one convex surface 
were the inputs for both top and bottom surfaces. 
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Figure 6.21 Convex LSF Low 0 Top 

 

Figure 6.22 Concave LSF Low 0 Top 

 

Figure 6.23 Convex LSF High 0 Bottom 

 

Figure 6.24 Concave LSF High 0 Bottom 

The Top surfaces and Bottom surfaces are combined mathematically into the 
following composite Maximum surfaces. Notice how the curvatures are inverted 
depending on whether it is a Top Maximum or Bottom Maximum surface. 

 

Figure 6.25 Top Maximum 

 

Figure 6.26 Bottom Maximum 
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Similarly, the following Minimum surfaces are produced: 

 

Figure 6.27 Top Minimum 

 

Figure 6.28 Bottom Minimum 

The Average surfaces turn out to be completely flat in this example: 

 

Figure 6.29 Top Average 

 

Figure 6.30 Bottom Average 

Lastly, the Three Sigma surfaces are produced. If the gaps are normally distributed, 
these surfaces should account for more than 99% of the possible gap values. 

 

Figure 6.31 Top Three Sigma 

 

Figure 6.32 Bottom Three Sigma 

6.5 Gauges 

Please see the Akrometrix Optical Techniques and Analyses 101 document for a 
complete discussion of Interface Analysis dual surface gauges.  
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7 Batch Processing 

7.1 Batch Processing 

Batch processing allows most of the one-off functionality in Surface Analysis to be 
performed on multiple data files with no user interaction. This functionality is very helpful 
when performing large experiments with multiple ROIs and/or multiple temperature 
points. There are six batch functions available: 

• Batch Analyze 

• Batch Mask 

• Batch Rotate 

• Batch Crop 

• Batch Convert 

• Feature Detection 

To access the batch processing functions, select the Tools→Batch Processing… 
menu item. This will open a batch processing window (Figure 7.1). Tabbed screens 
appear for the six batch processing functions. Common menu items for these functions 
appear on a menu bar above the tabs. 

 

Note: Multiple batch processing windows can be 
opened to process different data or process the same 
data with different settings. 

 

Figure 7.1 Batch Processing Screen 
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7.2 Batch Analysis 

The batch analysis function opens the image or displacement files in the selected 
folder(s), analyzes the data, and saves the results in graphical and/or numerical format. 
This is useful, for example, for analyzing all the warpage measurements taken during a 
temperature profile and plotting the results on the same scale. The batch analysis tab 
window shows the conditions to be applied during analysis and display, while the action 
is initiated using the Action menu item. 

Source → Select… Identifies the folder of *.akx_phase or *.akx_disp files on 
which the batch processing functions will be applied. As 
of Studio 8.0, multiple folders can now be analyzed via a 
pop-up folder selector. See Section 7.2.1. 

Edit → File Type Switches between analyzing phase images 
(*.akx_phase) and displacement data (*.akx_disp).  

Edit → Refresh 
Source Folder (F5) 

Allows the user to update the file count since the folder 
was originally selected. 

Edit → Settings → 
Load… 

Loads settings for Batch Processing from a *.akx_recipe 
file 

Edit → Settings → 
Save… 

Saves settings for Batch Processing to a *.akx_recipe 
file 

Edit → Settings → 
Load Defaults… 

Loads program defaults 

Edit → Settings → Set 
From Preferences 

Loads settings from the Options window. 

Edit → Settings → 
Duplicate Window 

Opens a duplicate of the current batch processing 
window, including all loaded data and current settings. 

Edit → ‘Batch Results’ 
Filename Template 

This allows the user to set a template for the filename of 
the Batch Results file, which is automatically saved after 
analysis. The template must contain “Batch Results,” 
and may also contain other strings and metadata tags. 
Metadata tags will use data from the first file in the table 
if applicable, and are available from the right-click 
context menu. Note that the file type cannot be changed 
from this dialog. Tools→Options (Section 4.2) is where 
this can be changed. 

Edit → Output 
Performance →  

Sequential or Parallel: for large batch operations parallel 
will speed up analysis at the expense of populating the 
table in non-sequential order. 

Action → Analyze Analyzes the phase or displacement files loaded into the 
file list. 
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Action → Generate 
Output 

Produces output files (pictures and/or data) of various 
kinds and writes them to disk, as well as displaying 
images in the Output tab. See Section 7.2.5. 

Action → Lock 
Results 

Locks the results of analysis to a particular window. This 
option is not active unless Generate Output has been 
performed. While it is active, the output images will be 
held in temporary memory and will not be affected by any 
other analysis of the same files, allowing the user to 
compare different analysis settings on the same files. 
Unlocking the results will clear them from memory, 
requiring the files to be reanalyzed. 

Action → Create 
Report… 

Opens the report creation window with analysis data 
from the Current Batch pre-loaded in memory. 

7.2.1 Using Batch Analysis 

The key steps in using batch analysis are: 

1. Select a folder to be analyzed (Source→Select… menu item). Multiple folders can 
be added by browsing for folders or by dragging and dropping from another 
window. Filenames can be filtered out by using the Filename Filter checkbox. 
Files can be added from a parent folder by right clicking on an already added folder 
row. Subfolders can be added via a checkbox on the folder row. If multiple rows 
are added, certain rows can be “deactivated” for quick comparison between 
multiple data sets without having to remove or add folders. 

 

Note: A common filename filter that many users might 
find useful is to enclose some part of the filename in 
asterisks. For example, *PT* will only include files that 
include the string “PT” somewhere in the filename. This 
is particularly useful when filtering out part tracked 
search area files from the individual ROIs. PT can be 
substituted for any other string that’s included in all the 
files needed. 

 

Note: The List Files option in the context menu in 
Figure 7.4 gives a list of all filenames of currently-
active files in the folder. This can be used with 
Filename Filter to more precisely filter out any 
unwanted files. 
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Figure 7.2 Batch Analysis Source Selection Browse for Folder 

 

Figure 7.3 Batch Analysis Source Selection Add Folders 

 

 

Figure 7.4 Batch Analysis Source Selection Add from parent... 

2. Once all folders have been added to the Batch Analysis Source dialog, click OK. 
The files from this dialog will be populated into the Batch Analysis Results table 
sans any displacement gauge information. Right-clicking on a row brings up a 
context menu where individual files or folders can be opened. In addition, several 
options allow the user to set the active files en masse. 
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Figure 7.5 Analysis Results Table with Context Menu 

3. Select analysis options (Section 7.2.3) and any additional columns of metadata 
required (right click on column headers in Results tab - Figure 7.6 and Figure 7.7). 

 

Figure 7.6 Batch Analysis Select Metadata Columns... 

 

Figure 7.7 Batch Analysis 
Metadata Column Selector 

4. Analyze the measurement data (Action→Analyze menu item). The measurement 
gauge results will be populated into the table. The extreme values of each 
parameter are shown below, which can provide the default scale for generating 
plots. The table is exported to each top level directory of the folders being 
analyzed.  
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Figure 7.8 Batch Results Table after Analysis 

5. Filter out any data not desired using the Active Metadata File Filter option. Files 
can be unchecked from being Active by setting up filter/logic conditions in the 
Metadata File Filter Query Builder (Figure 7.9). File filter queries can be saved and 
loaded as *.akx_query files in the Query Builder interface for future use. 

 

Figure 7.9 Metadata File Filter Query Builder 

 

Note: All numerical queries occur in microns. The word 
“null” can be substituted for a numerical query to find 
results for gauges that have failed to calculate. 

6. Select desired output and create results. The user may now either go to the 
automated report generator by selecting Action→Create Report (see Section 8) 
to create a formatted pdf report, or create and save images of the results using the 
Action→Generate Output functionality (see Section 7.2.5). Settings for the latter 
are found under Output Options (see Section 7.2.4). 

7.2.2 Using Batch Analysis to Create Relative Plots 

In order to set one of the images in the selected folder as a reference image (Section 
4.4), double-click on one file in the summary table and confirm that all analysis should 
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use its 3D data as reference. The program will then save all graphs and numeric data as 
relative to this reference surface. All other steps remain the same. 

7.2.3 Analysis Settings 

 

Note: Phase operations listed below will not be 
available if the file type is set to *.akx_disp. 

As of Studio 8.6, Analysis settings are grouped into a Simple and Advanced mode. 
Simple mode operates just as it did in previous versions, but Advanced gives the user 
additional flexibility in applying filters in different orders and multiple times. 

 

Note: Many of the gauges listed below are 
abbreviated. Hovering over a given gauge with the 
mouse cursor will show a tooltip with the full name. 

The base batch analysis filtering options are described below: 

Phase 
Amplitude 
Threshold 

Allows adjustment of the phase amplitude threshold on either an 
absolute or relative basis (see Section 3.4). A dialog appears with 
these options when checked. 

Mask Phase Applies a previously-created mask to phase images before 
analysis (see Section 3.2). A Load Mask window appears when 
the box is checked. 

Smooth Phase Applies a smoothing function once to phase images before 
analysis (see Section 3.5.6) 

Physical 
Dimensions 

Assigns a specific physical size to each data file (see Section 
2.3.5). 

Compensate 
(per phase) 

Enables a compensation for the non-planar surface of the grating. 
Physical dimensions are required to perform this calculation 

Mask 
Displacement 
Via Phase 
Amp 

Allows adjustment of the phase amplitude threshold on either an 
absolute or relative basis (see Section 2.4.10). A dialog appears 
with these options when checked. 

Mask 
Displacement 

Applies a previously-created mask to displacement files before 
analysis (see Section 3.2). A Load Mask window appears when 
the box is checked. 

Plane 
Rotation 

Selects the reference plane rotation option to be used during 
analysis (see Section 4.3). Can be turned off to use the grating 
tilt as reference. 

Smooth 
Displacement 

Applies a smoothing function to the surface data. See Optical 
Techniques and Analyses 101 for an explanation of this 
smoothing function. 
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Custom 
Smooth 
Displacement 

Applies a custom smoothing function to the surface data. See 
Optical Techniques and Analyses 101. 

Fit 
Displacement 

Opens a dialog where a polynomial fit can be calculated based on 
the data set. See Figure 5.2. Alternatively, if physical dimensions 
are assigned to the phase image, a spherical fit can be calculated. 

Unwrapping 
Parameters 

Allows adjustment of the unwrapping parameters of each phase 
image for more accurate analysis. See Section 4.6. 

Normalize 
Chords 

Causes all chord plots to be displayed with the endpoints set to 
zero after analysis (see Section 5.3.1). 

Z Units Selects English or metric units for out-of-plane displacement 
results. 

Gauges Selects which gauges (numerical values quantifying flatness) are 
displayed at the bottom of the graphical display windows. A gauge 
on the list may be highlighted by clicking on it once. Checking a 
box means that gauge will be displayed. The up and down arrows 
move the highlighted gauge up and down the list, changing the 
order in which gauges are displayed. Gauges are defined in the 
Optical Techniques and Analyses 101 manual. The ROC, DTA, 
Bow, and Twist gauges all require physical dimensions to be 
applied to the phase image. Step height definition files 
(*.akx_StepDef) can also be loaded and calculated alongside 
normal gauges, as can custom chordsets (*.akx_chordset). 

In the Advanced mode, filters can be adding by using the right click context menu. A 
‘Set All from Simple’ option allows for the Advanced mode to be set to mimic the behavior 
of options currently set in the Simple mode. Additionally, filters can be added in this 
context menu, and settings altered for certain filters. Arrows on the right hand side allow 
filters to be re-ordered. 

 

Figure 7.10. Analysis Settings Advanced Mode 

 

Figure 7.11. Analysis Settings Advanced Mode 
Edit Filter 
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7.2.4 Output Options 

These options affect the results of the Action→Generate Output command (See 
Section 7.2.5). 

.akx_disp Saves *.akx_disp files to disk during analysis. These files are 
produced in memory during analysis anyways, so this saves 
time and an extra step if the user knows that they want them 
anyways. When displacement files are the input, 
*_mod.akx_disp files are saved to denote the modified 
displacement files. 

Graphs & 
Data 

Selects which graph/data/image formats (see Sections 5.1 
through 5.4) are saved during Generate Output.  

Configuration 
File 

Allows the user to load a non-default display format for saved 
graphs. The 3D configuration file has an extension of 
*.akx_3Dconfig and is used for 3D plots (3D and Contour). See 
Section 5.1. The 2D configuration file has an extension of 
*.akx_2Dconfig file and is used for 2D Chord plots. See Section 
5.3.  

Legend Selects if a legend is displayed on each graph. 

Pin 1 
Indicator 

Places a pink sphere on the 3D or Color Contour plot types in 
the pin 1 corner of the data set. 

Min & Max 
Indicators 

Displays blue and red spheres where the min and max Z values 
are on the 3D Graph or Color Contour plots. 

Image 
Annotations: 

Allows arbitrary graphics to be placed on 3D Graph and Color 
Contour plots. Right click to bring up Add Image… context 
menu. Aspect Ratio, Size, Location, and X/Y Offset can be 
controlled to position the image in the desired location. 

 

Figure 7.12 Image Annotations List 

Common Z-
Scale 

When checked, causes all 3D or 2D plots generated by batch 
analysis to use the same vertical scale. Default min and max 
values are determined by the extremes in the combined data 
sets, but may be edited using the text box. When unchecked, 
each image is plotted on a scale set by its own data set. 
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Common Z 
Settings… 

The Auto update switch chooses whether to change the 
Common Z-Scale after each analysis. The Chords use overall 
Min Max switch puts the same Z-Scale into the chord plots as 
the 3Ds. If the user has analyzed something but changed the 
default Z-Scale value based upon the current file list, the Update 
button will restore the default Z-Scale. 

 

Figure 7.13 Common Z Settings 

Output Files This section is only active on chord plot tabs. Chord tabs allow 
the user to select whether images, data, or both are output. 

Header The header for each image file can be created using tags from 
the metadata stored in each input phase or displacement file. 
Available tags can be found in the properties of a phase or 
displacement image. Tags will reference the original file 
metadata such that the entry is a variable changing on input file. 
The default <SourceDataFilenameOnlyNoExt> tag puts the file 
name minus its extension into the header. The user can also 
enter any normal text as a constant header.  

Footer Allows the user to choose the footer from the available gauges 
chosen during analysis. Each gauge is input using brackets and 
the name as spelled in the Analysis Options Gauges section. 
For example, <Coplanarity> will add the Coplanarity gauge to 
the bottom of the graph. “\t” inserts a tab character and “\n” 
inserts a return character to start a new line. 

Graph Image 
Size 

Displays the image size to be output (will vary if config file is 
loaded with different image size). 

After output is generated, image and data files are saved to the folder in which the 
original phase or displacement file is located.  

 

Note: PNG files are the only option for output graphs 
as of Studio 8.0. 

Options for the Surface Data, Phase Image, and 2D Disp Image can be selected by 
right-clicking on the respective data type. These options are explained below. 
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Figure 7.14 Surface Data 
Options 

 

Figure 7.15 Phase Image Options 

 

Figure 7.16 2D Disp Image 
Options 

Surface data files can be exported as either *.dat, or *.txt, for importing into other 
numerical analysis programs. Phase Image files can be saved to disk or not in either the 
processed form (phase smooth is the only option that would change the phase data) or 
raw form. Lastly, 2D Disp Images can be saved to disk or not with either a common Z-
scale across all pictures or individual Z-scales on each picture. 

7.2.5 Output Tab 

After analyzing the data, the user may save images and directly view their results by 
selecting Action→Generate Output. This brings up an Output tab in which all plots 
selected under Output Options are visible. The user can use the arrows and tabs here to 
switch between files and graph types. If the results are locked using Action→Lock 
Results, then the images will remain visible even if the underlying *.akx_disp files are 
altered or overwritten.  

If the user has opened multiple batch processing windows, then it is possible to sync 
the visible image between them, allowing for side-by-side comparison of different analysis 
options. This is done using the context menu shown in Figure 7.17. The sync option is 
not available in a given batch processing tab unless its results are locked. When selected, 
the result plot is changed on all batch processing windows currently open when it is 
changed on one. This allows for quick comparison of results between different batch 
processing windows.  

 

Note: All batch processing results windows must be 
locked for the Sync option to be available. 
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Figure 7.17 Output Tab 

7.3 Batch Masking 

The Batch Mask feature allows the user to automate mask-burning for multiple image 
files contained in a specified folder (Figure 7.18). 

 

Figure 7.18 Batch Burn 

7.3.1 Using Batch Masking 

As of Studio 9.0, there are four distinct forms of masking available in the *.akx_phase 
Batch Mask tab: Phase Amplitude, Layout Mask, Expand Mask Points, and Mask Data 
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Islands. These options can be used independently or together by selecting the various 
checkboxes.  

 

Figure 7.19 Batch Masking Screen 

Layout Mask is the original region mask function. It uses a mask file, as described in 
Section 3.2. The mask file must be created and saved prior to the batch masking 
operation.  

The key steps in masking are: 

1. Select a folder containing data files to be masked (Source→Select… menu item) 

2. Check the boxes for all types of masking that will be applied. 

3. If using Phase Amplitude, check the correct Intensity Scale for the input files and 
the desired Absolute or Relative Threshold. (see Section 3.4 for background) 

4. If using Layout Mask, select a mask file (see Section 3.2 to create and save 
masks) to be applied, then select the Layout behavior. 

5. If using Expand Mask Points or Mask Data Islands, enter pixel counts (see 
Sections 3.2.6 and 3.2.7). 
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6. If using both, choose the order in which Expand Mask Points and Mask Data 
Islands occur (see Section 7.3.7). 

7. Select destination options (Section 7.3.8) 

8. Create and save results (Action→Mask menu item)  

7.3.2 Source, Edit, and Action Menus 

Source → Select… Identifies the folder of *.akx_phase or *.akx_disp files on 
which the mask will be applied.  

Source → Recent Shows the 4 most recent folders that were used. 

Edit → File Type Switches between masking phase images (*.akx_phase) 
and displacement data (*.akx_disp). When masking 
*.akx_disp files, new options become available (see 
Section 7.3.9). 

Edit → Include 
Subfolders 

Applies the batch processing function to subfolders 
within the selected folder in addition to the original folder. 

Edit → Refresh 
Source Folder (F5) 

Allows the user to update the file count since the folder 
was originally selected. 

Action → Mask Performs the mask operation  

7.3.3 Loading a Mask File 

Mask File Click on  button on the right to browse for a mask file. 

7.3.4 Layout Behavior 

Choose whether to scale the input mask file if any difference in dimension exists or 
to preserve the layout. If preserve is chosen and the array dimensions do not match, the 
mask array will be anchored to the top left of each image and any mask regions which lie 
outside the image dimensions will be truncated. 

7.3.5 Expand Mask Points 

Choose how many pixels to expand the mask by. This function takes place after 
Layout Mask. It will extend any masked areas that were already in the image, plus the 
regions from layout mask, if applicable. See Section 3.2.6 for details on expanding mask 
points. 

7.3.6 Mask Data Islands 

Choose how many pixels the largest masked data island should have. Any 
disconnected islands in the data of that size or smaller will be removed. Like Expand 
Mask Points, it will remove both islands that were already present in the data and any 
created by the application of Layout Mask. 

7.3.7 Changing Masking Order 

By default, Expand Mask Points happens before Mask Data Islands, but this order 
can be changed by clicking the <-> button between them. If Expand Mask Points is 
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applied first, then the edges of the mask will push closer and there will likely be more data 
islands small enough to be removed. If data islands are removed first, then any small 
regions of data created by expanding the mask will remain. 

7.3.8 Destination and Naming Options 

Overwrite Files Causes masked files to overwrite original data files. 

Create New Files Saves masked images to a new destination and/or with a 
new name. The original data files are unchanged. 

Destination Selects the folder to which the masked images will be 

saved. Click on the  button to the right to browse for 
the destination folder. 

Rename files as 
*(Masked).akx_phase 
(disp) 

Appends the string “(Masked)” to the end of the original 
filename for the masked file. 

Save In “Masked” 
sub-Folder 

A single new folder named “Masked” will be created in the 
destination folder and all masked files will be saved in this 
subfolder. 

7.3.9 Mask Results Table 

A Results section appears at the bottom of the interface. This table populates with a 
list of the source filenames when files are loaded. The rest of the table does not populate 
until masking has been performed. Once it has, the table fills with percentage masked 
information, plus overall minima and maxima when working with displacement files. The 
resulting information is useful as feedback for whether the given mask operations were 
successful. 

7.3.10 Masking Displacement Files 

When masking *.akx_disp files in Batch Mask, several new options appear in the 
Batch Processing Window, as shown in Figure 7.20. These options are Z-Range Mask 
and Plane Rotation. 

Displacement files can be masked with the standard mask operations described 
earlier, Z-Range Masks, or some combination thereof. Z-Range Mask functionality is 
described in Section 2.4.8, and works with the same options in batch mode as in one-
off. In Absolute or Percent modes, a range and mask logic are set to mask the source 
files, or a *.akx_zRangeMask file is loaded containing these settings. To enter Region 
mode, a *.akx_zRangeMask file must be loaded containing at least one region. The 
metric, logic, and offset can then be adjusted just as in one-off mode before masking.  

Plane Rotation allows the masked data rotation to be adjusted. The rotation options 
are those described in Section 4.3. This is useful for masking out noisy data that might 
have adversely affected initial rotation. 

The order of the different masking operations is indicated by the numbers before each 
operation name and should be kept in mind when using several different operations. 
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Figure 7.20 Batch Mask Results for Displacement Files 

7.4 Batch Rotation 

7.4.1 Using Batch Rotation 

Phase image rotation is described in Section 3.7 and also applies to displacement 
files. This batch function rotates all the images in the selected folder according to the 
options set in the batch rotation tab window. The batch rotation screen is shown in Figure 
7.21. 
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Figure 7.21 Batch Rotation Screen 

The key steps in using batch rotation are: 

1. Select a folder containing images to be rotated (Source→Select… menu item) 

2. Select rotation options (see Section 7.4.2) 

3. Select destination options (see Section 7.4.3) 

4. Create and save results (Action→Rotate menu item) 

The Source, Edit, and Action menus for Rotation are all virtually identical to the Mask 
operation. 

7.4.2 Rotation Options 

Angle Enter number of degrees to rotate the image clockwise or 
counterclockwise. 

7.4.3 Destination and Naming Options 

Overwrite Files Causes rotated data to overwrite original data files. 

Create New Files Saves rotated data to a new destination and/or with a new 
name. The original data files are unchanged. 

Destination Selects the folder to which the rotated data will be saved. 

Click on the  button to the right to browse for the 
destination folder. 

Rename files as 
*(Rotated).akx_phase 
(disp) 

Appends the string “(Rotated)” to the end of the original 
filename for the rotated file. 

Save In “Rotated” 
sub-Folder 

A single new folder named “Rotated” will be created in the 
destination folder and all rotated files will be saved in this 
subfolder. 
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7.5 Batch Cropping 

Batch cropping allows the user to extract multiple regions of interest from multiple 
phase or displacement images. For example, a measurement test which produces 
measurement data at three temperature points, with each phase or displacement image 
containing four regions of interest (3 × 4 = 12 measurements), can be easily analyzed in 
a two-step procedure: batch cropping, followed by batch analysis (Figure 7.22). 

 

 

Figure 7.22 Batch Cropping and Analysis 

As of Studio 8.5, there are two methods of cropping a file available on the Batch Crop 
tab: Crop To Extents and Partition. 

Crop To Extents removes masked data (white space) from the edges of images and 
does not require a partition. This is most useful after analysis that involved removing data 
from the edges of an image via masking. See Section 3.5.6 for a graphical illustration of 
how Crop To Extents works. 

7.5.1 Using Batch Cropping 

The cropping mode can be changed by using the radio buttons at the top of the batch 
crop tab. 

Crop to Extents does not require a partition but otherwise uses the same process as 
partition cropping, including the creation of new, cropped files. 

Partition cropping requires that the user has created a partition file as described in 
Section 3.5. This must be created and saved prior to the batch cropping operation. The 
partition may contain one or more ROIs. All the ROIs from each image in the selected 
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folder are saved as new, independent files, organized and named using the Destination 
Options on the batch crop tab.  

If Partition mode is selected, the user must also choose a partition file and layout 
behavior (see Section 7.5.2) To choose a partition, click on the  button and browse for 
it. A preview of the partition file will show on the right. 

The resulting image files can be batch processed in a second step to complete the 
analysis. The batch cropping screen is shown in Figure 7.23. 

The key steps in using batch cropping are:  

1. Select a folder containing images to be cropped (Source→Select… menu item)  

2. Either select a partition (see Section 3.5 to create and save partitions) to be 
applied, or choose Crop To Extents. 

3. Select destination options (Section 7.5.3)  

4. Create and save results (Action→Crop menu item)  

 

 

Figure 7.23 Batch Cropping Screen 

7.5.2 Partition Layout Behavior 

In Partition mode, the Layout Behavior must be selected. Choose whether to scale 
the input partition file if any difference in dimension exists or to preserve the layout. If 
preserve is chosen and the array dimensions do not match, the partition array will be 
anchored to the top left of each image and any regions which lie outside the image 
dimensions will be truncated. 
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7.5.3 Destination and Naming Options 

Because Crop To Extents does not use a partition file, some of these options are 
absent or greyed out in that mode. 

Overwrite Files Causes cropped files to overwrite original data files. This 
should not be used for partition crop with multiple 
domains. 

Create New Files Saves cropped images to a new destination with a new 
name. The original data files are unchanged. 

Output Roi Name 
Template 

Allows the user to create a template for ROI names of the 
output files. This template must contain the 
<PartitionRoiName> metadata tag. It may also contain 
other metadata tags or strings. Preset templates and 
common metadata tags are accessible through the right-
click context menu. 

Destination Selects the folder to which the cropped images will be 

saved. Click on the  button to the right to browse for 
the destination folder. 

Save in Source 
Filename sub-
Folders 

A new folder will be created for each file in the source 
folder and all cropped images derived from each file will 
be collected in this subfolder.  

Save in ROI sub-
Folder(s) 

A new folder will be created for each ROI in the partition 
and all cropped data derived from this ROI for all files will 
be collected in this subfolder.  

Save In “Cropped” 
sub-Folder 

A single new folder named “Cropped” will be created in 
the destination folder and all cropped files will be collected 
in this subfolder. 

Output Filename 
Template 

Allows the user to create a template for the filenames of 
the output files. To avoid overwriting, this template must 
contain the <SourceDataFilenameOnlyNoExt> tag, as 
well as <PartitionRoiName> in Partition mode. It may also 
contain other metadata tags or strings. Preset templates 
and common metadata tags are accessible through the 
right-click context menu. 

7.6 Batch Edit XY Orientation 

This functionality has been moved to the more powerful metadata editing capabilities 
in either Batch Edit akx_phase Metadata… or Create Report… Batch Edit akx_phase 
Metadata… (See Section 8.1.6) allows the user to edit metadata for akx_phase files. 
Create Report… (See Section 8) allows the editing of metadata for akx_disp files. 
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7.7 Batch Convert 

Converts *.akx_disp files containing phase data back to the *.akx_phase format. The 
key steps in using batch converting are: 

1. Select a folder containing displacement files to be converted (Source→Select… 
menu item) 

2. Perform the Batch Convert operation (Action→Convert menu item) 
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7.8 Batch Feature Detection 

7.8.1 Using Batch Feature Detection 

Batch Feature Detection allows the user to apply the Feature Detection function 
described in Section 2.4.7 to a specified folder of displacement files. This batch function 
detects features according to options loaded in a settings file and edited in the batch 
feature detection tab window, then applies a customized mask based on the detected 
features. The batch Feature Detection screen is shown in Figure 7.24. 

 

Figure 7.24 Batch Feature Detection Screen  

The key steps in using Feature Detection are: 

1. Select a folder containing *.akx_disp images to be masked (Source→Select… 
menu item) 

2. Load in a Feature Detection Settings file and edit the settings if desired (see 
Section 7.8.2). 

3. Select destination options (see Section 7.8.3) 

4. Create and save results (Action→Detect Features menu item) 
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5. View results in Results table (see Section 7.8.4). 

The Source, Edit, and Action menus for Feature Detection are all virtually identical to 
the Mask operation. 

7.8.2 Feature Detection Settings 

These Settings are all identical to those in the Feature Detection Parameter Window, 
which is described in Section 2.4.7. They are set by loading the Feature Detection 
Settings file, but can be edited by the user before batch detection. 

The user cannot, however, edit the detection ROI as is possible in one-off Feature 
Detection. The region or detected feature present in the loaded settings file is used. 

7.8.3 Destination and Naming Options 

Overwrite Files Resulting data overwrites original data files. 

Create New Files Saves resulting data to a new destination and/or with a new 
name. The original data files are unchanged. 

Destination Selects the output folder where resulting data is saved. 

Click on the  button to the right to browse for the 
destination folder. 

Rename files as 
*(FeatDet).akx_disp 

Appends the string “(FeatDet)” to the end of the original 
filename for the resulting data. 

Save In “FeatDet” 
sub-Folder 

A single new folder named “FeatDet” will be created in the 
destination folder and all resulting data will be saved in this 
subfolder. This is only available when the destination folder 
is the same as the source folder. 

7.8.4 Results Table 

The last section of the Batch Feature Detection Tab is the results table. This table is 
similar in functionality to the results table for Batch Mask, which is described in Section 
7.3.9. This table populates with a list of the source filenames when files are loaded, but 
does not fully populate until Feature Detection has been performed. Once populated, the 
table contains not only data about minima and maxima in the source and destination files, 
but also the number of features that were detected in each source file. All of this lets the 
user assess the quality of the feature detection operation. 
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8 Batch Reporting 

As of Studio 8.0, Surface Analysis now incorporates the ability to batch create reports 
based on the metadata (Section A.1.1) from each displacement file being analyzed. The 
Create Report window has three subsections: Groups, Roi Selector, and Layout Settings. 
A File menu allows saving and loading settings as a *.akx_ReportSettings file. When 
loading settings, the user can choose to load Source Folders, Grouping Parameters, 
and/or Layout Settings (Figure 8.1). 

 

Figure 8.1 Load Report Settings Filter 

As of Studio 8.6, Surface Analysis now allows for groups of room temperature data 
to be reported on. A radio button selection toggles between the thermal profile based and 
room temperature modes. 

 

Note: The Add file to profile… function described in 
Section 8.1.4 can be used to apply profile metadata to 
an orphaned measurement (typically a room 
temperature acquisition taken manually at the end of a 
profile).  

8.1 Grouping by Metadata fields 

Grouping can either happen before or after analysis. For purposes of analysis, 
multiple folders can be selected. See Section 7.2.1 for details on how to add folders. The 
context menus are identical in the Group interface Folder List section as they are to the 
folder selection interface in Batch Analysis. 

 

Note: If the Create Report function was opened from 
Batch Processing, the Folder List context menus will 
initially be the same as if there was no data, despite 
the analyzed data being present. New folders can still 
be added and removed, but the analyzed data cannot 
be removed or made inactive from the folder list. 
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Figure 8.2 Grouping Window 

 

Note: When the ‘Room Temp’ mode is selected, 
grouping parameters having to do with temperature 
profiles are disabled. 

8.1.1 Files 

Once the appropriate folders have been added to the Folder List, files can be filtered 
out by entering in search strings that the user desires. The “*” character can be added 
before, after, or in the middle of a string to denote parts of the filename that aren’t 
important to match. Other search query syntax examples can be found in the table below. 

Example Filename Filter Finds Files That... 

BGA contain 'BGA' 

Profile board contain 'Profile' and 'board' (any order) 

Subroom BGA contain the exact phrase 'Subroom BGA' 

Profile1 OR Profile2 contain 'Profile1' or 'Profile2' 

NOT SearchArea do not contain 'SearchArea' 

PT (0001 OR 0002) contain 'PT' with '0001' or '0002' 

0001 from OR "0002 from" contain the exact phrases '0001 from' or '0002 from' 

feasibility NOT msk contain 'feasibility' but not 'msk' 
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(Board1 OR Board2) (200C OR 223C OR 252C) contain 'Board1' or 'Board2' with '200C', '223C' or '252C' 

Roi0003 NOT ("Component Side" OR Demo) contain 'Roi0003' but not with 'Component Side' or 'Demo' 

Tray 1 OR NOT Cropped contain 'Tray 1' or do not contain 'Cropped' 

Profile (BGA OR ("Substrate Test")) contain 'Profile' with 'BGA' Or 'Substrate Test' 

Once the appropriate files are loaded into the folder list, the files must be indexed by 
clicking Build Database. After a database has been built, the files will be grouped together 
by acquisition index. If the user wishes to break the files into different groups for reporting 
purposes, one or more of the Grouping Parameters must be selected. 

8.1.2 Grouping Parameters 

1. Group By Folder: Source Folder or Full Path. Source Folder will use the name of 
the source folders to form groups. Any folder names that are repeated, but in 
different locations, will form one group. Full Path will use the unique Full Path for 
each input folder as the groups. 

2. Max Allowable Delta Temperature Setpoint (C): Sets the max allowable difference 
for setpoint temperature. This will allow setpoint temperatures that are off by a user 
specified amount to be grouped together despite the difference. Common 
acquisition indices are compared and the greatest differential is referenced for 
grouping. 

3. Max Allowable Delta Temperature Reading (C): Sets the max allowable difference 
for acquisition temperature. This will allow acquisition temperatures that are off by 
a user specified amount to be grouped together despite the difference. Common 
acquisition indices are compared and the greatest differential is referenced for 
grouping. 

4. Max Allowable Delta Profile Runtime (sec): Sets the max allowable difference in 
acquisition time. This will allow acquisition times that are off by a user specified 
amount to be grouped together despite the difference. Common acquisition indices 
are compared and the greatest differential is referenced for grouping. 

5. Time-Based Acquisition Matching: Only available if both ‘Max Allowable Delta 
Profile Runtime (sec)’ and ‘Group Common Acquisitions’ are selected. This 
parameter ignores acquisition index for grouping and instead groups based on 
time, referencing Max Allowable Delta Profile Runtime (sec). This option could be 
used if comparing two similar profiles where one profile had an extra acquisition 
inserted within the profile. 

6. Max Number Of Profiles: Sets the max number of profiles in a group. 

7. Max Number Of Rois: Sets the max number of Roi names in a group. 

8. Max Number Of Roi Sizes: Sets the max number of ROI sizes in a group. 

9. Max Number Of Roi Locations: Sets the max number of ROI locations in a group. 

10. Max Allowable Delta Roi Location X: Sets the max difference in X axis location of 
the region of interest. 
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11. Max Allowable Delta Roi Location Y: Sets the max difference in Y axis location of 
the region of interest. 

12. Max Allowable Delta Roi Width: Sets the max size difference along the X axis of 
the region of interest. 

13. Max Allowable Delta Roi Height: Sets the max size difference along the Y axis of 
the region of interest. 

14. Group Common Acquisitions: If multiple profiles are being reported on and the 
acquisition indexes aren’t all coincident, this option will filter out orphaned 
acquisitions. In Figure 8.3, the profiles being reported on have varying numbers 
of acquisitions and in Profile 2, the first acquisition has been removed. By checking 
this option, only the acquisitions highlighted in yellow will be added to the report. 

 

Figure 8.3 Group Common Acquisitions Example 

 

Note: When in doubt about a grouping parameter’s 
effect on the output groups, it can be quite useful to 
simply trial and error the setting in question to see the 
effect on the data. 

8.1.3 Metadata File Filter 

Files can be filtered out of the resulting groups by setting up filter/logic conditions in 
the Metadata File Filter. File filter queries can be saved and loaded as *.akx_query files 
in the Query Builder interface for future use. 

 

Figure 8.4 Metadata File Filter Query Builder 

Multiple logic conditions can be set using AND/OR conditionals as well as 
parentheses around sets of conditions. Conditions can be added or removed using the + 
and – buttons. Virtually any metadata field within the displacement files can be queried 
against. 

Profile 1 1 2 3 4 5

Profile 2 2 3

Profile 3 1 2 3

Acquisition Index
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Note: The first query line AND/OR conditional is 
ignored. 

8.1.4 Group Results and Editing Metadata 

Once the files are indexed, all groups are shown in the Group Results section (Figure 
8.5). This section lists pertinent information about each group, such as number of files, 
number of ROI names and locations, and number of temperature profiles. Individual 
groups can be activated or deactivated in this section, making it trivial to choose which 
ROIs go in the final report. 

 

Note: An asterisk next to the number of files indicates 
that some files were excluded. 

 

Figure 8.5 Group Results 

The Edit Group Metadata window can be loaded from the context menu, or by double-
clicking on any group. It allows the user to change ROI names and other metadata to 
better organize and label the report (Figure 8.5). 

 

Figure 8.6 Edit Group Metadata 
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Figure 8.7 Edit Group Metadata - Roi Name Converter 

In the Edit Group Metadata window that pops up (Figure 8.6), multiple metadata 
fields can be edited, including Temp Nominal, Pin 1 Location, Measured Side, Lot Id, 
Operator Id, Product Id, and Test Id. If a new value is entered into a field, it will be 
highlighted in yellow until the user clicks the Update button. The Temp Nominal context 
menu will allow the user to set its value to the Setpoint. 

 

Note: Batch editing of Pin 1 Location and Measured 
Side is useful when preparing files for Interface 
Analysis. 

The user can also choose what each file’s New Roi Name will be via the Roi Name 
Converter column. The resulting ROI name, including the current values of entered tags, 
will be shown in the New ROI Name column. By default, the <fn: Before 1st 
Underscore> function provided will create a New Roi Name by parsing the input filename 
and using the string before the first underscore. Usually this corresponds to the Test ID 
based on how Surface Measurement creates filenames by default. In cases where this 
does not make sense, however, the user can enter a static string, or any of the metadata 
fields surrounded by Less Than or Greater Than signs. For instance, <LotId> would enter 
the Lot Id metadata information. A list of available Metadata tags is accessible by right-
clicking on the Converter field. A few other predefined functions are also available via this 
same context menu (Figure 8.7). The user can also filter ROI names using custom regex 
converters, which are described in Section 8.1.5. 

Strings can be copied and pasted into new rows. Also, multiple rows can be selected 
at once by shift-clicking, clicking and dragging, or Ctrl+clicking, allowing values to be 
pasted onto multiple rows at once. The keyboard shortcuts Ctrl+C and Ctrl+V can be used 
to copy and paste values, and Ctrl+A can be used to select all values in a column for 
editing. 

 

Note: Any changes to file metadata will not be made 
until the Update button is pressed. To change ROI 
names based on a metadata update, it is necessary to 
update the metadata first and then reopen the Edit 
Group Metadata window. 
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If a file with no profile information is found from the input data, it is possible to add 
this orphaned file (a typical example would be data taken manually after a profile is 
complete) to an existing profile. In the Group Results section of Create Report, right-
clicking on a group will bring up a context menu (Figure 8.8). If multiple files are orphaned, 
when Add file to profile… is selected, the user will have to choose which file to add to a 
profile (Figure 8.9). Likewise, once the file to be added is selected, the profile to which 
they will be added must be chosen (Figure 8.10). With the profile selected, the user can 
choose the Setpoint, Temp Reading, Profile Runtime, and Acquisition Index to add 
to the metadata for that file. In addition, the modified file can be renamed. Once the profile 
data for a file has been changed, it will automatically be moved to the correct group 
(Figure 8.11). 

For files that are already assigned to a profile, these can be reassigned to other 
profiles if somehow their metadata is incorrect. The process for doing this is identical to 
adding a file to a profile. 

 

Figure 8.8 Group Results - Context Menu for Orphaned Files 

 

Figure 8.9 Add File to Profile - File Selector 

 

Figure 8.10 Add File to Profile - Profile Selector 

 

Figure 8.11 Group Results after Adding Files to Profile 



Surface Analysis User Manual 

 30-50SW-0001 Ver. 9.0 Page 109 of 126 

8.1.5 Custom Converters 

Figure 8.12 displays several custom regex converters, which allow easy extraction 
of specific character series from a filename and thereby easy ROI naming in the Edit 
Metadata window. The specific rules followed by custom converters are shown below. 

 

Figure 8.12 Custom Regex Converters 

1. Custom converters begin with <regex: and end with :regex> 

2. Custom converters can optionally include a ‘Group Index’ specifier, which may be 
required to get the desired regex match 

a. If no Group Index is specified, group index is 0 (default). 
b. Group Index is the first item included inside the regex syntax, and ends with a 

colon, specified as G#: or G##: 

3. Custom converters can operate on 1 of 4 sources (specifiers are NOT case-
sensitive): a colon is required after the source 

a. Filename, specified as FN 
b. Filepath (entire path, not including the filename), specified as FP 
c. Partition Full Path, specified as PFP 
d. Roi Name, specified as ROI 

4. The regex expression is supplied AFTER the source colon. 

5. Examples: 

a. <regex:fn:^.{0,4}:regex> the first 4 characters of the filename 
b. <regex:fn:.{0,5}$:regex> the last 5 characters of the filename 
c. <regex:G1:PFP:.{7}(.{6}):regex> a 6 character long substring of the partition 

full path, starting at index 7 
d. <regex:ROI:.{0,2}$:regex> the last two characters of the Roi Name 
e. <regex:G1:FP:.{9}(.{4}):regex> a 4 character long substring of the filepath, 

starting at index 9 

 

Note: Strings start at index 0. This is important for any 
search involving a numbered index.  
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8.1.6 Batch Edit akx_phase Metadata 

Metadata manipulation is also available for phase images in the Edit akx_phase 
Metadata window. This window (Figure 8.13) is accessible from Tools→Batch Edit 
akx_phase Metadata, similarly to the Create Report window. From this window, all profile 
reassignment and metadata editing described in Section 8.1.4 is available for Phase 
images. Changing metadata for phase images can increase efficiency in data processing, 
since these metadata changes will not be overwritten if the data is reanalyzed, which 
would create new *.akx_disp files. 

 

Figure 8.13 Edit akx_phase Metadata 

8.2 Selecting ROI’s 

In the Roi Selector tab (Figure 8.14), the user can view 3D graphs of all active files, 
sorted into tabs by group. This tab allows the user can see a thumbnail view of a 3D graph 
for each active file, sorted into tabs by group. The user can then quickly find the minima 
and maxima, both overall and in each group, and discard any bad data before generating 
a report. From this tab, the user can also open any individual *.akx_disp file in the report, 
or the folder that contains said file. This is done using right-click context menus on each 
thumbnail image. In addition, files can be included or removed en masse with Include 
All, Include None, Invert Included, and Include via metadata query… commands. 
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The user can activate or deactivate individual ROIs in each group by clicking on them. 
In addition, entire rows or columns can be removed from the report entirely. These 
operations are the only things in this tab that affect the resulting report – the other options 
at the bottom of this window affect only the data displayed in the Roi Selector tab. These 
options include changing the size of the thumbnail images and editing the units of the Z-
scale. Any changes made by the user will be applied when the Update button is pressed. 
The values of the minima and maxima for each group are displayed automatically, with 
the figures that have those values being highlighted in shades of purple – dark for Min, 
and light for Max. 

Using the common Z-Scale menu, the user can decide whether Z-scales for the 3D 
graphs are shared within individual groups, within all files, or not at all. When Across 
Groups is selected as the common Z-Scale, the minimum and maximum overall Z-values 
will be displayed, as well as the range, and clicking on the Min and Max buttons will 
change the selected group to the one with the lowest or highest Z-value, respectively. 

 

Figure 8.14 Roi Selector 

8.3 Choosing Report Layout Settings 

Once appropriate ROIs for the report have been organized into groups with any bad 
data discarded, the user can use the Layout Settings tab to determine the formatting and 
displayed data of the final report. The user also has the option to deactivate groups 
without changing other settings, making it simple to create both overall reports and 
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individual reports for different groups. The user has a variety of options in this tab, 
separated into several subsections. 

8.3.1 Group and Plot Selection 

The uppermost section of the Layout Settings tab offers several useful options. The 
user can choose which groups to include in a report using the Active checkboxes. They 
can see a variety of information about the group, including Z-Range, group number, 
number of ROI names, and the name of the first file in the group. Mousing over some of 
these cells will show a tooltip with further information, such as a list of all the ROI names, 
or currently selected Gauge Plots. 

Further to the right, this section also contains several editable labels that can appear 
in the report. These can be used to create titles for individual images, series labels in the 
legends of Gauge vs temperature plots, page titles and subtitles, and footers. Any of these 
options can use metadata tags like <RoiName> and <PageGraphType>. The labels will 
appear only on pages with data for the selected group, and the report will automatically 
separate groups into different sections. 

 

Figure 8.15 Layout Settings Tab 

The user can also click on the Gauge Plots cell for any group in this section. This will 
open the Gauge Plot Selector window shown in Figure 8.16. From this window, the user 
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can choose which of the calculated gauges to display in the report, and which statistical 
values should be displayed for those gauges. These values can be calculated for each 
ROI, for each temperature point, or globally throughout a group. Selecting an option by 
clicking on it and moving it up and down in the list with the arrows will reorder the gauge 
plots in the report. 

 

Note: If a desired gauge is not in this list, then it was 
not calculated during analysis. In Batch Processing, 
the user must select whichever gauges are desired in 
the final report, so that they are present in the 
*.akx_disp files that are used to build the report. 

 

Figure 8.16 Gauge Plot Selector 

8.3.2 Output Options 

This section allows the user to decide what graphs will be shown in the report, how 
they are configured, and what footer information the graphs have. Editing the 
configuration of graphs requires loading a previously created *.akx_2dConfig or 
*.akx_3dConfig file (depending on graph type) for each graph that is changed from its 
default layout.  

The Normalize checkbox causes all 2D chord plots to be displayed with the endpoints 
referenced to zero. The Pin 1 Indicator checkbox causes all images of the part to have a 
dot indicating the location of Pin 1. This function uses the Pin 1 metadata for the file, so 
requires that information to be specified. Image Annotations can be added as described 
in Section 7.2.4. 
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Finally, to add footers to the graph, the user can choose from a list of tags that 
changes with the selected graph. The user may also use tab (/t) and new line (/n) tags to 
format the footers in the final report. 

 

Note: In addition to the default output plots, custom 
chord plots can be loaded in using *.akx_chordset files 
and plotted like any other 2D graph. 

8.3.3 Report Order 

This option determines what data ordering takes precedence within a group. The 
default is Profile > ROI > Graph Type > Temperature. These options change to Acquire 
Timestamp > ROI > Graph Type when in ‘Room Temp’ mode. 

8.3.4 Page Break 

This determines after what data page breaks occur. The default is Profile, ROI, and 
Graph Type, but not temperature. These options change to Acquire Timestamp > Graph 
Type > ROI when in ‘Room Temp’ mode. 

8.3.5 Z-Scaling 

This section allows the user to choose the Z-scale for displacement graphs. They can 
choose the units of Z, and either enter a custom Z-scale or choose an automatic Z-scale. 
The automatic options are None, Per Group, and Across Groups. The ‘Chords Use 
Overall Min Max’ option determines whether 2D chord plots use individual minima and 
maxima in their z-scales, or the overall minima and maxima across all groups. 

8.3.6 Page Formatting 

1. Size – Letter or A4 

2. Orientation – Portrait or Landscape 

3. Layout: - Choose the # of columns and rows for plot pages. Predefined options for 
6/page or 24/page 

4. Separator Lines – Option to show lines separating plots. Options are None, 
Horizontal, Vertical, or Both 

5. Fill Direction – This option lets the user decide whether initial population of figures 
and graphs is top-bottom and then left-right, or vice versa. 

6. XY Unit – This lets the user determine the XY units on each graph if a lateral 
resolution is specified in each file. This would allow the graph XY axes to be shown 
in physical units instead of pixels. 

8.3.7 Gauge Table/Graph Displayed Temp 

This allows the user to choose from three temperatures for gauge tables and graphing 
gauges: Average reading temperature at that time, nominal temperature chosen in Profile 
Generator, or the Setpoint temperature of the profile. 

8.3.8 Header Image 

This allows the user to choose a header image to be placed at the top of each page. 
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8.3.9 Output 

Once all settings have been selected, the user can use the Output section to 
determine what results will be generated. There are three possible types of output – 
Report, Video, and Images – and any or all of them may be generated at one time by 
selecting their check boxes and pressing Generate.  

Generating any output requires appropriate save data, which the user is automatically 
prompted to enter if none has yet been added. Report and Video need both filename and 
destination folder, while Images only needs a destination folder. The first time that a 
filename or destination folder is entered, it will be shared to the other outputs. The … 
buttons after each option can be used to independently edit destinations and filenames 
for each output. 

1. Report – This is a pdf report containing all selected images and gauges. It is the 
most common option, and the one to which many of the customization options in 
the Layout Settings tab are dedicated. Figure 8.17 shows an example. Checking 
Open Report After Generating allows the user to immediately see the results 
when the report has been created.  

2. Gauge Preview – This button generates a pdf containing gauge results based on 
current settings but no images. Since no images are saved, this allows the user to 
more quickly see how the groups are organized and what the overall numerical 
results look like. This button works regardless of whether Report has been selected 
as an active output. 

3. Video – This is a video file which strings together all gauge plots and all selected 
images. The user can choose image size and the delay between images in the 
video.  

4. Images – This option saves all images selected in Output Options to a user 
selected folder. The user may select the image size. 
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Figure 8.17 Example Report with 6 images per page
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9 Manual Reporting 

Formerly an independent application in the Akrometrix Studio software platform, the 
Manual Report feature is now a part of Surface Analysis. It consists of a simple 6-up 
graphical layout tool (Figure 9.1) for creating reports from static image files. Typically, 
these are 3D, 2D, and Temperature Profile graphs produced by other Akrometrix software 
applications, but any image file can be used. Output PDFs created feature multi-figure 
portrait-style report pages, with up to six graphs and two legends on “Letter” sized paper. 

 

Figure 9.1 Manual Report Window 

The report page layout consists of eight image locations and nine textboxes. The 
larger image locations are designed to hold the typical 3D or 2D plots created in Surface 
Measurement or Surface Analysis.  In addition, any *.bmp, *.png, *.jpg, or *.tif image files 
can be loaded as well. The smaller image locations near the top are designed around 
holding the typical 2D (Chord) and 3D legend image files, respectively. 
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The textboxes control the Main Title, Secondary Title, individual Image Titles, and 
Footer text for each page. As pages are added to the report, page navigation is 
accomplished with the Previous Page / Next Page (< >) buttons found at the bottom of 
the screen below the footer textbox. The current page and total number of report pages 
are indicated between these buttons. 

9.1 Adding Page Contents 

Images are added to a report page by dragging and dropping a selected image file or 
files from a Windows Explorer window onto the desired destination image location. 
Alternatively, left clicking on the image location itself will bring up a load image dialog to 
browse to the file. 

If multiple files are selected (using Ctrl or Shift), image locations are filled in numerical 
order (starting with the dropped destination location) according to the file selection order.  

Individual image locations are also assigned by right clicking on the location and 
selecting Load Image… from the popup menu that appears. A standard Windows Open 
File dialog box is shown allowing the user to select a file.  

After an image has been assigned to a particular location, its filename pops up in a 
tool tip whenever the mouse pointer is paused over the image. The selected image 
(outlined in blue) can be viewed full-size by pressing Enter or double clicking on the image 
location. The full-size view is closed by pressing Enter, clicking on the OK button, or 
pressing “X” at the upper right of the window. 

In addition to entering new text, the textbox controls allow the user to select previously 
entered text from a pull-down list. Typed text is added to the list whenever a textbox loses 
its focus. 

9.2 Editing a Report 

The Edit menu allows the user to Add, Insert, and Delete report pages as well as 
remove all images in the report. Adding a page appends it the end of the report while 
inserting one places it before the next page relative to the currently viewed page. Any 
new page added or inserted copies the text entry fields from the currently viewed page, 
allowing patterns to be easily repeated and altered. In addition, the currently viewed page 
textbox entries can be duplicated to all report pages.  
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Figure 9.2 Manual Report Image Context Menu 

Individual images can be easily moved within the same page. Image locations are 
also manipulated with a right click context menu allowing Cut, Copy, Paste, Delete, and 
Clear operations, among others (Figure 9.2). 

9.3 Saving the Report 

After all report pages and titles have been assigned, the report can be saved by going 
to File→Save. This will save a *.akx_ManualReportContent file with the image locations 
and text box field entries so the report can be loaded/modified/generated at a later date. 

 

Note: The*.akx_ManualReportContent file only 
contains pointers to the image file locations. If the 
image files are moved or deleted from these locations, 
the image files will not be displayed when the file is 
loaded. 

If a PDF version of the report is needed, select File→Generate Report. A standard 
Save As dialog box prompts the user to specify a path and filename for the report. After 
clicking Save, the report will be created and opened in the default system PDF viewer. A 
new blank report can also be started via the File menu. 
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10 File Finder 

File Finder allows searching for phase and displacement files previously captured 
and saved to disk. Although Windows allows searching of files based on filename and file 
extension, it does not have access to the metadata fields within Akrometrix files. File 
Finder enables any metadata field within the phase or displacement file to be searched, 
enabling more detailed search queries. 

 

Figure 10.1 File Finder window 

Folders can be dragged into the Folder List section of the interface, or there are Add 
buttons in the right-click context menu (see Figure 10.1). This interface works the same 
way as in Batch Processing (Section 7.2.1). Multiple folders can be added at once and 
right-click context menus allow interaction with each added folder to add from that folder 
location, delete the folder, refresh it, etc. 

Once a folder or set of folders is added, a database must be built using the Build 
Database button. This indexes all the individual files in the folders and produces a 
database, in memory, of the filenames and their metadata contents. This Database file 
can be saved and loaded (Figure 10.2) again for future queries, instead of having to re-
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index. This can save substantial indexing time when dealing with hundreds or thousands 
of files. 

 

Figure 10.2 File Finder File Menu 

Next, Search Criteria can be specified (Figure 10.3) to filter out results based on 
metadata fields. This metadata filter function works exactly the same as in Batch 
Reporting (see Section 8.1.3). When all filters have been added, the Update button in 
the Results section will display all files in the folder list that meet the specified criteria, 
either Active or All, depending on the drop-down selection. The Search Criteria can be 
saved and loaded via the File menu (Figure 10.2). 

 

Figure 10.3 File Finder Search Criteria and Results 

The resultant list of files can be opened via the file list context menu (Figure 10.3), 
copied to another folder, or saved as a *.csv file. 



Surface Analysis User Manual 

Page 122 of 126 30-50SW-0001 Ver. 9.0 

11 Troubleshooting 

As with any measurement system software, the Surface Analysis program has its 
limitations. These limitations exist mainly because the analysis software is sensitive to 
patterns it was not designed to interpret, which is typical of any software using pattern 
recognition. 

11.1 Failure to Correctly Interpret the Phase Image 

After acquiring a phase image, a procedure called “unwrapping” is applied to the 
phase data (See Akrometrix Optical Techniques and Analyses 101). The unwrapping 
process removes the 2𝜋 discontinuity by examining the nearest neighbors’ pixel phase 
values starting at the center pixel. With the sequentially dependent nature of the 
unwrapping process, the height at all the pixels in an entire image can be related to one 
origin pixel. Conversion from the unwrapped phase image to vertical displacement is 
simply multiplication of each pixel phase value by the calibration factor. 

Problems arise when an error occurs at one point in the unwrapping process, either 
by incorrectly identifying a phase discontinuity or missing a discontinuity that has 
occurred. Once a problem occurs, all pixels downstream of the error point are offset from 
their correct value by the same increment of one full fringe cycle. 

11.1.1 Symptoms 

Unwrapping errors are propagated downstream of the error point. These errors 
appear in the 3D surface plots as ridges, troughs, or plateaus in the displacement surface. 
Two examples of such cases are shown in Figure 11.1, where the error originates from 
a step condition on the sample surface.  

 

Figure 11.1 Surface Plots with Unwrapping Errors 

11.1.2 Cause 

Unwrapping errors can occur at steps (i.e. vertical discontinuities in the sample 
surface). A step may be defined as a region where fringes are so closely spaced that they 
cannot be resolved by the video camera due to a rapid height change on the sample 
surface. Typically, fringes less than 5 pixels in width cannot be resolved. The Surface 
Analysis program is unable to determine the height at a step larger than approximately 
half a fringe height since the relative order of the fringes on the two surfaces cannot be 
determined. Unwrapping errors can also occur in regions where there is poor fringe 
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information or at the transition from such regions to regions of good phase information; 
including holes, shadows, pieces of tape, etc. 

11.1.3 Solutions 

1. The simplest, and best solution is to exclude error-causing features from the ROI. 
Adjust the position and size of the ROI to exclude these features.  

2. Apply a mask to the phase image over problematic areas to prevent them from 
being analyzed. Follow the directions given in Section 3.2. 

 

Note: Aggressive masking may create isolated data 
“islands” that cannot be crossed by the normal 
unwrapping algorithms. In this case, the user can alter 
the Unwrapping Parameters to properly display 
isolated data. See Section 4.6. 

3. Use Second Differences Phase Unwrapping and a high Threshold to remove low 
quality phase data from the analysis. See Section 4.6.3. 

4. Use the filtering option to help eliminate some unwrapping errors. Filtering smooths 
the phase image before unwrapping. Because filtering can smear out fine detail in 
the displacement surface, it should be applied to the analysis only to the extent 
necessary to eliminate undesirable phase unwrapping artifacts.  
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Appendix A  Miscellaneous Information 

A.1 File Formats 

Akrometrix Surface Analysis loads and saves data with the *.akx_* extension. For a 
more detailed breakdown of Surface Analysis specific formats please see the table 
below. Image export formats are exclusively *.png with varying filename postfixes to 
further denote their origins. 

Extension Contents 

*.akx_phase A single phase image with associated metadata. May optionally contain cropped 
versions of supporting data: intensity, and/or reference displacement 

*.akx_disp A single displacement data matrix with associated metadata. May optionally 
contain cropped versions of supporting data: phase, intensity, and/or reference 
displacement 

*.akx_partition Partition file (standard XML format) 

*.akx_3Dconfig Configuration file for 3D plot 

*.akx_2Dconfig Configuration file for 2D plot 

*.akx_chordset Chord set (standard XML format) 

*.akx_recipe Stores batch processing settings for recall later. 

A.1.1 Metadata Fields 

Metadata fields embedded in *.akx_phase or *.akx_disp objects can be used in 
building filenames, output paths, and report labels in various places in Akrometrix Studio 
applications. Some of the more commonly used metadata fields are described below. 

Metadata Field Description 

<RoiName> User defined. Editable in both Surface Measurement and Surface 
Analysis 

<LotId> User defined. Editable in both Surface Measurement and Surface 
Analysis 

<OperatorId> User defined. Editable in both Surface Measurement and Surface 
Analysis 

<ProductId> User defined. Editable in both Surface Measurement and Surface 
Analysis 

<SerialNumberId> User defined. Editable in both Surface Measurement and Surface 
Analysis 

<TestId> User defined. Editable in both Surface Measurement and Surface 
Analysis 

<Pin1Location> User defined. Editable in both Surface Measurement and Surface 
Analysis 

<MeasuredSide> User defined. Editable in both Surface Measurement and Surface 
Analysis 
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<InterfaceLocation> User defined. Editable in both Surface Measurement and Surface 
Analysis 

<TemperatureNominal> User defined when creating a profile in Profiler Generator. Also 
editable in Surface Analysis 

<TemperatureReading> Any thermocouple data for the acquisition (can include up to 16 
temperatures in the case of a CRE measurement). With no suffix, this 
metadata tag will provide TC1 data, but a two digit numerical suffix, such 
as “02” will provide the data for the corresponding thermocouple. 

<TemperatureSetpoint> User defined when creating a profile in Profile Generator 

<ProfileSecondsAndTemp> Time/temperature when a phase/disp file was acquired. 

Other metadata fields such as Equipment Model, etc. are available in the Properties 
window of any phase or displacement image (Figure 2.4). Any entry in this list can be 
surrounded by “<” “>” symbols to indicate to the application to use that metadata field in 
populating the corresponding text entry area. In addition, any gauge value can be added 
in the same way. 

A.2 Keyboard Shortcuts 

Shortcut Command Action 

Main Window Shortcuts 

Ctrl+O File→Open Open a new *.akx_phase or *akx_disp file 

Alt+F+X File→Exit Exit the Surface Analysis program 

F1 Help→User Manual Open the User Manual 

Phase Window Shortcuts 

Ctrl+C Copy (ROI) Copy ROI 

Ctrl+V Paste (ROI) Paste ROI 

Ctrl plus arrow key increases the ROI size by one pixel in the indicated direction. 

Alt plus arrow key decreases the ROI size by one pixel in the indicated direction. 

1-4 Advanced→View→Intensity 1-4 Show Intensity Images 1-4 

P Advanced→View→Phase Image Show Phase Image 

S Advanced→View→Surface Image Show Surface Image 

Ctrl+  Zoom in to phase image 

Ctrl-  Zoom out of phase image 

Ctrl+M Advanced→Mask→New Create a new mask 

Ctrl+Shift+M Advanced→Mask→Load Load a mask 

Ctrl+R Advanced→Partition→New Create a new partition 

Ctrl+Shift+R Advanced→Partition→Load Load a partition 

Ctrl+B Advanced→Unwrapping Parameters→Add Bridge Create a new phase bridge 

Ctrl+K Advanced→Chord→Add Chord Create a new chord 

Ctrl+Shift+K Advanced→Chord→Load Load a chord set 

Shift+T  Create a chord along top edge of the image 

Shift+B  Create a chord along bottom edge of the image 

Shift+L  Create a chord along left edge of the image 

Shift+R  Create a chord along right edge of the image 

Shift+D  Create downward diagonal chord (upper left to lower right corner) on the image 
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Shift+U  Create upward diagonal chord (lower left to upper right corner) on the image 

Shift+H  Create a chord along the horizontal centerline of the image 

Shift+V  Create a chord along the vertical centerline of the image 

3D Window Shortcuts 

Ctrl+S File→Save… Saves the 3D data as a displacement file (*.akx_disp) 

Ctrl+I File→Save Image… Saves the 3D data as an image (*_3D.png) 

Ctrl+P File→Print… Prints the image 

Ctrl+C Display→Copy View 
Copies the current display window viewing angle and magnification to 
the Clipboard. 

Ctrl+V Display→Paste View 
Applies the viewing angle and magnification saved to the Clipboard to 
the current display window (only appears after Copy View is used). 

Esc Display→Reset View Resets the Zoom back to 100% 

Ctrl+Alt+C Display→Configure… Opens the 3D graph configuration panel 

Batch Processing Window Shortcuts 

F5 
Edit→Refresh Source 
Folder 

Allows the user to update the list of source files since the folder 
was originally selected 

 


