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Studio Software Update 9.1.3 – Release Notes 

Previous Studio Release: 9.0 
Supported Equipment PC: Z370, Q470 

Recommended PLC Versions (hardware dependent): 1090/2090 for AXP2.0 1011 for PS600S 
Offline Studio Operating System: Extensive testing specifically performed on Win 10 64 bit 

  

Summary: 

All included Studio applications have been validated for compatibility with previously created Akrometrix Studio 
file formats. Files created prior to Studio 8.0 will not be readily usable with the Automated Report Generator or 
Batch Interface Analysis feature. Important bug fixes and added features are listed below. This list does not include 
all resolved bugs and added features. Known issues are presented with workarounds where applicable. 

Update Procedure: 

PLC/HMI Update 

Studio 9.1.3 requires an update to the PLC for the AXP 2.0 and PS600S system including a PLC (PS600S system including 
an HMI screen seen in front of electrical cabinet instead of a CSL208 temperature controller). Owners of any other 
Akrometrix models may skip this step. AXP 2.0 owners will use PLC version 1090 for equipment Serial Numbers 0412 or 
lower or PLC version 2090 for Serial Number 0413 or higher and PS600S owners will use PLC version 1011. HMI versions 
are the same for both systems. Further instructions for downloading PLC code and updating AXP 2.0 and PS600S systems 
will be provided separately. 

Install Studio 9.0 
THIS INSTALLATION HAS EXTRA STEPS TO ENSURE A CLEAN UPDATE. Download and Unzip the Studio 9.1.3 Installer 
zip file onto the system PC. Unplug the Studio USB dongle. Manually uninstall all Akrometrix Studio applications via 
Windows “Add or Remove Programs”, then restart the computer. Install all applications for Studio 9.1.3 by launching the 
provided file “Akrometrix Studio 9.1.3 Installer x64.exe”, then plug the Studio USB dongle back in. A full system power cycle 
is recommended after completing both PLC and software updates. 

Key Feature Changes or Additions: 

Studio 9.1.3 is releasing without fully updated User Manuals for this version, to be provided at a later date. 

New Unified Phase and Displacement Image Interaction 

All phase and displacement output files are now handled under one single interface in Surface Analysis.  The window stays 
in tabbed form as outputs are added (via Tools-Options), and surfaces are reanalyzed when changing tabs as changes are 
made in phase or displacement tabs.  Intensity and surface images can be seen in either tab.  Phase processing functions 
are performed on the phase tab and displacement processing functions on the displacement tab.  Physical dimensions are 
now input via clicking on the bottom left of the window where dimensions are shown.  A legend is now shown in the 
Displacement tab. 

The Gauges Tab has been removed and gauges results are now shown in the bottom of the window.  The context menu 
now allows “Gauges/Output Tabs” to be added on the current open image.  Graph appearance options have been simplified 
into the Gauges/Output Tabs window, as shown below. 
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Examples of the context menu sub-menus are shown in further images below. 

 

 

An example of a Diagonal Chord plots window tab is shown below. 
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Offline Part Tracking 

The Akrometrix Part Tracking function, of popular use within Surface Measurement, can now be used in Surface Analysis.  
Use is very similar to that of in Surface Measurement.  The Part Tracking window can be accessed from the Tools menu.  
In the Part Tracking interface go to File->Open Target Images.  This allows the users to load phase or displacement data 
and track/extract parts based upon Part Tracking settings. 

Use of offline Part Tracking on PCs that are not installed with equipment, will require further steps to setup the PC to run 
this software.  These steps are found in supplemental document, “Offline PC – Enable Part Tracking – Mil10.pdf”.  Use of 
this function will also require a Part Tracking USB dongle, included with Studio systems.  Any customers wishing to purchase 
an additional Part Tracking dongle should contact their local Akrometrix representative. 

Performance Improvements 

Batch process speeds have been significantly improved.  See the table below for a specific case study of 75x75 pixel ROIs 
on the current Studio PC.  Times are approximate and will vary per PC. 

 Studio 9.0 Studio 9.1.3 

1,000 phase files 4 minutes Less than 1 minute 

3,500 phase files 32 minutes 4 minutes 

25,000 phase files Unable to complete 17 minutes 

Further performance improvements have been made to using the Mask via Phase Amplitude Threshold interface. 

Test Setup Page Added to Automated Report Generator 

Automated Report Generator (ARG) already uses a Report Settings file which can be saved and loaded.  However, now 
Akrometrix is providing a Default.mdddl file as a starting point for Recipe Settings in ARG.  By loading this file from 
“Documents\AkroMetrix\Surface Analysis” a new ARG tab will be displayed.  The file is created when Surface Analysis is 
started.  This “Test Info” tab creates a front page to the standard ARG report output, allowing users to specify test parameters 
and other details they may wish to communicate about the test.   
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Create Mathematical Surfaces in Surface Analysis 

Surface Analysis can now be used to create displacement images, based on mathematical equations.  These surfaces can 
be used in Interface Analysis and practice of system use.  The displacements can be made one at a time, or they can be 
created matching the metadata as if they are created from a profile.  The one-off interface is shown below. 
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Batch Interface Analysis Improvements 

- Improved details in Loading and Saving IASettings files to include new surface appearance settings 

- Groups Tab: 

o Added new “Profile-based” grouping option 

o Added Pin 1 Location and Measured Side columns to Group Results window 

o Added support to Group by “Profile Acquisition Order” 

- Analysis Tab: 

o Gap data can now be saved as .dat files 

o Graph display options consolidated into a new “Settings Panel” window 

o Gap limits are unchecked by default 

- Layout Settings Tab 

o Reworked and simplified graph appearance options are now used in Batch IA 

o Default footer separator change to tab (\t) instead of new line (\n) 

- Reworked 1-off Interface Analysis context menu and interface in line with above changes 

Support Automated Shadow Moire Lens with Focus Automation 

The Studio release supports new hardware that can be added to TherMoire systems, which electronically controls zoom, 
focus and iris.  Contact your local Akrometrix representative for more information.  Any example of the interface added with 
this automated lens controller is shown below.  This also allows for presets to be programmed in the lens to return to specific 
zoom/focus/iris settings, as would be used in changing between gratings.   

Customers without this lens controller will still have new automation in setting focus.  Here the user can hit calculate to get 
a score for focus in the current ROI.  A lower score indicates better focus.  Optionally, the calculation can be performed over 
multiple camera captures, reducing the variation in the focus score from one capture to the next. Overall this function allows 
for optimization of lens focus.  
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Improved DFP Calibration and Support on PS600S 

The DFP2 Module is now fully supported and in use on the PS600S system.  Additionally, the DFP calibration approach 
has been improved to reduce DFP measurement noise.  Use of the calibration wizard is generally unchanged.  Users will 
see a legacy option to calibrate using the previous approach, for the purposes of any correlation needs. 
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New Gauges 

- Quadratic Signed Warpage (QSW):  A new version of signed warpage.  Coplanarity is again used for the value and 
further steps are taken to determine sign.  Surface data is split into a 4x4 matrix, with each area assigned a positive or 
negative value based on JFFSW math.  Looking at the full data set as 4 quadrants, for each quadrant the inner cell is 
compared to the outer cells to determine warpage direction.  This is done for all 4 quadrants to determine overall 
warpage direction.  Finally, any quadrants that show opposite results as the overall trend are listed in the gauge (TR = 
Top Right, TL = Top Left, BR = Bottom Right, BL = Bottom Left) 

- Wafer Bow:  Calculated as coplanarity / circle diameter. 

- RMS Deviation (RMSD):  Shows the root mean square deviation from the zero plane.  Stated another way, the square 
root of the mean of the deviation from the zero-plane squared.  Typically used for showing noise of a flat plane 
measurement. 

New Shortcuts 

- Pan in Surface Analysis by holding down middle mouse button 

- Zoom on 3D graph with Ctrl-+, Ctrl--, Ctrl-0 

- Num pad included in shortcuts, using numbers for intensity images, +/- to cycle through data views, and Ctrl+ (+/-/0) for 
zoom 

- ESC results Altitude, Rotation and Plot Cube in 3D graph; ESC also resets Gap distance in 1-off Interface Analysis 

- Ctrl+D performs the duplicate function in 3D graphs in Surface Analysis 

Studio 9.1.3 Features: 

- Displacement data can now be “Inverted” by the user, using new context menu function under “Transform->Invert” 

- “Average Phase Modulation” gauge has been removed due to redundancy in use with “Average Phase Amplitude” 

- Updated “Windows” selection style to more modern OS for easy of use 

- 3D graphs now have the top left corner as the origin (0,0) for consistency with other functions 

- Part Tracking can now create a measurement based on the outer extents of regions found via the added checkbox 
“Create Single Region From Instance Extents” 

- Profile Generator: 

o Remove length limits on profile creation length 

- Surface Measurement: 

o Delay per step is now limited to a range of 10-10,000 milliseconds (ms) 

o In the Edit Recipe window “Recipe-Specific Parameters” have been rename to “User Defined Parameters” 

o “Assign Sample Position” now added to Recipe Edit menu, recording stage height 

▪ TherMoire systems warn the user when the sample position is not at the specified stage height on 
Acquire or profile start in Thermal Profiler 

▪ TTSM-J and TTSM-JS models allow the grating to be moving the recipe height 

- Thermal Profiler: 

o Process thermocouples can now be renamed to custom names via right click on their column header 

- Surface Analysis 

o Tools->Preferences has been replaced with a reworked Tools->Options window 
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▪ Removed: SmoothPhaseOnOpen and AnalyzeOnOpen, and fixed Z-scale functions 

▪ Added: “Position Windows At Top-Left”, “Displacement Legend Visible”, “Fit To Window” 

o Improved display of multiple step height gauges 

o Grayscale bit depth has been added to status bar 

o Gauge length units have been removed from footer to save room, given redundancy with units shown in legend 

o Transform->Rotate commands are now disabled when Step Heights, Chords, Masks, or Partition regions are 
defined in order to prevent unwanted behavoir 

o Zoom->Fit To Window can now also zoom in 

o Plot Cube is now included when copying/pasting camera view 

o Minimum zoom on 3D graph tab is now 100% 

o Zooming with the mouse wheel now zooms with center on the mouse pointer 

o Non-filename 1-off windows can now be renamed by clicking on the title bar 

o Maximizing a window in the software in now done by a double-click on the title bar, and the window no longer 
maximizes all windows, but rather takes up the available space as a windowed display 

o Z-Range Masking now has options to mask based on 1, 2 or 3 standard deviations 

o 1-Off Interface Analysis gap plots can now be saved as displacement files 

o Batch Processing 

▪ Table results are now right justified for decimal alignment 

▪ Analyze Tab - Color Contour output now has 16 contour lines across the surface.  The 2D Disp Image 
output can be used for top-down color renderings without contour lines. 

▪ Analyze Tab – Output Options are now greyed out during Analyze function to prevent possible errors 

▪ Analyze Tab – Surface data can now be saved during Analyze step, saving the user the time of the 
Generate Output step 

▪ Mask Tab - Added displacement masking based on statistical standard deviation of data set 

o Automated Report Generator (ARG) 

▪ Added new “Profile-based” grouping option 

▪ Reworked and simplified graph appearance options are now used in Batch IA 
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▪ Default footer separator change to tab (\t) instead of new line (\n) 

▪ Footers are now seen on output images and videos 

Key Bug Fixes: 

- Improved handling in selection of regions contained inside other regions 

- Resolved multiple bugs related to switching between Shape and Image based Part Tracking, as well as saving of Target 
Images 

- Profile Generator: 

o Undo actions no longer move scrollbar to incorrect position 

o Undo list now shows actions at correct temperatures 

o “Time range” is now correctly honored when adding action “At Temperature”  

- Surface Measurement: 

o DFP SM – Camera Exposure Time no longer unintentionally changes after taking an acquisition then editing 
the recipe 

- Thermal Profiler: 

o Manual profiling mode can now be run multiple times 

o Manual profiling now saves to the specified output path 

- Surface Analysis: 

o Chords created without any surface data no longer cause software errors 

o Surface images can correctly update when rotating displacement data, in-plane 

o Resolved issues with saving displacement files on Windows->Close All 

o Dragging Chord off the edge of window no longer causes errors 

o Resolved issues with 1-off Interface Analysis gauge displays 

o Batch Processing 

▪ Analyze Tab – Multiple Step Height gauges can now be loaded from file 

▪ Mask Tab – Removed extraneous “Max” Column in tabled results 

o Automated Report Generator 

▪ Error no longer created when loading displacement files with AB or APA gauges defined or phase 
image outputs 

o Batch Interface Analysis 

▪ Min/max indicators are now seen as expected 

▪ Fixed Z-Legend color scale on gap plots 

Known Issues 

- No known issues are reported at this time. 

Versions (listed for reference): 

Studio Manager  9.0.19254 

SurfaceMeasurement 9.1.19254 

SurfaceAnalysis  9.1.19254 

ProfileGenerator 8.0.19254 

FileConverter  7.5.19254 

LicenseUtility  9.0.19254 
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User Manuals Studio Studio 8.5 


