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1 Introduction

1.1 Overview

Surface Analysis is a program designed to analyze and display the results of
shadow moiré and fringe projection measurements produced by Akrometrix warpage
measurement systems. The program typically resides on the measurement system
computer. If additional site licenses are purchased, Surface Analysis may also be
installed as a stand-alone application on other computers, offloading analysis tasks from
the measurement system. This manual is intended for use with Akrometrix Studio 8.3.

The analysis of interferometric data from shadow moiré and fringe projection systems
is a rich and complex subject. The main text of this manual emphasizes the operation of
the Surface Analysis program. The principles of interferometric techniques and analysis
will be discussed in Akrometrix Optical Techniques and Analyses 101 (AOTA101).
This paper should be read first by users unfamiliar with these techniques.

The output of the data acquisition program and thus the input of the Surface Analysis
program is an Akrometrix-defined file with the extension of either *.akx_phase or
*.akx_disp (displacement images). These files can contain measurement and reference
data as well as some measurement parameters and conditions. Surface Analysis
converts data from the *.akx_phase and *.akx_disp file into height data, and if required,
Akrometrix gauges.

The main analysis functions on shadow moiré acquired data in Surface Analysis are
based on the phase image in the *.akx_phase file. A phase image is a two-dimensional
grayscale image (computed from several intensity source images) containing a value at
each point related to the surface height at that point. Many of the options available in the
Surface Analysis program originate from two challenges in phase image analysis.

e First, the phase data must be analyzed as a whole and errors due to poor
guality data in one region of the surface can affect the results in other regions.
The Smoothing, Partitioning, Amplitude Threshold, Unwrapping Parameters,
and Masking functions allow bad data to be smoothed or excluded from
analysis.

e Second, the surface contour does not have an absolute frame of reference.
The Rotation, Grating Compensation, and Reference/Relative functions allow
the user to define the reference plane in a way most useful for understanding
the experimental results.

A second group of options control the display and output of experimental results.
Surface Analysis provides a suite of display formats, which can each be further
customized to the user’s preference. In addition, the displacement data can be exported
in tabular form for plotting or further analysis by other software packages.

Finally, Batch Processing allows repetitive functions to be automated:

e Batch Analysis allows the user to quickly analyze a set of related
measurement data (e.g. the same sample at different temperatures)
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Batch Masking allows the user to quickly mask more than one phase or
displacement image.

Batch Rotation allows the user to quickly rotate more than one phase or
displacement image.

Batch Cropping allows the user to quickly crop multiple regions of interest
from more than one phase or displacement image.

Batch Edit X/Y Orientation allows the user to assign Pinl location and
Measured Side Metadata to a phase or displacement image.

Batch Convert allows the user to convert displacement files back into phase
images

Batch Feature Detection allows the user to apply a custom mask based on
detected features in a phase image

1.2 Warnings and Notes
1.2.1 Warnings and Notes in this Manual

Warnings and Notes are marked throughout the manual with these icons:

L

il

O

Figure 1.1 Warning Icon Figure 1.2 Note Icon

Warnings are specific health hazards for the operator or potential sources of system
damage. Notes highlight system limitations or automatic responses that may require
corrective action by the operator for successful operation.

1.3 Technical Support

Akrometrix 404-486-0880 support@akrometrix.com
2700 NE Expressway 404-486-0890 (fax) http://www.akrometrix.com
Building B, Suite 500

Atlanta, GA 30345

When

contacting Akrometrix, please provide the system serial number, the version

numbers of the Akrometrix software being used, a description of the problem or question,
and contact information for reply. If the question concerns a particular measurement or
analysis, please provide electronic copies of the *.akx_phase files, final results, and a
description of data acquisition and/or analysis conditions. If the problem concerns

changes o

r failure in general system operation, please describe any events or system

modifications that occurred immediately before the problem arose.
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2 Loading Measurement Data

2.1 Starting the Program
The Surface Analysis program can be started in four different ways:

A. Right click on the phase or displacement image in Surface Measurement and
choose Open in Surface Analysis....

B. Double-click on a valid *.akx_phase or *.akx_disp file

C. Launch the Surface Analysis executable file directly from its shortcut (e.g. via
the Start menu)

D. Click the Surface Analysis button listed on the Akrometrix Studio Manager
bar on the left side of the screen.

Note: Only one instance (copy) of the software can run
4 at a time; subsequent calls to the program will activate
the open instance.

|

2.2 Loading Measurement Data

Once the Surface Analysis program starts, a GUI (Graphical User Interface) frame
will appear. The contents of the display frame depend on how the application was
launched:

A. If called from the measurement software via clicking on a phase image, the
current phase or displacement window from the data acquisition program is
shown.

B. If an *.akx_phase or *akx disp file was double-clicked, the phase or
displacement image contained in the selected file is shown.

C. If the EXE is launched from a shortcut or Studio Manager, no image is shown
and the user needs to select a file to open.

New measurement data files can be loaded into memory with the File=>Open menu
item. A standard Open dialog box appears, prompting the user to select a valid
*.akx_phase or *akx_disp file. Multiple files can be opened at one time by highlighting
multiple selections using the Shift or Control keys. Phase images and displacement
images can also be dragged and dropped into the Surface Analysis program in order to
open them.

L

Note: Surface Analysis can be configured to analyze
the image and display results immediately upon
opening the *.akx_phase file, using the
Tools>Options... menu item. See Section 4.2

i

2.3 Working with the Phase Image

An *.akx_phase file may contain a variety of information such as measurement data
(phase images, intensity images, etc.), reference data, as well as measurement
parameters and conditions. When the *.akx_phase file is loaded, all the information in the
file is loaded in memory. For display purposes, only the phase image will be shown in the
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GUI of the Surface Analysis program. Modification (Section 2.4.7) and Analysis
(Section 4) on the measurement data will be mainly applied to the phase image and any
associated reference data that exist.

2.3.1 Resizing a Phase Image

The phase image window may be resized in the normal fashion by dragging along
any edge or corner. The image in the window can be zoomed by using Ctrl+ or Ctrl-
(Figure 2.1 and Figure 2.2). Each action doubles or halves the size of the phase image.

2hN

250 x 200 pixels ~ | 100 % 250 x 200 pixels ~ | 200%

Figure 2.1 Phase Image 100% Magnification Figure 2.2 Phase Image 200% Magnification
2.3.2 Data Information

When a phase image is displayed in Surface Analysis, the image size and
magnification ratio information are shown on the status bar located at the bottom of the
image (Figure 2.1).

2.3.3 Measurement Information

In addition to the information described in Section 2.3.2, the measurement metadata
can be displayed by right-clicking on the image and choosing Properties... (Figure 2.3).
For a displacement image, the menu structure is Info->Properties.... In the Properties
window, information about the intensity images, phase image, and grating can be found,
along with many other test parameters.

2.3.4 Edit Metadata

Metadata for an individual phase image can be changed by right clicking on a phase
image and going to Edit Metadata. For further information on metadata see Section
All
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Edit Metadata...

Properties...

Figure 2.3 Displaying Measurement Metadata
2.3.5 Assigning Physical Size

Surface Analysis (and the TherMoiré measurement system in general) has no
internal means of knowing the physical ROl (Region of Interest) size, but physical
dimensions can be assigned by the user. Click the “Image Size” area on the status bar at
the bottom left of the phase image. Select Assign Size... from the pull-up menu (Figure
2.4). In the Physical Size window, assign the unit as inches or millimeters, then enter the
Width and Height of the image and click OK.

After physical dimensions have been assigned, the user can choose whether X and
Y axes are displayed in pixels, inches or millimeters using the same pull-up menu on the
status bar. The selected unit will appear on the X and Y axes of all graphs created after
analysis.

{© sample Image.akx_phase Q .’f]
r - Units
millimeter v
Width Height

[ = Jao0

A . bl oKk | Cancel |
ol i -5 4 C

Figure 2.4 Assigning Physical Size for a Phase Image

= Note: Physical dimensions are required for
Compensation (Section 4.5) and calculation of the
gauges Bow, Twist, DTA, and ROC (See Akrometrix
Optical Techniques and Analyses 101).
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2.3.6 Showing Surface or Intensity Images

Phase images have fringes across the whole field, hiding features on the sample
surface. If the user wishes to make masks, partitions, or chords on the surface or intensity
images, they can be shown by right-clicking on the phase image and selecting
Advanced->View->Surface Image (or, alternatively, any one of the 4 intensity images).
The image can also be quickly changed without the context menu by using the keyboard
shortcuts P, U, S, and the numbers 1-4. The currently viewed image can be saved to disk
in by selecting File->Save Image... or Ctrl+l.

—~

[© Sample Image.akx_phase !EH

-

250 x 200 pixels ~ | 100 % | 250 x 200 pixels + | 100 %

Figure 2.5 Phase and Surface Image Views

Analyze
Amplitude Thresheld...
Smooth

Rotation 3

Advanced s Unwrapping Parameters
Edit Metadata... Mask

Properties... Partition

Cherd

View l:} |E| Phase P
Rotate Unrotated Phase L
Duplicate Surface 5
Compensation Intensity 1 1
Shift... Intensity 2 2
Undo Intensity 3 3

Intensity 4 4

Figure 2.6 Menu Command for Showing Surface or Intensity Images
2.4 Working with Displacement Data

When an *.akx_disp image is loaded in Surface Analysis, a different window type is
created as shown in Figure 2.7.
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Lo -o-) )

| Suface |{ Displacemert || 3D Graph | Gauges | History |

- Sample.ake_disp

File Save...

Display Save Image...
Duplicate

Analysis

»
»
Transform >
4
4

Close
Info

Undo

215 x 221 pixels | 100 % | Coplanarity = 595 microns

Figure 2.7 Loaded Displacement Window

This window shows the displacement data, average surface image, 3D graph, gauge
results, as well as a history of operations performed on one tabbed interface. The
interaction with this window happens via context menu, just as with the phase image
window. There is now a File entry for saving the data in either its original format or as an
image. The data can also be duplicated or closed from this menu item.

This window can be resized using a hormal click and drag function. The data can be
resized using Ctrl+ or Ctrl- or by scrolling the mouse wheel. Either option increases or
decreases the size of the displayed data by 25%.

Other functions present in the phase image window are rearranged in this window to
accommodate new functionality. The organization is described in the following sections.

2.4.1 File

Save... Saves the data in *.akx_disp format

Save Image... Allows display window to be saved in graphical format
(*_3D.png or *_3D.jpQ).

Duplicate Makes a copy of the current displacement window in
memory.

Close Closes the displacement window. Prompts to save if any
changes are detected.

2.4.2 Display

Zoom Allows a reset of the image zoom that has been changed
by the mouse wheel.

Z-Axis Allows the Z-Axis units to be changed between microns
and mils as well as to change the Z-Axis scale.

XY Size Allows the X and Y data dimensions to be mapped to

physical dimensions in either mm or inches.
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2.4.3 Transform

Detect Features

Mask

Smooth

Plane Rotation

Fit Data...

Subtract

Rotate
Shift...

2.4.4 Analysis

Step Height

Partition

Chord

2.45 Info

Allows the user to filter data based on pattern recognition
for specific features. See Section 2.4.7.

Allows the data to be masked. All functions are the same
as described for phase images in Section 3.2, with the
exception of “Z-Range...”, which is unique to
displacement data. See Section 2.4.8.

Allows the user to apply either a default smoothing
function to the 3D data or a custom one. The default
smooth can be repeated multiple times. See AOTA101
for more information.

Allows the user to change the data rotation as in Section
4.3.

Opens a dialog where a polynomial fit can be calculated
based on the data set. See Figure 5.2. Alternatively, if
physical dimensions are assigned to the phase image, a
spherical fit can be calculated.

Displays the relative displacement data calculated by
subtracting a selected 3D data from the current 3D data
in a new window.

Allows the data to be rotated about its Z-axis as in
Section 3.7.

Allows the data to be shifted in its plane as in Section
3.8.

Allows the user to define two ROIs and calculate the
height difference between them. See Section 2.4.9.

Shows the same commands as under the
Advanced=->Partition menu for phase images, except for
Array. See Section 3.4.

Shows the same commands under the
Advanced->Chord menu for phase images. See
Section 5.4.

Allows the user to access the properties window and edit metadata associated with

the displacement image.
2.4.6 Undo

Allows the user to undo the most recent change.

Page 12 of 92
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2.4.7 Feature Detection

Feature Detection allows the user to create a custom mask by searching for certain
regions in the displacement data. This function is modal. Selecting it from the Transform
context menu brings up a feature ROI whose default shape is an ellipse (Figure 2.8) and
the Feature Detection window (Figure 2.9). While Feature Detection mode is active, the
user cannot change tabs in the displacement image window. This mode can be turned off
by pressing Esc or selecting Cancel from the context menu.

Detection Parameters
Shape match (%) |50 =

+2 DFP_De.ake dep oW =~ Height match (%) [50 | £

Suface Dwplacemert 1D Graph Gauges

[] Fill Holes

Feature Source
(@ Region
() Feature (60 x 65)

Detect

Center

Detected Features: n/a

603 x 650 pinels | 100% | TLC » -180.6 «

Figure 2.9 Feature Detection Parameter
Figure 2.8 Feature Detection Region Window

The Feature Detection process consists of two steps: detection and masking. The
parameter window and context menu are divided accordingly. During detection, the user
sets up a single ROI with matching parameters and finds all features that fit that shape.
During masking, the detected ROIs can be edited to create a final mask, which may then
be burned or saved. The user always has access to certain options, including saving or
loading Feature Detection settings files.

Switching between the Feature Detection steps is accomplished using the Detect
and Clear buttons in the middle of the Parameter Window. Detect scans the image for
instances of the feature in question, creating an ROI around each one that can be edited
in Masking mode. Clear deletes all ROIs but the original one, returning to the detection
step.

The two versions of the Feature Detection context menu are shown in Figure 2.10
and Figure 2.11. They are mostly the same, but since the mask step can have multiple
ROls, there are more editing options.
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Parameter Window |
Square Bounds
Edit...

Parameter Window Copy Ctrl+C

Square Bounds Paste Ctrl+V

Edit... Delete Del

Finished Finished

Cancel Esc Cancel Esc

Figure 2.10 Feature Detection Figure 2.11 Feature Detection
Context Menu - Detection Context Menu - Masking

e Parameter Window opens the window or brings it to the front, depending on
whether it is already open

e Square Bounds equalizes the horizontal and vertical dimensions of the ROI

as the shorter value of the two

Edit brings up the ROI Editing window described in Section 3.1.

Copy (Ctrl+C) copies the selected ROI into memory.

Paste (Ctrl+V) places an instance of the copied ROI at the cursor location.

Delete (Del) deletes a single ROI.

Cancel (Esc) exits out of Feature Detection without making any changes to

the displacement image, although the Feature Detection settings will be

remembered as long as the same instance of the *.akx_disp file is open.

e Finished exits Feature Detection when the user is done, leaving applied
masks in place. This menu item is always visible but only active at the end of
the Feature Detection process.

Note: Mask ROIs start out as copies of the Detection
ROI, but can be independently edited. Everything in
Section 3.1 applies to Feature Detection ROIs.

]

In the first half of the Feature Detection Parameter Window (Figure 2.9), the user can
set detection parameters based on their detection ROI. This is the initial ROl which
appears when Feature Detection is opened, and which the user should edit to cover the
feature to be found. Shape Match and Height Match control the degree of accuracy in
exact shape and size required to find matches. Higher numbers here will typically result
in more features found. Fill Holes fills all mask regions with fabricated data based on the
neighboring edges. Note that this option does not affect the final output, only the input
dataset for the detection process, so there will be no visual indication on the 3D data that
anything has changed. For a typical solder ball detection application, having this checked
will improve the number and accuracy of features found.

If previous detection has been performed the user may use Feature Source to search
with the Feature image shown in the center of the parameter window instead of using the
detection ROI. When the user is satisfied with their detection settings, they may press
Detect to detect similar regions.
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In the mask step, the user edits the ROIs on the displacement image and sets mask
parameters in the Parameter Window. These include the choice of whether Feature or
non-Feature data is masked. If Non-feature data is masked, then the user also has the
option to replace data in the remaining regions with a single value, which can be the
maximum, the minimum, or the value of the center pixel in each region. Scale regions
increases or decreases their size when masking, and Save Mask File converts the results
into a mask file that can be applied to other files without going through the full feature
detection process. Once the user is satisfied with their settings, they can select Mask to
apply the mask or Undo to remove it, and then exit Feature Detection by selecting
Finished from the context menu.

o B LT

Suface Displscement 30 Graph Gauges

-

CENDCFNODL)
1*;‘ »

Feature Detection - 35mm_BGA_DFP_00001s(... [l
File

Clear

Mask
() Features

@ Nondeatures
[ Replace Region Data | Certter

[ Scale Regions [100 5

[ save Mask File

Mask.

Detected Features: 748

CPCE R F RPN R BT N T
CREICF R NV IO EC PN
CHFCRCR PO FOR A I R
CFCRCE N NN N F RN
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i Y (pixels)
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-44.7 |0
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420.9
412.4
403.9
395.4

Figure 2.13 Analyzed Data with Feature Detection: Mask Feature and Mask Non-Feature
2.4.8 Z-Range Mask

Z-Range Mask functionality serves as a high and low pass filter for displacement data
by filtering based on Z-axis displacement values. Like Feature Detection, this is a modal
function that deactivates tab changing. Once Z-Range... is selected from the Mask menu,
the Z-range Mask Parameters window will appear (Figure 2.15) and the context menu
will change to that for Z-Range Mask (Figure 2.14). This mode can be turned off by
pressing Esc or selecting Cancel from the context menu.

E
File File
Mode |Absolute - Wode
Regions Regions
Metric | Range Metric  Range
#  Mn Max Avg #  Mn Ma Avg
Parameter Window Mask Pxsis | Outside Range ~ Mask Pixels | Outside Range ~
i o e
Reset Max (3740 : n/a +[00 i =[oa
'._|p|:|atE Min |-2214 S nfa + (0.0 2 =|nfa
Pixels Masked: 0.0 % Pixels Masked: 0.0 %
Burn Mask
A ) Cancel Esc
— Data Range: -221.4 to 374.0 microns Data Range: -221.4 to 374.0 microns
Figure 2.14 Z-Range Mask Figure 2.15 Z-Range Mask Figure 2.16 Z-Range Mask
Context Menu Parameters Window - Absolute ~ Parameters Window - Regions

The Z-Range Context Menu has 6 options, listed below.

Parameter Window Opens the Parameter window if it is closed and brings it to
the front if it is opened.

Add Region While Regions mode is active, allows the user to add a
region.
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Reset Removes any regions and masks and returns the data to
its unfiltered state.

Update Applies any parameter changes to the data.

Burn Mask Applies current filtering settings to the displacement

image and closes Z-Range Mask Mode.
Cancel Closes Z-Range Mask mode without applying a mask.

Note: Right-clicking on a single Region brings up a
context menu dedicated to ROI editing. Regions are
subject to the same ROI editing options described in
Section 3.1.

The Z-Range Mask Parameters Window has a variety of filtering options. At the very
top is a File menu with three options. Load allows the user to save the current parameters
as a Z-Range Mask File (*akx_zRangeMask). Save creates a new Z Range Mask file
from the current settings. Finally, Save Map, which activates once a mask has been
updated on the file, creates a *.akx_mask file out of the current Z-Range Mask. This turns
the masked data based on Z-Range into a normal, location based mask.

Next, the user can choose between Absolute Mode (Figure 2.15), in which data is
filtered based on absolute Z-values, and Regions Mode (Figure 2.16), in which data is
filtered based on the data values in selected regions. Most of the menu is the same
between these modes.

I

The regions section is next. This is inactive in Absolute mode. It lists all currently-
active regions, complete with data. The Metric drop-down allows the user to decide
whether to filter based on the average or range of the regions.

L 4

Note: When there are multiple regions, an overall
average of all of the pixels that they contain will be
used as the result data for Average, and the overall
largest and smallest Max and Min values will be used
for Range.

il

Mask Pixels allows the user to choose how the masked data should relate to the
range values. The options are Above Max, Above Min, Outside Range, Inside Range,
Below Max, and Below Min. Data within the selected range will be masked out.

The next section varies slightly between Region and Absolute modes, but both
display what values are being used to filter data. In Absolute mode, these values are set
directly, and may be quickly reset to the max or min of the data. In Regions mode, these
values are set mathematically based on the regions, but may be adjusted by changing
the Offset values of the maximum or minimum of the data.

—— Note: In both Regions and Absolute mode, the
— maximum is the top number and the minimum the
bottom.

|
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The final portion of the Z-Range Parameters Window displays data relevant to the
filtering process and allows the user to view the results. There is a display of the
percentage of currently-masked pixels, and a data range at the bottom with the Min and
Max of the original image. The user can hold down the View Original or View Discarded
buttons to see what the original data looked like and what portions of it are currently
masked out. Finally, the Update button allows the user to propagate any settings changes
and see them on the displacement image. No parameter changes have any effect until
either Update or Burn Mask has been selected. Example data filtered by two different Z-
Range Masks is shown in Figure 2.17.
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Figure 2.17 Data with High and Low Z-Range Masks
2.4.9 Step Height Calculation

Clicking on Step Height->Add Step (Figure 2.18) will add a pair of boxes to the
displacement view that can be moved around and resized. The step height difference is
calculated as the difference in average heights between the two regions (1A-1B). The
step height sign will vary depending on whether the A region is higher or lower than B
and the result is shown at the bottom of the displacement window (See Figure 2.19 and
Figure 2.20). Multiple step height pairs can be added. They can also be saved for loading
onto other displacement windows or used as a gauge in batch processing.
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- ] ST ' Locked
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Copy All
Paste
Add...
Load...
Save..
Delete All
Figure 2.18 Step Height Menu
o) Step.akc_disp [ &)= a2l Step.ako_disp ol e )=
\.Surfa;: Displacement @G;h Gauges History} ) \g_ * 5 —[aauges HTSIE . i

345 x 361 pixels | 100 % | Step 1 Height = 76 microns

‘ 345 x 361 pixels | 100 % | Step 1 Height = -76 microns ‘

Figure 2.19 Step Height Calculation A>B Figure 2.20 Step Height Calculation A<B

The step height pair mode can also be changed by right clicking on either of the boxes
and going to Switch to S-P. S-P mode uses the 1P box for its LSF reference plane and
is most useful when analyzing a calibration block with flat planes and known step heights
between them. A-B mode uses the reference plane that is already applied to the surface.
See Figure 2.21 and Figure 2.22 for an example.
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; o Step.akx_disp .)'E-

Displacement

o' Step.akx_disp
Surface | Displacement | 3D Graph | G
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8 ) Delete Del

Copy  Ctrl+C
Square Bounds

% Edit..

345 x 361 pixels ‘ 100 % ‘ Step 1 Height = 59 microns 345 x 361 pixels ‘ 100 % ‘ Step 1 Height = 77 microns

Figure 2.21 A-B Mode Figure 2.22 S-P Mode

2.5 Saving Displacement Images

A modified displacement image is NOT automatically saved to the hard drive. It can
be saved using the File=>»Save... menu item. If the modified image is not saved, the user
will be prompted again to save it when the displacement image window is closed or the
program is shut down.
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Modifying Measurement Data

Note: Context menu paths described in this section
and references to phase images will be different for
*.akx_disp files. Behavior of the functions such as
masks/partitions/etc. remains the same for
displacement images. Reference Section 2.4,
Working with Displacement Data for correct context
menu paths.

3.1 Setting the ROI

The Mask and Partition functions in Surface Analysis create one or more graphically
defined ROIs (Regions of Interest) on the phase image where these functions can be
applied. ROIs can be different shapes such as rectangle, ellipse, triangle, etc. The default
shape of an ROI is a rectangle. Choose a new shape by opening the Shape Selector
window from the View->Shape Selector menu item. Choose the shape before selecting
the Mask or Partition function (Figure 3.1).

m

After activating the desired function (Mask or Partition), click and drag the mouse
cursor from one corner of the desired ROI to the other. When an ROI region is selected,
it can be repositioned by dragging anywhere within its region and resized by dragging on
any of the eight “Handles” on the periphery. The shape, location, and size of the ROI can
also be changed by using the ROI Properties Window (Figure 3.2). To access this
window, right-click inside the ROI and choose Properties.... This window is useful for
drawing a pre-defined ROI. Size can be defined in either absolute (pixel) terms or
fractional terms (relative to the phase image dimensions).

Edit Mask Region X
Shape
Shape Selector = Rectangle v
Location Size:
x Posttion ¥ Position Width Height
OO <A
Mode
@® Absohte () Fractional
Figure 3.1 ROI Shape Selector Cancd

Figure 3.2 Edit ROl Region Size and Position

Other common functions for Masking and Partitioning can be called by right-clicking
inside an ROI:

Copy (Ctrl+C) creates a copy of the active ROI on the Windows Clipboard. It may be
pasted (Ctrl+V) inside the original phase image or in a different phase image.

Square Bounds equalizes the horizontal and vertical dimensions of the ROI as the
shorter value of the two

Delete deletes the active ROI
Delete All deletes all ROIs within the current phase image window

30-50SW-0001 Ver. 8.3 Page 21 of 92

Y akrometrix



Y akrometrix

Surface Analysis User Manual

&

Note: Other functions in Surface Analysis, such as
Feature Detection and Z-Range Mask, also use ROIls
in their interfaces. These ROIs can be edited using the
functionality described above.

]

3.2 Masking a Phase Image

Masking excludes regions inside the phase image from the analysis. Regions that
lack good phase data (e.g. holes, steps) can create errors in the analysis that extend
beyond the bad phase region. When using a mask, there is no displacement information
generated within the masked-out regions, and the remainder of the phase image can be
analyzed without interference.

Analyze
Amplitude Threshold...
Smaooth

Rotation b

Advanced » | Unwrapping Parameters
Edit Metadata... | Mask N

Add Region  Ctrl+M
Add Array...

Properties... Partition
Chord

Enabled
e Locked
Rotate
Duplicate Burn All
Compensation Copy Al
ShifE Paste

Undo

Load...

Save...

Delete Map

Delete Regions

Delete All

Figure 3.3 Mask Menu
3.2.1 Creating a Mask

A mask file can be either a binary graphical image (*.png) containing only black and
white colors or a *.akx_mask file representing the location, shape, and size of the regions
added during a mask operation. In the case of an image mask, the white color represents
valid data while the black color represents points or areas that need to be masked out. In
most cases, the mask shapes shown in Figure 3.1 are sufficient. However, if the user
needs to define an irregularly shaped mask, they can also be generated from an external
graphical tool such as MS Paint®. The file format needs to be *.bomp or *.png in order to
be loaded in Surface Analysis.

A mask can be created and saved in Surface Analysis by the following steps:

1. To create a new mask, right-click in the selected phase image and choose
Advanced>Mask->Add Region (or use the keyboard shortcut, Ctrl+M).

2. To create the first ROl in the new mask, hold down the left mouse button; draw a
rectangle on the phase image and then release. The ROI will appear as a
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transparent red shape. All the ROl commands described in Section 3.1 apply to
the mask ROI.

3. Additional mask ROIs can be added by repeating steps 1 and 2. Mask ROIs may
overlap.

4. When the mask is complete, it may be saved to a file (*.akx_mask or *.png) by
right-clicking inside the phase image (but not inside an editable mask ROI) and
choosing Advanced->Mask->Save....

5. The mask can be turned on and off without deleting the mask from memory by
right-clicking inside the phase image (but not inside an editable mask ROI) and
choosing Advanced->Mask->Enabled. Alternating this command will turn the
current mask(s) on and off. This is useful when evaluating masks between phase
image and 3D surface plot during analysis. When the masking function is disabled,
all mask ROIs are hidden.

6. The mask can be locked by going to Advanced->Mask—=>Locked. This setting will
prevent the user from interacting with any editable (red transparent) mask regions.

3.2.2 Loading and Editing a Mask

A previously created mask that was saved in the *.akx_mask, or *.png, formats can
be recalled and applied to any phase image. To load the mask file, right-click inside the
phase image, choose Advanced->Mask->Load..., and select the desired mask file.
More than one mask file can be loaded on the same phase image. An image mask is
shown in solid yellow color while a *.akx_mask file is shown as editable transparent red
regions.

o

ol
Figure 3.4 Loaded Image Mask in Yellow

A loaded image mask cannot be edited but can be turned on and off by toggling the
Advanced>Mask->Enable function. To delete a loaded image mask, choose
Advanced>Mask->Delete Map. To delete a loaded *.akx_mask mask, choose
Advanced>Mask->Delete Regions. New mask ROIs may be added by right-clicking
inside the phase image and choosing Advanced->Mask->Add Region.

The modified mask, including both old and new components, can be saved by right-
clicking inside the phase image (but not inside an editable mask ROI) and choosing
Advanced>Mask->Save....
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Note: If a *.akx_mask is loaded onto a phase image
with different pixel dimensions than the one on which it
was created, a dialog will appear, as shown and
discussed below.

Load Mask Absolute SExMismatch (IS

I

@ Scale layout to fit 185x 108

Preserve layout designed for 1762 131

OK || Cancel

Figure 3.5 Abolute Size Mismatch Dialog

Scale layout will use the fractional values from the mask relative to the original phase
image dimensions. Preserve layout will load the regions using the raw pixel dimensions
and coordinates.

&

Note: If a *.png or *.bmp is loaded onto a phase image
with different pixel dimensions than the one on which it
was created, a dialog will appear, as shown and
discussed below.

Load Mask Image =

o The selected mask image

2.png

il

is not the same size as the phase image. Continue anyway?

Yes No

Figure 3.6 Load Image Mask Mismatched Size Dialog

Hitting continue on this dialog will load the image mask regardless of the mismatch,
scaling the masked regions to the aspect ratio of the current phase image.

3.2.3 Copying and Pasting Masks

All masks on a phase image can be copied by going to Advanced->Mask—->Copy
All. Alternatively, individual mask regions can be copied and pasted by right clicking on
them and going to Copy. When a region is selected the shortcut Ctrl+C also works.

Pasting a mask is similar. Once a mask region has been copied, right click on the
target phase image and go to Paste Mask. When the target phase image has focus, the
shortcut Ctrl+V also works for this function.
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Figure 3.7 Paste Mask Option in Phase Image Context Menu

—

—_—

3.2.4 Burning a Mask

Analyze
Srmooth
Rotation
Advanced
Paste Mask  Ctrl+V
Properties...

___ = Note: If a mask is pasted onto a phase image with
— different pixel dimensions than the one on which it was
created, the mask will be scaled fractionally in location
and size.

Burning a mask combines the current phase image with one or more mask ROIs
created in memory or loaded from a file. The mask pattern will be permanently embedded
in the phase image. This function prevents the future separation and loss of mask files

used during analysis.

A mask can be burned by:

e right-clicking inside an editable mask ROI and choosing Burn

¢ right-clicking inside the phase image (but not inside an editable mask ROI) and
choosing Advanced->Mask->Burn All.

The burned mask ROIs appear in gray as shown in Figure 3.8.

. \ |

i nd

250 x 200 pixels ~ | 100 % |

Figure 3.8 Burned Mask Areas
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3.2.5 Adding a Mask Array

An array is a grid of mask ROIs. This function is useful for automatically creating a
large quantity of mask regions on a phase image. Common use cases include repetitive
regions on a PCB or BGA.

nv. - I

Figure 3.9 Example of a Mask Array

1. To create a new array right click in the selected phase image and choose
Advanced->Mask->Array...

2. By default, a grid of mask regions appear on the phase image. Also, a box with
various array parameter options appear (Figure 3.10). The height and width refer
to the individual dimensions of a single mask region. The center offset is the
distance of the center of the full array from the center of the image. The spacing
controls how much space exists between each mask region. The inset refers to
how much of the image is covered by the array (a larger inset reduces the total
array size). Each option affects all ROIs in the same way.

L]

Note: There is no way to independently edit one mask
region through the menu at this stage. Later in the
process there is a way to independently change the
shape and location of each of the partitions.

]

3. Click Update to view the changed array inside the phase image.

Array Generator - BGA_1_00002s(24C) n
File
Width Height
Region Size |50 = 50
X Y
Center Offset |0 = 0
X Y
Spacing = r
] 0.0000 = 0.0000 |+
X Y
Region Inset |0 = 0
Selection Area Inside  ~
Region Count: 1

Figure 3.10 Mask Array Parameters

Page 26 of 92 30-50SW-0001 Ver. 8.3



Y akrometrix

Surface Analysis User Manual

4. To save the mask regions, use the green array bounds box to select the specific
regions to be saved. Note that only regions whose whole areas are enclosed by
the green rectangle will be saved, as seen in the figure below. Click on Add
Regions to add the selected regions. The program will lock these regions so that
they cannot be edited. Interaction with the created array can occur just as with a
normal mask (see Section 3.2.1).

Figure 3.11 Green Array Bounds Box
3.3 Cropping a Phase Image

Cropping an image allows the user to extract and save a smaller portion of the current
phase image. This is useful for defining a smaller region inside the original phase image
or eliminating bad phase data at an image edge.

Note: As of Studio 8.0, the crop function has been
4 removed in favor or creating a partition file with only
one region. Please see Section 3.5.

3.4 Phase Amplitude Thresholding

As of Studio 8.0, Surface Analysis now has the ability to adjust the phase amplitude
threshold used to auto-mask a phase image after it has been saved by Surface
Measurement. Previously, this value could only be changed by re-acquiring data during
testing. This works by virtue of the fact that *.akx_phase files typically store the raw
intensity images used to build phase data. By resetting the phase amplitude value, areas
of the image that were above the acquisition PAT can be recovered and data that should
have been masked can be removed.

|

In order to adjust the Phase Amplitude Threshold, right click on the phase image and
select the Amplitude Threshold... menu option. A dialog will pop up asking the user
whether or not they want to keep existing masked points. Clicking Yes will create a map
of the already masked out points that will not be affected by any PAT adjustments. This
is particularly useful if the user has already created a mask of data that had good phase
amplitude but was simply not needed in the measurement. Saying No will recalculate
mask on all areas of the image.
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Analyze Amplitude Thresold Adjustment Phase Amplitude Threshold x
Amplitude Threshold... | 2
Srmooth 0 Keep existing masked points? (]
. 0.0 461
RDtatan r Intial Value =2.0 | Set
Advanced 3 Yes No 3.05% Masked
Properties...
Figure 3.13 PAT Keep Existing o
Figure 3.12 Amplitude Masked Points? . .
: Figure 3.14 Phase Amplitude
Threshold Menu Option . .
P Thresholding Adjustment
Window

When the adjustment window pops up, move the slider to adjust mask calculation.

The Min and Max values on this slider are pulled directly from the phase amplitude of the
image.

e — - &3
Elﬂll_Shin}r.akx_phase o= =] Phase Amplitude Threshold | |

7302 =

U

4296 11934
Initial Value = 589.9

6.19% Masked

OK || Cancel

342 x 232 pixels ~ | 100 %

Figure 3.15 Phase Amplitude Thresholding

Masked areas will increase and decrease, and be highlighted red on the phase
image. To go back to the original PAT value, click the Set button.
&

Note: Dragging the slider quickly or large distances
may cause some delay in recalculating mask areas.
This is particularly true with large phase images and/or
slower computers.

In Batch Processing, the Phase Amplitude Threshold dialog has both absolute and
relative threshold settings, as well as both 8-bit and 12-bit scales, depending on which
type of image is being processed.

il
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3.5

Phase Amplitude Threshold >

Intensity Scale

() Bbit

(@) Absolute 430

4k
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QK Cancel

Figure 3.16 Phase Amplitude Threshold Batch Dialog
Partitioning a Phase Image

Partitioning is a function where one or more ROIs are cropped from a phase image
while leaving the original phase image intact. This function is useful for measuring multiple
samples in a single run, and later extracting the individual samples from each phase
image recorded. The same partition can be applied to multiple phase images using the
Batch Cropping tool described in Section 6.

Analyze
Amplitude Threshold...
Smooth

Rotation v
| Advanced N | T ,
Properties... TP ,
KT‘ | Partition » Array..
) Chord » Add Region. o
im0 Rotate »
Duplicate Visible
Locked

Compensation

Shift.. Default ROl Prefix...

Extract All

Undo

‘Extract to file' naming...
Copy All

Paste

Load...

Save...

Delete All

Figure 3.17 Partition Menu

3.5.1 Creating a Partition

1.

2.

To create a new partition, right-click in the selected phase image and choose
Advanced->Partition->Add Region... (or Ctrl+R).

To create the first domain in the new partition, draw a rectangle on the phase image
with the mouse.

A green ROI appears and all the ROl commands described in Section 3.1 apply
to the partition ROI. By default, the regions will be named “Region 001”7, “Region
002”, etc, but the default can be <changed by going to
Advanced->Partition->Default ROl Prefix... Previously used ROI names will be
saved in a list for recall later.
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Default ROl Prefix ot

Erter the default RO Prefic:

Reqiond

ReqionZ
Redion

| 8] .4 | lLancel

Figure 3.18 Default ROI Prefix Dialog

4. Right-clicking inside any ROI and choosing Edit... allows the region name to be
changed as well as the shape, location, size, and Mode of the domain (Figure
3.19). Click OK when complete.

Note: The Mode selection determines whether the
partition location and size are displayed in absolute
pixels or fractions. The location is relative to the top left
corner of the phase image. The size is relative to the
full x and y dimension of the phase image.

Edit Partition Region ‘L&J [

Name

I

Reqion 001
Shape
Rectangle -
Location Size
x Position v Position Width Height
31 = 36 = 71 = 58 z
Mode
@ Absolute () Fractional

Figure 3.19 A Partition ROI Properties Window

5. Additional domains can be added to the partition (Figure 3.20) by repeating steps
1 through 3. Domains may overlap.
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[@ PCB_3components.akx_phase
: Ca E =

327 x 299 pixels ~ 100%

Figure 3.20 Multiple Domains on One Phase Image

6. When the partition is complete, it can be saved to a file (*.akx_partition) by right-
clicking inside the phase image (but not inside a domain) and choosing
Advanced->Partition->Save....

7. Even if it has not been saved, a partition may be used until it is cleared. It may be
cleared by right-clicking inside the phase image (but not inside a domain) and
choosing Advanced->Partition->Delete All.

3.5.2 Loading and Editing a Partition

A previously created partition that was saved in a *.akx_patrtition file can be recalled
and applied to any phase image. To load the partition file, right-click inside the phase
image, choose Advanced->Partition->Load..., and select the desired partition file.

Any domain in the partition may be modified or deleted by right-clicking inside the
domain and using the ROl commands described in Section 3.1. It may also be edited
graphically using the cursor. New domains may be added by right-clicking inside the
phase image (but not inside a domain) and choosing Advanced->Partition>Add
Region....

The modified partition, including both old and new domains, may be saved by right-
clicking inside the phase image (but not inside a domain) and choosing
Advanced->Partition->Save....

&

Note: If a partition is loaded onto a phase image with
different pixel dimensions than the one on which it was
created, a dialog will appear, as shown and discussed
below.

il
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Load Partition Absolute Size Mismatch *

(®) Scale layout to fit 125 161

() Preserve layout designed for 306 x 309

Cancel

Figure 3.21 Load Partition Absolute Size Mismatch

Scale layout will use the fractional values from the mask relative to the original phase
image dimensions. Preserve layout will load the regions using the raw pixel dimensions
and coordinates. If Preserve is chosen, a dialog will let the user know how many regions
were discarded because they were entirely outside of the data bounds as well as how
many regions extend outside of the data bounds. Only regions with their top left corner
present in the target image pixel bounds will be loaded.

Load Partition Info X
1 of 2 regions were discarded.
1 of 1 regions extend outside the data bounds.

Figure 3.22 Load Partition Preserve Layout Info
3.5.3 Copying and Pasting Partition Regions

A mask can be copied by going to Advanced->Partition=>Copy All. Alternatively,
individual partition regions can be copied and pasted by right clicking on them and going
to Copy. When a region is selected the shortcut Ctrl+C also works here.

Pasting a partition is similar. Once a partition region has been copied, right click on
the target phase image and go to Paste Partition Region. When the target phase image
has focus, the shortcut Ctrl+V also works for this function.

Analyze

Smooth

Reotation 3
Advanced 2

Paste Partition Region  Ctrl+V

Properties...
ds .

|
Figure 3.23 Paste Partition Region Option in Phase Image Context Menu

Note: If a partition is pasted onto a phase image with
different pixel dimensions than the one on which it was
created, the region will be scaled fractionally in location
and size.

|
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3.5.4 Extracting Domains

Partitions can be extracted from the original phase image, either to new windows
(Figure 3.24) or to independent *.akx_phase files. To extract a domain as an independent
phase image in its own window, right-click inside the domain and choose Extract, then
choose between ‘to window’ and ‘to file...” (Figure 3.25). To extract all domains when
multiple exist, right-click inside any ROI and choose Extract All, and again choose to
extract to windows or files. If ‘to windows’ is chosen, a new window will pop up for each
ROI.

When partitions are extracted to files, the default file name is the ROl name appended
to the name of the parent file (Example: Sample_0001.akx_phase). This default can be
changed in Advanced->Partition->’Extract to File’ Naming. The default file names can
be edited when extracting individual partitions to files, but are used automatically when
Extract All->’to files...’ is chosen.

im

(S ¢

215x 221 pixels - | 100 %

® === ® (o= ][=]

15

130 x 87 pixels ~ | 100 %

119 119 pixels - | 100 %

Figure 3.24 Extracted Domains from a Phase Image

s )

&1 Extract * to window
1 Copy  Ctrl+C to file...
Square Bounds
¥ Delete Del
%, Edit..

Figure 3.25 Partition Context Menu - Extract
3.5.5 Adding a Partition Array

An array is a grid of ROIs. This function is useful for automatically creating a large
guantity of regions on a phase image. Common use cases include examining die level
warpage on wafers and package level warpage on strips.
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Figure 3.26 Example of a Partition Array
1. To create a new array right click in the selected phase image and choose
Advanced->Partition->Array...

2. By default, a grid of ROIs appear on the phase image. Also, a box with various
array parameter options appear (Figure 3.27). The height and width refer to the
individual dimensions of a single ROI. The center offset is the distance of the
center of the full array from the center of the image. The spacing controls how
much space exists between each partition region. The inset refers to how much
of the image is covered by the array (a larger inset reduces the total array size).
Each option affects all ROIs in the same way.

&

Note: There is no way to independently edit one region

— | through the menu at this stage. Later in the process
2 there is a way to independently change the shape and

location of each of the partitions.

3. Click Update to view the changed array inside the phase image.

Array Generator - BGA_‘\_lg]]?_G(MQ - BGA_1_0.. H
File

Width Height
Region Size |50 z 50

X Y
Certer Offset |0 S 0

X Y

Spacing = -
(pixels/region) 0.0000 /= 0.0000 12

X Y
Region Inset |0 = 0

Selection Area | Inside
Origin Upper Left

Naming Scheme Count (H} ~

Counter
Starting Value 1

Region Prefix Region Suffix

Update

Region Count: 1

Figure 3.27 Partition Array Parameters
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4. To save the partitions, use the green array bounds box to select the specific
partitions to be saved. Note that only partitions whose whole areas are enclosed
by the green rectangle will be saved, as seen in the figure below. Click on Add
Regions to add the selected regions. The program will lock these regions so that
they cannot be edited. Interaction with the created array can occur just as with a
normal partition (see Section 3.5.1).

Figure 3.28 Green Array Bounds Box

3.6 Smoothing a Phase Image

The Smooth command applies a smoothing function to the active phase image to
reduce noise in the data. This is useful for reducing analysis error due to fringe
miscounting and increasing reproducibility in gauge values. Warpage gauge values, such
as coplanarity, are frequently determined by a small number of data points, e.g. the
highest and lowest displacement values. Therefore, they are extremely sensitive to
statistical outliers in the data set. Smoothing, by reducing statistical noise, can make
these values more repeatable from measurement to measurement.

To apply the smooth function, right-click inside the phase image and choose Smooth.
This command can be repeated multiple times. For further information about the smooth
function, refer to Akrometrix Optical Techniques and Analysis 101.

L

Note: Smoothing may cause errors when applied to
images where the fringes are very tightly spaced or at
boundaries of mask ROIs. Therefore, it is not
recommended to apply the smooth function on data
acquired with the MP10 Surface Measurement
system which produces a closely spaced fringe pattern
on a phase image.

il

3.7 Rotating a Phase Image

Rotating a phase image is a feature useful when a sample does not have the desired
orientation in the original phase image (e.g. a part has rotated on the sample support
fixture during a temperature profile).

To rotate a phase image, right-click on the image, choose Advanced->Rotate and
select the desired rotation.

L

Note: Phase image rotation is different from reference
plane rotation that is discussed in Section 4.3. The
former rotates a 2D image while the latter rotates a 3D
surface. To choose the method of rotating a reference

1]
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plane, right-click on the phase image and choose
Rotation (Figure 3.30).

reapes
Analyze . . T TNRRAN |
Amplitude Threshold... Analyze
Smooth Amplitude Threshold...
Rotation 3
Smooth
l‘ Advanced 4 Unwrapping Parameters  »
Properties... Mask » Retation » | Mone
Partition v ! Advanced L4 LSF
‘C{:vm : Properties.., LSF Low O
Rotate 3 180 deg LSF High 0
Duplicate 90 deg CW Three Point
Compensation 90 deg CCW -
— — Four Point
Undo

Figure 3.30 Reference Plane Rotation
Figure 3.29 Phase Image Rotation

3.8 Shifting a Phase Image

Shifting a phase image is a feature useful when a sample does not have the desired
position in the original phase image, e.g. a part has shifted to one side of the sample
support fixture during a temperature profile.

To shift a phase image, right-click on the phase image, choose Advanced->Shift...
and select the desired shift in either the X (left-right) or Y (up-down) direction. The image
will shift with respect to an origin that is defined as the top left of the phase image. Areas
shifted from outside the boundaries of the phase image will be filled with mask (see
Figure 3.31).

@ s-

[@l Sample Image.akx_phase !EE

Shift Image x i
X-Direction Y-Direction
20 S n
iuN A
| _OK Cancel
250 x 200 pixels ~ | 100 % | 250 x 200 pixels ~ | 100 %

Figure 3.31 Shifting a Phase Image
3.9 Undoing a Phase Image Modification

To undo phase image modification from masking, partitioning, smoothing, rotating or
shifting, right-click and select Advanced->Undo; select the action to undo from the
available list.

There can be up to 99 actions on the undo list. The latest action will be shown at the
top of the list. Clicking on the latest action will remove this single action and move the
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phase image back one state. Clicking on any item in the middle of the list will remove all
the actions from the top to this item.

3.10 Saving Phase Images

A modified phase image is NOT automatically saved to the hard drive. It can be saved
using the File>Save... menu item. If the modified image is not saved, the user will be
prompted again to save it when the phase image window is closed or the program is shut
down.
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4 Analyzing Measurement Data

Analysis is the mathematical conversion of the measurement data (e.g. phase image)
into displacement data (the height of the surface at each image pixel in physical units).
Surface Analysis is normally set to display displacement data graphically as soon as the
analysis is complete. The graphical output options will be described in Section 4.6. This
section describes how to initiate the analysis process and a key factor in the analysis, the
choice of reference plane.

4.1 Analysis
There are three methods to trigger analysis of the measurement data

A. To trigger analysis manually, right-click on the phase or displacement image to
be analyzed and select Analyze.

B. To trigger analysis automatically when a *.akx_phase file is opened, select the
Tools->Options... menu item and check Analyze on Open.

C. To analyze multiple measurement data in parallel, use the Batch Analysis
function described in Section 6.2.

—— Note: Ifno graphical display options are checked in the
— options window, there will be no visible indication that
analysis has taken place in cases A and B above.

4.2 The Options Window

The settings on the options window (Figure 4.1) determine the reference plane and
display options when the measurement data is analyzed. These settings will be applied
to all the measurement data, either manually or automatically on opening.

|

To open the options window, select the Tools=>Options... menu item. All the settings
are explained below:

Units XY Displays the in-plane dimensions in English (inches) or metric
units (millimeters).

Units Z Displays the out-of-plane dimensions in English (mils, 1 mil =
0.001 inches) or metric units (microns, or pum).

Smooth Phase on Checking this box causes the phase image to be smoothed
Open one time immediately after loaded.

Analyze on Open Checking this box causes the measurement data to be
analyzed immediately after loaded.

Grating Checking this box applies compensation to all measurement

Compensation data that contain compensation parameters (See Section 4.5
for a discussion of grating compensation). It may be turned
on or off for individual measurement data by right-clicking on
a phase image and choosing Advanced->Compensate.
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Normalize Checking this box causes all 2D chord plots to be displayed
Chords with the endpoints referenced to zero.

Default Rotation Pull-down list sets the reference plane rotation to be applied
during the analysis. See Section 4.3.

Gauges — Surface Select which gauges (numerical values quantifying flatness)
are Active. Activating a gauge means that it will be calculated
and displayed in both the Displacement Window Gauges tab
and at the bottom of any 3D graphs. A gauge on the list may
be highlighted by clicking on it once. The up and down arrows
move the highlighted gauge up and down the list, changing
the order in which gauges are displayed.

Note: The second check box currently has no effect,
4 and its value is not retained. It will have a use in future
updates.

|

Gauges — Chord  Select which gauges show up at the bottom of a Chord Graph.
Order By also determines the order in which the selected
gauges are displayed.

Graphs Selects which graph formats (see Sections 5.1 through 5.4)
are displayed after analysis. A graph on the list may be
highlighted by clicking on it once. Checking a box means that
graph will be displayed. The up and down arrows move the
highlighted graph up and down the list, changing the order in
which graphs are displayed.

Configuration Allows the user to load a non-default display format for

File graphs. The 3D configuration file has an extension of
*.akx_3Dconfig and is used for 3D plots. See Section 5.1.
The 2D configuration file has an extension of *.akx_2Dconfig
and is used for any 2D chords. See Sections 5.3 and 5.4.

Graph Size Sets the initial size for all graphical displays created during
analysis.

Gauge Display Gauge values listed at the bottom of the 3D or 2D display
window may be arranged horizontally or vertically.

Use Latest 3D Applies the perspective of the most recently modified 3D

View surface plot to all subsequently spawned 3D surface plots. In
other words, if the user changes the altitude or rotation from
which the surface is viewed in one graph, new graphs will
automatically be shown from the same viewpoint. The zoom
factor of the most recent graph will also be inherited.
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Fixed Z-Scale When checked, this allows the user to adjust the data scale
for all 3D or 2D plots. When unchecked, each image is plotted
on a scale set by its own data set. This option is also available
in Batch Analysis (Tools>Batch Processing...2>Analysis
Tab).

Batch Analysis Allows the user to load a *.akx_recipe file to change the
default Batch Analysis settings. Also allows the default file
format to be selected as well as whether the file full path is
included in the batch results.

OK Any changes to the settings are saved and the window is
closed.
Cancel The window will close without changes to the settings.
Options % X
Analysis Window Output
Units
E
miIIimxe\t(er ~ microzn ~ orCorﬂour f
E 5:'?:0':: Centerine ‘
[] Smacth Phaze On Open E I:;f;ﬂg:miﬂie:

[ Left Right Edges

[] Analyze On Open

3D Conrfiguration File

[] Grating Compensation |

[] Nomalize Chords Graph Size
Width Height
LSF - 861 |5 551

Default Rotation

Gauge Display
(® Horizontal ) Vetical

Gauges

Suface Chord [ Use Latest 3D View

2 m e D
[/ [ | HD Coplanarity ‘
OO | Bow

OO Twist

/O oTA

/[ FF5 Wampage

[/ ]| FFS Wampage DB

[ LIEES Wamane hd

[] Enabled [] Enabled
Waximum Waximum
Minimum Minimum

Batch Analysis

Default Settings File | | Set...

Batch Results Default File Format | bt (Tab-Delimited Text) w

Include full path info for files listed in Batch Results

Cancel

Figure 4.1 Options Window
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Note: If no options are checked on the Graphs list,
~| there will be no visible indication that analysis has
taken place.

|

4.3 Reference Plane — Rotation

In order to display the displacement data, the user may define a coordinate system
with a zero reference plane. This is especially useful when calculating gauges. To set the
reference plane rotation to be used during analysis, select Tools=>Options... and
choose from the Default Rotation pull-down list.

The rotation choice can also be made before analysis by right-clicking on the phase
image and choosing Rotation or Transform->Plane Rotation on a displacement image,
then selecting from the list. The selected option is checked.

&

Note: The rotation option chosen in the options
window will be applied to all the measurement data
when loaded. The rotation option chosen from an
individual phase or displacement image will only be
applied to that particular data.

il

Surface Analysis provides the user with several options for defining the zero
reference plane:

e None: The displacement data is not rotated and thus the reference plane is
parallel to the grating. The zero value on the data does not correspond to any
specific feature of the displacement surface.

e LSF: The displacement data is rotated so that the zero reference plane is the
best fit plane calculated from all displacement points.

e LSF Low O: LSF rotation option with the lowest displacement point set equal
to zero (all others are positive displacement values).

e LSF High 0: LSF rotation option with the highest displacement point set equal
to zero (all others are negative displacement values).

e Three Point: The displacement data is rotated so that the zero reference plane
is defined by three corners (upper left, lower left, upper right).

e Four Point: The displacement data is rotated so that the zero reference plane
is the best fit plane calculated from all four corners.

When analyzing a displacement image, the User Defined rotation option is also
available. This allows the user to specify a region on the sample surface to fit a LSF plane
to. This LSF plane is then used to rotate the entire surface.
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Figure 4.2 User Defined Plane Rotation

In Figure 4.2 the green box can be dragged around and resized to cover the area
that represents the desired rotation. In the context menu, Rotate will perform the rotation.
If the rotation is deemed acceptable, Accept will complete the operation and remove the
green box. Revert will undo the rotation. In addition, the green box can be copied from
one displacement window to another using the Copy/Paste commands. Lastly, the box
size and location can be set from another *.akx_disp file as well as edited using the
Square Bounds and Edit commands.

The values of the individual data points change as a function of rotation (choice of
reference plane), so gauges (e.g. coplanarity) and other calculated values are also a
function of rotation. See Akrometrix Optical Technigues and Analyses 101 for further
discussion.

4.4 Reference Surface — Relative Displacement

A relative displacement measurement is calculated by taking the difference between
two absolute displacement measurements with the same image pixel size. It is useful for
observing the change in sample warpage as a function of sample history. The baseline
displacement surface is set to be reference surface. The relative displacement surface is
the current active surface minus the reference surface.

To define a reference surface, right-click on a 3D graph analyzed from a phase image
and check Use as Reference. This surface data will then act as a reference to all other
displacement data. After identifying the reference surface, right-click on a second phase
image of the same pixel dimensions. An additional menu item, Analyze Relative, appears
on the list below Analyze. To obtain the relative displacement data, select Analyze
Relative. Otherwise, choose Analyze to obtain the absolute displacement data. The
relative displacement display can be turned off by right-clicking on the reference surface
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image and unchecking Reference Surface. After that, Analyze Relative will disappear
from the menu list for the phase images.
L 4

Note: Analyze Relative only compares data with the
same pixel dimensions. If the second phase image is
of different pixel dimensions than the reference phase
image, the user will be shown an error message.

il

4.5 Reference Surface — Grating Compensation

The non-planar surface of a grating can be compensated by a reference surface (see
Akrometrix Optical Technigues and Analyses 101). To enable grating compensation
during analysis, check the Enabled box under Grating Compensation in the options
window.

The compensation choice can also be made for individual phase images by right-
clicking on the phase image and checking Advanced->Compensation. To turn off
compensation, repeat the process and uncheck the selection by clicking it again.

L

Note: In the options window, the Grating
Compensation option can be enabled or disabled
regardless of whether the grating has been
compensated or not. This option will be applied to all
opened phase images that contain compensation data.

—

" Note: The compensation option on an individual phase

— | 1image will be grayed out if no compensation

2 parameters can be found in the *.akx_phase file.
Otherwise, this option is shown in black and can be
checked or unchecked. The compensation option
chosen for each phase image will only be applied to
that particular image.

&

Note: In order to apply grating compensation, physical
dimensions have to be assigned to the phase image
(see Section 2.3.5). The grating compensation
calculation assumes that the ROI is centered with
respect to the grating. The accuracy of the
compensation will be reduced if the ROI is not
centered, particularly if it lies outside the central 4” by
4” area of the grating.

]|
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4.6 Unwrapping Parameters

A procedure called “unwrapping” is a key part of the analysis of measured phase data
(See Akrometrix Optical Techniques and Analyses 101). The unwrapping process
starts in the geometric center of the image and converts phase data to displacement
values. Because the flood-fill algorithm used is inherently sequential, it simply stops any
time a mask value is reached. As a result, it was impossible in previous versions of
Surface Analysis to see data that was entirely separated by mask from the center of the
surface being analyzed. An example of such data is shown in Figure 4.3. Only the center
is analyzed because of the mask, which stops the unwrapping process from continuing
to the valid surrounding data.

&l 0001 WPk [ = || &[Sl
. n

X (pixels) a7

Yipixels)  microns

rll

102 x 109 pixels - | 200% -24.5

Mo s
=
[

Figure 4.3 Isolated data

As of Studio 8.2, Unwrapping Parameters functionality allows the user to control
aspects of the otherwise automated unwrapping process, thereby mitigating these data
isolation issues. Unwrapping Parameters as a category covers two specific, mutually
exclusive functions, Start Point and Phase Bridging, which solve the issue of isolated data
in different ways.

4.6.1 Start Point

Start Point allows the user to manually change the start location of the unwrapping
process, which, by default, starts in the center of the image. If only one isolated island of
data is of interest, changing the start point allows the user to start the analysis in that
island. Figure 4.4 shows an example. Instead of starting in the center as in Figure 4.3,
the same image is analyzed with the start point moved to a corner, and the previously-
inaccessible edges are now visible at the expense of the center.

X (pixels)

microns
55.0

ss  Y(pixels)

Figure 4.4 Analyzed Data with Altered Start Point
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The key steps in editing a Start Point are:

1. Right click on the phase image and go to Advanced->Unwrapping
Parameters->Edit.

2. Inthe resulting menu, change the X and Y location of the start point and select OK.

3. An orange dot will appear on the phase image, representing the new start point
location. This can be toggled on and off using Advanced->Unwrapping
Parameters->»Start Point.

4. Analyze the file using the new Start Point.
4.6.2 Phase Bridging

Phase Bridging is a more complex solution to the issue of isolated data. With phase
bridging, the user draws a bridge from one data “island” to another, so that the analysis
software can bridge the gap. Unlike Start Point, Phase Bridging can be used to show all
of the data at once. Examples of phase bridging are shown in Figure 4.5 and Figure 4.6.
Note that in Figure 4.5 the data is all at a similar height, while Figure 4.6 contains a
discontinuous step whose height causes much of the actual warpage to be masked.
Phase data is still used to calculate exact height from areas, although the height
difference itself is entered manually for each bridge.

@) sample.ake phase =R =E=]
Sample

X (pixels) i3y 212228

Coplanarity = 602.1 microns

L g

215x 221 pixels ~ 200%! on: 30 Altitude: 45 Zoom: 100% Center: 0.50, 0.50

Figure 4.5 Phase-bridged Data at Similar Heights
0001_UP.akx... [ |[- )| 3]
™

X (pixels) L
65

a4 Y (pixels)

22 65 microns

102 x 109 pixels ~ | 200%

Figure 4.6 Phase-bridged Data with a Step
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The key steps in creating a Phase Bridge are:

1. Right click on the phase image and go to Advanced->Unwrapping
Parameters->Add Bridge, or press Ctrl+B.

2. Click on a start and end point in the phase image. Make sure to start in one data
‘island,” and end in another.

3. As of Studio 8.3, Surface Analysis will then show a “Rotated” phase image where
the data is shown relative to an LSF plane of the “A” phase region. This helps in
determining where to place bridges and what height estimates to apply. Note that
this is not the final data rotation as that is performed on the whole data set after
unwrapping is complete.

4. An orange arrow will appear on the phase image, representing the new phase
bridge. This can be toggled on and off using Advanced->Unwrapping
Parameters->Phase Bridging

5. The user can add as many phase bridges as are necessary to connect all of the
isolated data.

6. Analyze the file using the new Phase Bridge(s).

L

Note: Once a phase bridge has been added,
unwrapping will begin from the beginning of the first
phase bridge, and then start at the end of the bridge
when that is complete, and so on across all phase
bridges. This is why Start Point and Phase Bridging are
mutually exclusive, and also why it is not possible to
have multiple bridges leaving the same section of data.
Bridges must move sequentially from section to
section.

il

The user has a variety of options when it comes to editing and adjusting phase
bridges. The start and end points of an existing phase bridge may be altered at any time
by clicking and dragging the white handles at either end. In addition, right-clicking on an
existing phase bridge brings up a unigque context menu whose options are explained

below.
Reverse Direction Switches the start and end points of the phase bridge
Align Aligns the phase bridge horizontally or vertically
Delete (Del) Deletes the phase bridge
Edit Brings up the Phase Bridge Edit Window shown in

Figure 4.7.
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Figure 4.7 Phase Bridge Edit Window

The Edit Bridge window gives the user access to several powerful options for
controlling phase bridges. These include:

Name Change the name of the phase bridge. The default naming
scheme for phase bridges is A-B, B-C, C-D, etc.

Start Point Determines the coordinates of the start point of the phase
bridge.

End Point Determines the coordinates of the end point of the phase
bridge.

Include Region in Selecting this option includes a given region when an

LSF Calculation LSF plane calculation is performed on the data (see
Section 4.3).

Mode Determines whether the coordinates of the start and end

points are expressed in absolute or fractional mode.

Height Estimate The user-entered height estimate is used by the program
to determine the relative height of bridged sections. Since
phase data is relative, the program doesn’t treat a
connected section a different fringe order unless the user
tells it to. The user height estimate determines the fringe
order of the isolated section while the actual phase data
is used for fine scale height within that fringe order.
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Figure 4.8 Phase Bridge Step Height Example

&

Note: Height estimates must fall within +/- 0.25 Fringe
Values of the measurement (+/-64 microns with the
100 LPI). Height Estimates incorrect by +/- 0.25 to 0.75
Fringe Values will generate an error from the software
stating an incorrect height estimate. Height
approximations incorrect beyond this threshold would
lead to incorrect data. This is illustrated in Figure 4.8
using the same data set from Figure 4.6.

—_—

4.6.3 Unwrapping Parameter Files

Once unwrapping parameters have been set, the user can copy or save them to use
them in other files. From the Advanced>Unwrapping Parameters context menu, the user
can:

Load existing *.akx_unwrap files.

Save any active unwrapping parameters as *.akx_unwrap files.
Copy any active unwrapping parameters.

Paste copied unwrapping parameters onto phase images.

&

—4 Note: In this context, “active unwrapping parameters”
— are those that are toggled on in the context menu and
visible in orange on the phase image.
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5 Displaying Results
After analysis, the information is displayed in a choice of four graphical formats:

3D Surface (Section 5.1)

3D Contour (Section 5.2)

2D Diagonal (Section 5.3)
2D Chord (Section 5.4)

The data displayed in each graph can be exported in numerical form (Section 5.5).
In the meantime, gauges (single values representing the warpage) can be displayed at
the bottom of the 3D graphs (Section 5.6).

5.1 Graphical Output — 3D Surface Plot
5.1.1 3D Display Window

To display the 3D Surface plot after analysis, check the box next to 3D on the Graphs
list in the options window (Section 4.2). After right-clicking and selecting Analyze on the
phase image or Analysis->Generate Results on a displacement image, a new 3D
display window is opened and the 3D height map represented in color is shown in the
center of this window. Interaction with the 3D display when generated from a
displacement image is similar to that of the original image. Further details on the 3D
display window generated from a phase image are discussed in this Section 5.1.4. The
name of the data file will be shown on the top and gauges selected in the options window
will be displayed below the 3D image. The caption of the 3D display window can be
renamed by right-clicking on its title bar and selecting Rename Window.... Additional
information including cursor coordinate position, viewpoint and zoom ratio can be found
in the status bar at the bottom left. See Figure 5.1.

5.1.2 Key/Mouse Interactions with the Graph
There are five interactions that can be done with the 3D graph:

1. Coordinates of each individual data points are shown live in the status bar by
hovering the cursor over the 3D image.

2. Rotate adjusts the angle from which the surface is viewed. Press the left mouse
button and drag the plot to the desired orientation in the display window. The
current Rotation and Altitude parameters will be displayed in the status bar.

3. Zoom adjusts the scale of the plot. Scroll the mouse wheel and change the plot to
the desired scale in the display window. The current 3D graph magnification level
will be displayed in the status bar.

4. Pan adjusts the plot center point. Simultaneously press the Ctrl key and left click
on the plot to set the center point. Subsequent rotate and zoom functions will rotate
and zoom about this new point.

5. Esc key brings the 3D graph back to its original size (zoom ratio of 100%) and
center point.
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Figure 5.1 3D Surface Plot
5.1.3 Changing Viewpoint
The viewpoint of a 3D graph can be set using four different approaches:
e Use Latest 3D View box in the options window (Section 4.2)
e Rotate and Pan operations (Section 5.1.2)
e Copy View and Paste View in the 3D display command list (Section 5.1.4)
e The display Configuration window (Section 5.1.5)
5.1.4 Graph Command List

Right-clicking on the display window will show a different context menu depending on
whether it came from a phase image or a displacement file. The context menu for a 3D
graph created from a phase image is described below. For 3D graphs originating from a
displacement window, the context menu command list is the same as that on the 3D
Graph tab in the multi-tabbed *.akx_disp window. See Section 2.4.

File Allows saving of the current displacement data either
numerically or as a picture. Also contains commands for
exporting a legend, printing the picture and closing the
window.
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Smooth Applies a smoothing function to the 3D data and shows the
smoothed surface in a new window. This command can be
repeated multiple times. See AOTA101 for more information.

Fit Data... Opens a dialog where a polynomial fit can be calculated
based on the data set. See Figure 5.2. Alternatively, if
physical dimensions are assigned to the phase image, a
spherical fit can be calculated.

Plot Chord(s) Plots pre-defined chords in a new window.

Show Relative To Displays the relative displacement data calculated by
subtracting a selected 3D data from the current 3D data in a
new window.

Use as Reference Sets the current 3D data to serve as the reference surface

SOFC Displays a window containing all Second Order Fit
Coefficients used to calculate a 2" order polynomial fit for
the surface.

Display Contains the copy, paste, and reset view commands for
applying one 3D graph orientation and zoom to another. Also
contains Z-Axis units, scale options, and a switch to show Pin
1 Location on plots. Lastly, graph configuration parameters
are accessed here. See Section 5.1.5

Properties... Opens a displacement object properties window with all saved
parameters relating to the displacement object.

Fit Diata >

(®) Pobynomial Order &
() Spherical

Retain Masked Points

Cancel

Figure 5.2 Fit Data Dialog
5.1.5 Display Configuration Window

The display configuration window (Figure 5.3) gives the user the ability to customize
the graph display format. The custom format can be saved and re-used, and set as the
default format for all 3D plots. To display the configuration window, right-click inside the
graph window and select Configure....
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In the configuration window, to load a previously saved display configuration, choose
File>Open... (Ctrl+0O). To save the current display configuration, choose File->Save....

(Ctrl+S).

m

Note: The display configuration file (*.akx_3Dconfig)
loaded from the display properties window is applied to
the current display window (Figure 5.1). Configuration
files loaded from the Options window (see Section 4.2,

Figure 4.1) will be applied to all newly created display

windows.
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Figure 5.3 Display Configuration Window
5.2 Graphical Output — 3D Contour Plot

To display the 3D Contour plot after analysis, check the box next to ColorContour
on the Graphs list in the options window. Most of the contour plot commands and features
are identical to those described in Section 5.1 (Figure 5.4).
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JFFS Warpage = -595.4 microns  Signed Warpage = -595.4 microns

(X.Y,Z) = N/A Rotation: 0 Altitude: 90 Zoom: 90% Center: 0.50, 0.50

Figure 5.4 Contour Plot

5.3 Graphical Output — Default Chord Plots

A chord is a 2D line across the surface of a part. A chord plot graphs the z-values
along these lines. Surface Analysis can display a wide variety of plots for both default and
custom chords. The most common default chords are Diagonals, Horizontal Centerline,
Vertical Centerline, Top Bottom Edges, and Left Right Edges. These common chords are
all available on the Graphs list in Tools>Options, and checking them there causes these
chord plots to come up automatically when analyzing a phase image.

Note: The diagonal plot (Figure 5.5) represents two
_| cross-sections of the surface along diagonal lines
connecting the corners.

|

The plot window for any of these common chord plots, along with some other default
chords, can also be opened by right-clicking on the 3D display window and selecting Plot
Chord(s)=>Chord Name. A full list of available default chords is below.

Diagonals
Centerlines

Top Bottom Edges
Left Right Edges
All Edges
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All Edges Centers Diags

e Five Vertical
e Five Horizontal
e Horizontal Centerline
e Vertical Centerline
. - -
_ Note: All of the chords oriented horizontally are plotted
—_| from left to right and all vertical chords are plotted from
top to bottom.
—" Note: The caption of the 2D display window can be
— renamed by right-clicking on its title bar and selecting
i Rename Window....
— 1" Note: On the 3D Graph tab of a displacement file,
—_ | Analysis>Plot Chord(s)=>Chord Name will bring up
2 a chord plot.
'DbSEmp\e EI@
Sample
400 T
Scale ¥-Axis...
Save... Ctrl+5
300 T Save Image... Ctrl+4l
’J; ™ Mormalized F9
g 200 - Reset View E=c
o Print.. Ctrl+P
g 100 T Create Legend...
b= Configure...
» /™ /
g -/
F -100 T
O
200 L
-300 — —— | | i .
0 50 100 150 200 250 300
Position Along Diagonals (pixels)
Downward Diagonal Upward Diagonal
Downward Diagonal Min =-188 microns Downward Diagonal Max = 205 microns Upward Diagonal Min =-215 microns Upward Diagonal Max = 348 microns
\ (Y] = (123, 395)

Figure 5.5 Diagonal Plot

5.3.1 Display Command List

Right-click inside the display window to show the command list.

Scale Y-Axis...

Save...

Displays a window where the minimum and maximum values
of the Y axis may be modified. Defaults are the min and max

values of the data plus a software determined buffer.
Exports the data in numerical format (Section 5.5)
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Save Image... Allows display window to be saved in graphical format
(*_dia.png).

Normalized Causes all diagonal plots to be displayed with the endpoints
for each diagonal set to zero.

Reset View Resets the graph view after it has been zoomed.

Print... Allows display window to be printed to any available system
printer.

Create Legend... Allows the legend to be saved as a separate picture file for
reporting purposes.

Configure... The 2D display properties window is very similar to the 3D
version described in Section 5.1.5.

5.4 Graphical Output — Custom Chord Plots

In addition to the default chords described in Section 5.3, arbitrary chords or chord
sets can be defined, where out-of-plane displacement data along any line(s) can be
displayed. The following subsections will describe how to draw a generic chord or chord
set.

5.4.1 Creating a Chord

Right-click inside a phase image and select Advanced->Chord->New Chord
(Ctrl+K). Using the mouse, draw a line across the image, holding down the left mouse
button at the start point and releasing it at the end point.

L

Note: Chords can also be plotted on 2D displacement
images (*.akx_disp files). The menus and functionality
are the same, but the Chord Menu is found under
Analysis>Chord for displacement images, rather
than Advanced->Chord in phase images. The rest of
this section will use the terminology for phase images.

il

Several preset chords can be added to the phase or displacement image using
keyboard shortcuts.

Shift+T: Top Edge

Shift+B: Bottom Edge

Shift+L: Left Edge

Shift+R: Right Edge

Shift+D: Downward diagonal (upper left to lower right corner)
Shift+U: Upward diagonal (lower left to upper right corner)
Shift+H: Horizontal centerline

Shift+V: Vertical centerline

Note: Preset chords can be removed by hitting the
-| keyboard shortcut a second time. They cannot be
edited.

|
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5.4.2 Editing a Chord

To reposition the endpoints of a chord, click on the chord. Square white handles will
appear on either end of the chord, which can be moved with the cursor.

Right-click on a chord to show the chord command options list:
Reverse Direction Reverses the direction of the data along the chord when

plotted.

Align Aligns the chord horizontally or vertically.

Plot Plots the current chord in a new 2D display window.

Plot Set Plots all chords appearing on the phase or displacement
image (only available when more than one chord is shown on
the image).

Delete (Del) Deletes the selected chord.

Edit... Allows the endpoint positions to be set to specific pixel values

using text boxes. Also allows renaming of the chord.
5.4.3 Plotting a Chord

Right-click on the chord and choose Plot or Plot Set. Calculation is performed and a
display window appears. All display commands available for Diagonal plots are applicable
here, including exporting the chord displacement data in humerical form. See Section
5.3.1.

5.4.4 Using a Chord Set

One or more chords form a set, which can be saved, re-used, and plotted collectively.
A set is started automatically when the first chord is drawn on the phase or displacement
image. Additional chords added using Advanced->Chord->New Chord become part of
this set.

A set can be saved by right-clicking on the phase image and choosing
Advanced>Chord->Save Set... and a saved set can be loaded by choosing
Advanced->Chord->Load Set.... A saved set has a filename ending in *.akx_chordset.
These files can be loaded in batch analysis and report creation as well as on individual
phase or displacement images.

&

Note: If a loaded chord set was generated from a
larger phase or displacement image than the current
one, only the chords with both ends falling within the
current image in that set will be loaded.

Il

All the chords in a set can be plotted on the same graph by right-clicking on any of
the chords and selecting Plot Set.

A new set can be started by right-clicking on the phase image and choosing
Advanced->Chord->New Set (Ctrl+G). Up to 9 sets can be created for one image.

Multiple sets can be in memory at the same time. The sets are numbered 1 through
9, depending on the order in which they are created or loaded. A particular set can be
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displayed by typing Shift + its number on the keyboard or choosing
Advanced->Chord->Set and selecting the desired set number.

5.4.5 Saving a Chord Image

After a chord or chord set is plotted, the graphical image can be saved by right-
clicking on the 2D image and choosing Save Image.... The image may be saved in PNG
format with different suffixes as listed below:

Chord Type File Suffix | File Extension
Diagonal _dia .png
Horizontal Centerline _hzc .png
Horizontal Edges _hze .png
Vertical Centerline _vtc .png
Vertical Edges _vte .png
Arbitrary _crd .png

5.5 Numerical Output

Numerical data from all display windows can be exported from the context menu. For
any 2D plot, this is done by right-clicking on the display window and selecting Save.... A
standard Save window appears with multiple choices for the save format in the Save as
type pull-down list at the bottom. 3D plots — Color Contour and 3D graph — have slightly
different context menus and save options, as described in Section 5.1.4.

Akx_disp Exports data in the Akrometrix akx_disp format (not available
for chords)

Dat files Exports data in tab-delimited text format
Text files Exports data in space-delimited text format

Dat and text files containing chord data will use the same prefixes as chord image
files, as described in Section 5.4.5.

5.6 Gauge Output

Gauges can be selected in the Gauges list in the Options window and are displayed
at the bottom of 3D Surface, Contour or Chord plots where appropriate. Gauge definitions
are available in Akrometrix Optical Techniques and Analyses 101.
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6 Batch Processing

6.1 Batch Processing

Batch processing allows most of the one-off functionality in Surface Analysis to be
performed on multiple data files with no user interaction. This functionality is very helpful
when performing large experiments with multiple ROIs and/or multiple temperature
points. There are seven batch functions available:

e Batch Analyze

e Batch Mask

Batch Rotate
Batch Crop

Edit XY Orientation
Batch Convert
Feature Detection

To access the batch processing functions, select the Tools>Batch Processing...
menu item. This will open a batch processing window (Figure 6.1). Tabbed screens
appear for the seven batch processing functions. Common menu items for these functions
appear on a menu bar above the tabs.

Note: Multiple batch processing windows can be
4 opened to process different data or process the same
data with different settings.

o2/ Batch Processing =N =
Source Edit  Action
Analyze  Mask Rotate Crop  Edt XY Orientation Convert Feature Detection
Analysis Options Results | Output]
[ Phase Ampituce Threshold [] Active Metadata Fie Fiter
[ Smocth Phase Actve  Filename Coplana

[ Mask Phase

d Diagonal Min Downward Diagenal Max Upward Diagonal Max

[%  Select Metadata Columns.

akx_disp 3D Graph  Diagonals

Graphs & Data Configuration Fie Header
Legend

[<SourceDataFilenameOnlyNoExt> |

Qutput Files [0 Commen Z-Scale
Footer

[<Copianarty> |

Graph Image Size: 861x 551

DOO0OOO00ROE

Image Filename Suffic 3D

Figure 6.1 Batch Processing Screen
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6.2 Batch Analysis

The batch analysis function opens the image or displacement files in the selected
folder(s), analyzes the data, and saves the results in graphical and/or numerical format.
This is useful, for example, for analyzing all the warpage measurements taken during a
temperature profile and plotting the results on the same scale. The batch analysis tab
window shows the conditions to be applied during analysis and display, while the action
is initiated using the Action menu item.

Source - Select... Identifies the folder of *.akx_phase or *.akx_disp files on
which the batch processing functions will be applied. As
of Studio 8.0, multiple folders can now be analyzed via a
pop-up folder selector. See Section 6.2.1.

Edit 2 File Type Switches  between analyzing phase images
(*.akx_phase) and displacement data (*.akx_disp).

Edit = Refresh Allows the user to update the file count since the folder
Source Folder (F5) was originally selected.

Edit = Settings =2 Loads settings for Batch Processing from a *.akx_recipe
Load... file

Edit = Settings =2 Saves settings for Batch Processing to a *.akx_recipe
Save... file

Edit = Settings =2 Loads program defaults

Load Defaults...

Edit = Settings = Set Loads settings from the Options window.
From Preferences

Edit = Settings =2 Opens a duplicate of the current batch processing
Duplicate Window window, including all loaded data and current settings.

Edit = Output Sequential or Parallel: for large batch operations parallel
Performance 2> will speed up analysis at the expense of populating the

table in non-sequential order.

Action = Group... Initiates the grouping function in order to organize files
for reporting purposes. This must be done before
analysis. See Section 7.1 for details.

Action = Analyze Analyzes the phase or displacement files loaded into the
file list.

Action = Generate Produces output files (pictures and/or data) of various

Output kinds and writes them to disk, as well as displaying

images in the Output tab. See Section 6.2.5.
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Action = Lock Locks the results of analysis to a particular window. This

Results option is not active unless Generate Output has been
performed. While it is active, the output images will be
held in temporary memory and will not be affected by any
other analysis of the same files, allowing the user to
compare different analysis settings on the same files.
Unlocking the results will clear them from memory,
requiring the files to be reanalyzed.

Action - Create Opens the report creation window with analysis data
Report... from the Current Batch pre-loaded in memory.

6.2.1 Using Batch Analysis
The key steps in using batch analysis are:

1. Select a folder to be analyzed (Source->Select... menu item). Multiple folders can
be added and filenames filtered out. Files can be added from a parent folder by
right clicking on an already added folder row. Subfolders can be added via a
checkbox in this form. If multiple rows are added, certain rows can be “deactivated”
for quick comparison between multiple data sets without having to remove or add
folders.

L

—3 Note: A common filename filter that many users might
find useful is to enclose some part of the filename in
asterisks. For example, *PT* will only include files that
include the string “PT” somewhere in the filename. This
is particularly useful when filtering out part tracked
search area files from the individual ROIs. PT can be
substituted for any other string that’s included in all the
files needed.

]

Note: The List Files option in the context menu in
Figure 6.4 gives a list of all filenames of currently-
active files in the folder. This can be used with
Filename Filter to more precisely filter out any
unwanted files.

I

Browse For Folder X

Files
File Type: akx_phase [ ] Filename Fiter

Add Folder

Folder List
Active  Subfolders Files Folder Name

== DVD RW Drive (D:) -
= USE Drive (E})

= YUSE Drive (F)

- USE Drive (G:)

= USE Drive (H:)

s USB Drive (1)

¥ Network

[E5] Control Panel v
< >

Cancel Cancel

Figure 6.2 Batch Analysis Source Selection Browse for Folder
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Batch Analysis Source *

Files
Filz Type: akee_phase [] Filename Fiter
Folder List
| Active  Subfolders Files Folder Name
] =] 1 C:\Akrometrix:Surface Analysis'Results

Add...
Add Recent

Refresh

Remove All

Figure 6.3 Batch Analysis Source Selection Add Folders

Batch Analysis Source ®
Files
File Type: akoe_phase [ Filename Fitter Syrtax Examples >
Folder List

| Active  Subfolders Files Folder Name

] [} 1 C:\krometrixcySurface Analysis'Results Add..

Add from parent...

Add Recent 3
List files

Show folder

Open folder
Refrech

Remove

Figure 6.4 Batch Analysis Source Selection Add from parent...

2. Once all folders have been added to the Batch Analysis Source dialog, click OK.
The files from this dialog will be populated into the Batch Analysis Results table
sans any displacement gauge information. Right-clicking on a row brings up a
context menu where individual files or folders can be opened. In addition, several
options allow the user to set the active files en masse.

% BGA_1_00434 Open 'BGA_1_004385(216C).akx_phase' |
b1 BGA_1_00467 Open Containing Folder e
& BGA_2_0000: Export Table... E—
[+ BGA_2_ 00237

] BGA_2_0029( All Active I
] BGA_2 00362 Mone Active [
% BGA_2 00438 Inwert Active -
] BGA_2 00467 Set Every MNth Active... I
] BGA,_3_00003 Rermove Inactive I

Figure 6.5 Analysis Results Table with Context Menu

3. Select analysis options (Section 6.2.3) and any additional columns of metadata
required (right click on column headers in Results tab).

4. Analyze the measurement data (Action->Analyze menu item). The measurement
gauge results will be populated into the table. The extreme values of each
parameter are shown below, which can provide the default scale for generating
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plots. The table is exported to each top level directory of the folders being

analyzed.

Active Filename Coplanarity Dowrward Diac
Region 001_Unit_00001s(25C) akx_disp 67 -1559
Region 001_Unit_D0261s(148C) aloc_disp 173 -41
Region 001_Unit_0035%=(215C) aloc_disp 175 -48
Region 001_Unit_0C Open 'Region 001_Unit_00399s(215C).ake;_disp'
Region 001_Unit_0C Open Containing Folder
Region 001_Unit_00 Export Table...

Region 001_Unit_01 All Active

il D Mone Active

Region 0071 from Actiomr oo ST TS TMEsKET SR s T T=TE
£

5/9 BExtrema 114 -2

Figure 6.6 Batch Results Table after Analysis

5. Filter out any data not desired using the Active Metadata File Filter option. Files
can be unchecked from being Active by setting up filter/logic conditions in the
Metadata File Filter Query Builder (Figure 6.7). File filter queries can be saved and
loaded as *.akx_query files in the Query Builder interface for future use.

Query Builder = X
File I}
Clear
AND ~ | (| | Suface Gauge Value ~ | JFFS Warpage DB ~ | |iggreaterthan | |25 ‘ ) +
Cancel

Figure 6.7 Metadata File Filter Query Builder

Note: In Studio 8.3, all numerical queries occur in
microns. The word “null” can be substituted for a
numerical query to find results for gauges that have
failed to calculate.

I

6. Select desired output and create results. The user may now either go to the
automated report generator by selecting Action—>Create Report (see Section 7)
to create a formatted pdf report, or create and save images of the results using the
Action=>Generate Output functionality (see Section 6.2.5). Settings for the latter
are found under Output Options (see Section 6.2.4).
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6.2.2 Using Batch Analysis to Create Relative Plots

In order to set one of the images in the selected folder as a reference image (Section
4.4), double-click on one file in the summary table and confirm that all analysis should
use its 3D data as reference. The program will then save all graphs and numeric data as
relative to this reference surface. All other steps remain the same.

6.2.3 Analysis Options

L

= Note: Phase operations listed below will not be
—" available if the file type is set to *.akx_disp.

Batch analysis options are described below:

Phase Amplitude Allows adjustment of the phase amplitude threshold on
Threshold either an absolute or relative basis (see Section 3.4). A
dialog appears with these options when checked.

Smooth Phase Applies a smoothing function once to phase images before
analysis (see Section 3.6)

Mask Phase Applies a previously-created mask to phase images
before analysis (see Section 3.2). A Load Mask window
appears when the box is checked.

Unwrapping Allows adjustment of the unwrapping parameters of each

Parameters phase image for more accurate analysis. See Section 4.6.

Physical Assigns a specific physical size to each data file (see

Dimensions Section 2.3.5).

Compensate (per Enables a compensation for the non-planar surface of the

phase) grating. Physical dimensions are required to perform this
calculation

Normalize Chords  Causes all chord plots to be displayed with the endpoints
set to zero after analysis (see Section 5.3.1).

Applies a smoothing function to the surface data. See
Optical Techniques and Analyses 101 for an
explanation of this smoothing function.

Smooth
Displacement

Applies a custom smoothing function to the surface data.

Custom  Smooth See Optical Techniques and Analyses 101.

Displacement

Mask Applies a previously-created mask to displacement files
before analysis (see Section 3.2). A Load Mask window

Displacement appears when the box is checked.

Selects the reference plane rotation option to be used
during analysis (see Section 4.3). Can be turned off to use
the grating tilt as reference.

Plane Rotation
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Fit Displacement

Z Units

Gauges

6.2.4 Output Options

Opens a dialog where a polynomial fit can be calculated
based on the data set. See Figure 5.2. Alternatively, if
physical dimensions are assigned to the phase image, a
spherical fit can be calculated.

Selects English or metric units for out-of-plane
displacement results.

Selects which gauges (numerical values quantifying
flatness) are displayed at the bottom of the graphical
display windows. A gauge on the list may be highlighted
by clicking on it once. Checking a box means that gauge
will be displayed. The up and down arrows move the
highlighted gauge up and down the list, changing the order
in which gauges are displayed. Gauges are defined in the
Optical Techniques and Analyses 101 manual. The
ROC, DTA, Bow, and Twist gauges all require physical
dimensions to be applied to the phase image. Step height
definition files (*.akx_StepDef) can also be loaded and
calculated alongside normal gauges, as can custom
chordsets (*.akx_chordset).

— . .
—_ Note: Many of the gauges on the list are abbreviated.
—4 Hovering the mouse cursor over an abbreviated gauge

will bring up a tooltip containing its full name.

These options affect the results of the Action>Generate Output command (See

Section 6.2.5).
.akx_disp

Graphs & Data

Configuration
File

Legend

Saves *.akx_disp files to disk during analysis. These files are
produced in memory during analysis anyways, so this saves
time and an extra step if the user knows that they want them
anyways. When displacement files are the input,
* mod.akx_disp files are saved to denote the modified
displacement files.

Selects which graph/data/image formats (see Sections 5.1
through 5.4) are saved during Generate Output.

Allows the user to load a non-default display format for saved
graphs. The 3D configuration file has an extension of
*.akx_3Dconfig and is used for 3D plots (3D and Contour).
See Section 5.1. The 2D configuration file has an extension
of *.akx_2Dconfig file and is used for 2D Chord plots. See
Section 5.3.

Selects if a legend is displayed on each graph.
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Common Z-Scale When checked, causes all 3D or 2D plots generated by batch
analysis to use the same vertical scale. Default min and max
values are determined by the extremes in the combined data
sets, but may be edited using the text box. When unchecked,
each image is plotted on a scale set by its own data set.

Common Z The Auto update switch chooses whether to change the

Settings... Common Z-Scale after each analysis. The Chords use overall
Min Max switch puts the same Z-Scale into the chord plots as
the 3D’s. If the user has analyzed something but changed the
default Z-Scale value based upon the current file list, the
Update button will restore the default Z-Scale.

| Common Z Settings... v| Image Filer

Auto update

Chords use overall Min Max

Update

Figure 6.8 Common Z Settings

Output Files This section is only active on chord plot tabs. Chord tabs allow
the user to select whether images, data, or both are output.

Header The header for each image file can be created using tags from
the metadata stored in each input phase or displacement file.
Available tags can be found in the properties of a phase or
displacement image. Tags will reference the original file
metadata such that the entry is a variable changing on input
file. The default <SourceDataFilenameOnlyNoExt> tag puts
the file name minus its extension into the header. The user
can also enter any normal text as a constant header.

Footer Allows the user to choose the footer from the available
gauges chosen during analysis. Each gauge is input using
brackets and the name as spelled in the Analysis Options
Gauges section. For example, <Coplanarity> will add the
Coplanarity gauge to the bottom of the graph. “\t” inserts a tab
character and “\n” inserts a return character to start a new
line.

Graph Image Size Displays the image size to be output (will vary if config file is
loaded with different image size).

After output is generated, image and data files are saved to the folder in which the
original phase or displacement file is located.

L

— Note: PNG files are the only option for output graphs
~ | as of Studio 8.0.

|
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Options for the Surface Data, Phase Image, and 2D Disp Image can be selected by
right-clicking on the respective data type. These options are explained below.

|| Lett Hight Edges | LSIL gL Lugss . B =
Surfa Surface Data Surface Data

m ._L.i-. dat " P d Ph 0 Pizn Imana -

2D Di bt 20D rocesE e Commeon Z Scale...

C-nmmu: Sa:elmage File . Com Save Image File

Figure 6.9 Surface Data } i . .
Options Figure 6.10 Phase Image Options Figure 6.11 2D Disp Image

Options

Surface data files can be exported as either *.dat, or *.txt, for importing into other
numerical analysis programs. Phase Image files can be saved to disk or not in either the
processed form (phase smooth is the only option that would change the phase image
look) or raw form. Lastly, 2D Disp Images can be saved to disk or not with either a
common Z-scale across all pictures or individual Z-scales on each picture.

6.2.5 Output Tab

After analyzing the data, the user may save images and directly view their results by
selecting Action>Generate Output. This brings up an Output tab in which all plots
selected under Output Options are visible. The user can use the arrows and tabs here to
switch between files and graph types. If the results are locked using Action->Lock
Results, then the images will remain visible even if the underlying *.akx_disp files are
altered or overwritten.

If the user has opened multiple batch processing windows, then it is possible to sync
the visible image between them, allowing for side-by-side comparison of different analysis
options. This is done using the context menu shown in Figure 6.12. The sync option is
not available in a given batch processing tab unless its results are locked. When selected,
the result plot is changed on all batch processing windows currently open when it is
changed on one. This allows for quick comparison of results between different batch
processing windows.

&

Note: All batch processing results windows must be
locked in order for the Sync option to be available.
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a) Batch Processing (LOCKED)
Source  Edit  Action
Analyze Mask Rotate Crop

LSF

ZU mil

Gauges
Surface  Chord

[E=N BoR ==

Edit XY Orientation Convert Feature Detection

Results Output
3D Diagonals

Open 'Sample.akx_phase'

Coplanarity

HD Coplanarity
Bow

Twist

DTA

FFS Wampage
FFS Wampage DB
JFFS Wampage

Signed Wampage DB
Center Deflection
Max

Min

SS

3S Warpage
SOFC

ROC

Step Height

TLC

TRC

BLC

BRC

Center Point
Comer Gap

O

£+ Open Containing Folder

s Sync input ile index Coplanarity = 23.44 mils

Input Filename | Sample 4 ¥ 1/

3D Greph  Diagonals

3D Graph i <SourceDataFilenameOnlyNoExt >
Color Contour
Diagonals
Horizontal Centerine
op Bottom Edges
cal Centerline

N

1472 - <Coplanarity>

do
~
“

2D Disp Image
Surface Image

OO0O00000ROR

Z Setting = Image Filename Suffic 3D

Phase i Source: C:\l

| Files: 1

Figure 6.12 Output Tab

6.3 Batch Masking

The Batch Mask feature allows the user to automate mask-burning for multiple image
files contained in a specified folder (Figure 6.13).

.
.
7

—

7z

Figure 6.13 Batch Burn
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6.3.1 Using Batch Masking

This function uses a mask file, as described in Section 3.2. The mask file must be
created and saved prior to the batch masking operation. The batch masking screen is
shown in

Figure 6.14.

Source  Edit  Action
Analyze Mask  Rotate Crop Edit XY Crientation Convert Feature Detection

Mask File

|C:"- El -
|

Layout Behavior
(® Scale layout to input file

() Preserve layout designed for 603 x 650

Destination Options
() Overwrite Files
(®) Create New Files
Maming Options

Destination

‘ Same As Source

] Rename files as * (Masked) akx_phase

[] Save In "Masked" sub-Folder

Figure 6.14 Batch Masking Screen
The key steps in using batch masking are:

1. Select a folder containing data files to be masked (Folder->Select... menu item)
2. Select a mask (see Section 3.2 to create and save masks) to be applied.
3. Select the Layout Behavior
4. Select destination options (Section 6.3.4)
5. Create and save results (Action->Mask menu item)
6.3.2 Source, Edit, and Action Menus
Source > Select... Identifies the folder of *.akx_phase or *.akx_disp files on
which the mask will be applied.
Source - Recent Shows the 4 most recent folders that were used.
Edit = File Type Switches between masking phase images (*.akx_phase)

and displacement data (*.akx_disp). When masking
*.akx_disp files, new options become available (see
Section 6.3.6).

Edit = Include Applies the batch processing function to subfolders
Subfolders within the selected folder in addition to the original folder.
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Edit 2 Refresh Allows the user to update the file count since the folder
Source Folder (F5) was originally selected.
Action = Mask Performs the mask operation

6.3.3 Loading a Mask File

Mask to Apply Click on _-| button on the right to browse for a mask file.
6.3.4 Layout Behavior

Choose whether to scale the input mask file if any difference in dimension exists or
to preserve the layout. If preserve is chosen and the array dimensions do not match, the
mask array will be anchored to the top left of each image and any mask regions which lie
outside the image dimensions will be truncated.

6.3.5 Destination and New Naming Options

Overwrite Files Causes masked files to overwrite original data files.

Create New Files Saves masked images to a new destination and/or with a
new name. The original data files are unchanged.

Destination Selects the folder to which the masked images will be

saved. Click on the | button to the right to browse for
the destination folder.

Rename files as Appends the string “(Masked)” to the end of the original

*(Masked).akx_phase filename for the masked file.

(disp)

Save In “Masked” A single new folder named “Masked” will be created in the

sub-Folder destination folder and all masked files will be saved in this
subfolder.

6.3.6 Masking Displacement Files

When masking *.akx_disp files in Batch Mask, several new options appear in the
Batch Processing Window, as shown in Figure 6.15. These options are Z-Range
Masking, Plane Rotation, and a Results Table.

Displacement files can be masked with the standard masks described earlier, Z-
Range Masks, or both. Z-Range Mask functionality is described in Section 2.4.8, and
works in essentially the same modal fashion with the same options in batch mode as in
one-off mode. In Absolute Mode, the user may set a range and mask logic to mask the
source files, or load in a *.akx_zRangeMask file containing these settings. To enter
Region mode, the user must load a *.akx_zRangeMask file containing at least one region.
They may then adjust metric, logic, and offset as they would in one-off mode before
masking.

Plane Rotation gives the user an option to adjust the rotation of masked data. The
rotation options are those described in Section 4.3. If this option is checked, then after
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masking the rotation plane of the data will be changed to the selected one. This is useful
for masking out noisy data that might have adversely affected initial rotation.

- Batch Processing EI@

Source  Edit  Action

Analyze Mask Rotate Crop  Edit XY Orientation Corvert Feature Detection

[ Layout Mask Z-Range Mask
Mode
Mask File
‘ ® Absolute
Mask Piels | Outside Range
Range Max (200 2
fmicrons) i, oo =

[] Plane Rotation  LSF

Destination Options

() Overwrite Files
® Create New Files
Naming Options

Destination

| Same As Source

Rename files as * (Masked) alo_disp

Save In "Masked" sub-Folder

Source Files {10} Min Maze Destination File Min Maze
Batch Samples_0001_00013s(25C) aloc_disp -16.2 25.7 || BatchSamples_0001_00013s(25C) {Masked).alox_disp -10.0 199
BatchSamples_0001_00067s(28C) aloc_disp -17.4 232 BatchSamples_0001_00067s(28C) (Masked).aloc_disp -10.0 19.8
Batch Samples_0001_00105s(38C) aloc_disp 174 18.8 || BatchSamples_0001_00105s(38C) (Masked).aloc_disp -10.0 188
BatchSamples_0001_00195s(32C). akx_disp -19.7 21.4 | BatchSamples_0001_00195s(32C) (Masked).akx_disp -10.0 192
BatchSamples_0001_00304s(27C) akoc_disp 156 26.4 | BatchSamples_0001_00304s(27C) (Masked) akoc_disp -10.0 200
BatchSamples_0002_00013s(25C).akes_disp -127 22.0 | BatchSamples_0002_00013=(25C) (Masked).ales_disp -10.0 200
BatchSamples_0002_00067s(28C) akos_disp 128 20.3 | BatchSamples_0002_00067s(28C) (Masked).ako_disp -10.0 200
Batch Samples_0002_00105s(38C).alec_disp -13.0 18.3 | BatchSamples_0002_00105s(38C) (Masked).aloc_disp -10.0 183
BatchSamples_0002_00195s(32C) ako_disp -15.3 19.3 | BatchSamples_0002_00195s(32C) (Masked).ake_disp 99 133
BatchSamples_0002_00304s(27C).akoe_disp -144 226 | BatchSamples_0002_00304=(27C) (Masied).alor_disp -10.0 200

Mz -127 264 k] 200
Miry -19.7 183 -100 183

Disp | Source: C:Y Files: 10

Figure 6.15 Batch Mask Results for Displacement Files

Finally, when File Type is set to *.akx_disp, the Results section appears at the bottom
of the Batch Mask window. This populates itself with a list of the source filenames when
files are loaded. The rest of the table does not populate until masking has been
performed. Once it has, the table fills with the minima and maxima of each original and
destination file, plus overall minima and maxima. This allows the user to see whether
anomalous maxima or minima were actually filtered out, as is often the intent of masking
operations, and to assess the quality of the masking operation.
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6.4 Batch Rotation
6.4.1 Using Batch Rotation

Phase image rotation is described in Section 3.7 and also applies to displacement
files. This batch function rotates all the images in the selected folder according to the
options set in the batch rotation tab window. The batch rotation screen is shown in Figure

6.16.

ol Batch Processing

Source  Edit  Action

Angle ® Clockwise
1.0 () CourterClockwise
Destination Options

() Overwrite Files
(® Create New Files
Naming Options

Destination

Analyze Mask Fotate Crop  Edit XY Orientation Convert Festure Detection

| Same As Source

[[] Rename files as * {Rotated).ake_phase

[] Save In "Rotated" sub-Falder

Phase | Source: Mone | Files: 0

(=)o /==

Figure 6.16 Batch Rotation Screen

The key steps in using batch rotation are:

1. Select a folder containing images to be rotated (Source->Select... menu item)

. Select rotation options (see Section 6.4.2)

2
3. Select destination options (see Section 6.4.3)
4

. Create and save results (Action->Rotate menu item)
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The Source, Edit, and Action menus for Rotation are all virtually identical to the Mask
operation.

6.4.2 Rotation Options
Angle Enter number of degrees to rotate the image clockwise or
counterclockwise.
6.4.3 Destination and New Naming Options

Overwrite Files Causes rotated data to overwrite original data files.

Create New Files Saves rotated data to a new destination and/or with a new
name. The original data files are unchanged.

Destination Selects the folder to which the rotated data will be saved.

Click on the J button to the right to browse for the
destination folder.

Rename files as Appends the string “(Rotated)” to the end of the original

*(Rotated).akx_phase filename for the rotated file.

(disp)

Save In “Rotated” A single new folder named “Rotated” will be created in the

sub-Folder destination folder and all rotated files will be saved in this
subfolder.

6.5 Batch Cropping

Batch cropping allows the user to extract multiple regions of interest from multiple
phase or displacement images. For example, a measurement test which produces
measurement data at three temperature points, with each phase or displacement image
containing four regions of interest (3 x 4 = 12 measurements), can be easily analyzed in
a two-step procedure: batch cropping, followed by batch analysis (Figure 6.17).

iﬂﬂ \:\C‘ \:\n.
SSS (SSS SSSS
Batch * Crop
R I, O
€ N N N € N
Batch ¢ Process

Figure 6.17 Batch Cropping and Analysis
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6.5.1 Using Batch Cropping

Selects which gauges (numerical values quantifying flatness) are displayed at the bottom
of the graphical display windows. A gauge on the list may be highlighted by clicking on it
once. Checking a box means that gauge will be displayed. The up and down arrows move
the highlighted gauge up and down the list, changing the order in which gauges are
displayed. Gauges are defined in the Optical Techniques and Analyses 101 manual.
The ROC, DTA, Bow, and Twist gauges all require physical dimensions to be applied to
the phase image. Step height definition files (*.akx_StepDef) can also be loaded and
calculated alongside normal gauges.

6.6 Batch Edit XY Orientation

For purposes of orienting and registering surface data in Interface Analysis, a new
tab has been added to the Batch Processing window. This tab allows multiple data files
to be tagged with Pin 1 location and Measured Side information.

Source  Edit  Action
Analyze Mask PRotate Crop  Edit XY Orentation  Convert

Fin 1 Location Measured Side

Unspecified e Unspecified e

Figure 6.18 Edit XY Orientation Screen
The key steps in using Edit XY Orientation are:
1. Select a folder containing data to be edited Source->Select... menu item)
2. Select a Pin 1 Location and Measured Side to be applied.
3. Perform the Batch Edit operation (Action=>Edit XY Orientation menu item)
6.7 Batch Convert

Converts *.akx_disp files containing phase data back to the *.akx_phase format. The
key steps in using batch converting are:

1. Select a folder containing displacement files to be converted (Source->Select...
menu item)

2. Perform the Batch Convert operation (Action->Convert menu item)
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6.8 Batch Feature Detection
6.8.1 Using Batch Feature Detection

Batch Feature Detection allows the user to apply the Feature Detection function
described in Section 2.4.7 to a specified folder of displacement files. This batch function
detects features according to options loaded in a settings file and edited in the batch
feature detection tab window, then applies a customized mask based on the detected
features. The batch Feature Detection screen is shown in Figure 6.19.

Source  Edit  Action
Pnalyze Mask FRotate Crop  Edit XY Orentation Convert Festure Detection

Settings

Detection Parameters Mask
Feature Source @ Festures
@ Region
Noneat
Shape match (%) O Feature (26 x 65) () Nonfeatures
Replace Region Data
Height match (%)
[ Fil Holes [ Scale Regions
Destination Options
O Overwrite Files

(®) Create New Files
Naming Options
Destination
|Same As Source | l:l

[ Rename files as “(Feat Det).akox_disp
[] Save in "FeatDet" subfolder

Source Files Min Max: Features Destination File Min

ka| Source: None | Files: 0

Figure 6.19 Batch Feature Detection Screen
The key steps in using Feature Detection are:

1. Select a folder containing *.akx_disp images to be masked (Source->Select...
menu item)

2. Load in a Feature Detection Settings file and edit the settings if desired (see
Section 6.8.2).
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3. Select destination options (see Section 6.8.3)
4. Create and save results (Action—>Detect Features menu item)
5. View results in Results table (see Section 6.8.4).

The Source, Edit, and Action menus for Feature Detection are all virtually identical to
the Mask operation.

6.8.2 Feature Detection Settings

These Settings are all identical to those in the Feature Detection Parameter Window,
which is described in Section 2.4.7. They are set by loading the Feature Detection
Settings file, but can be edited by the user before batch detection.

The user cannot, however, edit the detection ROI as is possible in one-off Feature
Detection. The region or detected feature present in the loaded settings file is used.

6.8.3 Destination and New Naming Options

Overwrite Files Resulting data overwrites original data files.

Create New Files Saves resulting data to a new destination and/or with a new
name. The original data files are unchanged.

Destination Selects the output folder where resulting data is saved.

Click on the J button to the right to browse for the
destination folder.

Rename files as Appends the string “(FeatDet)” to the end of the original
*(FeatDet).akx_disp filename for the resulting data.

Save In “FeatDet” A single new folder named “FeatDet” will be created in the
sub-Folder destination folder and all resulting data will be saved in this

subfolder. This is only available when the destination folder
is the same as the source folder.

6.8.4 Results Table

The last section of the Batch Feature Detection Tab is the results table. This table is
similar in functionality to the results table for Batch Mask, which is described in Section
6.3.6. This table populates itself with a list of the source filenames when files are loaded,
but does not fully populate until Feature Detection has been performed. Once populated,
the table contains not only data about minima and maxima in the source and destination
files, but also the number of features that were detected in each source file. All of this lets
the user assess the quality of the feature detection operation.
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7 Batch Reporting

As of Studio 8.0, Surface Analysis now incorporates the ability to batch create reports
based on the metadata from each displacement file being analyzed. The Create Report
window has three subsections: Groups, Roi Selector, and Layout Settings.

il

il

&

&

Note: Automated report generation does not currently
work for room temperature measurements, because
temperature and profile metadata are used to organize
the data. The Add file to profile... function described
in Section 7.1.3 can be used to apply profile metadata
to an orphaned measurement (typically a room
temperature acquisition taken manually at the end of a
profile).

7.1 Grouping by Metadata fields

Grouping can either happen before or after analysis. For purposes of analysis,
multiple folders can be selected. See Section 6.2.1 for details on how to add folders. The
context menus are identical in the Group interface Folder List section as they are to the
folder selection interface in Batch Analysis.

Note: If the Create Report function was opened from
Batch Processing, the Folder List context menus will
initially be the same as if there was no data, despite
the analyzed data being present. New folders can still
be added and removed, but the analyzed data cannot
be removed or made inactive from the folder list.

a:l Create Report

File

Fles
Fie Type: dkr_disp
Folder List

Groups | Roi Selector] Layout Settings

Fiename Fiter |

&

| [Syrtax Examples < || Examle Fiename Fiter Finds Files That...

BGA contain ‘BGA

Active  Subfolders

Files

Folder Name

Add...
Add Recent »

Profile board

"Subroom BGA"

Profile1 OR Profile2

NOT SearchArea

PT (00D1 OR D002)

"DD01 from” OR "0002 from”
feasibilty NOT msk

conts

Build Database

Grouping Parameters

[] Max Alowable d (s)

Metadata File Fiter

Group Restits

[ Max Alowable dTs ©) [0 =

[ Max Alowable dTa €) [0+

[ Max Number OF Profes
[ Max Number OF Roi Names
[ Max Number OF Roi Sizes

[ Max Number Of Roi Locations

contain ‘Profle’ and board (any order)
ase 'Subroom BGA'

contain Yeasibiity” but not sk’

[ Max Alowable dLoc X [ Group Common Acauistions
[ Max Alowable dLoc ¥
[ Max Alowable dSize With

[ Max Alowable dSize Height [0 =

Equipment

SM Version Acq Dates Roi Names Roilocatons  RoiSizes  Profiles

Profie Acgs  MaxdTs(C)  MaxdTa(C)  Maxdt(s)

Figure 7.1 Grouping Window
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7.1.1 Files

Once the appropriate folders have been added to the Folder List, files can be filtered
out by entering in search strings that the user desires. The “*” character can be added
before, after, or in the middle of a string to denote parts of the filename that aren’t
important to match. Other search query syntax examples can be found in the table below.

Example Filename Filter Finds Files That...

BGA contain 'BGA'

Profile board contain 'Profile’ and 'board' (any order)

Subroom BGA contain the exact phrase 'Subroom BGA'

Profilel OR Profile2 contain 'Profilel’ or 'Profile2'

NOT SearchArea do not contain 'SearchArea’

PT (0001 OR 0002) contain 'PT' with '0001' or '0002'

0001 from OR "0002 from" contain the exact phrases '0001 from' or '0002 from'
feasibility NOT msk contain 'feasibility' but not 'msk'’

(Board1 OR Board2) (200C OR 223C OR 252C) contain 'Boardl' or '‘Board2' with '200C', '223C' or '252C'
R0i0003 NOT ("Component Side" OR Demo) contain 'Roi0003' but not with 'Component Side' or 'Demo’
Tray 1 OR NOT Cropped contain 'Tray 1' or do not contain 'Cropped'

Profile (BGA OR ("Substrate Test")) contain 'Profile' with 'BGA' Or 'Substrate Test'

Once the appropriate files are loaded into the folder list, the files must be indexed by
clicking Build Database. After a database has been built, the files will be grouped together
by acquisition index. If the user wishes to break the files into different groups for reporting
purposes, one or more of the Grouping Parameters must be selected.

7.1.2 Grouping Parameters

1. Max Allowable dTs (C): Sets the max allowable difference for setpoint temperature.
This will allow setpoint temperatures that are off by a user specified amount to be
grouped together despite the difference. Common acquisition indices are
compared and the greatest differential is referenced for grouping.

2. Max Allowable dTa (C): Sets the max allowable difference for acquisition
temperature. This will allow acquisition temperatures that are off by a user
specified amount to be grouped together despite the difference. Common
acquisition indices are compared and the greatest differential is referenced for
grouping.

3. Max Allowable dt (s): Sets the max allowable difference in acquisition time. This
will allow acquisition times that are off by a user specified amount to be grouped
together despite the difference. Common acquisition indices are compared and the
greatest differential is referenced for grouping.

4. Time-Based Acquisition Matching: Only available if both ‘Max Allowable dt (s) and
‘Group Common Acquisitions’ are selected. This parameter ignores acquisition
index for grouping and instead groups based on time, referencing max allowable
dt (s). This option could be used if comparing two similar profiles where one profile
had an extra acquisition inserted within the profile.
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10.

11.

12.

13.

7.1.3

Max Number Of Profiles: Sets the max number of profiles in a group.

Max Number Of Roi Names: Sets the max number of Roi names in a group.

Max Number Of Roi Sizes: Sets the max number of ROI sizes in a group.

Max Number Of Roi Locations: Sets the max number of ROI locations in a group.

Max Allowable dLoc X: Sets the max difference in X axis location of the region of
interest.

Max Allowable dLoc Y: Sets the max difference in Y axis location of the region of
interest.

Max Allowable dSize Width: Sets the max size difference along the X axis of the
region of interest.

Max Allowable dSize Height: Sets the max size difference along the Y axis of the
region of interest.

Group Common Acquisitions: If multiple profiles are being reported on and the
acquisition indexes aren’t all coincident, this option will filter out orphaned
acquisitions. In Figure 7.2, the profiles being reported on have varying numbers
of acquisitions and in Profile 2, the first acquisition has been removed. By checking
this option, only the acquisitions highlighted in yellow will be added to the report.

Acquisition Index
Profilel 1 2 3 4 5

Profile 2[00 2 3
Profile3 1 2 3
Figure 7.2 Group Common Acquisitions Example

—

Note: When in doubt about a grouping parameter’s
effect on the output groups, it can be quite useful to
simply trial and error the setting in question to see the
effect on the data.

Metadata File Filter

il

Files can be filtered out of the resulting groups by setting up filter/logic conditions in
the Metadata File Filter. File filter queries can be saved and loaded as *.akx_query files
in the Query Builder interface for future use.

Query Builder
File

N

Clear

AND ~| | { Surface Gauge Value ~ | |JFFS Wampage DB ~| |isgreaterthan ~| |25 ‘ ) +

Cancel

Figure 7.3 Metadata File Filter Query Builder
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7.1.4 Group Results

Once the files are indexed, all groups are shown in the Group Results section (Figure
7.4). This section lists pertinent information about each group, such as number of files,
number of ROl names and locations, and number of temperature profiles. Individual
groups can be activated or deactivated in this section, making it trivial to choose which
ROls go in the final report.

&

Note: An asterisk next to the number of files indicates
that some files were excluded.

il

(Group Results

Active Group Files (2) Equipment SM Version Acq Dates Roi Names Roi Locations Roi Sizes Profiles Profile Acgs Max dTs {C) Max dTa {C) Max dt (s)

1 2 S/NOOgLCRE Zla9e0 02.093/16 ROI 533417 2 1 2 n/a n/a n/a
Edit metadata...

Copy files to folder...

Reassign file to new profile...

Figure 7.4 Group Results

The Edit Group Metadata window can be loaded from the context menu, or by double-
clicking on any group. It allows the user to change ROI names and other metadata to
better organize and label the report (Figure 7.4).

Edit Group Metadata X
aloc_disp (35) # | Profile I:dfx Slﬁ;g‘fm NE?nT.fal ngg”iﬁg Lot Id Operator Id Product Id Test Id Fartit ™
A4_DFP_3-4_00007s(24C) - Copy| 1 1 1 25 24 |asdt 20160202T163624  Profiie
44 DFP_3-4_00043s(38C)| 2 1 2 40 38 20160202T163624  Profiie
A4 DFP_3-4_00068s(48C)| 3 1 3 50 48 20160202T163624  Profiie
A4_DFP_3-4_DO081s(58C) | 4 1 4 60 58 20160202T163624  Profile
A4 DFP_3-4 00098s(B8C)| 5 1 5 70 ’F 5ot Nommial o Setpovt 20160202T163624  Profiie
£4_DFP_3-4_00113s(78C)| 6 1 6 80 R 20160202T163624  Profiie
44 DFP_3-4_00129s(88C)| 7 1 7 50 Closr 20160202T163624  Profiie
A4 DFP_3-4 001445(38C)| 8 1 8 100 - 20160202T163624  Profiie
44_DFP_3-4_00158s(108C)| 9§ 1 5 10 108 20160202T163624  Profile
44 DFP_3-4 00174s(118C)| 10 | 1 10| 120 118 20160202T163624  Profiie
44 DFP_3-4_00188s(128C) | 11 1 1 130 128 20160202T163624 Profile ¥
< >
Cancel
Figure 7.5 Edit Group Metadata
Edit Group '1' Metadata = *
alor_disp (24) Partition Full Path Cument Roi Name Roi Mame Converter MNew Roi Name ~
BGA_1_000025(24C) |ProfileAcq001/Tracked Pars/PT0003 | PTO003 — PT0003
BGA_1_002375(195C) ProfilAcqD02 Tracked Parts/PTO003 | PTO003 Copy RUEE PT0003
BGA_1_00290s(215C) [ProfileAcqD03/ Tracked Pats/PTO003 | PTODD3 Paste S PTO00Z
BGA_1_00363=(243C) ProfileAcqD04/ Tracked Parts/PT0003 | PTO003 =y v PTO003
BGA_1_004385(216C) [ProfileAcq 005/ Tracked Parts/PT0003 | PT0003 Metadata Tags » PT0003
BGA_1_004675(200C) Profile Acq006/ Tracked Parts/PT0003 | PTO0D3 Predefined Gonverters » <fn: Before 1st Underscore>
BGA_2_00002s(24C) ProfieAcq001/Tracked Parts/PT0004 | PTODO4 N «<fn: After Last Underscore>
BGA_2_00237s(195C) Profile Acq 002/ Tracked Parts/PT0004 | PTOOD4 <fp: Folder Name>
BGA_2_00290s(215C) ProfileAcq 003/ Tracked Parts/PT0004 | PT0004 <pfp: Node N>
BGA_2_D03635(243C) ProfileAcq004/ Tracked Parts/PT0004 | PTO0D4 FT0004
BGA_2_D04385(216C) Profile Acq 005/ Tracked Parts/PT0004 | PTODD4 PT0004 v
< >
Cancel

Figure 7.6 Edit Group Metadata - Roi Name Converter
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In the Edit Group Metadata window that pops up (Figure 7.5), multiple metadata
fields can be edited, including Temp Nominal, Lot Id, Operator Id, Product Id, and Test
Id. If a new value is entered into a field, it will be highlighted in yellow until the user clicks
the Update button. The Temp Nominal context menu will allow the user to set its value to
the Setpoint.

The user can also choose what each file’s New Roi Name will be via the Roi Name
Converter column. The resulting ROI name, including the current values of entered tags,
will be shown in the New ROI Name column. By default, the <fn: Before 1st
Underscore> function provided will create a New Roi Name by parsing the input filename
and using the string before the first underscore. Usually this corresponds to the Test ID
based on how Surface Measurement creates filenames by default. In cases where this
does not make sense, however, the user can enter a static string, or any of the metadata
fields surrounded by Less Than or Greater Than signs. For instance, <Lotld> would enter
the Lot Id metadata information. A list of available Metadata tags is accessible by right-
clicking on the Converter field. A few other predefined functions are also available via this
same context menu (Figure 7.6). The user can also filter ROl names using custom regex
converters, which are described in Section 7.1.5.

For any field except Temp Nominal, strings can be copied and pasted into new rows.
Also, multiple rows can be selected at once by shift-clicking, allowing values to be pasted
onto multiple rows at once.

L

Note: Any changes to file metadata will not be made
until the Update button is pressed. To change ROI
names based on a metadata update, it is necessary to
update the metadata first and then reopen the Edit
Group Metadata window.

il

If a file with no profile information is found from the input data, it is possible to add
this orphaned file (a typical example would be data taken manually after a profile is
complete) to an existing profile. In the Group Results section of Create Report, right-
clicking on a group will bring up a context menu (Figure 7.7). If multiple files are orphaned,
when Add file to profile... is selected, the user will have to choose which file to add to a
profile (Figure 7.8). Likewise, once the file to be added is selected, the profile to which
they will be added must be chosen (Figure 7.9). With the profile selected, the user can
choose the Setpoint, Temp Reading, Profile Runtime, and Acquisition Index to add
to the metadata for that file. In addition, the modified file can be renamed. Once the profile
data for a file has been changed, it will automatically be moved to the correct group
(Figure 7.10).

For files that are already assigned to a profile, these can be reassigned to other
profiles if somehow their metadata is incorrect. The process for doing this is identical to
adding a file to a profile.
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Group Results

Active Group Files (8) Equipment SM Version Acq Dates Roi Names Roi Locations Roi Sizes Profiles Profile Acgs MaxdTs (C)  MaxdTa (C) Max dt (s |
M | 6 S/NO194 Therblore AXP|8.1.10481 [03r2317 @ @ 611x134 |1 3 n/a n/a n/a
M 2 2 S/N0134 Therl - Loninari7 @ @ 611x14  |n/a wa n/a a n/a
Edit metadata...

Copy files to folder...

Figure 7.7 Group Results - Context Menu for Orphaned Files

Add File To Profile = X

Select the file:

1_59999(24C) alox_disp

\in progress’\,
ices\in progress’.

Figure 7.8 Add File to Profile - File Selector
=1 X

Min Index Max Index Missing Indices

Add File To Profile

Profile  Roi Name Files  First File

6  PCB2_reflow2_000025(27C) (Masked) alos_disp
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Figure 7.10 Group Results after Adding Files to Profile

7.1.5 Custom Converters

Figure 7.11 displays several custom regex converters, which allow easy extraction
of specific character series from a filename and thereby easy ROI naming in the Edit
Metadata window. The specific rules followed by custom converters are shown below.

_

shoc_disp (5) Il Path Current: Roi Name: Roi Name Converter New Roi Name
ThinPCE_0001_00002s(24C)_0001 j01/0001/0001 0001 aregexfn:™ {0.4kregexs first 4 chars of filename Thin
ThinPCE_0001_000025(24C)_0002 )U1/0001/0002 0002 <regexn: {0.5lsregecs |ast 5 chars of filename _oo02
ThinPCB_0001_000025(24C)_0003 J01/0001/0003 0003 <regex G 1:PFP: {7} {6)regex> & char subsring of PFP, start a7 | Acq001
ThinPCB_0001_001575(148C)_0001 J02/0001/0001 0001 <regex RO {02} regecs last 2 chars of Roi Name 01
ThinPCE_0001_00157s(148C)_0002 j02/0001/0002 0002 <rogex G1.FP- {9} {4}jregax>4 char sub of flepath, start at 9| Greg

C:\Users\Greg'\Desktop'\Akrometrix\>

[ »

Figure 7.11 Custom Regex Converters
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1. Custom converters begin with <regex: and end with :regex>

2. Custom converters can optionally include a ‘Group Index’ specifier, which may be
required to get the desired regex match

a. If no Group Index is specified, group index is 0 (default).
b. Group Index is the first item included inside the regex syntax, and ends with a
colon, specified as G#: or G##:

3. Custom converters can operate on 1 of 4 sources (specifiers are NOT case-
sensitive): a colon is required after the source

a. Filename, specified as FN

b. Filepath (entire path, not including the filename), specified as FP
c. Partition Full Path, specified as PFP

d. Roi Name, specified as ROI

4. The regex expression is supplied AFTER the source colon.
5. Examples:

a. <regex:fn:~.{0,4}:regex> the first 4 characters of the filename

b. <regex:fn:.{0,5}$:regex> the last 5 characters of the filename

c. <regex:G1l:PFP:.{7}(.{6}):regex> a 6 character long substring of the partition
full path, starting at index 7

d. <regex:ROI:.{0,2}$:regex> the last two characters of the Roi Name

e. <regex:G1l:FP:.{9}(.{4}):regex> a 4 character long substring of the filepath,
starting at index 9

&

p— Note: Strings start at index 0. This is important for any
—= search involving a numbered index.

7.2 Selecting ROI's

In the Roi Selector tab (Figure 7.12), the user can view 3D graphs of all active files,
sorted into tabs by group. This tab allows the user can see a thumbnail view of a 3D graph
for each active file, sorted into tabs by group. The user can then quickly find the minima
and maxima, both overall and in each group, and discard any bad data before generating
a report. From this tab, the user can also open any individual *akx_disp file in the report,
or the folder that contains said file. This is done using right-click context menus on each
thumbnail image. In addition, files can be included or removed en masse with Include
All, Include None, Invert Included, and Include via metadata query... commands.

The user can activate or deactivate individual ROls in each group by clicking on them.
In addition, entire rows or columns can be removed from the report entirely. These
operations are the only things in this tab that affect the resulting report — the other options
at the bottom of this window affect only the data displayed in the Roi Selector tab. These
options include changing the size of the thumbnail images and editing the units of the Z-
scale. Any changes made by the user will be applied when the Update button is pressed.
The values of the minima and maxima for each group are displayed automatically, with
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the figures that have those values being highlighted in shades of purple — dark for Min,
and light for Max.

Using the common Z-Scale menu, the user can decide whether Z-scales for the 3D
graphs are shared within individual groups, within all files, or not at all. When Across
Groups is selected as the common Z-Scale, the minimum and maximum overall Z-values
will be displayed, as well as the range, and clicking on the Min and Max buttons will
change the selected group to the one with the lowest or highest Z-value, respectively.

File
Groups Roi Selector | Layout Settings|
Group 1 I

T T2 T3 T4 5 T6

Ts=217C Ts=245C Ts=217C Ts=200C
= = Ta=216C Ta=200C

t=438s

Ts=200C
Ta=199C

PT0003

2| '5(199
Open Containing Folder

PT0004

Include All

Include None
Invert Included

Include via metadata query...

| Update L Min:177 S} Z Range: 3.79 Active ftems: 24/24

image Sze |96 v|  CommonZScdle [PerGowp  v|  ZUnt mi v

Figure 7.12 Roi Selector
7.3 Choosing Report Layout Settings

Once appropriate ROIs for the report have been organized into groups with any bad
data discarded, the user can use the Layout Settings tab to determine the formatting and
displayed data of the final report. The user also has the option to deactivate groups
without changing other settings, making it simple to create both overall reports and
individual reports for different groups. The user has a variety of options in this tab,
separated into several subsections.

7.3.1 Group and Plot Selection

The uppermost section of the Layout Settings tab offers several useful options. The
user can choose which groups to include in a report using the Active checkboxes. They
can see a variety of information about the group, including Z-Range, group number,
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number of ROl names, and the name of the first file in the group. Mousing over some of
these cells will show a tooltip with further information, such as a list of all the ROl names,
or currently selected Gauge Plots.

Further to the right, this section also contains a number of editable labels that can
appear in the report. These can be used to create titles for individual images, series labels
in the legends of Gauge vs temperature plots, page titles and subtitles, and footers. Any
of these options can use metadata tags like <RoiName> and <PageGraphType>. The
labels will appear only on pages with data for the selected group, and the report will
automatically separate groups into different sections.

'"5 Create Report =] @ ]

File

Groups| Roi Selector Layout Settings ]

Active  Group Z-Range Group Order  Profie  Profile Order  Files (10)  Fist File Roi Names Gaugs Plots ~ Gauge vs Temp Series Name Image Tl
1 04710 0.92 1 1 1 5 test1_00D1_DD013s(24C) aloc_disp 0001 173 <RoiName> <Roilame
2 06310 1.19 2 1 1 5 test1_0002_0D00135(24C) alox_disp 0002 13 <RoiName> <Roilame

Report Order Page Break Page Formatting

30 Graph  Diagonals ] Prefile Size
8 Roi + [ Roi = »
N Graph Type s [ Graph Type st
Configuration File Temperature ] Temperature
[ Set . Orientation
[] Vertical Centerine S eain Portrait “
[] Left Right Edges 9 ™ .
[] 2D Disp Image it [od o Do
[] Phizse Image Footer 2 5 3 5 Predefined +
<Coplanarity> T Common Z Scale
By [ o] Fill Direction
< Coplanarity> ® Automatic Per Group ~ Down
Add Chordset <Max> n/a
<Min> . Max Separator Lines
) = = Vetical
Header Image \t (Tab) (O User-Defined 0.0
\n (New Line) XY Unit
Output [[] Chords Use Overall Min Max pixel v

[] Report

Gauge Table/Graph Displayed Temp
Gauge Preview -
Average TemperstureMNominal ~ ~

[] Video

[ Images

861x 551

Generate

Figure 7.13 Layout Settings Tab

The user can also click on the Gauge Plots cell for any group in this section. This will
open the Gauge Plot Selector window shown in Figure 7.14. From this window, the user
can choose which of the calculated gauges to display in the report, and which statistical
values should be displayed for those gauges. These values can be calculated for each
ROI, for each temperature point, or globally throughout a group. Selecting an option by
clicking on it and moving it up and down in the list with the arrows will reorder the gauge
plots in the report.
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Note: If a desired gauge is not in this list, then it was
not calculated during analysis. In Batch Processing,
the user must select whichever gauges are desired in
the final report, so that they are present in the
*.akx_disp files that are used to build the report.

I

Roi Mames Gauge Plots Gauge vs Temp Series Name Image Ti
akoc_disp [P} /m:HUiName> <RoiNam
Gauge Plot Selectorr b4
+ Fer Foi | Per Temp Global +
Maze
0 v 3 O | O 0 |g
Avg + 35ig [l 1 ]
Ma | O O
Min O O O
Range O | O
SdDev| [ O [
Secondary Title |
Cancel

Figure 7.14 Gauge Plot Selector
7.3.2 Output Options

This section allows the user to decide what graphs will be shown in the report, how
they are configured, and what footer information the graphs have. Editing the
configuration of graphs requires loading a previously created *.akx_2dConfig or
*.akx_3dConfig file (depending on graph type) for each graph that is changed from its
default layout. To add footers to the graph, the user can choose from a list of tags that
changes with the selected graph. The user may also use tab (/t) and new line (/n) tags to
format the footers in the final report. Finally, the Normalize checkbox causes all 2D chord
plots to be displayed with the endpoints referenced to zero.

L 4
Note: In addition to the default output plots, custom

chord plots can be loaded in using *.akx_chordset files
and plotted like any other 2D graph.

il

7.3.3 Report Order

This option determines what data ordering takes precedence within a group. The
default is Profile > ROI > Graph Type > Temperature.

7.3.4 Page Break

This determines after what data page breaks occur. The default is Profile, ROI, and
Graph Type, but not temperature.
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7.3.5 Z-Scaling

This section allows the user to choose the Z-scale for displacement graphs. They can
choose the units of Z, and either enter a custom Z-scale or choose an automatic Z-scale.
The automatic options are None, Per Group, and Across Groups. The ‘Chords Use
Overall Min Max’ option determines whether 2D chord plots use individual minima and
maxima in their z-scales, or the overall minima and maxima across all groups.

7.3.6 Page Template

This option determines whether data layout is portrait (6 graphs/page) or landscape
(24 graphs/page).

7.3.7 Page Fill

This option lets the user decide whether initial population of figures and graphs is top-
bottom and then left-right, or vice versa.

7.3.8 XY Unit

This lets the user determine the XY units on each graph if a lateral resolution is
specified in each file. This would allow the graph XY axes to be shown in physical units
instead of pixels.

7.3.9 Gauge Table/Graph Displayed Temp

This allows the user to choose from three temperatures for gauge tables and graphing
gauges: Average reading temperature at that time, nominal temperature chosen in Profile
Generator, or the Setpoint temperature of the profile.

7.3.10 Header Image File
This allows the user to choose a header image to go at the top of each page.
7.3.11 Output

Once all settings have been selected, the user can use the Output section to
determine what results will be generated. There are three possible types of output —
Report, Video, and Images — and any or all of them may be generated at one time by
selecting their check boxes and pressing Generate.

Generating any output requires appropriate save data, which the user is automatically
prompted to enter if none has yet been added. Report and Video need both filename and
destination folder, while Images only needs a destination folder. The first time that a
filename or destination folder is entered, it will be shared to the other outputs. The ...
buttons after each option can be used to independently edit destinations and filenames
for each output.

1. Report — This is a pdf report containing all selected images and gauges. It is the
most common option, and the one to which many of the customization options in
the Layout Settings tab are dedicated. Figure 7.15 shows an example. Checking
Open Report After Generating allows the user to immediately see the results
when the report has been created.

2. Gauge Preview — This button generates a pdf containing gauge results based on
current settings but no images. Since no images are saved, this allows the user to
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more quickly see how the groups are organized and what the overall numerical
results look like. This button works regardless of whether Report has been selected
as an active output.

3. Video - This is a video file which strings together all gauge plots and all selected
images. The user can choose image size and the delay between images in the
video.

4. Images - This option saves all images selected in Output Options to a user
selected folder. The user may select the image size.
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Figure 7.15 Example Report with 6 images per page
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8 Troubleshooting

As with any measurement system software, the Surface Analysis program has its
limitations. These limitations exist mainly because the analysis software is sensitive to
patterns it was not designed to interpret, which is typical of any software using pattern
recognition.

8.1 Failure to Correctly Interpret the Phase Image

After acquiring a phase image, a procedure called “unwrapping” is applied to the
phase data (See Akrometrix Optical Technigues and Analyses 101). The unwrapping
process removes the 2w discontinuity by examining the nearest neighbors’ pixel phase
values starting at the center pixel. With the sequentially dependent nature of the
unwrapping process, the height at all the pixels in an entire image can be related to one
origin pixel. Conversion from the unwrapped phase image to vertical displacement is
simply multiplication of each pixel phase value by the calibration factor.

Problems arise when an error occurs at one point in the unwrapping process, either
by incorrectly identifying a phase discontinuity or missing a discontinuity that has
occurred. Once a problem occurs, all pixels downstream of the error point are offset from
their correct value by the same increment of one full fringe cycle.

8.1.1 Symptoms

Unwrapping errors are propagated downstream of the error point. These errors
appear in the 3D surface plots as ridges, troughs, or plateaus in the displacement surface.
Two examples of such cases are shown in Figure 8.1, where the error originates from a
step condition on the sample surface.

8.1.2 Cause

Unwrapping errors can occur at steps (i.e. vertical discontinuities in the sample
surface). A step may be defined as a region where fringes are so closely spaced that they
cannot be resolved by the video camera due to a rapid height change on the sample
surface. Typically, fringes less than 5 pixels in width cannot be resolved. The Surface
Analysis program is unable to determine the height at a step larger than approximately
half a fringe height since the relative order of the fringes on the two surfaces cannot be
determined. Unwrapping errors can also occur in regions where there is poor fringe
information or at the transition from such regions to regions of good phase information;
including holes, shadows, pieces of tape, etc.

8.1.3 Solutions

1. The simplest solution is to exclude error-causing features from the ROI. Adjust the
position and size of the ROI to exclude these features.

2. Use the filtering option to help eliminate some unwrapping errors. Filtering
smoothes the phase image before unwrapping. Because filtering can smear out
fine detail in the displacement surface, it should be applied to the analysis only to
the extent necessary to eliminate extended phase unwrapping defects.
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3. Apply a mask to the data analysis and eliminate unwrapping errors by excluding
problematic areas from being analyzed. Follow the directions given in Section 3.2.

&

Note: Aggressive masking may create isolated data
“‘islands” that cannot be crossed by the normal
unwrapping algorithms. In this case, the user can alter
the Unwrapping Parameters to properly display
isolated data. See Section 4.6.

Figure 8.1 Surface Plots with Unwrapping Errors
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Appendix A Miscellaneous Information

A.1 File Formats

Akrometrix Surface Analysis loads and saves data with the *.akx_* extension. For a
more detailed breakdown of Surface Analysis specific formats please see the table
below. Image export formats are exclusively *.png with varying filename postfixes to
further denote their origins.

Extension Contents

*.akx_phase A single phase image with associated metadata. May optionally contain cropped
versions of supporting data: intensity, and/or reference displacement

*.akx_disp A single displacement data matrix with associated metadata. May optionally
contain cropped versions of supporting data: phase, intensity, and/or reference
displacement

*.akx_partition Partition file (standard XML format)
*.akx_3Dconfig Configuration file for 3D plot

*.akx_2Dconfig Configuration file for 2D plot

*.akx_chordset Chord set (standard XML format)

*.akx_recipe Stores batch processing settings for recall later.

A.1.1 Metadata Fields

Metadata fields embedded in *.akx_phase or *.akx_disp objects can be used in
building filenames, output paths, and report labels in various places in Akrometrix Studio
applications. Some of the more commonly used metadata fields are described below.

<RoiName> User defined when adding ROIs to the Camera Window in Surface
Measurement. Also defined when partitioning in Surface Analysis.

<Lotld> User defined in the Metadata settings dialog in Surface Measurement or
Thermal Profiler

<Testld> User defined in the Metadata settings dialog in Surface Measurement or
Thermal Profiler

<Operatorld> User defined in the Metadata settings dialog in Surface Measurement or
Thermal Profiler

<Productld> User defined in the Metadata settings dialog in Surface Measurement or
Thermal Profiler

<TemperatureNominal> User defined when creating a profile in Profiler Generator

<TemperatureReading> Any thermocouple data for the acquisition (can include up to 16

temperatures in the case of a CRE measurement). With no suffix, this
metadata tag will provide TC1 data, but a two digit numerical suffix, such
as “02” will provide the data for the corresponding thermocouple.

<TemperatureSetpoint> User defined when creating a profile in Profile Generator

<ProfileSecondsAndTemp> | Time/temperature when a phase/disp file was acquired.
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Other metadata fields such as Pin 1 Location, Equipment Model, etc. are available in
the Properties window of any phase or displacement image (Figure 2.3). Any entry in this
list can be surrounded by “<” “>” symbols to indicate to the application to use that
metadata field in populating the corresponding text entry area. In addition, any gauge
value can be added in the same way.

A.2 Keyboard Shortcuts

Shortcut Command Action
Main Window Shortcuts
Ctrl+O File>Open Open a new *.akx_phase or *akx_disp file
Alt+F+X File>Exit Exit the Surface Analysis program
F1 Help>User Manual Open the User Manual
Phase Window Shortcuts
Ctrl+C Copy (ROI) Copy ROI
Ctrl+V Paste (ROI) Paste ROI

Ctrl plus arrow key increases the ROI size by one pixel in the indicated direction.
Alt plus arrow key decreases the ROI size by one pixel in the indicated direction.

1-4 Advanced->View=>Intensity 1-4 Show Intensity Images 1-4
P Advanced->View->Phase Image Show Phase Image
S Advanced->View->Surface Image Show Surface Image
Ctrl+ Zoom in to phase image
Ctrl- Zoom out of phase image
Ctrl+M Advanced->Mask->New Create a new mask
Ctrl+R Advanced->Partition>New Create a new partition
Ctrl+B Advanced->Unwrapping Parameters>Add Bridge Create a new phase bridge
Ctrl+K Advanced->Chord->New Chord Create a new chord
Ctrl+G Advanced->Chord->New Set Create a new chord set
Shift+1-9 Advanced->Chord->1-9 Show Chord Sets 1-9
Shift+T Create a chord along top edge of the image
Shift+B Create a chord along bottom edge of the image
Shift+L Create a chord along left edge of the image
Shift+R Create a chord along right edge of the image
Shift+D Create downward diagonal chord (upper left to lower right corner) on the image
Shift+U Create upward diagonal chord (lower left to upper right corner) on the image
Shift+H Create a chord along the horizontal centerline of the image
Shift+V Create a chord along the vertical centerline of the image
3D Window Shortcuts

Cirl+C Copy View glcl)gé)%s;ge current display window viewing angle and magnification to the
Cuty | paste view e e e o o

Batch Processing Window Shortcuts
F5 Edit>Refresh Source Folder Allows the user to update the list of source files since the folder

was originally selected
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