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1 Introduction

1.1 Overview

Surface Analysis is a program designed to analyze and display the results of
shadow moiré and fringe projection measurements produced by Akrometrix warpage
measurement systems. The program typically resides on the measurement system
computer. If additional site licenses are purchased, Surface Analysis may also be
installed as a stand-alone application on other computers, offloading analysis tasks from
the measurement system.

The analysis of interferometric data from shadow moiré and fringe projection
systems is a rich and complex subject. The main text of this manual emphasizes the
operation of the Surface Analysis program. The principles of interferometric techniques
and analysis will be discussed in Akrometrix Optical Techniques and Analyses 101
(AOTAL101). This paper should be read first by users unfamiliar with these techniques.

The output of the data acquisition program and thus the input of the Surface
Analysis program is an Akrometrix-defined file with the extension of *.akx_phase. This
file can contain measurement and reference data as well as some measurement
parameters and conditions. Surface Analysis converts data from the *.akx_phase file
into height data, and if required, Akrometrix gauges.

The main analysis functions in Surface Analysis are based on the phase image in
the *.akx_phase file. A phase image is a two-dimensional grayscale image (computed
from several intensity source images) containing a value at each point related to the
surface height at that point. Many of the options available in the Surface Analysis
program originate from two challenges in phase image analysis.

e First, the phase data must be analyzed as a whole and errors due to poor
guality data in one region of the surface can affect the results in other
regions. The Phase Smoothing, Cropping and Masking functions allow bad
data to be smoothed or excluded from analysis.

e Second, the surface contour does not have an absolute frame of reference.
The Rotation, Grating Compensation, and Reference/Relative functions allow
the user to define the reference plane in a way most useful for understanding
the experimental results.

A second group of options control the display and output of experimental results.
Surface Analysis provides a suite of display formats, which can each be further
customized to the user’s preference. In addition, the displacement data can be exported
in tabular form for plotting or further analysis by other software packages.

Finally, four features allow repetitive functions to be automated:

e Batch Analysis allows the user to quickly analyze a set of related
measurement data (e.g. the same sample at different temperatures)

e Batch Masking allows the user to quickly mask more than one phase image.
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e Batch Rotation allows the user to quickly rotate more than one phase image

e Batch Cropping allows the user to quickly crop multiple regions of interest
from more than one phase image

1.2 Warnings and Notes

1.2.1 Warnings and Notes in this Manual
Warnings and Notes are marked throughout the manual with these icons:

O

Figure 1.1 Warning Icon Figure 1.2 Note Icon

&

il

Warnings are specific health hazards for the operator or potential sources of system
damage. Notes highlight system limitations or automatic responses that may require
corrective action by the operator for successful operation.

1.3 Technical Support

Akrometrix 404-486-0880 support@akrometrix.com
2700 NE Expressway 404-486-0890 (fax) http://www.akrometrix.com
Building B, Suite 500

Atlanta, GA 30345

When contacting Akrometrix, please provide the system serial number, the version
numbers of the Akrometrix software being used, a description of the problem or
guestion, and contact information for reply. If the question concerns a particular
measurement or analysis, please provide electronic copies of the *.akx_phase files, final
results, and a description of data acquisition and/or analysis conditions. If the problem
concerns changes or failure in general system operation, please describe any events or
system modifications that occurred immediately before the problem arose.
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2 Loading Measurement Data

2.1 Starting the Program
The Surface Analysis program can be started in four different ways:

A. Right click on the phase image in the Surface Measurement and choose
Open in Surface Analysis....

B. Double-click on a valid *.akx_phase file

C. Launch the Surface Analysis executable file directly from its shortcut (e.qg.
via the Start menu)

D. Click the Surface Analysis button listed on the Akrometrix Studio Manager
bar on the left side of the screen.

Note: Only one instance (copy) of the software can run
4 at a time; subsequent calls to the program will activate
the open instance.

|

2.2 Loading Measurement Data

Once the Surface Analysis program starts, a GUI (Graphical User Interface) frame
will appear. The contents of the display frame depend on how the application was
launched:

A. If called from the measurement software via clicking on a phase image, the
current phase image from the data acquisition program is shown.

B. If an *.akx_phase file was double-clicked, the phase image contained in the
selected *.akx_phase file is shown.

C. If the EXE is launched from a shortcut or Studio Manager, no image is
shown and the user needs to select a file to open.

New measurement data files can be loaded into memory with the File=>Open menu
item. A standard Open dialog box appears prompting the user to select a valid
*.akx_phase file. Multiple *.akx_phase files can be opened at one time by highlighting
multiple selections using the Shift or Control keys. Phase images can also be dragged
and dropped into the Surface Analysis program in order to open them.

&

Note: Surface Analysis can be configured to analyze
the image and display results immediately upon
opening the  *.akx_phase file, using the
Tools>Options... menu item. See Section 4.2

il

2.3 Working with the Phase Image

An *.akx_phase file may contain a variety of information such as measurement data
(phase images, intensity images, etc.), reference data, as well as measurement
parameters and conditions. When the *.akx_phase file is loaded, all the information in
the file is loaded in memory. For display purposes, only the phase image will be shown
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in the GUI of the Surface Analysis program. Modification (Section 3) and Analysis
(Section 4) on the measurement data will be mainly applied to the phase image and
any associated reference data that exist.

2.3.1 Resizing a Phase Image

The phase image window may be resized in the normal fashion by dragging along
any edge or corner. The image in the window can be zoomed by using Ctrl+ or Ctrl-
(Figure 2.1 and Figure 2.2). Each action doubles or halves the size of the phase
image.

N

250 x 200 pixels v | 100 % | 250 x 200 pixels ~ | 200% |

Figure 2.1 Phase Image 100% Magnification Figure 2.2 Phase Image 200% Magnification

2.3.2 Data Information

When a phase image is displayed in Surface Analysis, some data information can
be present as well. First of all, the full path of the *.akx_phase file can be shown by
hovering the cursor over the title bar of the phase image. Second, the image size and
magnification ratio information are shown on the status bar located at the bottom of the
image (Figure 2.3).

@J Sample Image.akx_phase Q
N A
)

R (¢

_ 1.
250 x 200 pixels v | 100 % |

Figure 2.3 Data Information Shown on the Phase Image
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2.3.3 Measurement Information

In addition to the data information described in Section 2.3.2, the measurement
parameters and conditions can be displayed by right-clicking on the image and
choosing Properties... (Figure 2.4). In the Properties window, information about the
intensity images, phase image, and grating can be found.

Sample Image.aloc_phase Properties X,
Greting | Intensty 0 | Intensty 1 | intensity 2 | ntensty 3| Phase

Smooth
Rotation »

-

Advanced

N Properties...

Figure 2.4 Displaying Measurement Parameters and Conditions

2.3.4 Assigning Physical Size

Surface Analysis (and the TherMoiré measurement system in general) has no
internal means of knowing the physical ROl (Region of Interest) size, but physical
dimensions can be assigned by the user. Click the “Image Size” area on the status bar
at the bottom left of the phase image. Select Assign Size... from the pull-up menu
(Figure 2.5). In the Physical Size window, assign the unit as inches or millimeters, then
enter the Width and Height of the image and click OK.

After physical dimensions have been assigned, the user can choose whether X and
Y axes are displayed in pixels, inches or millimeters using the same pull-up menu on
the status bar. The selected unit will appear on the X and Y axes of all graphs created
after analysis.

Sample Image.akx_phase @ O
| ;_A : * AT

Units
millimeter v

Width Height

G0 o= N T T

ok | Cconcel |
I

Figure 2.5 Assigning Physical Size for a Phase Image

i i
50.0x40.0mm ~ | 100 %

(| 250 x 200 pixels ~| 100 % |
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&

Note:

Physical
Compensation (Section 4.5) and calculation of Bow
and Twist
Techniques and Analyses 101).

dimensions

gauges (See

2.3.5 Showing Surface or Intensity Images

are

Akrometrix

required for

Optical

Phase images have fringes across the whole field, hiding features on the sample
surface. If the user wishes to make masks, partitions, or chords on the surface or
intensity images, they can be shown by right-clicking on the phase image and selecting
Advanced->View->Surface Image (or, alternatively, any one of the 4 intensity
images). The image can also be quickly changed without the context menu by using the
keyboard shortcuts P, S, and the numbers 1-4. The currently viewed image can be
saved to disk in the .bmp format by selecting File->Save Image... or Ctrl+I.

-

250 x 200 pixels ~ | 100 % |

a

250 x 200 pixels ~ | 100 % |

-
. f o =
(O R A e S e e (=) >l (O Sample Image.akx_phase HEB

Figure 2.6 Phase and Surface Image Views

Analyze
Smooth
Rotation

| Advanced

Mask

l Properties...

10 x 140 pixels ~ | 100 % |

Partition

Chord

View

Rotate
Duplicate

Shift...

Phase P
Surface S
Intensity 1 1
Intensity 2 2
Intensity 3 3
Intensity 4 4

Figure 2.7 Menu Command for Showing Surface or Intensity Images
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3 Modifying Measurement Data

3.1 Setting the ROI

The Mask, Crop, and Partition functions in Surface Analysis create one or more
graphically defined ROIs (Regions of Interest) on the phase image where these
functions can be applied. ROIs can be different shapes such as rectangle, ellipse,
triangle, etc. The default shape of an ROI is a rectangle. Choose a new shape by
opening the Shape Selector window from the View->Shape Selector menu item.
Choose the shape before selecting the Mask, Crop, or Partition function (Figure 3.1).

Draw an ROI inside the image by picking the first corner and dragging the cursor to
another corner and letting go of the button. When an ROI region is selected, it can be
repositioned by dragging anywhere within its region and resized by dragging on any of
the eight “Handles” on the periphery. The shape, location, and size of the ROI can also
be changed by using the ROI Properties Window (Figure 3.2). To access this window,
right-click inside the ROI and choose Properties.... This window is useful for drawing a
pre-defined ROI.

Edit Crop Region o x|
shape Selector x o
Rectangle -
Location Size
O O <> A x Position y Position Width Height
73 = s = oz H [ns =
. oK Cancel
Figure 3.1 ROI Shape Selector |

Figure 3.2 Edit ROI Region Size and Position

Other common functions for Masking, Cropping, and Partitioning can be called by
right-clicking inside an ROI:

Copy (Ctrl+C) creates a copy of the active ROI on the Windows Clipboard. It may
be pasted (Ctrl+V) inside the original phase image or in a different phase image (Not
available for Crop function)

Square Bounds equalizes the horizontal and vertical dimensions of the ROI as the
shorter value of the two

Delete deletes the active ROI (Not available for Crop function)

Delete All deletes all ROIs within the current phase image window (Not available
for Crop function)

Note: The ROI functions for Mask, Crop, and Partition
modes are all slightly different. See the following
sections.

il
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3.2 Masking a Phase Image

Masking excludes regions inside the phase image from the analysis. Regions that
lack good phase data (e.g. holes, steps) can create errors in the analysis that extend
beyond the bad phase region. When using a mask, there is no displacement information
generated within the masked-out regions, and the remainder of the phase image can be
analyzed without interference.

3.2.1 Creating a Mask

A mask file is a binary graphical image containing only black and white colors. The
white color represents valid data while the black color represents points or areas that
need to be masked out. In most cases, the mask shapes shown in Figure 3.1 are
sufficient. However, if the user needs to define an irregularly shaped mask, they can
also be generated from an external graphical tool such as MS Paint®. The file format
needs to be *.bmp, *.png, or *.tif in order to be loaded in Surface Analysis.

A mask can be created and saved in Surface Analysis by the following steps:

1. To create a new mask, right-click in the selected phase image and choose
Advanced->Mask->New (or use the keyboard shortcut, Ctrl+M).

2. To create the first ROl in the new mask, hold down the left mouse button; draw a
rectangle on the phase image and then release. The ROI will appear as a
transparent red shape. All the ROl commands described in Section 3.1 apply to
the mask ROI.

3. Additional mask ROIs can be added by repeating steps 1 and 2. Mask ROIs may
overlap.

4. When the mask is complete, it may be saved to a file (*.bmp, *.png, or *.tif) by
right-clicking inside the phase image (but not inside an editable mask ROI) and
choosing Advanced->Mask->Save....

5. Masking function can be turned on and off without deleting the mask from
memory by right-clicking inside the phase image (but not inside an editable mask
ROI) and choosing Advanced->Mask->Enable. Alternating this command will
turn the current mask(s) on and off. This is useful when evaluating masks
between phase image and 3D surface plot during a trial. When the masking
function is disabled, all mask ROIs are hidden.

3.2.2 Loading and Editing a Mask

A previously created mask that was saved in the *.bmp, *.png, or *.tif formats can
be recalled and applied to any phase image. To load the mask file, right-click inside the
phase image, choose Advanced->Mask->Load..., and select the desired mask file.
More than one mask file can be loaded on the same phase image. A loaded mask is
shown in solid yellow color.
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A loaded mask cannot be edited but can be turned on and off by toggling the
Advanced->Mask->Enable function. To delete the loaded mask, choose
Advanced->Mask->Clear. The Clear command does not apply to mask ROIs which
are not loaded from a file; these can be removed using the Delete or Delete All
commands. New mask ROIs may be added by right-clicking inside the phase image and
choosing Advanced->Mask->New.

The modified mask, including both old and new components, can be saved by right-
clicking inside the phase image (but not inside an editable mask ROI) and choosing
Advanced->Mask->Save....

&

— Note: If a mask is applied to a phase image with
— different pixel dimensions than the one on which it was
i created, it will be located on the new phase image with
the upper left corner as the origin. Any mask ROIs that
lie entirely outside the boundaries of the new phase
image will not appear. Mask ROIs lying partially outside
the phase image boundaries will be truncated.

3.2.3 Burning a Mask

Burning a mask combines the current phase image with one or more mask ROIs
created in memory or loaded from a file. The mask pattern will be permanently
embedded in the phase image as the grayscale value 128. This function prevents the
future separation and loss of mask files used during analysis.

A mask can be burned by:
¢ right-clicking inside an editable mask ROI and choosing Burn or,

e right-clicking inside the phase image (but not inside an editable mask ROI)
and choosing Advanced->Mask-=>Burn.

The burned mask ROIs appear as a gray color as shown in Figure 3.3.

[©/ sample Image.akx_phase [Mlm]P3
ol s\

i -
250 x 200 pixels ~ | 100 %

Figure 3.3 Burned Mask Areas
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3.3

Cropping a Phase Image

Cropping an image allows the user to extract and save a smaller portion of the
current phase image. This is useful for defining a smaller region inside the original
phase image or eliminating bad phase data at an image edge.

1.

2.

3.4

Inside the phase image to be modified, right-click and go to Advanced->Crop...
Draw an ROI inside the image using the cursor.

Size and position the ROI to enclose the desired region with the mouse or the
ROI Properties Window (Figure 3.2).

To abort the crop operation, right-click and go to Cancel inside the ROI or use
Esc on the keyboard.

To execute the cropping operation, right-click and select Crop inside the ROI.
The enclosed cropped region is now shown in the display.

&

Note: After cropping, the source phase image will be
removed and replaced with a new cropped phase
image. To keep both the old and new images, use the
partition function (Section 3.4).

il

Partitioning a Phase Image

Partitioning is a function where one or more ROIs are cropped from a phase image
while leaving the original phase image intact. This function is useful for measuring
multiple samples in a single run, and later extracting the individual samples from each
phase image recorded. The same partition can be applied to multiple phase images
using the Batch Cropping tool described in Section 6.

3.4.1 Creating a Partition

1.

To create a new partition, right-click in the selected phase image and choose
Advanced->Partition>New (or Ctrl+R).

To create the first domain in the new partition, draw a rectangle on the phase
image with the mouse.

An ROI properties window will appear to allow the user to modify domain
properties. Like the other ROI property windows, this can be used to edit the
shape, location, and size of the domain. It can also be used to rename the
domain and change the font and alignment of the label inside the domain (Figure
3.4). Click OK when complete. A green ROI appears and all the ROl commands
described in Section 3.1 apply to the partition ROI.
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Edit Partition Region B X

Mame
Region 1 Font... | Align... |
Shape
|Hec:tar1gle j
Location Size
x Position y Position Width Height

ok | cancel |

Figure 3.4 A Partition ROI Properties Window

4. Additional domains can be added to the partition (Figure 3.5) by repeating steps
1 through 3. Domains may overlap.

327 x 299 pixels v | 100% |

Figure 3.5 Multiple Domains on One Phase Image

5. When the patrtition is complete, it can be saved to a file (*.akx_partition) by right-
clicking inside the phase image (but not inside a domain) and choosing
Advanced->Partition->Save....
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6. Even if it has not been saved, a partition may be used until it is cleared. It may be
cleared by right-clicking inside the phase image (but not inside a domain) and
choosing Advanced->Partition->Clear.

3.4.2 Loading and Editing a Partition

A previously created partition that was saved in an *.akx_partition file can be
recalled and applied to any phase image. To load the partition file, right-click inside the
phase image, choose Advanced->Partition=>Load..., and select the desired partition
file.

Any domain in the partition may be modified or deleted by right-clicking inside the
domain and using the ROl commands described in Section 3.1. It may also be edited
graphically using the cursor. New domains may be added by right-clicking inside the
phase image (but not inside a domain) and choosing Advanced->Partition->New.

The modified partition, including both old and new domains, may be saved by right-
clicking inside the phase image (but not inside a domain) and choosing
Advanced->Partition->Save....

&

— Note: If a partition is applied to a phase image with
— different pixel dimensions than the one on which it was
i created, it will be located on the new phase image with
the upper left corner as the origin. Any domains that lie
entirely or partially outside the boundaries of the new
phase image will be excluded.

3.4.3 Extracting Domains

To extract a domain as an independent phase image in its own window, right-click
inside the domain and choose Extract. To extract all domains, right-click inside any
domain and choose Extract All. Unlike the crop function, where the source image was
replaced by the new image, the partition function retains both old and new images.

[©/ Sample Image.akx_phase [H(=]
_ .

= A4 3

@ Region 1

i S
250 x 200 pixels ~ | 100 % 114 x 91 pixels - | 100 % 120 x 120 pixels - | 100 %

Figure 3.6 Extracted Domains from a Phase Image
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3.5 Smoothing a Phase Image

The Smooth command applies a smoothing function to the active phase image to
reduce noise in the data. This is useful for reducing analysis error due to fringe
miscounting and increasing reproducibility in gauge values. Warpage gauge values,
such as coplanarity, are frequently determined by a small number of data points, e.g.
the highest and lowest displacement values. Therefore, they are extremely sensitive to
statistical outliers in the data set. Smoothing, by reducing statistical noise, can make
these values more repeatable from measurement to measurement.

To apply the smooth function, right-click inside the phase image and choose
Smooth. This command can be repeated multiple times. For further information about
the smooth function, refer to Akrometrix Optical Techniques and Analysis 101.

&

Note: Smoothing may cause errors when applied to
images where the fringes are very tightly spaced or at
boundaries of mask ROIs. Therefore, it is not
recommended to apply the smooth function on data
acquired with the MP10 Surface Measurement system
which produces a closely spaced fringe pattern on a
phase image.

]

3.6 Rotating a Phase Image

Rotating a phase image is a feature useful when a sample does not have the
desired orientation in the original phase image (e.g. a part has rotated on the sample
support fixture during a temperature profile).

To rotate a phase image, right-click on the image, choose Advanced->Rotate and
select the desired rotation.

&

Note: Phase image rotation is different from reference
plane rotation that is discussed in Section 4.3. The
former rotates a 2D image while the latter rotates a 3D
surface. To choose the method of rotating a reference
plane, right-click on the phase image and choose
Rotation (Figure 3.8).

il
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@ sample Image.akx_phase !En
i . N

Analyze
Smooth

Rotation MNone

Advanced LSF

Properties... LSF Low O

9005 LSF High 0

%0 deg CW
shift.. 0 deg COW
Arbitzary...

Three Paint
AN

i . Four Point
250 x 200 pixels « | 100 % our Poin

Figure 3.7 Phase Image Rotation Figure 3.8 Reference Plane Rotation

3.7 Shifting a Phase Image

Shifting a phase image is a feature useful when a sample does not have the desired
position in the original phase image, e.g. a part has shifted to one side of the sample
support fixture during a temperature profile.

To shift a phase image, right-click on the phase image, choose Advanced->Shift...
and select the desired shift in either the X (left-right) or Y (up-down) direction. The
image will shift with respect to an origin that is defined as the top left of the phase
image. Areas shifted from outside the boundaries of the phase image will be filled with
mask (see Figure 3.9).

w— |
B sample Image.akx_phase |« DL/_\J

Shift Image
¥-Direction Y-Direction
E= ==
(2 = oK Cancel ;- :
250 x 200 pixels ~ | 100 % | Q 250 x 200 pixels | 100 %

Figure 3.9 Shifting a Phase Image

3.8 Undoing a Phase Image Modification

To undo phase image modification from masking, cropping, smoothing, rotating or
shifting, right-click and select Advanced->Undo; select the action to undo from the
available list.

There can be up to 99 actions on the undo list. The latest action will be shown at the
top of the list. Clicking on the latest action will remove this single action and move the
phase image back one state. Clicking on any item in the middle of the list will remove all
the actions from the top to this item.
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3.9 Saving Phase Images

A modified phase image is NOT automatically saved to the hard drive. It can be
saved using the File->Save... menu item. If the modified image is not saved, the user
will be prompted again to save it when the phase image window is closed or the
program is shut down.
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4 Analyzing Measurement Data

Analysis is the mathematical conversion of the measurement data (e.g. phase
image) into displacement data (the height of the surface at each image pixel in physical
units). Surface Analysis is normally set to display displacement data graphically as
soon as the analysis is complete. The graphical output options will be described in
Section 5. This section describes how to initiate the analysis process and a key factor
in the analysis, the choice of reference plane.

4.1 Analysis
There are three methods to trigger analysis of the measurement data

A. To trigger analysis manually, right-click on the phase image to be analyzed
and select Analyze.

B. To trigger analysis automatically when a *.akx_phase file is opened, select
the Tools>Options... menu item and check Analyze on Open.

C. To analyze multiple measurement data in parallel, use the Batch Analysis
function described in Section 6.2.

Note: If no graphical display options are checked in the
4 options window, there will be no visible indication that
analysis has taken place in cases A and B above.

|

4.2 The Options Window

The settings on the options window (Figure 4.1) determine the reference plane and
display options when the measurement data is analyzed. These settings will be applied
to all the measurement data, either manually or automatically on opening.

To open the options window, select the Tools=>Options... menu item. All the
settings are explained below:

Units XY Displays the in-plane dimensions in English (inches) or metric
units (millimeters).

Units Z Displays the out-of-plane dimensions in English (mils, 1 mil =
0.001 inches) or metric units (microns, or um).

Initial Physical Assigns the specified physical dimensions for Width (X) and

Size Height (Y) to the phase image when loaded. The unit of X and

Y is assigned in Units XY.

Smooth on Open  Checking this box causes the phase image to be smoothed
one time immediately after loaded.

Analyze on Open Checking this box causes the measurement data to be
analyzed immediately after loaded.
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Normalize Chords Checking this box causes all 2D chord plots to be displayed
with the endpoints referenced to zero.

Grating Checking this box applies compensation to all measurement

Compensation data that contain compensation parameters(See Section 4.5
for a discussion of grating compensation). It may be turned on
or off for individual measurement data by right-clicking on a
phase image and choosing Advanced->Compensate.

Rotation Pull-down list sets the reference plane rotation to be applied
during the analysis. See Section 4.3.

Gauges Select which gauges (numerical values quantifying flatness)
are displayed at the bottom of the graphical display windows.
A gauge on the list may be highlighted by clicking on it once.
Checking a box means that gauge will be displayed. The up
and down arrows move the highlighted gauge up and down
the list, changing the order in which gauges are displayed.

Graphs Selects which graph formats (see Sections 5.1 through 5.4 )
are displayed after analysis. A graph on the list may be
highlighted by clicking on it once. Checking a box means that
graph will be displayed. The up and down arrows move the
highlighted graph up and down the list, changing the order in
which graphs are displayed.

Configuration File Allows the user to load a non-default display format for
graphs. The 3D configuration file has an extension of
*.akx_3Dconfig and is used for 3D plots. See Section 5.1.
The 2D configuration file has an extension of *.akx_2Dconfig
and is used for any 2D chords. See Section 5.3 and 5.4.

Graph Size Sets the initial size for all graphical displays created during
analysis.

Gauge Display Gauge values listed at the bottom of the 3D or 2D display
window may be arranged horizontally or vertically.

Use Latest 3D Applies the perspective of the most recently modified 3D

View surface plot to all subsequently spawned 3D surface plots. In

other words, if the user changes the altitude or rotation from
which the surface is viewed in one graph, new graphs will
automatically be shown from the same viewpoint. The zoom
factor of the most recent graph will also be inherited.

Fixed Z-Scale When checked, this allows the user to adjust the data scale
for all 3D or 2D plots. When unchecked, each image is plotted
on a scale set by its own data set. This option is also available
in Batch Analysis (Tools>Batch Processing...2>Analysis
Tab).

Graph File Format Sets the default graphical file format for saving a graph.
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Data File Format  Sets the default numerical data format for saving a graph.

OK Any changes to the settings are saved and the window is
closed.
Cancel The window will close without changes to the settings.
Options g|
Analysis Window Output
Units Graphs
xY z +
millimeter s micron | % [ ColorContour
[] Diagonals @
[ HorizontalCenterine
[] HerizantalEdges
[] VerticalCerterine
[ VerticalEdges
3D Configuration File
[] Smocth Phase On Open
Graph Size
L] Anaiyze On Open Width Height
[] Grating Compensation 861 & B51 |3
[] Smooth Displacement
[] Nomalize Chards Gauge Display
() Horizontal (&) Vertical
Default Rotation | LSF v
Tome [ Use Latest 3D View
[#] Coplanarity @ Fixed Z-5cale
[¥] FullFieldSignedWamage Surface Chord
[] Bow
[] CenterDeflection @ [ Enabled [ Enabled
[] ChardMax Maximum Maximum
[] ChordMin
[ Max
] Min Winimum Minimum
] roC
[] SignedWampage
[] Twist

Figure 4.1 Options Window

Il

Note: If no options are checked on the Graphs list,
there will be no visible indication that analysis has
taken place.

]

4.3 Reference Plane — Rotation

In order to display the displacement data, the user may define a coordinate system
with a zero reference plane. This is especially useful when calculating gauges. To set
the reference plane rotation to be used during analysis, select Tools->Options... and
choose from the Default Rotation pull-down list.

The rotation choice can also be made before analysis by right-clicking on the phase
image and choosing Rotation, then selecting from the list. The selected option is
checked.
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Note: The rotation option chosen in the options window
will be applied to all the measurement data when
loaded. The rotation option chosen from an individual
phase image will only be applied to that particular data.

I

Surface Analysis provides the user with several options for defining the zero
reference plane:

e None: The displacement data is not rotated and thus the reference plane is
parallel to the grating. The zero value on the data does not correspond to any
specific feature of the displacement surface.

e LSF: The displacement data is rotated so that the zero reference plane is the
best fit plane calculated from all displacement points.

e LSF Low 0O: LSF rotation option with the lowest displacement point set equal
to zero (all others are positive displacement values).

e LSF High 0: LSF rotation option with the highest displacement point set
equal to zero (all others are negative displacement values).

e Three Point: The displacement data is rotated so that the zero reference
plane is defined by three corners (upper left, lower left, upper right).

e Four Point: The displacement data is rotated so that the zero reference
plane is the best fit plane calculated from all four corners.

The values of the individual data points change as a function of rotation (choice of
reference plane), so gauges (e.g. coplanarity) and other calculated values are also a
function of rotation. See Akrometrix Optical Techniques and Analyses 101 for further
discussion.

4.4 Reference Surface — Relative Displacement

A relative displacement measurement is calculated by taking the difference between
two absolute displacement measurements with the same image pixel size. It is useful
for observing the change in sample warpage as a function of sample history. The
baseline displacement surface is set to be reference surface. The relative displacement
surface is the current active surface minus the reference surface.

To define a reference surface, right-click on a 3D graph analyzed from a phase
image and check Reference Surface. This surface data will then act as a reference to
all other displacement data. After identifying the reference surface, right-click on a
second phase image of the same pixel dimensions. An additional menu item, Analyze
Relative, appears on the list below Analyze. To obtain the relative displacement data,
select Analyze Relative. Otherwise, choose Analyze to obtain the absolute
displacement data. The relative displacement display can be turned off by right-clicking
on the reference surface image and unchecking Reference Surface. After that,
Analyze Relative will disappear from the menu list for the phase images.

L

Note: Analyze Relative only compares data with the
same pixel dimensions. If the second phase image is of
different pixel dimensions than the reference phase
image, the user will be shown an error message.

—
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4.5 Reference Surface — Grating Compensation

The non-planar surface of a grating can be compensated by a reference surface
(see Akrometrix Optical Techniqgues and Analyses 101). To enable grating
compensation during analysis, check the Enabled box under Grating Compensation
in the options window.

The compensation choice can also be made for individual phase images by right-
clicking on the phase image and checking Advanced->Compensation. To turn off
compensation, repeat the process and uncheck the selection by clicking it again.

&

Note: In the options window, the Grating
Compensation option can be enabled or disabled
regardless of whether the grating has been
compensated or not. This option will be applied to all
opened phase images that contain compensation data.

il

&

Note: The compensation option on an individual phase
image will be grayed out if no compensation
parameters can be found in the *.akx_phase file.
Otherwise, this option is shown in black and can be
checked or unchecked. The compensation option
chosen for each phase image will only be applied to
that particular image.

I

* Note: In order to apply grating compensation, physical

dimensions have to be assigned to the phase image
(see Section 2.3.4). The grating compensation
calculation assumes that the ROI is centered with
respect to the grating. The accuracy of the
compensation will be reduced if the ROI is not
centered, particularly if it lies outside the central 4” by
4” area of the grating.

I
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5 Displaying Results
After analysis, the information is displayed in a choice of four graphical formats:

3D Surface (Section 5.1)

3D Contour (Section 5.2)

2D Diagonal (Section 5.3)
2D Chord (Section 5.4)

The data displayed in each graph can be exported in numerical form (Section 5.5).
In the meantime, gauges (single values representing the warpage) can be displayed at
the bottom of the 3D graphs (Section 5.6).

5.1 Graphical Output — 3D Surface Plot

5.1.1 3D Display Window

To display the 3D Surface plot after analysis, check the box next to 3D on the
Graphs list in the options window (Section 4.2). After right-clicking and selecting
Analyze on the phase image, a new 3D display window is opened and the 3D height
map represented in color is shown in the center of this window. The name of the data
file will be shown on the top and gauges selected in the options window will be
displayed below the 3D image. The caption of the 3D display window can be renamed
by right-clicking on its title bar and selecting Rename Window.... Additional information
including cursor coordinate position, viewpoint and zoom ratio can be found in the
status bar at the bottom left. See Figure 5.1.

5.1.2 Key/Mouse Interactions on the Graph
There are four interactions that can be done with the 3D graph:

1. Coordinates of each individual data points are shown live in the status bar by
hovering the cursor over the 3D image.

2. Rotate adjusts the angle from which the surface is viewed. Press the left mouse
button and drag the plot to the desired orientation in the display window. The
current Rotation and Altitude parameters will be displayed in the status bar.

3. Zoom adjusts the scale of the plot. Scroll the mouse wheel and change the plot
to the desired scale in the display window. The current 3D graph magnification
level will be displayed in the status bar.

4. Esc key brings the 3D graph back to its original size (zoom ratio of 100%).
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sample image

¥ (niezls)
(phezls) -

(%,¥,Z) = 199,147,-217 | Rotation: 30 Altitude: 45 Zoom: 100%

sample image

Scale Z-Axis. ..
Smooth
Fit Data... microns

Plot Chord(s) 3 Diagonals

VerticalEdges
Use As Reference HorizontalEdges

Save... Ctri+s VerticalCenteriine
HorizontalCenterline

Save Image... Ctrl+
Ctri+C
Ctrl+p

Copy View

Print...

Create Legend...

Configure. .

Oog

Coplanarity = 952 microns
FullFieldSignedWarpage = 952 microns
ROC =n/a

5.1.3 Changing Viewpoint

Figure 5.1 3D Surface Plot

The viewpoint of a 3D graph can be set using four different approaches:

e Use Latest 3D View box in the options window (Section 4.2)

e Rotate operation (Section 5.1.2)

e Copy View and Paste View in the 3D display command list (Section 5.1.4)

e The display Configuration window (Section 5.1.5)

5.1.4 Graph Command List

Right-click on the display window to show the following command list:

Scale Z-Axis...

Smooth

Fit Data...

Plot Chord(s)

Displays a window where the Z axis minimum and
maximum values can be modified. Defaults are the min
and max values of the data.

Applies a smoothing function to the 3D data and shows the
smoothed surface in a new window. This command can be
repeated multiple times. See AOTA101 for more
information.

Opens a dialog where a polynomial fit can be calculated
based on the data set. See Figure 5.2. Alternatively, if
physical dimensions are assigned to the phase image, a
spherical fit can be calculated.

Plots pre-defined chords in a new window.
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Show Relative To
Use as Reference
Save...

Save Image...
Copy View

Paste View

Print...
Create Legend...

Configure...

Properties...

Displays the relative displacement data calculated by
subtracting a selected 3D data from the current 3D data in
a new window.

Sets the current 3D data to serve as the reference surface

Exports the data in numerical (Section 5.5) or *.akx_disp
format

Allows display window to be saved in graphical format
(*_3D.bmp or *_3D.jpQ).

Copies the current display window viewing angle and
magnification to the Clipboard.

Applies the viewing angle and magnification saved to the
Clipboard to the current display window (only appears after
Copy View is used).

Allows display window to be printed to any available
system printer.

Allows a legend to be saved as a separate picture file for
reporting purposes.

Opens a window where graph display parameters can be
changed, including things such as color, font, and layout.
See Section 5.1.5

Opens a displacement object properties window with all
saved parameters relating to the displacement object.

Fit Data X

{(*) Pohnomial Order @ =

Retain Masked Points

QK l [ Cancel

Figure 5.2 Fit Data Dialog

5.1.5 Display Configuration Window

The display configuration window (Figure 5.3) gives the user access to a very
flexible system for customizing the graph display format. The custom format can be
saved and re-used, and set as the default format for all 3D plots. To display the
configuration window, right-click inside the graph window and select Configure....
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In the configuration window, to load a previously saved display configuration,
choose File>Open... (Ctrl+0O). To save the current display configuration, choose

File=>Save

.. (CUrl+S).

Note: The display configuration file (*.akx_3Dconfig)
loaded from the display properties window is applied to

I

the current display window (Figure 5.1). Configuration

files loaded from the Options window (see Section 4.2,
Figure 4.1) will be applied to all newly created display

windows.
Configuration %
File
[: Footer ~
Alignment Certer
Bold False
Color B tack
Fort Ayial
ltalic False
Shadow False
Size 13
Text Coplanarity = 952 micronsnFull Field Signed’
E General
Back Color [ ] White
Data File Format dat
Graph Size 261, 551
Image File Format ipg
Show Legend True
XY Decimal Places 1
E Header
Alignment Certer
Bold False
Color B tack
Fort Ayial
ltalic False
Shadow False 7
Footer
QK ] [ Cancel

Figure 5.3 Display Configuration Window

5.2 Graphical Output — 3D Contour Plot

To display the 3D Contour plot after analysis, check the box next to ColorContour
on the Graphs list in the options window. Most of the contour plot commands and
features are identical to those described in Section 5.1 (Figure 5.4).
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Print...
Create Legend. ..
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VerticalCenterline

HorizontalCenterline

EEX

microns
264

Figure 5.4 Contour Plot

5.3 Graphical Output — Diagonal Plot

The diagonal plot (Figure 5.5) represents two cross-sections of the surface along
diagonal lines connecting the corners. To display the 2D diagonal plot after analysis,
check the box next to Diagonals on the Graphs list in the options window. If it is not
checked, the 2D diagonal plot window can also be opened by right-clicking on the 3D
display window and selecting Plot->Diagonals. The caption of the 2D display window
can be renamed by right-clicking on its title bar and selecting Rename Window....

sample image

Displacement (microns)

400 T
300 +
200 +
100

sample image

Scale Y-Axis...

Save... Ctrl+s
Save Image... Ctrl+l
Normalized Fg
Print... Ctrl+P
Create Legend...

Configure...

EEX

-100
-200
-300
-400 +
-500

600 F

Position Along Diagonals (pixels)

—— DownwardDiagonal

T T t
100 150 200

—— UpwardDiagonal

250

Figure 5.5 Diagonal Plot
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5.3.1 Display Command List

Right-click inside the display window to show the command list.

Scale Y-Axis...
Save...

Save Image...
Normalized
Print...

Create Legend...

Configure...

Displays a window where the minimum and maximum values
of the Y axis may be modified. Defaults are the min and max
values of the data plus a software determined buffer.

Exports the data in numerical format (Section 5.5)

Allows display window to be saved in graphical format
(*_dia.bmp or *_dia.jpQ).

Causes all diagonal plots to be displayed with the endpoints for
each diagonal set to zero.

Allows display window to be printed to any available system
printer.

Allows the legend to be saved as a separate picture file for
reporting purposes.

The 2D display properties window is very similar to the 3D
version described in Section 5.1.5.

5.4 Graphical Output — Chord Plot
In addition to the diagonal plot, four special chord options are defined as follows

Vertical Edges (from top to bottom)
Horizontal Edges (from left to right)
Vertical Centerline (from top to bottom)
Horizontal Centerline (from left to right)

They can be accessed by right-clicking on the 3D display window and selecting
Plot. In more general cases, an arbitrary chord or chord set can be defined, where out-
of-plane displacement data along any line(s) can be displayed. The following sub
sections will describe how to draw a generic chord or chord set.

5.4.1 Creating a Chord

Right-click inside a phase image and select Advanced->Chord->New Chord
(Ctrl+K). Using the mouse, draw a line across the phase image, holding down the left
mouse button at the start point and releasing it at the end point.

Several preset chords can be added to the phase image using keyboard shortcuts.

Shift+T: Top Edge

Shift+B: Bottom Edge

Shift+L: Left Edge

Shift+R: Right Edge

Shift+D: Downward diagonal (upper left to lower right corner)
Shift+U: Upward diagonal (lower left to upper right corner)
Shift+H: Horizontal centerline
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e Shift+V: Vertical centerline

&

Note: Preset chords can be removed by hitting the
keyboard shortcut a second time.

|

5.4.2 Editing a Chord

To reposition the endpoints of a chord, click on the chord. Square white handles will
appear on either end of the chord, which can be moved with the cursor.
&

Note: Preset chords defined in Section 5.4.1 cannot
be selected or edited.

|

Right-click on a chord to show the chord command options list:
Reverse Direction Reverses the direction of the data along the chord when

plotted.

Align Aligns the chord horizontally or vertically.

Plot Plots the current chord in a new 2D display window.

Plot Set Plots all chords appearing on the phase image (only available
when more than one chord is shown on the image).

Delete Deletes the selected chord.

Delete All Deletes all chords appearing on the phase image (only

available when more than one chord is shown on the image).

Properties... Allows the endpoint positions to be set to specific pixel values
using text boxes. Also allows renaming of the chord.

5.4.3 Plotting a Chord

Right-click on the chord and choose Plot or Plot Set. Calculation is performed and
a display window appears. All display commands available for Diagonal plots are
applicable here, including exporting the chord displacement data in numerical form. See
Section 5.3.

5.4.4 Using a Chord Set

One or more chords form a set, which can be saved, re-used, and plotted
collectively. A set is started automatically when the first chord is drawn on the phase
image. Additional chords added using Advanced->Chord->New Chord become part of
this set.

A set can be saved by right-clicking on the phase image and choosing
Advanced>Chord>Save Set... and a saved set can be loaded by choosing
Advanced->Chord->Load Set.... A saved set has a filename ending in *.akx_chordset.
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Note: If a loaded chord set was generated from a
larger phase image than the current one, only the
chords with both ends falling within the current image in
that set will be loaded.

I

All the chords in a set can be plotted on the same graph by right-clicking on any of
the chords and selecting Plot Set.

A new set can be started by right-clicking on the phase image and choosing
Advanced->Chord->New Set (Ctrl+G). Up to 9 sets can be created for one image.

Multiple sets can be in memory at the same time. The sets are numbered 1 through
9, depending on the order in which they are created or loaded. A particular set can be
displayed by typing Shift + its number on the keyboard or choosing
Advanced->Chord->Set and selecting the desired set number.

5.4.5 Saving a Chord Image

After a chord or chord set is plotted, the graphical image can be saved by right-
clicking on the 2D image and choosing Save Image.... The image may be saved either
in BMP or JPG format with different suffixes as listed below:

Chord Type File Suffix | File Extention
Diagonal _dia .bmp or .jpg
Horizontal Centerline _hzc .bmp or .jpg
Horizontal Edges _hze .bmp or .jpg
Vertical Centerline _vitc .bmp or .jpg
Vertical Edges _vte .bmp or .jpg
Arbitrary _crd .bmp or .jpg

5.5 Numerical Output

Numerical data from all display windows can be exported by right-clicking on the
display window and selecting Save.... A standard Save window appears with three
choices for the save format in the Save as type pull-down list at the bottom.

Akx_disp Exports data in the Akrometrix akx_disp format
Dat files Exports data in tab-delimited text format
Text files Exports data in space-delimited text format

5.6 Gauge Output

Gauges can be selected in the Gauges list in the options window and are displayed
at the bottom of 3D Surface, Contour or Chord plots where appropriate. Gauge
definitions are available in Akrometrix Optical Techniques and Analyses 101.
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6 Batch Processing

6.1 Batch Processing

Batch processing allows most of the one-off functionality in Surface Analysis to be
performed on multiple data files with no user interaction. This functionality is very helpful
when performing large experiments with multiple ROIs and/or multiple temperature
points. There are four batch functions available:

Batch Analyze
Batch Mask
Batch Rotate
Batch Crop

To access the batch processing functions, select the Tools=>Batch Processing...
menu item. This will open a batch processing window (Figure 6.1). Four tabbed screens
appear for the four batch processing functions. Common menu items for the four
functions appear on a menu bar above these tabs.

Note: Multiple batch processing windows can be
opened to process different data or process the same
data with different settings.

Folder  Edit  Action

il

Analyze | Mask | Rotate | Crop
[ Include Subfolders

Analysis Options

Filename Coplanarity DownwardDiagonalMin DownwardDiagonalMax UpwardDiagonalMin UpwardDiagy

Smooth Phase

[ Mask

[ Physical Dimensions

[] Compensate (per phase)
[ Normaiize Chords

[] Smooth Displacement

Rotation | LSF v

Z Units | micron -

Gaugss

Coplanarity
DownwardDiagonalMin
Downward DizgonalMax
UpwardDiagonalMin
UpwardDiagonalMax
BottomEdgeMax Qutput Options

BottomEdgeMin 50
Bow et
CenterDeflection
FullFieldSignedWarpage
HorzontalCanterineMax

H (Certainelt Graphs & Data
lorizontalCenteriineMin
LeftEdgeMax gD
LeHEaen [] ColorContour
il Diaganals

[] HorizontalCarterine
[] HorizertalEdges
[] VerticalCerterine
[] VerticalEdges

E] < >

Extrema

Disgonials
Output Files Header

(® Dynamic (Filename)
O Constant

Configuration File

(] [0 tegena

Common Z-Scale
[] Enabled

Save Action

ImageAndDats  |v
Graph Size

Width Image File Format

g ™

Height
Footer

[ Coplanariy

Maximum
Min

Right EdgeMax Data File Format

Right EdgeMin Minimum dat v

ROC
SignedWarpags

Gauge Layout

(&) Horizortal () Vertical
TopEdgeMax
TopEdgeMin

Twist
VerticalCenterineMax
VerticalCanterinsMin

Image Filename Suffix: _30

OO0O0O00000000000000000REEEIE

Source:Mone | | Files:0)

Figure 6.1 Batch Processing Screen
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Folder - Select... Identifies the folder of *.akx_phase files on which the
batch processing functions will be applied

Edit 2 Refresh Source Allows the user to update the file count since the folder
Folder (F5) was originally selected.

Edit = Save Settings  Saves settings of all four batch functions to the User
Configuration.xml file.

Edit = Load Settings  Loads settings from the User Configuration.xml file.

Edit > Set From Loads settings defined in the Options window.
Preferences
Action Initiates the batch processing function, depending on

which tabbed screen is showing.

6.2 Batch Analysis

The batch analysis function opens the image files in the selected folder, analyzes
the data, and saves the results in graphical and/or numerical format. This is useful, for
example, for analyzing all the warpage measurements taken during a temperature
profile and plotting the results on the same scale. The batch analysis tab window shows
the conditions to be applied during analysis and display, while the action is initiated
using the Action menu item.

6.2.1 Using Batch Analysis
The key steps in using batch analysis are:

1. Select a folder to be analyzed (Folder->Select... menu item)
2. Select analysis options (Section 6.2.3)

3. Analyze the measurement data (Action-=>Analyze menu item)
4. Select output options (Section 6.2.4)

5. Create and save results (Action=>Generate Output menu item)

After Step 3, a table of summary results appears, with one row for each
measurement image analyzed. The extreme values of each parameter in the table are
shown below, which will provide the default scale for plotting results in the final step.
The user can open any of the phase images listed in the table by right-clicking on a row
and clicking Open.

6.2.2 Using Batch Analysis to Create Relative Plots

In order to set one of the images in the selected folder as reference image (Section
4.4), double-click on one file in the summary table and confirm that all analysis should
use its 3D data as reference. The program will then save all graphs and numeric data
as relative to this reference surface. All other steps remain the same.
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6.2.3 Analysis Options

Include Subfolders
Smooth Phase

Mask

Physical
Dimensions

Compensate

Normalize Chords

Smooth
Displacement

Rotation

Z Units

Gauges

6.2.4 Output Options

Graphs & Data

Applies the batch processing function to subfolders within
the selected folder in addition to the original folder.

Applies a smoothing function once to phase images before
analysis (see Section 3.5)

Applies a previously-created mask to phase images before
analysis (see Section 3.2). A Load Mask window appears
when the box is checked.

Assigns a specific physical size to each data (see Section
2.3.4).

Enables a compensation for the non-planar surface of the
grating.

Causes all chord plots to be displayed with the endpoints set
to zero after analysis (see Section 5.3.1).

Applies a smoothing function to the displacement calculated
from phase. See

Selects the reference plane rotation option to be used during
analysis (see Section 4.3).

Selects English or metric units for out-of-plane displacement
results.

Selects which gauges (numerical values quantifying
flatness) are displayed at the bottom of the graphical display
windows. A gauge on the list may be highlighted by clicking
on it once. Checking a box means that gauge will be
displayed. The up and down arrows move the highlighted
gauge up and down the list, changing the order in which
gauges are displayed.

Selects which graph formats (see Sections 5.1 through 5.4)
are saved after analysis. A graph on the list may be
highlighted by clicking on it once. Checking a box means that
graph will be saved. The up and down arrows move the
highlighted graph up and down the list, changing the order in
which graphs are displayed.
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Configuration File

Graph Size
Gauge Layout

Legend

Common Z-Scale

Output Files

Header

Footer

Allows the user to load a non-default display format for saved
graphs. The 3D configuration file has an extension of
*.akx_3Dconfig and is used for 3D plots (3D and Contour).
See Section 5.1. The 2D configuration file has an extension
of *.akx_2Dconfig file and is used for 2D Chord plots. See
Section 5.3.

Sets the initial size for all display windows to be saved.

Gauge values listed at the bottom of the 3D or 2D display
window may be aligned horizontally or vertically.

Selects if a legend is displayed on each graph.

When checked, causes all 3D or 2D plots generated by batch
analysis to use the same vertical scale. Default min and max
values are determined by the extremes in the combined data
sets, but may be edited using the text box. When unchecked,
each image is plotted on a scale set by its own data set.

Data can be saved in either graphical or numeric format or
both. The user can select the image file format and data file
format to be saved as well.

Allows the graph to use a dynamic header created from the
file name or a constant header typed by the user.

Allows user to choose the footer from the available items in
the list.

6.3 Batch Masking

The Batch Mask feature allows the user to automate mask-burning for multiple
image files contained in a specified folder (Figure 6.2).

.
.
7

——

7
/2
/2

Figure 6.2 Batch Burn

6.3.1 Using Batch Masking

This function uses a mask file, as described in Section 3.2. The mask file must be
created and saved prior to the batch masking operation. The batch masking screen is

shown in Figure 6.3.

Page 36 of 46

30-50SW-0001 Rev. D



Y akrometrix

Surface Analysis User Manual

Batch Processing |

Folder  Edit  Action

Analyze | Mask | Rotate || Crop

[ Include Subfolders
Mask To Apply
C:\Mask1.bmp
Destination Options

(O Overwrite Files
() Create New Files

Maming Options

Destination
Same As Source E]

[] Tagfiles as * {Masked).akoc_phase

[ Save In "Masked" sub-Folder

Figure 6.3 Batch Masking Screen
The key steps in using batch masking are:

1. Select a folder containing images to be masked (Folder->Select... menu item)

2. Select a mask (see Section 3.2 to create and save masks) to be applied on the
phase images

3. Select destination options (Section 6.3.3)
4. Create and save results (Action>Mask menu item)

6.3.2 Source Directory

Include Subfolders Applies the batch processing function to subfolders within
the selected folder in addition to the original folder.

Mask to Apply Click on | button on the right to browse for a mask file.

6.3.3 Destination and New Naming Options

Overwrite Files Causes masked files to overwrite original data files.

Create New Files Saves masked images to a new destination and/or with a
new name. The original data files are unchanged.

Destination Selects the folder to which the masked images will be

saved. Click on the - button to the right to browse for
the destination folder.
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Tag files as Appends the string “(Masked)” to the end of the original

*(Masked).akx_phase filename for the masked file.

Save In “Masked” A single new folder named “Masked” will be created in the

sub-Folder destination folder and all masked files will be saved in this
subfolder.

6.4 Batch Rotation

6.4.1 Using Batch Rotation

Phase image rotation is described in Section 3.6. This batch function rotates all the
images in the selected folder according to the options set in the batch rotation tab
window. The batch rotation screen is shown in Figure 6.4.

Batch Processing

Folder  Edit  Acti

[ Include Subfolders

Angle () Clockwise
1 v (O Counter-Clockwise
Destination Options

(O Overwrite Files
(%) Create New Files

Maming Options

Destination
Same As Source E]

[] Tagfiles as * (Rotated) akoc_phase

[] Save In "Ratated" sub-Folder

Figure 6.4 Batch Rotation Screen

The key steps in using batch rotation are:
1. Select a folder containing images to be rotated (Folder->Select... menu item)
2. Select rotation options (see Section 6.4.2)
3. Select destination options (see Section 6.4.3)
4. Create and save results (Action>Rotate menu item)
6.4.2 Rotation Options

Include Subfolders  Applies the batch processing function to subfolders within
the selected folder in addition to the original folder.
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Angle Enter number of degrees to rotate the image clockwise or
counterclockwise.

6.4.3 Destination and New Naming Options

Overwrite Files Causes rotated images to overwrite original data files.

Create New Files Saves rotated images to a new destination and/or with a
new name. The original data files are unchanged.

Destination Selects the folder to which the rotated images will be

saved. Click on the J button to the right to browse for
the destination folder.

Tag files as Appends the string “(Rotated)” to the end of the original

*(Rotated).akx_phase filename for the rotated file.

Save In “Rotated” A single new folder named “Rotated” will be created in the

sub-Folder destination folder and all rotated files will be saved in this
subfolder.

6.5 Batch Cropping

Batch cropping allows the user to extract multiple regions of interest from multiple
phase images. For example, a measurement test which produces measurement data at
three temperature points, with each phase image containing four regions of interest (3 x
4 = 12 measurements), can be easily analyzed in a two step procedure: batch cropping,
followed by batch analysis (Figure 6.5).

\ﬂﬂ "ln.?\-.. \ﬂﬂ

L_-\.l N-_--..l N—as.l

Batch * Crop
R I, O
€ N N N € N

Batch ¢ Process

Figure 6.5 Batch Cropping and Analysis
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6.5.1 Using Batch Cropping

Batch cropping requires that the user has created a partition file as described in
Section 3.4. This must be created and saved prior to the batch cropping operation. The
partition may contain only one domain, in which it becomes equivalent to the crop
function (Section 3.3). Each domain from all the phase images in the selected folder
are permanently saved as new, independent files, organized according to the
Destination Options on the batch crop tab. The resulting image files can then be batch
processed in a second step to complete the analysis. The batch cropping screen is
shown in Figure 6.6.

Batch Processing

Folder  Edit  Action

Analyze | Mask | Rotate |;

[ Include Subfolders

Partition To Apply

{Partition Description)
Destination Options
(O Overwrite Files
(=) Create New Files

Mew File Options

Destination
Same As Source E]

[] Save In Phase Image sub-Folder(s) O Prepend ROI To Source Filename

[] Save In ROl sub-Folderis) (®) Append ROI Name To Source Flename

[] Save In "Cropped" sub-Folder
O Use ROl Name

Figure 6.6 Batch Cropping Screen
The key steps in using batch cropping are:

1. Select a folder containing images to be cropped (Folder->Select... menu item)
2. Select a partition (see Section 3.4 to create and save partitions) to be applied
3. Select destination options (Section 6.5.3)
4. Create and save results (Action>Crop menu item)

6.5.2 Source Directory

Include Subfolders  Applies the batch processing function to subfolders within
the selected folder in addition to the original folder.

Partition to Apply Click on the _--| button to browse for a partition file.
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6.5.3 Destination and New File Options

Overwrite Files

Create New Files
Destination

Save In Phase
Image sub-Folder(s)

Save In ROI sub-
Folder(s)

Save In “Cropped”
sub-Folder

Prepend ROI To
Source Filename

Append ROl Name
to Source Filename

Use Source
Filename

Use ROl Name

Causes cropped files to overwrite original data files. This
should only be used if the partition contains only one
domain.

Saves cropped images to a new destination and/or with a
new name. The original data files are unchanged.

Selects the folder to which the cropped images will be

saved. Click on the J button to the right to browse for a
destination folder.

A new folder will be created for each *.akx_phase file in the
source folder and all cropped images derived from this
*.akx_phase file will be collected in this subfolder.

A new folder will be created for each ROI in the partition
and all cropped images derived from this ROI for all image
files will be collected in this subfolder.

A single new folder named “Cropped” will be created in the
destination folder and all cropped files will be collected in
this subfolder.

Cropped images will be uniquely named with a combination
of ROl name and original data file name, the ROI name
coming first.

Cropped images will be uniquely named with a combination
of ROI name and original data file name, the data file name
coming first.

Cropped images will be named with the original image
name. This option is disabled if the destination folder is the
same as the source folder. In addition, this should only be
used if the partition contains only one domain.

Cropped images will be named with the ROl name from the
partition file. This can create a problem if there are multiple
phase images in the source folder.
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6.6 Batch Edit XY Orientation

For purposes of orienting and registering surface data in Interface Analysis, a new
tab has been added to the Batch Processing window. This tab allows multiple phase
images to be tagged with Pin 1 location and Measured Side information.

a5 Batch Processing

Folder Edit  Action

| Analyze | Mask | Rtate | Crop |} Edit XY Orientation |

[ Include Subfolders

Fin 1 Location Measured Side
| Unspecfied v | Unspecified

Figure 6.7 Edit XY Orientation Screen
The key steps in using batch cropping are:
1. Select a folder containing images to be edited (Folder->Select... menu item)
2. Select a Pin 1 Location and Measured Side to be applied.

3. Perform the Batch Edit operation (Action>Edit XY Orientation menu item)
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7 Troubleshooting

As with any measurement system software, the Surface Analysis program has its
limitations. These limitations exist mainly because the analysis software is sensitive to
patterns it was not designed to interpret, which is typical of any software using pattern
recognition.

7.1 Failure to Correctly Interpret the Phase Image

After acquiring a phase image, a procedure called “unwrapping” is applied to the
phase data (See Akrometrix Optical Techniques and Analyses 101). The
unwrapping process removes the 2 discontinuity by examining the nearest neighbors’
pixel phase values starting at the center pixel. With the sequential dependent nature of
the unwrapping process, the height at all the pixels in an entire image can be related to
one origin pixel. Conversion from the unwrapped phase image to vertical displacement
is simply multiplication of each pixel phase value by the calibration factor.

Problems arise when an error occurs at one point in the unwrapping process, either
by incorrectly identifying a phase discontinuity or missing a discontinuity that has
occurred. Once a problem occurs, all pixels downstream of the error point are offset
from their correct value by the same increment of one full fringe cycle.

7.1.1 Symptoms

Unwrapping errors are propagated downstream of the error point. These errors
appear in the 3D surface plots as ridges, troughs, or plateaus in the displacement
surface. Two examples of such cases are shown in Figure 7.1, where the error
originates from a step condition on the sample surface.

7.1.2 Cause

Unwrapping errors can occur at steps (i.e. vertical discontinuities in the sample
surface). A step may be defined as a region where fringes are so closely spaced that
they cannot be resolved by the video camera due to a rapid height change on the
sample surface. Typically, fringes less than 5 pixels in width cannot be resolved. The
Surface Analysis program is unable to determine the height at a step larger than
approximately half a fringe height since the relative order of the fringes on the two
surfaces cannot be determined. Unwrapping errors can also occur in regions where
there is poor fringe information or at the transition from such regions to regions of good
phase information; including holes, shadows, pieces of tape, etc.

7.1.3 Solutions

1. The simplest solution is to exclude error-causing features from the ROI. Adjust
the position and size of the ROI to exclude these features.

2. Use the filtering option to help eliminate some unwrapping errors. Filtering
smoothes the phase image before unwrapping. Because filtering can smear out
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fine detail in the displacement surface, it should be applied to the analysis only to
the extent necessary to eliminate extended phase unwrapping defects.

3. Apply a mask to the data analysis and eliminate unwrapping errors by excluding
problematic areas from being analyzed. Follow the directions given in Section
3.2.

Figure 7.1 Surface Plots with Unwrapping Errors
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Appendix A Miscellaneous Information

A.1 File Formats

Akrometrix Surface Analysis loads and saves data with the *.akx_* extension. For a
more detailed breakdown of Surface Analysis specific formats please see the table
below. Image export formats include .bmp and .jpg with varying filename postfixes to
further denote their origins.

Extension Contents

*.akx_phase A single phase image with associated metadata. May optionally
contain cropped versions of supporting data: intensity, and/or
reference displacement

*.akx_disp A single displacement data matrix with associated metadata. May
optionally contain cropped versions of supporting data: phase,
intensity, and/or reference displacement

*.akx_partition  Partition file (standard XML format)

*.akx_3Dconfig ' Configuration file for 3D plot

*.akx_2Dconfig = Configuration file for 2D plot

*.akx_chordset | Chord set (standard XML format)

A.2 Keyboard Shortcuts

Shortcut Command Action

Main Window Shortcuts

Ctrl+O File=>Open Open a new *.akx_phase file
Alt+F+X  File=>Exit Exit the Surface Analysis program
F1 Help>User Manual | Open the User Manual

Phase Window Shortcuts
Ctrl+C Copy (Mask or Partition Region) | Copy Mask or Partition Region

Ctrl+V Paste (Mask or Partition Region)  Paste Mask or Partition Region
1-4 Advanced->View=>Intensity 1-4 Show Intensity Images 1-4

P Advanced->View->Phase Image  Show Phase Image

S Advanced->View->Surface Image ' Show Surface Image
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Ctrl+ Zoom in to phase image
Ctrl- Zoom out of phase image
Ctrl+M Advanced->Mask->New Create a new mask
Ctrl+R Advanced->Partition>New Create a new partition
Ctrl+K Advanced->Chord->New Chord Create a new chord
Ctri+G Advanced->Chord->New Set Create a new chord set
Shift+1-9  Advanced->Chord->1-9 Show Chord Sets 1-9
Shift+T Create a chord along top edge of the image
Shift+B Create a chord along bottom edge of the image
Shift+L Create a chord along left edge of the image
Shift+R Create a chord along right edge of the image
Shift+D Create a chord along the downward diagonal line
(upper left to lower right corner) of the image
Shift+U Create a chord along the upward diagonal line (lower
left to upper right corner) of the image
Shift+H Qreate a chord along the horizontal centerline of the
image
Shift+V _Create a chord along the vertical centerline of the
image
3D Window Shortcuts
Ctrl+C Copy View Copies the current display window viewing

angle and magnification to the Clipboard.

Ctrl+Vv Paste View Applies the viewing angle and magnification
saved to the Clipboard to the current display
window (only appears after Copy View is used).

Batch Processing Window Shortcuts

F5 Edit>Refresh Allows the user to update the list of source files
Source Folder since the folder was originally selected
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