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1 Introduction

1.1 Overview

Surface Analysis is a program designed to analyze and display the results of
shadow moiré and fringe projection measurements produced by Akrometrix warpage
measurement systems. The program typically resides on the measurement system
computer. If additional site licenses are purchased, Surface Analysis may also be
installed as a stand-alone application on other computers, offloading analysis tasks from
the measurement system. This manual is intended for use with Akrometrix Studio 8.0.

The analysis of interferometric data from shadow moiré and fringe projection systems
is a rich and complex subject. The main text of this manual emphasizes the operation of
the Surface Analysis program. The principles of interferometric techniques and analysis
will be discussed in Akrometrix Optical Techniques and Analyses 101 (AOTA101).
This paper should be read first by users unfamiliar with these techniques.

The output of the data acquisition program and thus the input of the Surface Analysis
program is an Akrometrix-defined file with the extension of either *.akx_phase or
*.akx_disp (displacement images). These files can contain measurement and reference
data as well as some measurement parameters and conditions. Surface Analysis
converts data from the *.akx_phase and *.akx_disp file into height data, and if required,
Akrometrix gauges.

The main analysis functions on shadow moiré acquired data in Surface Analysis are
based on the phase image in the *.akx_phase file. A phase image is a two-dimensional
grayscale image (computed from several intensity source images) containing a value at
each point related to the surface height at that point. Many of the options available in the
Surface Analysis program originate from two challenges in phase image analysis.

e First, the phase data must be analyzed as a whole and errors due to poor
guality data in one region of the surface can affect the results in other regions.
The Smoothing, Partitioning and Masking functions allow bad data to be
smoothed or excluded from analysis.

e Second, the surface contour does not have an absolute frame of reference.
The Rotation, Grating Compensation, and Reference/Relative functions allow
the user to define the reference plane in a way most useful for understanding
the experimental results.

A second group of options control the display and output of experimental results.
Surface Analysis provides a suite of display formats, which can each be further
customized to the user’s preference. In addition, the displacement data can be exported
in tabular form for plotting or further analysis by other software packages.

Finally, Batch Processing allows repetitive functions to be automated:

e Batch Analysis allows the user to quickly analyze a set of related
measurement data (e.g. the same sample at different temperatures)
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e Batch Masking allows the user to quickly mask more than one phase or
displacement image.

e Batch Rotation allows the user to quickly rotate more than one phase or
displacement image.

e Batch Cropping allows the user to quickly crop multiple regions of interest
from more than one phase or displacement image.

e Batch Edit X/Y Orientation allows the user to assign Pinl location and
Measured Side Metadata to a phase or displacement image.

1.2 Warnings and Notes
1.2.1 Warnings and Notes in this Manual
Warnings and Notes are marked throughout the manual with these icons:

O

Figure 1.1 Warning Icon Figure 1.2 Note Icon

&

1]

Warnings are specific health hazards for the operator or potential sources of system
damage. Notes highlight system limitations or automatic responses that may require
corrective action by the operator for successful operation.

1.3 Technical Support

Akrometrix 404-486-0880 support@akrometrix.com
2700 NE Expressway 404-486-0890 (fax) http://www.akrometrix.com
Building B, Suite 500

Atlanta, GA 30345

When contacting Akrometrix, please provide the system serial number, the version
numbers of the Akrometrix software being used, a description of the problem or question,
and contact information for reply. If the question concerns a particular measurement or
analysis, please provide electronic copies of the *.akx_phase files, final results, and a
description of data acquisition and/or analysis conditions. If the problem concerns
changes or failure in general system operation, please describe any events or system
modifications that occurred immediately before the problem arose.
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2 Loading Measurement Data

2.1 Starting the Program
The Surface Analysis program can be started in four different ways:

A. Right click on the phase or displacement image in Surface Measurement and
choose Open in Surface Analysis....

B. Double-click on a valid *.akx_phase or *.akx_disp file

C. Launch the Surface Analysis executable file directly from its shortcut (e.g. via
the Start menu)

D. Click the Surface Analysis button listed on the Akrometrix Studio Manager
bar on the left side of the screen.

Note: Only one instance (copy) of the software can run
4 at a time; subsequent calls to the program will activate
the open instance.

|

2.2 Loading Measurement Data

Once the Surface Analysis program starts, a GUI (Graphical User Interface) frame
will appear. The contents of the display frame depend on how the application was
launched:

A. If called from the measurement software via clicking on a phase image, the
current phase or displacement window from the data acquisition program is
shown.

B. If an *.akx_phase or *akx disp file was double-clicked, the phase or
displacement image contained in the selected file is shown.

C. If the EXE is launched from a shortcut or Studio Manager, no image is shown
and the user needs to select a file to open.

New measurement data files can be loaded into memory with the File=>Open menu
item. A standard Open dialog box appears prompting the user to select a valid
*.akx_phase or *akx_disp file. Multiple files can be opened at one time by highlighting
multiple selections using the Shift or Control keys. Phase images and displacement
images can also be dragged and dropped into the Surface Analysis program in order to
open them.

L

Note: Surface Analysis can be configured to analyze
the image and display results immediately upon
opening the *.akx_phase file, using the
Tools>Options... menu item. See Section 4.2

i

2.3 Working with the Phase Image

An *.akx_phase file may contain a variety of information such as measurement data
(phase images, intensity images, etc.), reference data, as well as measurement
parameters and conditions. When the *.akx_phase file is loaded, all the information in the
file is loaded in memory. For display purposes, only the phase image will be shown in the
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GUI of the Surface Analysis program. Modification (Section 3) and Analysis (Section
4) on the measurement data will be mainly applied to the phase image and any associated
reference data that exist.

2.3.1 Resizing a Phase Image

The phase image window may be resized in the normal fashion by dragging along
any edge or corner. The image in the window can be zoomed by using Ctrl+ or Ctrl-
(Figure 2.1 and Figure 2.2). Each action doubles or halves the size of the phase image.

i a0,
250 x 200 pixels ~ | 100 % | 250 x 200 pixels ~ 200% |

Figure 2.1 Phase Image 100% Magnification Figure 2.2 Phase Image 200% Magnification
2.3.2 Data Information

When a phase image is displayed in Surface Analysis, some data information can
be present as well. First of all, the full path of the *.akx_phase file can be shown by
hovering the cursor over the title bar of the phase image. Second, the image size and
magnification ratio information are shown on the status bar located at the bottom of the
image (Figure 2.3).

akx_phase QV‘
[~ .
|

@l Sample Image.

N .

. =Ly
250 x 200 pixels v | 100 %

Figure 2.3 Data Information Shown on the Phase Image
2.3.3 Measurement Information

In addition to the data information described in Section 2.3.2, the measurement
metadata can be displayed by right-clicking on the image and choosing Properties...
(Figure 2.4). For a displacement image, the menu structure is Info->Properties.... In the
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Properties window, information about the intensity images, phase image, and grating can
be found, along with many other test parameters.

Analyze
Amplitude Threshold...
Smooth

Rotation r o

Advanced 3

Sample Image aloc_phase Properties

Grating | Intensty 0 | Intensity 1 | intensty 2 | Intensiy 3| Phase |

Properties... F

Figure 2.4 Displaying Measurement Metadata

2.3.4 Assigning Physical Size

Surface Analysis (and the TherMoiré measurement system in general) has no
internal means of knowing the physical ROl (Region of Interest) size, but physical
dimensions can be assigned by the user. Click the “Image Size” area on the status bar at
the bottom left of the phase image. Select Assign Size... from the pull-up menu (Figure
2.5). In the Physical Size window, assign the unit as inches or millimeters, then enter the
Width and Height of the image and click OK.

After physical dimensions have been assigned, the user can choose whether X and
Y axes are displayed in pixels, inches or millimeters using the same pull-up menu on the
status bar. The selected unit will appear on the X and Y axes of all graphs created after

analysis.

Sample Image.akx_phase 4_

| 250 x 200 pixels +] 100 % |

i AN
50.0x40.0mm ~| 100 %

Width

Units

milimeter v

Height

|

oKk | Cancel |

[400 =

Figure 2.5 Assigning Physical Size for a Phase Image

Note:

Physical
Compensation (Section 4.5) and calculation of Bow
and Twist (See Akrometrix

Techniques and Analyses 101).

dimensions are

gauges

required

a_

for

Optical
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2.3.5 Showing Surface or Intensity Images

Phase images have fringes across the whole field, hiding features on the sample
surface. If the user wishes to make masks, partitions, or chords on the surface or intensity
images, they can be shown by right-clicking on the phase image and selecting
Advanced->View->Surface Image (or, alternatively, any one of the 4 intensity images).
The image can also be quickly changed without the context menu by using the keyboard
shortcuts P, S, and the numbers 1-4. The currently viewed image can be saved to disk in
the .omp format by selecting File->Save Image... or Ctrl+l.

[© Sample Image.akx_phase !EH

-

250 x 200 pixels ~ | 100 % | 250 x 200 pixels + | 100 %

Figure 2.6 Phase and Surface Image Views

Lo |

Analyze

Amplitude Threshold...

Smooth

Rotation 3

Advanced 4 | Mask 4

Properties.., | Wiew » | Phase P
Partition » Surface 5
Chord » Intensity 1 1
Rotate L Intensity 2 2
Duplicate Intensity 3 3
Compensation Intensity 4 4
Shift...
Undo

Figure 2.7 Menu Command for Showing Surface or Intensity Images
2.4 Working with Displacement Data

When an *.akx_disp image is loaded in Surface Analysis, a different window type is
created as shown in Figure 2.8.
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Lo -o-) )

- Sample.ake_disp

| Suface |{ Displacemert || 3D Graph | Gauges | History |

File Save...

Display Save Image...
Duplicate

Analysis

»
»
Transform >
4
4

Close
Info

Undo

215 x 221 pixels | 100 % | Coplanarity = 595 microns

Figure 2.8 Loaded Displacement Window

This window shows the displacement data, average surface image, 3D graph, gauge
results, as well as a history of operations performed on one tabbed interface. The
interaction with this window happens via context menu, just as with the phase image
window. There is now a File entry for saving the data in either its original format or as an
image. The data can also be duplicated or closed from this menu item.

Other functions present in the phase image window are rearranged in this window to
accommodate new functionality. The organization is described in the following sections.

2.4.1 File

Save...

Save Image...

Duplicate
Close

2.4.2 Display

Zoom
Z-AXis
XY Size

2.4.3 Transform

Mask

Saves the data in *.akx_disp format

Allows display window to be saved in graphical format
(*_3D.png or *_3D.jpg).

Makes a copy of the current displacement window in
memory.

Closes the displacement window. Prompts to save if any
changes are detected.

Allows a reset of the image zoom that has been changed
by the mouse wheel.

Allows the Z-Axis units to be changed between microns
and mils as well as to change the Z-Axis scale.

Allows the X and Y data dimensions to be mapped to
physical dimensions in either mm or inches.

Allows the data to be masked. All functions are the same
as described for phase images in Section 3.2.
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Smooth

Plane Rotation

Fit Data...

Subtract

Rotate
Shift...

2.4.4 Analysis

Step Height

Partition

Chord

Allows the user to apply either a default smoothing
function to the 3D data or a custom one. The default
smooth can be repeated multiple times. See AOTA101
for more information.

Allows the user to change the data rotation as in Section
4.3.

Opens a dialog where a polynomial fit can be calculated
based on the data set. See Figure 5.2. Alternatively, if
physical dimensions are assigned to the phase image, a
spherical fit can be calculated.

Displays the relative displacement data calculated by
subtracting a selected 3D data from the current 3D data
in a new window.

Allows the data to be rotated about its Z-axis as in
Section 3.7.

Allows the data to be shifted in its plane as in Section
3.8.

Allows the user to define two ROIs and calculate the
height difference between them. See Section 2.4.5.

Shows the same commands under the
Advanced->Partition menu for phase images. See
Section 3.4.

Shows the same commands under the
Advanced->Chord menu for phase images. See
Section 5.4.

2.4.5 Step Height Calculation

Clicking on Step Height>Add Step (Figure 2.9) will add a pair of boxes to the
displacement view that can be moved around and resized. The step height difference is
calculated as the difference in average heights between the two regions (1A-1B). The
step height sign will vary depending on whether the A region is higher or lower than B
and the result is shown at the bottom of the displacement window (See Figure 2.10 and
Figure 2.11). Multiple step height pairs can be added. They can also be saved for loading
onto other displacement windows or used as a gauge in batch processing.

Page 12 of 72
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- Sample.ako_disp EI@
Surface | Displacement | 3D Graph | Gauges | History

File 3
Display 3
Transform 3
Analysis » Generate Results
Info v Step Height v Add Step
Undo Partition » -
Visible
; P— Ehoid ' Locked
215 % 221 pixels | 100 % | Coplanarity = 23.4 mils ‘ Set All to A-B
Set All to 5-P
Copy All
Paste
Add...
Load...
Save.
Delete All

Figure 2.9 Step Height Menu

a) Step.akx_disp [o @ == a Step.akx_disp [=n Eol ==

| Suface | Displacemert |3D Graph | Gauges [ Hitoy|

| Suface | Displacement |30 Graph | Gauges | Hisory

|
[
(¥
345 x 361 pixels | 100 % | Step 1 Height = 76 microns J 345 x 361 pixels | 100 % | Step 1 Height = -76 microns

Figure 2.10 Step Height Calculation A>B Figure 2.11 Step Height Calculation A<B

The step height pair mode can also be changed by right clicking on either of the boxes
and going to Switch to S-P. S-P mode uses the 1P box for its LSF reference plane and
is most useful when analyzing a calibration block with flat planes and known step heights
between them. A-B mode uses the reference plane that is already applied to the surface.
See Figure 2.12 and Figure 2.13 for an example.
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' =% '

Swap Aand B
Switch to S-P

R ) Delete Del

Copy  Ctrl+C
Square Bounds

Edit...

345 x 361 pixels ‘ 100 % l Step 1 Height = 59 microns

345 x 361 pixel

a2 Step.ak_disp ‘ o) Step.akoc_disp

Surface | Displacement | 3D Graph | Gauges | History

-

Is ‘ 100 % ‘ Step 1 Height = 77 microns

Figure 2.12 A-B Mode

Figure 2.13 S-P Mode
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Modifying Measurement Data

Note: Context menu paths described in this section
and references to phase images will be different for
*.akx_disp files. Behavior of the functions such as
masks/partitions/etc.  remains the same for
displacement images. Reference Section 2.4,
Working with Displacement Data for correct context
menu paths.

3.1 Setting the ROI

The Mask and Partition functions in Surface Analysis create one or more graphically
defined ROIs (Regions of Interest) on the phase image where these functions can be
applied. ROIs can be different shapes such as rectangle, ellipse, triangle, etc. The default
shape of an ROI is a rectangle. Choose a new shape by opening the Shape Selector
window from the View->Shape Selector menu item. Choose the shape before selecting
the Mask or Partition function (Figure 3.1).

m

After activating the desired function (Mask or Partition), click and drag the mouse
cursor from one corner of the desired ROI to the other. When an ROI region is selected,
it can be repositioned by dragging anywhere within its region and resized by dragging on
any of the eight “Handles” on the periphery. The shape, location, and size of the ROI can
also be changed by using the ROI Properties Window (Figure 3.2). To access this
window, right-click inside the ROI and choose Properties.... This window is useful for
drawing a pre-defined ROI. Size can be defined in either absolute (pixel) terms or
fractional terms (relative to the phase image dimensions).

e ==

Shape

Rectangle -

Edit Crop Region

]

Y akrometrix

Shape Selector

[SI[e]{eIVN

Location

x Posttion
54

y Position

N

Mode
@ Absolute

Size

77
i

Fractional

Width

Height

Figure 3.1 ROI Shape Selector -
Cancel

Figure 3.2 Edit ROl Region Size and Position

Other common functions for Masking and Partitioning can be called by right-clicking

inside an ROI:

Copy (Ctrl+C) creates a copy of the active ROI on the Windows Clipboard. It may be
pasted (Ctrl+V) inside the original phase image or in a different phase image.

Square Bounds equalizes the horizontal and vertical dimensions of the ROI as the

shorter value of the two
Delete deletes the active ROI

30-50SW-0001 Ver. 8.0
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Delete All deletes all ROIs within the current phase image window

L

Note: The ROI functions for Mask and Partition modes
are slightly different. See the following sections.

l

3.2 Masking a Phase Image

Masking excludes regions inside the phase image from the analysis. Regions that
lack good phase data (e.g. holes, steps) can create errors in the analysis that extend
beyond the bad phase region. When using a mask, there is no displacement information
generated within the masked-out regions, and the remainder of the phase image can be
analyzed without interference.

Analyze
Amplitude Threshold...

Smooth
Rotation 3

Advanced 4 Mask Add Region  Ctrl+M

Properties... i
p LT Enabled

Partition
Chord
Rotate

Locked

Burn All

* v v v |

Duplicate Copy All
Compensation Paste

Shift...

Add...

Undo Load...

Save..

Delete Map

Delete Regions

Delete All

Figure 3.3 Mask Menu
3.2.1 Creating a Mask

A mask file can be either a binary graphical image (*.png) containing only black and
white colors or a *.akx_mask file representing the location, shape, and size of the regions
added during a mask operation. In the case of an image mask, the white color represents
valid data while the black color represents points or areas that need to be masked out. In
most cases, the mask shapes shown in Figure 3.1 are sufficient. However, if the user
needs to define an irregularly shaped mask, they can also be generated from an external
graphical tool such as MS Paint®. The file format needs to be *.bmp or *.png in order to
be loaded in Surface Analysis.

A mask can be created and saved in Surface Analysis by the following steps:

1. To create a new mask, right-click in the selected phase image and choose
Advanced->Mask->Add Region (or use the keyboard shortcut, Ctrl+M).

2. To create the first ROl in the new mask, hold down the left mouse button; draw a
rectangle on the phase image and then release. The ROI will appear as a
transparent red shape. All the ROl commands described in Section 3.1 apply to
the mask ROI.
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3. Additional mask ROIs can be added by repeating steps 1 and 2. Mask ROIs may
overlap.

4. When the mask is complete, it may be saved to a file (*.akx_mask or *.png) by
right-clicking inside the phase image (but not inside an editable mask ROI) and
choosing Advanced->Mask->Save....

5. The mask can be turned on and off without deleting the mask from memory by
right-clicking inside the phase image (but not inside an editable mask ROI) and
choosing Advanced->Mask—->Enabled. Alternating this command will turn the
current mask(s) on and off. This is useful when evaluating masks between phase
image and 3D surface plot during analysis. When the masking function is disabled,
all mask ROIs are hidden.

6. The mask can be locked by going to Advanced->Mask->Locked. This setting will
prevent the user from interacting with any editable (red transparent) mask regions.

3.2.2 Loading and Editing a Mask

A previously created mask that was saved in the *.akx_mask, or *.png, formats can
be recalled and applied to any phase image. To load the mask file, right-click inside the
phase image, choose Advanced->Mask->Load..., and select the desired mask file.
More than one mask file can be loaded on the same phase image. An image mask is
shown in solid yellow color while a *.akx_mask file is shown as editable transparent red
regions.

o

ol
Figure 3.4 Loaded Image Mask in Yellow

A loaded image mask cannot be edited but can be turned on and off by toggling the
Advanced>Mask->Enable function. To delete a loaded image mask, choose
Advanced>Mask->Delete Map. To delete a loaded *.akx_mask mask, choose
Advanced>Mask->Delete Regions. New mask ROIs may be added by right-clicking
inside the phase image and choosing Advanced->Mask->Add Region.

The modified mask, including both old and new components, can be saved by right-
clicking inside the phase image (but not inside an editable mask ROI) and choosing
Advanced->Mask->Save....
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Note: If a *.akx_mask is loaded onto a phase image
with different pixel dimensions than the one on which it
was created, a dialog will appear, as shown and
discussed below.

Load Mask Absolute SExMismatch (IS

I

@ Scale layout to fit 185x 108

Preserve layout designed for 1762 131

OK || Cancel

Figure 3.5 Abolute Size Mismatch Dialog

Scale layout will use the fractional values from the mask relative to the original phase
image dimensions. Preserve layout will load the regions using the raw pixel dimensions
and coordinates.

&

Note: If a *.png or *.bmp is loaded onto a phase image
with different pixel dimensions than the one on which it
was created, a dialog will appear, as shown and
discussed below.

Load Mask Image =

o The selected mask image

2.png

il

is not the same size as the phase image. Continue anyway?

Yes No

Figure 3.6 Load Image Mask Mismatched Size Dialog

Hitting continue on this dialog will load the image mask regardless of the mismatch,
scaling the masked regions to the aspect ratio of the current phase image.

3.2.3 Copying and Pasting Masks

A mask can be copied by going to Advanced->Mask->Copy All. Alternatively,
individual mask regions can be copied and pasted by right clicking on them and going to
Copy. When a region is selected the shortcut Ctrl+C also works here.

Pasting a mask is similar. Once a mask region has been copied, right click on the
target phase image and go to Paste Mask. When the target phase image has focus, the
shortcut Ctrl+V also works for this function.
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Figure 3.7 Paste Mask Option in Phase Image Context Menu

—

—_—

3.2.4 Burning a Mask

Analyze
Srmooth
Rotation
Advanced
Paste Mask  Ctrl+V
Properties...

Note: If a mask is pasted onto a phase image with
— different pixel dimensions than the one on which it was
created, the mask will be scaled fractionally in location
and size.

Burning a mask combines the current phase image with one or more mask ROIs
created in memory or loaded from a file. The mask pattern will be permanently embedded
in the phase image. This function prevents the future separation and loss of mask files

used during analysis.

A mask can be burned by:

¢ right-clicking inside an editable mask ROI and choosing Burn or,

¢ right-clicking inside the phase image (but not inside an editable mask ROI) and
choosing Advanced->Mask->Burn All.

The burned mask ROIs appear as a gray color as shown in Figure 3.8.

. \ |

i nd

250 x 200 pixels ~ | 100 % |

Figure 3.8 Burned Mask Areas
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3.3 Cropping a Phase Image

Cropping an image allows the user to extract and save a smaller portion of the current
phase image. This is useful for defining a smaller region inside the original phase image
or eliminating bad phase data at an image edge.

Note: As of Studio 8.0, the crop function has been
4 removed in favor or creating a partition file with only
one region. Please see Section 3.5.

3.4 Phase Amplitude Thresholding

As of Studio 8.0 Surface Analysis now has the ability to adjust the phase amplitude
threshold used to auto-mask a phase image after it has been saved by Surface
Measurement. Previously, this value could only be changed by re-acquiring data during
testing. This works by virtue of the fact that *.akx_phase files typically store the raw
intensity images used to build phase data. By resetting the phase amplitude value, areas
of the image that were above the acquisition PAT can be recovered and data that should
have been masked can be removed.

|

In order to adjust the Phase Amplitude Threshold, right click on the phase image and
select the Amplitude Threshold... menu option. A dialog will pop up asking the user
whether or not they want to keep existing masked points. Clicking Yes will create a map
of the already masked out points that will not be affected by any PAT adjustments. This
is particularly useful if the user has already created a mask of data that had good phase
amplitude but was simply not needed in the measurement. Saying No will recalculate
mask on all areas of the image.

Analyze Amplitude Thresold Adjustment Phase Amplitude Threshold x
| Amplitude Threshold... | 2
Srmooth o Keep existing masked points? (]
- 0.0 46.1
RDtatan r Initial Value =20 | Set
Advanced 3 Yes No 3.05% Masked
Properties...
Figure 3.10 PAT Keep Existing =
Figure 3.9 Amplitude Threshold Masked Points? . .
Menu Option Figure 3.11 Phase Amplitude

Thresholding Adjustment
Window

When the adjustment window pops up, move the slider to adjust mask calculation.
The Min and Max values on this slider are pulled directly from the phase amplitude of the
image.
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i@ 011_shiny.ak_phase

342 x 232 pixels ~ | 100 %

===l Phase Amplitude Threshold &=
| p
7802 |2
4296 11934
Initial Value = 589.9
6.19% Masked
OK || Cancel

Figure 3.12 Phase Amplitude Thresholding

Masked areas will increase and decrease, and be highlighted red on the phase

image. To go back to the original PAT value, click the Set button.

'y
¥

—_—

Note: Dragging the slider quickly or large distances
may cause some delay in recalculating mask areas.
This is particularly true with large phase images and/or

slower computers.

In Batch Processing, the Phase Amplitude Threshold dialog has both absolute and
relative threshold settings, as well as both 8-bit and 12-bit scales, depending on which
type of image is being processed.

Phase Amplitude Threshold

(®) Absolute 43.0

i) Relative £

o
[

Intensity Scale

() Bbit

4k

4k

oK

(® 12bit

Cancel

ot

Figure 3.13 Phase Amplitude Threshold Batch Dialog
3.5 Partitioning a Phase Image

Partitioning is a function where one or more ROIs are cropped from a phase image
while leaving the original phase image intact. This function is useful for measuring multiple
samples in a single run, and later extracting the individual samples from each phase
image recorded. The same partition can be applied to multiple phase images using the
Batch Cropping tool described in Section 6.

30-50SW-0001 Ver. 8.0
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3.5.1

4.

Analyze
Smooth

Rotation 3

| Advanced 4 | Mask 4
Properties... Crop...
| Partition Array...

Ll Chord Add Region...  Curl+R

View

- v - |-

e Rotate Visible

Locked
Default ROI Prefix..

Duplicate

Compensation
Shift... Extract All
Undo 3

Copy All

Paste

Load...

Save...

Delete All

Figure 3.14 Partition Menu
Creating a Partition

. To create a new partition, right-click in the selected phase image and choose

Advanced->Partition->Add Region... (or Ctrl+R).

To create the first domain in the new partition, draw a rectangle on the phase image
with the mouse.

A green ROI appears and all the ROI commands described in Section 3.1 apply
to the partition ROI. By default, the regions will be named “Region 001”7, “Region
002”, etc, but the default can be changed by going to
Advanced->Partition>Default ROI Prefix... Previously used ROl names will be

saved in a list for recall later.
Default RO Prefix -

| 8] | I Cancel

Figure 3.15 Default ROI Prefix Dialog

Right-clicking inside any ROI and choosing Edit... allows the region name to be
changed as well as the shape, location, size, and Mode of the domain (Figure
3.16). Click OK when complete.

Note: The Mode selection determines whether the
¢ partition location and size are displayed in absolute
pixels or fractions. The location is relative to the top left

|
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corner of the phase image. The size is relative to the
full x and y dimension of the phase image.

Location

x Position v Positian

) = 36 =

- -

Mode
@ Absolute () Fractional

Figure 3.16 A Partition ROI Properties Window

5. Additional domains can be added to the partition (Figure 3.17) by repeating steps
1 through 3. Domains may overlap.

327 x 299 pixels v | 100% |

Figure 3.17 Multiple Domains on One Phase Image

6. When the partition is complete, it can be saved to a file (*.akx_partition) by right-
clicking inside the phase image (but not inside a domain) and choosing
Advanced->Partition->Save....
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7. Even if it has not been saved, a partition may be used until it is cleared. It may be
cleared by right-clicking inside the phase image (but not inside a domain) and
choosing Advanced->Partition->Delete All.

3.5.2 Loading and Editing a Partition

A previously created partition that was saved in a *.akx_patrtition file can be recalled
and applied to any phase image. To load the partition file, right-click inside the phase
image, choose Advanced->Partition->Load..., and select the desired partition file.

Any domain in the partition may be modified or deleted by right-clicking inside the
domain and using the ROl commands described in Section 3.1. It may also be edited
graphically using the cursor. New domains may be added by right-clicking inside the
phase image (but not inside a domain) and choosing Advanced->Partition>Add
Region....

The modified partition, including both old and new domains, may be saved by right-
clicking inside the phase image (but not inside a domain) and choosing
Advanced->Partition->Save....

&

— Note: If a partition is loaded onto a phase image with
— different pixel dimensions than the one on which it was
created, a dialog will appear, as shown and discussed
below.

—

Load Partition Absclute Size Mismatch e

(®) Scale layout to fit 125 161

(O Preserve layout designed for 306x 309

Cancel

Figure 3.18 Load Partition Absolute Size Mismatch

Scale layout will use the fractional values from the mask relative to the original phase
image dimensions. Preserve layout will load the regions using the raw pixel dimensions
and coordinates. If Preserve is chosen, a dialog will let the user know how many regions
were discarded because they were entirely outside of the data bounds as well as how
many regions extend outside of the data bounds. Only regions with their top left corner
present in the target image pixel bounds will be loaded.

Load Partition Info X
1 of 2 regions were discarded.
1 of 1 regions extend outside the data bounds.

Figure 3.19 Load Partition Preserve Layout Info
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3.5.3 Copying and Pasting Partition Regions

A mask can be copied by going to Advanced->Partition=>Copy All. Alternatively,
individual partition regions can be copied and pasted by right clicking on them and going
to Copy. When a region is selected the shortcut Ctrl+C also works here.

Pasting a partition is similar. Once a partition region has been copied, right click on
the target phase image and go to Paste Partition Region. When the target phase image
has focus, the shortcut Ctrl+V also works for this function.

Analyze

Smooth

Reotation 2
Advanced k

Paste Partiticn Region  Ctrl+V

Properties...
iz -

|
Figure 3.20 Paste Partition Region Option in Phase Image Context Menu

Note: If a partition is pasted onto a phase image with
different pixel dimensions than the one on which it was
created, the region will be scaled fractionally in location
and size.

I

3.5.4 Extracting Domains

To extract a domain as an independent phase image in its own window, right-click
inside the domain and choose Extract. To extract all domains, right-click inside any
domain and choose Extract All. A new window will pop up for each ROI.

(@ Sample.akocph... [ = | & [[u5n]

(] EE=j#

15

‘“ 130 87 pixels - | 100 % 119119 pixels ~ | 100 %

215x 221 pixels - | 100 %

Figure 3.21 Extracted Domains from a Phase Image
3.5.5 Adding an Array

An array is a grid of ROIs. This function is useful for automatically creating a large
guantity of regions on a phase image. Common use cases include examining die level
warpage on wafers and package level warpage on strips.
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Figure 3.22 Example of an Array

1. To create a new array right click in the selected phase image and choose

Advanced->Partition->Array...

2. By default, a grid of ROIs appear on the phase image. Also, a box with various
array parameter options appear (Figure 3.23). The height and width refer to the
individual dimensions of a single ROI. The center offset is the distance of the
center of the full array from the center of the image. The inset refers to how much
of the region is analyzed (useful if the solder array is smaller than the part border
for instance). Each option affects all ROIs in the same way.

&

I

Note: There is no way to independently edit one region
through the menu at this stage. Later in the process
there is a way to independently change the shape and
location of each of the partitions.

3. Click Update to view the changed array inside the phase image.

Array Generator - Board01_000015(25C)
File

Width Height
RegionSze (50 |2 [0 |5
X Y

Center Offset |0 i

X Y
Spacing = =
koo [D0000}]  [p0000
X Y
Region Inset (0 = 0

Selection Area | Inside
Orgin | UpperLeft
Naming Scheme

Count (H)  ~

Region Prefix Region Suffix

Convert To Partition

Prompt to save

Region Count: 361

Figure 3.23 Array Parameters

4.To save the patrtitions, use the green array bounds box to select the specific
partitions to be saved. Note that only partitions whose whole areas are enclosed
by the green rectangle will be saved, as seen in the figure below. Click on
Convert To Partition to save the partition file.
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Figure 3.24 Green Array Bounds Box

5. To extract the regions, right click on the phase image and choose
Advanced->Partition>Locked and uncheck locked. This will separate the ROIs
into independent ROI's whose size and position can be edited.

6. Loading an array is the same process as loading a partition. Right click on the
phase image and choose Advanced->Partition->Load to choose the pertinent
partition.

3.6 Smoothing a Phase Image

The Smooth command applies a smoothing function to the active phase image to
reduce noise in the data. This is useful for reducing analysis error due to fringe
miscounting and increasing reproducibility in gauge values. Warpage gauge values, such
as coplanarity, are frequently determined by a small number of data points, e.g. the
highest and lowest displacement values. Therefore, they are extremely sensitive to
statistical outliers in the data set. Smoothing, by reducing statistical noise, can make
these values more repeatable from measurement to measurement.

To apply the smooth function, right-click inside the phase image and choose Smooth.
This command can be repeated multiple times. For further information about the smooth
function, refer to Akrometrix Optical Techniques and Analysis 101.

L

Note: Smoothing may cause errors when applied to
images where the fringes are very tightly spaced or at
boundaries of mask ROIs. Therefore, it is not
recommended to apply the smooth function on data
acquired with the MP10 Surface Measurement
system which produces a closely spaced fringe pattern
on a phase image.

il

3.7 Rotating a Phase Image

Rotating a phase image is a feature useful when a sample does not have the desired
orientation in the original phase image (e.g. a part has rotated on the sample support
fixture during a temperature profile).

To rotate a phase image, right-click on the image, choose Advanced->Rotate and
select the desired rotation.

L

Note: Phase image rotation is different from reference
plane rotation that is discussed in Section 4.3. The
former rotates a 2D image while the latter rotates a 3D
surface. To choose the method of rotating a reference

1]
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plane, right-click on the phase image and choose
Rotation (Figure 3.26).

Analyze

Amplitude Threshold... g Analyze
Smocth : ‘: Amplitude Threshold... :
Rotation 4 ¥ Smooth L‘ .

Advanced » | Mask .

Properties... View » Rotation 4 | None
Partition 3 Advanced 3 L5F
Cherd ’ Properties LSF Low D

Rotate 4 180 deg

Duplicate 90 deg CW
Compensation 90 deg CCW
Shift... Arbitrary...
Undo

LSF High 0
Three Paoint

Faur Paint

. ) Figure 3.26 Reference Plane Rotation
Figure 3.25 Phase Image Rotation

3.8 Shifting a Phase Image

Shifting a phase image is a feature useful when a sample does not have the desired
position in the original phase image, e.g. a part has shifted to one side of the sample
support fixture during a temperature profile.

To shift a phase image, right-click on the phase image, choose Advanced->Shift...
and select the desired shift in either the X (left-right) or Y (up-down) direction. The image
will shift with respect to an origin that is defined as the top left of the phase image. Areas
shifted from outside the boundaries of the phase image will be filled with mask (see
Figure 3.27).

Shift Image

¥:-Direction Y-Direction
‘ [0 H [wo A
g | R S . ¥
-OK Cancel s
250 x 200 pixels ~ | 100 % | Q 250 x 200 pixels | 100 %

Figure 3.27 Shifting a Phase Image
3.9 Undoing a Phase Image Modification

To undo phase image modification from masking, partitioning, smoothing, rotating or
shifting, right-click and select Advanced->Undo; select the action to undo from the
available list.

There can be up to 99 actions on the undo list. The latest action will be shown at the
top of the list. Clicking on the latest action will remove this single action and move the
phase image back one state. Clicking on any item in the middle of the list will remove all
the actions from the top to this item.
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3.10 Saving Phase Images

A modified phase image is NOT automatically saved to the hard drive. It can be saved
using the File>Save... menu item. If the modified image is not saved, the user will be
prompted again to save it when the phase image window is closed or the program is shut
down.
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4 Analyzing Measurement Data

Analysis is the mathematical conversion of the measurement data (e.g. phase image)
into displacement data (the height of the surface at each image pixel in physical units).
Surface Analysis is normally set to display displacement data graphically as soon as the
analysis is complete. The graphical output options will be described in Section 5. This
section describes how to initiate the analysis process and a key factor in the analysis, the
choice of reference plane.

4.1 Analysis
There are three methods to trigger analysis of the measurement data

A. To trigger analysis manually, right-click on the phase or displacement image to
be analyzed and select Analyze.

B. To trigger analysis automatically when a *.akx_phase file is opened, select the
Tools->Options... menu item and check Analyze on Open.

C. To analyze multiple measurement data in parallel, use the Batch Analysis
function described in Section 6.2.

—— Note: Ifno graphical display options are checked in the
— options window, there will be no visible indication that
analysis has taken place in cases A and B above.

4.2 The Options Window

The settings on the options window (Figure 4.1) determine the reference plane and
display options when the measurement data is analyzed. These settings will be applied
to all the measurement data, either manually or automatically on opening.

|

To open the options window, select the Tools=>Options... menu item. All the settings
are explained below:

Units XY Displays the in-plane dimensions in English (inches) or metric
units (millimeters).

Units Z Displays the out-of-plane dimensions in English (mils, 1 mil =
0.001 inches) or metric units (microns, or pum).

Smooth Phase on Checking this box causes the phase image to be smoothed
Open one time immediately after loaded.

Analyze on Open Checking this box causes the measurement data to be
analyzed immediately after loaded.

Grating Checking this box applies compensation to all measurement

Compensation data that contain compensation parameters (See Section 4.5
for a discussion of grating compensation). It may be turned
on or off for individual measurement data by right-clicking on
a phase image and choosing Advanced->Compensate.
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Smooth Checking this box caused all phase images to be
Displacement displacement smoothed when analyzed.

Normalize Checking this box causes all 2D chord plots to be displayed
Chords with the endpoints referenced to zero.

Default Rotation Pull-down list sets the reference plane rotation to be applied
during the analysis. See Section 4.3.

Gauges — Surface Select which gauges (numerical values quantifying flatness)
are Active and/or Show in 3D Footer. Checking the first box
(Active) means that gauge will be displayed in the
Displacement Window Gauges tab. Checking the second box
(Show in 3D Footer) means the gauge will be displayed at the
bottom of a 3D graph. A gauge on the list may be highlighted
by clicking on it once. The up and down arrows move the
highlighted gauge up and down the list, changing the order in
which gauges are displayed.

Gauges — Chord  Select which gauges show up at the bottom of a Chord Graph.
Order By also determines the order in which the selected
gauges are displayed.

Graphs Selects which graph formats (see Sections 5.1 through 5.4)
are displayed after analysis. A graph on the list may be
highlighted by clicking on it once. Checking a box means that
graph will be displayed. The up and down arrows move the
highlighted graph up and down the list, changing the order in
which graphs are displayed.

Configuration Allows the user to load a non-default display format for

File graphs. The 3D configuration file has an extension of
*.akx_3Dconfig and is used for 3D plots. See Section 5.1.
The 2D configuration file has an extension of *.akx_2Dconfig
and is used for any 2D chords. See Section 5.3 and 5.4.

Graph Size Sets the initial size for all graphical displays created during
analysis.

Gauge Display Gauge values listed at the bottom of the 3D or 2D display
window may be arranged horizontally or vertically.

Use Latest 3D Applies the perspective of the most recently modified 3D

View surface plot to all subsequently spawned 3D surface plots. In
other words, if the user changes the altitude or rotation from
which the surface is viewed in one graph, new graphs will
automatically be shown from the same viewpoint. The zoom
factor of the most recent graph will also be inherited.
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Fixed Z-Scale

Batch Analysis
OK

Cancel

Il

]

4.3 Reference Plane — Rotation

When checked, this allows the user to adjust the data scale
for all 3D or 2D plots. When unchecked, each image is plotted
on a scale set by its own data set. This option is also available
in Batch Analysis (Tools>Batch Processing...2>Analysis

Tab).

Allows the user to load a *.akx_recipe file to change the
default Batch Analysis settings

Any changes to the settings are saved and the window is

closed.

The window will close without changes to the settings.

Options
Analysis
Units
z

millimeter micron

[] Smooth Phase On Open
[] Analyze On Open

[[] Grating Compensation
[] Smooth Displacement

[] Normalize Chords

Default Rotation | LSF Low 0 a7

Gauges
Suface Chord

5 B o B
O|| coplanarity

|| HD Coplanarity
O/ Bow

1|7 Twist
|| FFs Wampage
|| FFs Warpage DB

Batch Analysis

=N %

Window Output

[ Vertical Centerine
[ Left Right Edges

3D Corfiguration File

Graph Size
WWidth Height
861 |5 851 |

Gauge Display

(® Horizontal ) Vertical

[ Use Latest 3D View

Fixed Z-Scale
Surface Chord
[] Enabled [] Enabled
Maximum aximum

Minimum Minimum

Default Settings File

Cancel

Figure 4.1 Options Window

Note: If no options are checked on the Graphs list,
there will be no visible indication that analysis has

taken place.

In order to display the displacement data, the user may define a coordinate system
with a zero reference plane. This is especially useful when calculating gauges. To set the

reference plane rotation to be used during analysis, select Tools=>Options...

and

choose from the Default Rotation pull-down list.
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The rotation choice can also be made before analysis by right-clicking on the phase
image and choosing Rotation or Transform->Plane Rotation on a displacement image,
then selecting from the list. The selected option is checked.

L

Note: The rotation option chosen in the options
window will be applied to all the measurement data
when loaded. The rotation option chosen from an
individual phase or displacement image will only be
applied to that particular data.

il

Surface Analysis provides the user with several options for defining the zero
reference plane:

e None: The displacement data is not rotated and thus the reference plane is
parallel to the grating. The zero value on the data does not correspond to any
specific feature of the displacement surface.

e LSF: The displacement data is rotated so that the zero reference plane is the
best fit plane calculated from all displacement points.

e LSF Low O: LSF rotation option with the lowest displacement point set equal
to zero (all others are positive displacement values).

e LSF High 0: LSF rotation option with the highest displacement point set equal
to zero (all others are negative displacement values).

e Three Point: The displacement data is rotated so that the zero reference plane
is defined by three corners (upper left, lower left, upper right).

e Four Point: The displacement data is rotated so that the zero reference plane
is the best fit plane calculated from all four corners.

When analyzing a displacement image, the User Defined rotation option is also
available. This allows the user to specify a region on the sample surface to fit a LSF plane
to. This LSF plane is then use to rotate the entire surface.
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a5l Sample.akx_disp VE '@ |[=]
{ER':); Displacement | 3D Graph l Gauges I History |

Rotate
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Copy  Ctrl+C

Paste Ctrl+V
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215 x 221 pixels | 100 % Siquiare Bounds

%,  Edit..

Figure 4.2 User Defined Plane Rotation

In Figure 4.2 the green box can be dragged around and resized to cover the area
that represents the desired rotation. In the context menu, Rotate will perform the rotation.
If the rotation is deemed acceptable, Accept will complete the operation and remove the
green box. Revert will undo the rotation. In addition, the green box can be copied from
one displacement window to another using the Copy/Paste commands. Lastly, the box
size and location can be set from another *.akx_disp file as well as edited using the
Square Bounds and Edit commands.

The values of the individual data points change as a function of rotation (choice of
reference plane), so gauges (e.g. coplanarity) and other calculated values are also a
function of rotation. See Akrometrix Optical Technigues and Analyses 101 for further
discussion.

4.4 Reference Surface — Relative Displacement

A relative displacement measurement is calculated by taking the difference between
two absolute displacement measurements with the same image pixel size. It is useful for
observing the change in sample warpage as a function of sample history. The baseline
displacement surface is set to be reference surface. The relative displacement surface is
the current active surface minus the reference surface.

To define a reference surface, right-click on a 3D graph analyzed from a phase image
and check Use as Reference. This surface data will then act as a reference to all other
displacement data. After identifying the reference surface, right-click on a second phase
image of the same pixel dimensions. An additional menu item, Analyze Relative, appears
on the list below Analyze. To obtain the relative displacement data, select Analyze
Relative. Otherwise, choose Analyze to obtain the absolute displacement data. The
relative displacement display can be turned off by right-clicking on the reference surface
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image and unchecking Reference Surface. After that, Analyze Relative will disappear
from the menu list for the phase images.
L 4

Note: Analyze Relative only compares data with the
same pixel dimensions. If the second phase image is
of different pixel dimensions than the reference phase
image, the user will be shown an error message.

il

4.5 Reference Surface — Grating Compensation

The non-planar surface of a grating can be compensated by a reference surface (see
Akrometrix Optical Technigues and Analyses 101). To enable grating compensation
during analysis, check the Enabled box under Grating Compensation in the options
window.

The compensation choice can also be made for individual phase images by right-
clicking on the phase image and checking Advanced->Compensation. To turn off
compensation, repeat the process and uncheck the selection by clicking it again.

L

Note: In the options window, the Grating
Compensation option can be enabled or disabled
regardless of whether the grating has been
compensated or not. This option will be applied to all
opened phase images that contain compensation data.

—

" Note: The compensation option on an individual phase

— | 1image will be grayed out if no compensation

2 parameters can be found in the *.akx_phase file.
Otherwise, this option is shown in black and can be
checked or unchecked. The compensation option
chosen for each phase image will only be applied to
that particular image.

&

Note: In order to apply grating compensation, physical
dimensions have to be assigned to the phase image
(see Section 2.3.4). The grating compensation
calculation assumes that the ROI is centered with
respect to the grating. The accuracy of the
compensation will be reduced if the ROI is not
centered, particularly if it lies outside the central 4” by
4” area of the grating.

]|
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5 Displaying Results
After analysis, the information is displayed in a choice of four graphical formats:

3D Surface (Section 5.1)

3D Contour (Section 5.2)

2D Diagonal (Section 5.3)
2D Chord (Section 5.4)

The data displayed in each graph can be exported in numerical form (Section 5.5).
In the meantime, gauges (single values representing the warpage) can be displayed at
the bottom of the 3D graphs (Section 5.6).

5.1 Graphical Output — 3D Surface Plot
5.1.1 3D Display Window

To display the 3D Surface plot after analysis, check the box next to 3D on the Graphs
list in the options window (Section 4.2). After right-clicking and selecting Analyze on the
phase image or Analysis->Generate Results on a displacement image, a new 3D
display window is opened and the 3D height map represented in color is shown in the
center of this window. Interaction with the 3D display when generated from a
displacement image is similar to that of the original image. Further details on the 3D
display window generated from a phase image are discussed in this Section 5.1.4. The
name of the data file will be shown on the top and gauges selected in the options window
will be displayed below the 3D image. The caption of the 3D display window can be
renamed by right-clicking on its title bar and selecting Rename Window.... Additional
information including cursor coordinate position, viewpoint and zoom ratio can be found
in the status bar at the bottom left. See Figure 5.1.

5.1.2 Key/Mouse Interactions with the Graph
There are five interactions that can be done with the 3D graph:

1. Coordinates of each individual data points are shown live in the status bar by
hovering the cursor over the 3D image.

2. Rotate adjusts the angle from which the surface is viewed. Press the left mouse
button and drag the plot to the desired orientation in the display window. The
current Rotation and Altitude parameters will be displayed in the status bar.

3. Zoom adjusts the scale of the plot. Scroll the mouse wheel and change the plot to
the desired scale in the display window. The current 3D graph magnification level
will be displayed in the status bar.

4. Pan adjusts the plot center point. Simultaneously press the Ctrl key and left click
on the plot to set the center point. Subsequent rotate and zoom functions will rotate
and zoom about this new point.

5. Esc key brings the 3D graph back to its original size (zoom ratio of 100%) and
center point.
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X (pixels)
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| Smooth Save Image... Ctrl+ 3 11.1
¥ - 9.3
i Fir Data. Export Legend... N\, 44 7.5
3§ Plot Chord(s) » Print Ctrlsp NG 5.7
| i o L\ 3.9

Show Relative To A 0
Close 2.1
Use As Reference 0.3
-1.5
Display > -3.3
-5.1
Properties... -6.9
-8.7

JEDECFullFieldSignedWarpage = -595 microns SignedWarpage = -595 microns

(X.Y,Z) = N/A Rotation: 31 Altitude: 45 Zoom: 100% Center: 0.50, 0.50

Figure 5.1 3D Surface Plot
5.1.3 Changing Viewpoint
The viewpoint of a 3D graph can be set using four different approaches:
e Use Latest 3D View box in the options window (Section 4.2)
e Rotate and Pan operations (Section 5.1.2)
e Copy View and Paste View in the 3D display command list (Section 5.1.4)
e The display Configuration window (Section 5.1.5)
5.1.4 Graph Command List

Right-clicking on the display window will show a different context menu depending on
whether it came from a phase image or a displacement file. The context menu for a 3D
graph created from a phase image is described below. For 3D graphs originating from a
displacement window, the context menu command list is the same as that on the 3D
Graph tab in the mutli-tabbed *.akx_disp window. See Section 2.4.

File Allows saving of the current displacement data either
numerically or as a picture. Also contains commands for
exporting a legend, printing the picture and closing the
window.
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Smooth

Fit Data...

Plot Chord(s)
Show Relative To

Use as Reference

Display

Properties...

Fit Data

Applies a smoothing function to the 3D data and shows
the smoothed surface in a new window. This command
can be repeated multiple times. See AOTA101 for more
information.

Opens a dialog where a polynomial fit can be calculated
based on the data set. See Figure 5.2. Alternatively, if
physical dimensions are assigned to the phase image, a
spherical fit can be calculated.

Plots pre-defined chords in a new window.

Displays the relative displacement data calculated by
subtracting a selected 3D data from the current 3D data in
a new window.

Sets the current 3D data to serve as the reference
surface

Contains the copy, paste, and reset view commands for
applying one 3D graph orientation and zoom to another.
Also contains Z-Axis units and scale options. Lastly,
graph configuration parameters are access here. See
Section 5.1.5

Opens a displacement object properties window with all
saved parameters relating to the displacement object.

>

(@) Polynomial Order (A

i) Spherical

Retain Masked Points

Cancel

Figure 5.2 Fit Data Dialog

5.1.5 Display Configuration Window

The display configuration window (Figure 5.3) gives the user the ability to customize
the graph display format. The custom format can be saved and re-used, and set as the
default format for all 3D plots. To display the configuration window, right-click inside the
graph window and select Configure....

In the configuration window, to load a previously saved display configuration, choose
File=>Open... (Ctrl+0). To save the current display configuration, choose File->Save....

(Ctrl+S).
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I

Note: The display configuration file (*.akx_3Dconfig)
loaded from the display properties window is applied to

the current display window (Figure 5.1). Configuration
files loaded from the Options window (see Section 4.2,
Figure 4.1) will be applied to all newly created display

windows.
Properties n
Eile
~
Color Above Range [] LightGray
Color Above Range Enabled True
Color Below Range B Gray
Color Below Range Enabled True
Enabled Falze
Z-Mandmum { mils
Z-Minimum { mils
Footer
Bold Falze
Color Il cizck
Font Default
ttalic Falze
Shadow Falze
Size 16
Alignment Center
Text Coplanarity = 22 microns
General
Back Color [ 1 Whie
Data File Format aloc_disp
Graph Size 861, 551
Image File Format irg
Save Image As Custom Size Falzse LY
Color Range Settings
QK Cancel

Figure 5.3 Display Configuration Window

5.2 Graphical Output — 3D Contour Plot
To display the 3D Contour plot after analysis, check the box next to Co

lorContour

on the Graphs list in the options window. Most of the contour plot commands and features

are identical to those described in Section 5.1 (Figure 5.4).
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Figure 5.4 Contour Plot

5.3 Graphical Output — Diagonal Plot

The diagonal plot (Figure 5.5) represents two cross-sections of the surface along
diagonal lines connecting the corners. To display the 2D diagonal plot after analysis,
check the box next to Diagonals on the Graphs list in the options window. If it is not
checked, the 2D diagonal plot window can also be opened by right-clicking on the 3D
display window and selecting Plot->Diagonals. The caption of the 2D display window
can be renamed by right-clicking on its title bar and selecting Rename Window....

A EEEE
Sample
400
Scale ¥-Axis...
Save.. ctri+s
300 T Save Image... Ctrl+l
i foem ™ Normalized Fa
S 200 4 Reset View Esc
S Print... Ctrl+P
é 100 &+ Create Legend...
‘GC-J' Coenfigure.., /—\ /
£
g ° S
(5]
©
2 100 |
(]
-200 1
-300 +— —t———+—+—t—+—+—+—+—————+—F—+——+—+——+ —
0 50 100 150 200 250 300
Position Along Diagonals (pixels)
—— Downward Diagonal —— Upward Diagonal
Downward Diagonal Min =-188 microns Downward Diagonal Max = 205 micrans Upward Diagonal Min =-215 microns Upward Diagonal Max = 348 microns
(X.¥) = (123, 395)

Figure 5.5 Diagonal Plot
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5.3.1 Display Command List
Right-click inside the display window to show the command list.

Scale Y-Axis... Displays a window where the minimum and maximum values
of the Y axis may be modified. Defaults are the min and max
values of the data plus a software determined buffer.

Save... Exports the data in numerical format (Section 5.5)

Save Image... Allows display window to be saved in graphical format
(*_dia.bmp or *_dia.jpQ).

Normalized Causes all diagonal plots to be displayed with the endpoints
for each diagonal set to zero.

Reset View Resets the graph view after it has been zoomed.

Print... Allows display window to be printed to any available system
printer.

Create Legend... Allows the legend to be saved as a separate picture file for
reporting purposes.

Configure... The 2D display properties window is very similar to the 3D
version described in Section 5.1.5.

5.4 Graphical Output — Chord Plot
In addition to the diagonal plot, other special chord options are defined as follows

Centerlines

Top Bottom Edges

Left Right Edges

All Edges

All Edges Centers Diags
Five Vertical

Five Horizontal
Horizontal Centerline
Vertical Centerline

They can be accessed by right-clicking on the 3D display window and selecting Plot
Chord(s). All of these chords oriented horizontally are plotted from left to right and all
vertical chords are plotted from top to bottom. In more general cases, an arbitrary chord
or chord set can be defined, where out-of-plane displacement data along any line(s) can
be displayed. The following sub sections will describe how to draw a generic chord or
chord set.

5.4.1 Creating a Chord

Right-click inside a phase image and select Advanced->Chord->New Chord
(Ctrl+K) or Analysis=>Chord->New Chord (Ctrl+K) on a displacement image. Using
the mouse, draw a line across the phase or displacement image, holding down the left
mouse button at the start point and releasing it at the end point.
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Several

preset chords can be added to the phase or displacement image using

keyboard shortcuts.

Shift+T: Top Edge

Shift+B: Bottom Edge

Shift+L: Left Edge

Shift+R: Right Edge

Shift+D: Downward diagonal (upper left to lower right corner)
Shift+U: Upward diagonal (lower left to upper right corner)
Shift+H: Horizontal centerline

Shift+V: Vertical centerline

&

Note: Preset chords can be removed by hitting the
keyboard shortcut a second time.

1]

5.4.2 Editing a Chord

To reposition the endpoints of a chord, click on the chord. Square white handles will
appear on either end of the chord, which can be moved with the cursor.

&

Note: Preset chords defined in Section 5.4.1 cannot
be selected or edited.

|

Right-click on a chord to show the chord command options list:

Reverse Direction Reverses the direction of the data along the chord when

plotted.

Align Aligns the chord horizontally or vertically.

Plot Plots the current chord in a new 2D display window.

Plot Set Plots all chords appearing on the phase or displacement
image (only available when more than one chord is shown on
the image).

Delete Deletes the selected chord.

Edit... Allows the endpoint positions to be set to specific pixel values

using text boxes. Also allows renaming of the chord.

5.4.3 Plotting a Chord

Right-click on the chord and choose Plot or Plot Set. Calculation is performed and a
display window appears. All display commands available for Diagonal plots are applicable
here, including exporting the chord displacement data in numerical form. See Section

5.3.

5.4.4 Using a Chord Set

One or more chords form a set, which can be saved, re-used, and plotted collectively.
A set is started automatically when the first chord is drawn on the phase or displacement
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image. Additional chords added using Advanced->Chord->New Chord become part of
this set.

A set can be saved by right-clicking on the phase image and choosing
Advanced>Chord->Save Set... and a saved set can be loaded by choosing
Advanced->Chord->Load Set.... A saved set has a filename ending in *.akx_chordset.

&

Note: If a loaded chord set was generated from a
larger phase or displacement image than the current
one, only the chords with both ends falling within the
current image in that set will be loaded.

U]

All the chords in a set can be plotted on the same graph by right-clicking on any of
the chords and selecting Plot Set.

A new set can be started by right-clicking on the phase image and choosing
Advanced->Chord->New Set (Ctrl+G) or Analysis>Chord->New Set (Ctrl+G) on a
displacement image. Up to 9 sets can be created for one image.

Multiple sets can be in memory at the same time. The sets are numbered 1 through
9, depending on the order in which they are created or loaded. A particular set can be
displayed by typing Shift + its number on the keyboard or choosing
Advanced->Chord->Set and selecting the desired set number.

5.4.5 Saving a Chord Image

After a chord or chord set is plotted, the graphical image can be saved by right-
clicking on the 2D image and choosing Save Image.... The image may be saved either
in BMP or JPG format with different suffixes as listed below:

Chord Type File Suffix | File Extension
Diagonal _dia .png
Horizontal Centerline _hzc .png
Horizontal Edges _hze .png
Vertical Centerline _vtc .png
Vertical Edges _vte .png
Arbitrary _crd .png

5.5 Numerical Output

Numerical data from all display windows can be exported by right-clicking on the
display window and selecting Save.... A standard Save window appears with three
choices for the save format in the Save as type pull-down list at the bottom.

Akx_disp Exports data in the Akrometrix akx_disp format (not available
for chords)

Dat files Exports data in tab-delimited text format
Text files Exports data in space-delimited text format
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5.6 Gauge Output

Gauges can be selected in the Gauges list in the options window and are displayed
at the bottom of 3D Surface, Contour or Chord plots where appropriate. Gauge definitions
are available in Akrometrix Optical Techniques and Analyses 101.
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6 Batch Processing

6.1 Batch Processing

Batch processing allows most of the one-off functionality in Surface Analysis to be
performed on multiple data files with no user interaction. This functionality is very helpful
when performing large experiments with multiple ROIs and/or multiple temperature
points. There are six batch functions available:

e Batch Analyze

e Batch Mask

Batch Rotate
Batch Crop

Edit XY Orientation
Convert

To access the batch processing functions, select the Tools>Batch Processing...
menu item. This will open a batch processing window (Figure 6.1). Tabbed screens
appear for the six batch processing functions. Common menu items for these functions
appear on a menu bar above the tabs.

—— Note: Multiple batch processing windows can be
4 opened to process different data or process the same
data with different settings.

# Batch Processing [E=RECH ==/

Source Edit  Action
Analyze Mask Rotste Crop  Edit XY Orientation Corvert

REolime Adive  Flename a Coplanarty Dowrward Diagonal Min Dowrward Diagoral Max  Upward Diagorial Min Upward Diagonal Max
[ Phase Ampitude Threshold

[ Smootn Phase.

[ Mask Phase

[ Pnysical Dimensions

[ compensate (per phase)

[ Normaiize Chords:

[ Smootn Displacemen t

[ Custom Smooth Displacement
[ wask Displacement

Plane Rotation | LSF ~
[ Fit Displacement

Zunts | mil v

»
)
g

{30 Graph } Diagonals

aloc_disp
Graphs & Date Corfiguration Fle _— Header
3D Graph eaen [<SourceDataFienameOniyNoExt > ]
Output Files Common Z-Scale
[ Enabled Footer

Waximum [<Coplanarty> |

OOOOOOO00000000& E‘.%

Step Height

o o o

Phase Image = = Graph Image Size: 8613 551

Common ZSetings... v Image Filename Suffic_3D

Figure 6.1 Batch Processing Screen
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6.2 Batch Analysis

The batch analysis function opens the image or displacement files in the selected
folder, analyzes the data, and saves the results in graphical and/or numerical format. This
is useful, for example, for analyzing all the warpage measurements taken during a
temperature profile and plotting the results on the same scale. The batch analysis tab
window shows the conditions to be applied during analysis and display, while the action
is initiated using the Action menu item.

Source - Select... Identifies the folder of *.akx_phase or *.akx_disp files on
which the batch processing functions will be applied. As
of Studio 8.0, multiple folders can now be analyzed via a
pop-up folder selector. See Section 6.2.1.

Edit 2 File Type Switches  between analyzing phase images
(*.akx_phase) and displacement data (*.akx_disp).

Edit = Refresh Allows the user to update the file count since the folder
Source Folder (F5) was originally selected.

Edit = Settings =2 Loads settings for Batch Processing from a *.akx_recipe
Load... file

Edit = Settings =2 Saves settings for Batch Processing to a *.akx_recipe
Save... file

Edit = Settings =2 Loads program defaults

Load Defaults...

Edit = Settings = Set Loads settings from the Options window.
From Preferences

Edit = Output Sequential or Parallel: for large batch operations parallel
Performance 2> will speed up analysis at the expense of populating the
table in non-sequential order.

Action = Group... Initiates the grouping function in order to organize files
for reporting purposes. This can be done after analysis
as well.

Action = Analyze Analyzes the phase or displacement files loaded into the
file list.

Action = Generate Produces output files (pictures and/or data) of various

Output kinds and writes them to disk.

Action = Create Opens the report creation window with data from the

Report... Current Batch pre-loaded in memory.

6.2.1 Using Batch Analysis
The key steps in using batch analysis are:

1. Select afolder to be analyzed (Source->Select... menu item). Multiple folders can
be added and filenames filtered out. Files can be added from a parent folder by
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right clicking on an already added folder row. Subfolders can be added via a
checkbox in this form. If multiple rows are added, certain rows can be “deactivated”
for quick comparison between multiple data sets without having to remove or add
folders.

* Note: A common filename filter that many users might

find useful is to enclose some part of the filename in
asterisks. For example, *PT* will only include files that
include the string “PT” somewhere in the filename. This
is particularly useful when filtering out part tracked
search area files from the individual ROIs. PT can be
substituted for any other string that’s included in all the

Batch Analysis Source Browse For Folder * s
Fies Add Folder
File Type: aloe_phase [] Filename Fiter
Folder List -
> & DVD RW Drive (D) ~
Active  Subfolders Files Folder Name 5 USE Drive (E) -

> wa USB Drive (F)
> USB Drive (G3)
* wm USB Drive (H:)
> wa USB Drive (1)
> o Network

» [E2] Control Panel
<

Figure 6.2 Batch Analysis Source Selection Browse for Folder

Batch Analysis Source X

Files.
File Type: aloc_phase [] Filename Filter
Folder List
| Active  Subfolders Files Folder Name ()
) 1 1 C:\AkrometriSurface Analysis'\Results

Add...
Add Recent
Refresh

Remove All

Figure 6.3 Batch Analysis Source Selection Add Folders

Batch Analysis Source x
Files

File Type: akx_phase [ Filename Fiter

Folder List

[ acive  Subfoiders

Files Folder Name

C:\Akrometrich Surface Analysish\Results

Add...

Add from parent...
Add Recent

Show

Open
Refresh

Remove

Figure 6.4 Batch Analysis Source Selection Add from parent...

2. Once all folders have been added to the Batch Analysis Source dialog, click OK.
The files from this dialog will be populated into the Batch Analysis Results table
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sans any displacement gauge information. Right-clicking on a row brings up a
context menu where individual files or folders can be opened.
Active Filename Coplanarity Downward Diago
Region 001 _Unit_00001s(25C).ale_disp
Region 001_Unit_00261s(f-*n=——
- Open 'Region 001_Unit_00261s(143C) .ak_disp' H
Region 001_Unit_003599s(

Open Containing Folder
Region 001_Urit_00483s( [

Region 001_Unit_00530s( Export Table..
Region 001_Unit_0745s( All Active I
Region 001_Unit_01576s( Mone Active

Region 0071 from Action1_0000Z=(26C) (Masked) aloc_disp
Region 0071 from Action1_00151s(100C) (Masked) aloc_disp

KA AR EEDEEE]

Figure 6.5 Analysis Results Table with Context Menu
3. Select analysis options (Section 6.2.2)

4. Analyze the measurement data (Action->Analyze menu item). The measurement
gauge results will be populated into the table. The extreme values of each
parameter are shown below, which can provide the default scale for generating
plots. The table is exported to each top level directory of the folders being

analyzed.
Active Filename Coplanarity Dowrrward Diag
el egion _Umit_ s, akoc_disp / -
R 001 _Unit_00001=2(25C) abex_d 367 159
o ion _Unit_| 5 akox_disp
Region 001_Unit_00261=(148C) alo_d 173 -41
i eqgion _Unit_| i /
R 0071 _Unit_0035%9s(2150) sl diso 175 -48
Region 001_Unit_0C Open 'Region 001_Unit_00399:(215C).akx_disp'
Region 001_Unit_0C Open Containing Folder
Region 001_Unit_0C Export Table...
Region 001_Unit_01 All Active
Region 001 from Act Mone Active
Region 007 from Actiom T oo T TS Moo TSk ea) g asE T =TH
£
5/9 BExtrema 114 -2

Figure 6.6 Batch Results Table after Analysis
5. Select output options (Section 6.2.3)
6. Create and save results (Action=>Generate Output menu item)
6.2.1 Using Batch Analysis to Create Relative Plots

In order to set one of the images in the selected folder as reference image (Section
4.4), double-click on one file in the summary table and confirm that all analysis should
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use its 3D data as reference. The program will then save all graphs and numeric data as
relative to this reference surface. All other steps remain the same.

6.2.2 Analysis Options

L

Note: Phase operations listed below will not be
available if the file type is set to *.akx_disp.

|

Batch analysis options are described below:

Phase Amplitude  Allows adjustment of the phase amplitude threshold on
Threshold either an absolute or relative basis (see Section 3.4). A
dialog appears with these options when checked.

Smooth Phase Applies a smoothing function once to phase images before
analysis (see Section 3.6)

Mask Phase Applies a previously-created mask to phase images before
analysis (see Section 3.2). A Load Mask window appears
when the box is checked.

Physical Assigns a specific physical size to each data (see Section

Dimensions 2.3.4).

Compensate (per Enables a compensation for the non-planar surface of the

phase) grating. Physical dimensions are required to perform this
calculation

Normalize Chords Causes all chord plots to be displayed with the endpoints
set to zero after analysis (see Section 5.3.1).

Applies a smoothing function to the surface data. See
Optical Techniques and Analyses 101 for an explanation
of this smoothing function.

Smooth
Displacement

Applies a custom smoothing function to the surface data.

Custom  Smooth See Optical Techniques and Analyses 101.

Displacement

Mask Applies a previously-created mask to displacement files
before analysis (see Section 3.2). A Load Mask window

Displacement appears when the box is checked.

Selects the reference plane rotation option to be used
during analysis (see Section 4.3). Can be turned off to use
the grating tilt as reference.

Plane Rotation

Opens a dialog where a polynomial fit can be calculated

. based on the data set. See Figure 5.2. Alternatively, if

Fit Displacement  ppysical dimensions are assigned to the phase image, a
spherical fit can be calculated.

Z Units Selects English or metric units for out-of-plane
displacement results.
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Gauges

6.2.3 Output Options

.akx_disp

Graphs & Data

Configuration
File

Legend
Common Z-Scale

Selects which gauges (numerical values quantifying
flatness) are displayed at the bottom of the graphical
display windows. A gauge on the list may be highlighted by
clicking on it once. Checking a box means that gauge will
be displayed. The up and down arrows move the
highlighted gauge up and down the list, changing the order
in which gauges are displayed. Gauges are defined in the
Optical Technigues and Analyses 101 manual. The
ROC, Bow, and Twist gauges all require physical
dimensions to be applied to the phase image. Step height
definition files (*.akx_StepDef) can also be loaded and
calculated alongside normal gauges.

Saves *.akx_disp files to disk during analysis. These files are
produced in memory during analysis anyways, so this saves
time and an extra step if the user knows that they want them
anyways. When displacement files are the input,
* mod.akx_disp files are saved to denote the modified
displacement files.

Selects which graph/data/image formats (see Sections 5.1
through 5.4) are saved during Generate Output.

Allows the user to load a non-default display format for saved
graphs. The 3D configuration file has an extension of
*.akx_3Dconfig and is used for 3D plots (3D and Contour).
See Section 5.1. The 2D configuration file has an extension
of *.akx_2Dconfig file and is used for 2D Chord plots. See
Section 5.3.

Selects if a legend is displayed on each graph.

When checked, causes all 3D or 2D plots generated by batch
analysis to use the same vertical scale. Default min and max
values are determined by the extremes in the combined data
sets, but may be edited using the text box. When unchecked,
each image is plotted on a scale set by its own data set.
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Common Z The Auto update switch chooses whether to change the

Settings... Common Z-Scale after each analysis. The Chords use overall
Min Max switch puts the same Z-Scale into the chord plots as
the 3D’s. If the user has analyzed something but changed the
default Z-Scale value based upon the current file list, the
Update button will restore the default Z-Scale.

| Comman Z Settings... 1|I'| Image Filer

Auto update

Chords use overall Min Max

Update

Figure 6.7 Common Z Settings

Output Files This section is only visible on chord plot tabs. Chord tabs
allow the user to select whether images, data, or both are
output.

Header The header for each image file can be created using tags from

the metadata stored in each input phase or displacement file.
Available tags can be found in the properties of a phase or
displacement image. Tags will reference the original file
metadata such that the entry is a variable changing on input
file. The default <SourceDataFilenameOnlyNoExt> tag puts
the file name minus its extension into the header. The user
can also enter any normal text as a constant header.

Footer Allows the user to choose the footer from the available
gauges chosen during analysis. Each gauge is input using
brackets and the name as spelled in the Analysis Options
Gauges section. For example, <Coplanarity> will add the
Coplanarity gauge to the bottom of the graph. “\t” inserts a tab
character and “\n” inserts a return character to start a new
line.

Graph Image Size Displays the image size to be output (will vary if config file is
loaded with different image size).

Image files are saved to the folder in which the original phase or displacement file is
located.
— Note: PNG files are the only option for output graphs
~ | as of Studio 8.0.

|

Options for the Surface Data, Phase Image, and 2D Disp Image can be selected by
right-clicking on the respective data type. These options are explained below.
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| Ler Fignt bages L o i e Surface Data
SufacaD= Surface Data
p——
Phase dat Ph Processed Phase il
; 20 Dig Common Z Scale...

Commc Saielmage File . Com Save Image File

Figure 6.8 Surface Data ] i . .
Options Figure 6.9 Phase Image Options Figure 6.10 2D Disp Image

Options
Surface data files can be exported as either *.dat, or *.txt, for importing into other
numerical analysis programs. Phase Image files can be saved to disk or not in either the
processed form (phase smooth is the only option that would change the phase image
look) or raw form. Lastly, 2D Disp Images can be saved to disk or not with either a
common Z-scale across all pictures or individual Z-scales on each picture.

6.3 Batch Masking

The Batch Mask feature allows the user to automate mask-burning for multiple image
files contained in a specified folder (Figure 6.11).

.
.
.

——

/2
/2
/4

Figure 6.11 Batch Burn
6.3.1 Using Batch Masking

This function uses a mask file, as described in Section 3.2. The mask file must be
created and saved prior to the batch masking operation. The batch masking screen is
shown in Figure 6.12.
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Source  Edit  Action
Analyze Mask FRotate Crop  Edit XY Orientation Convert

Mask To Apply

|C M\Users reumy AKROMETRIX\Desktop \BP - Copy’ 1 akx_mask

Layout Behavior
(@) Scale layout to input file

(O) Preserve layout designed for 197x 199

Destination Options

(O Overwrite Files
(® Create New Files

MNaming Options

Destination

|Same As Source

[] Tagfiles as = (Masked).alx_phase

[ save In "Masked" sub-Folder

Figure 6.12 Batch Masking Screen

The key steps in using batch masking are:

N

Source = Select...

Source = Recent
Edit - File Type

Edit = Include
Subfolders

Edit = Refresh
Source Folder (F5)

Action = Mask
6.3.3 Loading a Mask File

Mask to Apply

Select a folder containing data files to be masked (Folder->Select... menu item)
Select a mask (see Section 3.2 to create and save masks) to be applied.

Select the Layout Behavior

Select destination options (Section 6.3.4)

Create and save results (Action->Mask menu item)

Source, Edit, and Action Menus

Identifies the folder of *.akx_phase or *.akx_disp files on
which the mask will be applied.

Shows the 4 most recent folders that were used.

Switches between masking phase images (*.akx_phase)
and displacement data (*.akx_disp).

Applies the batch processing function to subfolders
within the selected folder in addition to the original folder.

Allows the user to update the file count since the folder
was originally selected.

Performs the mask operation

Click on J button on the right to browse for a mask file.
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6.3.4 Layout Behavior

Choose whether to scale the input mask file if any difference in dimension exists or
to preserve the layout. If preserve is chosen and the array dimensions do not match, the
mask array will be anchored to the top left of each image and any mask regions which lie
outside the image dimensions will be truncated.

6.3.5 Destination and New Naming Options

Overwrite Files Causes masked files to overwrite original data files.

Create New Files Saves masked images to a new destination and/or with a
new name. The original data files are unchanged.

Destination Selects the folder to which the masked images will be

saved. Click on the | button to the right to browse for
the destination folder.

Tag files as Appends the string “(Masked)” to the end of the original

*(Masked).akx_phase filename for the masked file.

(disp)

Save In “Masked” A single new folder named “Masked” will be created in the

sub-Folder destination folder and all masked files will be saved in this
subfolder.

6.4 Batch Rotation
6.4.1 Using Batch Rotation

Phase image rotation is described in Section 3.7 and also applies to displacement
files. This batch function rotates all the images in the selected folder according to the
options set in the batch rotation tab window. The batch rotation screen is shown in Figure
6.13.
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Source  Edit  Action
Analyze Mask PFotate Crop  Edit XY Orentation

Angle (@) Clockwise
1.0 > () CourterClockwise
Destination Options

() Owerwrite Files
(®) Create New Files

MNaming Options

Destination

Convert

|Same As Source

[] Tagfiles as * (Rotated).akee_phase

] Sawe In "Rotated" sub-Folder

Figure 6.13 Batch Rotation Screen

The key steps in using batch rotation are:

1. Select a folder containing images to be rotated (Folder->Select... menu item)

2. Select rotation options (see Section 6.4.2)

3. Select destination options (see Section 6.4.3)

4. Create and save results (Action=>Rotate menu item)

The Source, Edit, and Action menus for Rotation are all virtually identical to the Mask

operation.
6.4.2 Rotation Options

Angle Enter number of degrees to rotate the image clockwise or
counterclockwise.

6.4.3 Destination and New Naming Options

Overwrite Files
Create New Files

Destination

Tag files as
*(Rotated).akx_phase

(disp)

Causes rotated data to overwrite original data files.

Saves rotated data to a new destination and/or with a new
name. The original data files are unchanged.

Selects the folder to which the rotated data will be saved.

Click on the J button to the right to browse for the
destination folder.

Appends the string “(Rotated)” to the end of the original
filename for the rotated file.
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Save In “Rotated” A single new folder named “Rotated” will be created in the
sub-Folder destination folder and all rotated files will be saved in this
subfolder.

6.5 Batch Cropping

Batch cropping allows the user to extract multiple regions of interest from multiple
phase or displacement images. For example, a measurement test which produces
measurement data at three temperature points, with each phase or displacement image
containing four regions of interest (3 x 4 = 12 measurements), can be easily analyzed in
a two-step procedure: batch cropping, followed by batch analysis (Figure 6.14).

iu:!ﬂ \:\C‘ i:\-.

La-.., N-_--..: N-._-...,

Batch * Crop
Rk E k I
“ % € % € %

Batch ¢ Process
& A G P
e e e e <

Figure 6.14 Batch Cropping and Analysis

6.5.1 Using Batch Cropping

Batch cropping requires that the user has created a partition file as described in
Section 3.5. This must be created and saved prior to the batch cropping operation. The
partition may contain only one domain, in which it becomes equivalent to the crop function
(Section 3.3). Each domain from all the phase or displacement images in the selected
folder are permanently saved as new, independent files, organized according to the
Destination Options on the batch crop tab. The resulting image files can then be batch
processed in a second step to complete the analysis. The batch cropping screen is shown
in Figure 6.15.
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Source  Edit  Action
Analyze Mask FRotate Crop  Edit XY Orientation Convert

Partition To Apply

(Partition Description)

Layout Behavior

(® Scale layout to input file

Destination Options
() Overwrite Files

(@) Create New Files

New File Options

Destination
|San'|e As Source

[] Save In Source Filename sub-Folderis) (O Prepend ROI To Source Filename
[ Save In ROl sub-Falder(s) (®) Append ROl Name To Source Filename

[ save In "Cropped"” sub-Folder
(D) Use ROl Name

Figure 6.15 Batch Cropping Screen
The key steps in using batch cropping are:
1. Select a folder containing images to be cropped (Folder->Select... menu item)
2. Select a partition (see Section 3.5 to create and save partitions) to be applied
3. Select destination options (Section 6.5.3)
4. Create and save results (Action>Crop menu item)

The Source, Edit, and Action menus for Crop are all virtually identical to the Mask
operation.

6.5.2 Source Directory

Partition to Apply  cjick on the _-_| button to browse for a partition file. A
preview of the partition file will show on the right

6.5.3 Layout Behavior

Choose whether to scale the input partition file if any difference in dimension exists
or to preserve the layout. If preserve is chosen and the array dimensions do not match,
the partition array will be anchored to the top left of each image and any regions which lie
outside the image dimensions will be truncated.

6.5.4 Destination and New File Options

Overwrite Files Causes cropped files to overwrite original data files. This
should only be used if the partition contains only one
domain.
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Create New Files

Destination

Save In Source
Filename sub-
Folder(s)

Save In ROl sub-
Folder(s)

Save In “Cropped”
sub-Folder

Prepend ROI To
Source Filename

Append ROl Name
to Source Filename

Use Source
Filename

Use ROI Name

Saves cropped data to a new destination and/or with a new
name. The original data files are unchanged.

Selects the folder to which the cropped data will be saved.

Click on the J button to the right to browse for a
destination folder.

A new folder will be created for each file in the source folder
and all cropped images derived from each file will be
collected in this subfolder.

A new folder will be created for each ROI in the partition
and all cropped data derived from this ROI for all files will
be collected in this subfolder.

A single new folder named “Cropped” will be created in the
destination folder and all cropped files will be collected in
this subfolder.

Cropped data will be uniquely named with a combination of
ROI name and original data file name, the ROI name
coming first.

Cropped data will be uniquely named with a combination of
ROI name and original data file name, the data file name
coming first.

Cropped data will be named with the original filename. This
option is disabled if the destination folder is the same as
the source folder. In addition, this should only be used if the
partition contains only one domain.

Cropped data will be named with the ROl name from the
partition file. This can create a problem if there are multiple
files in the source folder.

6.6 Batch Edit XY Orientation

For purposes of orienting and registering surface data in Interface Analysis, a new
tab has been added to the Batch Processing window. This tab allows multiple data files
to be tagged with Pin 1 location and Measured Side information.

Source  Edit  Action
Aralyze Mask PRotate Crop  Edit XY Orentation  Convert
PFin 1 Location Measured Side
|Unspecified e |Unspecified e

Figure 6.16 Edit XY Orientation Screen
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The key steps in using Edit XY Orientation are:

1. Select a folder containing data to be edited (Folder->Select... menu item)
2. Select a Pin 1 Location and Measured Side to be applied.

3. Perform the Batch Edit operation (Action->Edit XY Orientation menu item)

6.7 Batch Convert

Converts *.akx_disp files containing phase data back to the *.akx_phase format. The
key steps in using batch converting are:

1. Select a folder containing displacement files to be converted (Folder->Select...
menu item)

2. Perform the Batch Convert operation (Action->Convert menu item)
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7 Batch Reporting

As of Studio 8.0, Surface Analysis now incorporates the ability to batch create reports
based on the metadata from each displacement file being analyzed. The Create Report
window has three subsections: Groups, Roi Selector, and Layout Settings.

7.1 Grouping by Metadata fields

Grouping can either happen before or after analysis. For purposes of analysis,
multiple folders can be selected. See Section 6.2.1 for details on how to add folders. The
context menus are identical in the Group interface Folder List section as they are to the
folder selection interface in Batch Analysis.

'y

Note: If the Create Report function was opened from
Batch Processing, the Folder List context menus will
initially be the same as if there was no data loaded,
despite the analyzed data being present. New folders
can still be added and removed, but the analyzed data
cannot be removed or made inactive from the folder
list.

Group = %

Files
File Type: akx_phase [ Filename Fitter

Folder List

Active  Subfolders Files Folder Name &

Grouping Parameters

[ Max Allowable dTs (C) [ Mase Number OF Profiles [] Max Alowable dLoe X [ Max Alowable dSize Width [ Group By Common Metadata
Equipment Model
[ Max Allowable dTa (C) [ Max Number OF Roi Names [ Max Allowable dLoc ¥ [ Max Allowable dSize Height =

Equipment S/N
[] Max Allowable dt 5} [] Group Commen Acquisttions Time-Based Acquistion Matching

Lot Id
Operator Id
Froduct Id hd

Group Results

Active Group Files Equipment SM Version Acq Dates Roi Names Roi Locations Ruoi Sizes Profiles Profile Acgs Max dTs (C) Max dTa (C) Macdt (s) |~

Figure 7.1 Grouping Window
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7.1.1 Files

Once the appropriate folders have been added to the Folder List, files can be filtered
out inclusively by entering in strings that the user desires. The “*” character can be added
before, after, or in the middle of a string to denote parts of the filename that aren’t
important to match.

Examples: *PT will find all files that end in the string “PT”

a*b will find all files that begin with the string “a” and end in “b”

Once the appropriate files are loaded into the folder list, the files must be indexed by
clicking Build Database. After a database has been built, the files will be grouped together
by acquisition index. If the user wishes to break the files into different groups for reporting
purposes, one or more of the Grouping Parameters must be selected.

7.1.2 Grouping Parameters

1. Max Allowable dTs (C): Sets the max allowable difference for setpoint temperature.
This will allow setpoint temperatures that are off by a user specified amount to be
grouped together despite the difference. Common acquisition indices are
compared and the greatest differential is referenced for grouping.

2. Max Allowable dTa (C): Sets the max allowable difference for acquisition
temperature. This will allow acquisition temperatures that are off by a user
specified amount to be grouped together despite the difference. Common
acquisition indices are compared and the greatest differential is referenced for

grouping.
3. Max Allowable dt (s): Sets the max allowable difference in acquisition time. This
will allow acquisition times that are off by a user specified amount to be grouped

together despite the difference. Common acquisition indices are compared and the
greatest differential is referenced for grouping.

4. Max Number Of Profiles: Sets the max number of profiles in a group.
5. Max Number Of Roi Names: Sets the max number of ROl names in a group.

6. Group Common Acquisitions: If multiple profiles are being reported on and the
acquisition indexes aren’t all coincident this option will filter out orphaned
acquisitions. In Figure 7.2, the profiles being reported on have varying numbers
of acquisitions and in Profile 2, the first acquisition has been removed. By checking
this option, only the acquisitions highlighted in yellow will be added to the report.

Acquisition Index
Profilel 1 2 3 4 5

Profile 2[00 2 3
Profile3 1 2 3
Figure 7.2 Group Common Acquisitions Example

7. Max Allowable dLoc X: Sets the max difference in X axis location of the region of
interest.
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8. Max Allowable dLoc Y: Sets the max difference in Y axis location of the region of
interest.

9. Max Allowable dSize Width: Sets the max size difference along the X axis of the
region of interest.

10. Max Allowable dSize Height: Sets the max size difference along the Y axis of the
region of interest.

11. Group by Common Metadata: Allows grouping of data by other common metadata
fields including Equipment Model, S/N, Lot Id, Operator Id, etc.

&

Note: When in doubt about a grouping parameter’s
effect on the output groups, it can be quite useful to
simply trial and error the setting in question to see the
effect on the data.

7.1.3 Group Results

Once the files are indexed, all groups are shown in the Group Results section (Figure
7.3). This section lists pertinent information about each group, such as number of files,
number of ROl names and locations, and number of temperature profiles. Individual
groups can be activated or deactivated in this section, making it trivial to choose which
ROls go in the final report.

&

il

Note: An asterisk next to the number of files indicates
that some files were excluded.

il

Group Results

Active Group Files (14) Equipment SM Version Acq Dates Roi Names Roi Locations Roi Sizes Profiles Profile Acas Max dTs (C) Max dTa iC) Max dt (s)
1 14 S/NOOOT DFP e DE/03/16 ROI 316,581 478x 478 |1 7 n/a n/a n/a
Renarne ROIs...

Figure 7.3 Group Results

Right-clicking on any loaded group allows the user to Rename ROlIs to better organize
and label the report (Figure 7.3).

Rename Rois =] X

#  Profle  Fiename Cument Roi Name Farttion Full Path Converter New Foi Name
ﬂ—_w__

1 |A4_DFP_34_DD043s(38C) akor_disp ROI ProfileAcq002/ROI e

3 1 |A4_DFP_34_DDOSs(48C)akx_disp ROI Profile AcqQ03/ROI e Paste A

4 1| A4_DFP_3-4_DOD81s(58C) akor_disp RO Profile Acq004/RO| B [Metactatajlage Ry Ad

5 1 |A4_DFP_3-4_00098s(58C)alox_disp ROI Profie Acq005/ROI < Predefined * <fn: Before 1st Underscore>

5 1| Ad_DFP_3-4_00113s(78C).akor_disp ROI Profile Acq006/RO| <fn: Before 1st Underscore> <fn: After Last Underscore>

7 1 A4_DFP_3-4_DD1295(88C). akx_disp ROI Profile Acq007/RO! <fn: Before 1st Underscore> <fp: Folder Name>

3 1 |A4_DFP_34_DD1445(38C) akoc_disp ROI Profile Acq008/RO <fn: Before 1st Underscore> <pfp: Node N>

] 1| A4_DFP_34_D01556(108C) cloc_disp ROI ProfileAcq008/ROI <in; Before Tst Underscore> A

10 1 Ad_DFP_3-4_00174s(118C).akoc_disp ROI Profile Acq010/ROI <fn: Before 1st Underscore> A

1" 1 |A4_DFP_34_D01896(128C)akx_disp ROI ProfilsAsq011/ROI <n: Bafore Tst Underscore> A

12 1 |A4_DFP_34_D0204(138C)cloc_disp ROI ProfilsAcq012/ROI <’ Before Tst Underscore> A v

Cancel

Figure 7.4 Rename ROIs

In the Rename Rois window that pops up (Figure 7.4), the user can choose what
each file’s New Roi Name will be via the Converter column. The resulting ROI name,
including the current values of entered tags, will be shown in the New ROI Name column.
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By default, the <fn: Before 1st Underscore> function provided will create a New Roi
Name by parsing the input filename and using the string before the first underscore.
Usually this corresponds to the Test ID based on how Surface Measurement creates
filenames by default. In cases where this does not make sense, however, the user can
enter a static string, or any of the metadata fields surrounded by Less Than or Greater
Than signs. For instance, <Lotld> would enter the Lot Id metadata information. A list of
available Metadata tags is accessible by right-clicking on the Converter field. A few other
predefined functions are also available via this same context menu (Figure 7.4). Strings
can be copied and pasted into new rows. Also, multiple rows can be selected at once by
shift-clicking, allowing values to be pasted onto multiple rows at once.

L 4

Note: Any changes to file metadata will not be made
until the OK button is pressed. To change ROI name
based on a metadata update, it is necessary to update
the metadata first and then reopen the Rename Rois
window.

il

If multiple groups are found from the input data, it is possible to add orphaned files (a
typical example would be data taken manually after a profile is complete) to an existing
profile. In the Group Results section of Create Report, right-clicking on a group will bring
up a context menu (Figure 7.5). If multiple files are orphaned, when Add file to profile...
is selected, the user will have to choose which file to add to a profile (Figure 7.6).
Likewise, once the file to be added is selected, the profile to which they will be added
must be chosen (Figure 7.7). With the profile selected, the user can choose the Setpoint,
Temp Reading, Profile Runtime, and Acquisition Index to add to the metadata for that
file. Once the profile data for a file has been changed, it will automatically be moved to
the correct group (Figure 7.8).

Group Resulis

Active Group Files {8) Equipment SM Version Acq Dates Roi Mames Roi Locations Roi Sizes Profiles Profile Acgs Max dTs (C) Max dTz (C) Mazx dt ()
1 6 5/ND154 TherMoire AXP 8.1.10451 03/28/17 2) 2) E11:x134 1 3 n/a n/a n/a
2 2 S/ND134 Therpt 03/29/17 2) 2) 611x134  |nfa nfa n/a nfa n/a

o 0110401
Add file to profile...

Renarne ROIs...

Figure 7.5 Group Results - Context Menu for Orphaned Files

Add File To Profile = X

Select the file:

[P\ Test. Services\in I353s(2 disp
P:\Test. Services\in progress’. 1_5999s(24C) aloc_disp

Coce

Figure 7.6 Add File to Profile - File Selector
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Add File To Profile =] X
Frofle  Fles  Fist Flle Min Index Max Indexc Wissing Indices
IS R e
Add ! _9999(24C) akox_disp'to the selected profile with the following metadata:
Setpoint Temp Reading  Profile Rurtime g Index
2 = 2 s 5995 3 n 2
Carcs

Figure 7.7 Add File to Profile - Profile Selector

Group Results

Active Group Files (8) Equipmert SM Version Acg Dates Roi Names Roi Locations Roi Sizes Profiles Profile Acqs Max dTs (C) Max dTa (C) Max dt {s)
1 8 5/N0194 TherMoire AXP 8.1.70457 03/2817 @ ] 6112134 1 4 n/a n/a n/a

Figure 7.8 Group Results after Adding Files to Profile

7.2 Selecting ROI's

In the Roi Selector tab (Figure 7.9), the user can view 3D graphs of all active files,
sorted into tabs by group. This tab allows the user can see a thumbnail view of a 3D graph
for each active file, sorted into tabs by group. The user can then quickly find the minima
and maxima, both overall and in each group, and discard any bad data before generating
a report.

The user can activate or deactivate individual ROIs in each group by clicking on them.
In addition, entire rows or columns can be removed from the report entirely. These
operations are the only things in this tab that affect the resulting report — the other options
at the bottom of this window affect only the data displayed in the Roi Selector tab. These
options include changing the size of the thumbnail images and editing the units of the Z-
scale. Any changes made by the user will be applied when the Update button is pressed.
The values of the minima and maxima for each group are displayed automatically, with
the figures that have those values being highlighted in shades of purple — dark for Min,
and light for Max.

Using the common Z-Scale menu, the user can decide whether Z-scales for the 3D
graphs are shared within individual groups, within all files, or not at all. When Across
Groups is selected as the common Z-Scale, the minimum and maximum overall Z-values
will be displayed, as well as the range, and clicking on the Min and Max buttons will
change the selected group to the one with the lowest or highest Z-value, respectively.

Page 64 of 72 30-50SW-0001 Ver. 8.0



akrometrix

Surface Analysis User Manual

Groups Roi Selector | Layout Settings|
Group 1

m T2 T3
Ts=25C Ts=217C Ts=260C
Ta=24C Ta=217C Ta=260C

t=2s t=239s t=319s

o p— p—
Image Size CommonZScale [FerGoup | ZUnt [ml v

Figure 7.9 Roi Selector
7.3 Choosing Report Layout Settings

Once appropriate ROIs for the report have been organized into groups with any bad
data discarded, the user can use the Layout Settings tab to determine the formatting and
displayed data of the final report. The user also has the option to deactivate groups
without changing other settings, making it simple to create both overall reports and
individual reports for different groups. The user has a variety of options in this tab,
separated into several subsections.

7.3.1 Group and Plot Selection

The uppermost section of the Layout Settings tab offers several useful options. The
user can choose which groups to include in a report using the Active tabs. They can see
a variety of information about the group, including Z-Range, group number, number of
ROI names, and the name of the first file in the group. Mousing over some of these cells
will show a tooltip with further information, like a list of all the ROl names, and selected
Gauge Plots, for instance.

Further to the right, this section also contains a number of editable labels that can
appear in the report. These can be used to create titles for individual images, series labels
in the legends of Gauge vs temperature plots, page titles and subtitles, and footers. Any
of these options can use metadata tags like <RoiName> and <PageGraphType>. The
labels will appear only on pages with data for the selected group, and the report will
automatically separate groups into different sections.
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o Create Report

=] o =

Groups| Rei Selector Layout Settings

Roi Names

Gauge Plots ~ Gauge vs Temp Series Name

Image Ti

Header Image File

<Max>

<Min>

it (Tab)

Generate Report.

report.

il

&

n (New Line)

n/a
Min
(O UserDefined 0

[] Chords Use Overall Min Max

Figure 7.10 Layout Settings Tab

The user can also click on the Gauge Plots cell for any group in this section. This will
open the Gauge Plot Selector window shown in Figure 7.11. From this window, the user
can choose which of the calculated gauges to display in the report. Selecting an option
and moving it up and down in the list with the arrows will reorder the gauge plots in the

Active Group Z-Range Group Order  Profile  Profile Order Files (8} First File
1 0.0to 3773 1 1 1 8 _00002s(24C) akx_disp @ 143 <RoiName:> <RoiNam
< >
COutput Options Report Order Page Break Page Template
30 Graph | Diagonals [T — (4] Profile 6/Fage (Partrat)
Color Cortour = o o Type = E ggph e oace
Diagonals Corfiguration File Temperature ‘ [ Tempersturs ==
[] Horizontal Centerine Set Down
] Top Bottom Edges
2Z-Scaling XY Unit
Uit ml v s v
[] Phase Image Footer
| [T =] Common Z Scale
<Coplanarity> @® Automatic | Per Group

Note: If a desired gauge is not in this list, then it was
not calculated during analysis. In Batch Processing,
the user must select whichever gauges are desired in
the final report, so that they are present in the

*.akx_disp files that are used to build the report.

7.3.2 Output Options

This section allows the user to decide what graphs will be shown in the report, how
they are configured, and what footer information the graphs have. Editing the
configuration of graphs requires loading a previously created *.akx 2dConfig or

_D0002s(24C) akoe_disp

Roi Names

@

Gauge Plots
1/3

Gauge Plot Selector H—_ *

[ Max
[ Min
Coplanarity

1+
¥

CK

Cancel

Page Break

Profile
Roi

[ Granh Tume

Figure 7.11 Gauge Plot Selector
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*.akx_3dConfig file (depending on graph type) for each graph that is changed from its
default layout. To add footers to the graph, the user can choose from a list of tags that
changes with the selected graph. The user may also use tab (/t) and new line (/n) tags to
format the footers in the final report. Finally, the Normalize checkbox causes all 2D chord
plots to be displayed with the endpoints referenced to zero.

7.3.3 Report Order

This option determines what data ordering takes precedence within a group. The
default is Profile > ROI > Graph Type > Temperature.

7.3.4 Page Break

This determines after what data page breaks occur. The default is Profile, ROI, and
Graph Type, but not temperature. This allows the user to separate graphs by file metadata
and organize the final report.

7.3.5 Z-Scaling

This section allows the user to choose the Z-scale for displacement graphs. They can
choose the units of Z, and either enter a custom Z-scale or choose an automatic Z-scale.
The automatic options are None, Per Group, and Across Groups. The toggle “Chords Use
Overall Min Max” determines whether 2D chord plots use individual minima and maxima
in their z-scales, or the overall minima and maxima across all groups.

7.3.6 Page Template

This option determines whether data layout is portrait (6 graphs/page) or landscape
(24 graphs/page).

7.3.7 Page Fill

This option lets the user decide whether initial population of figures and graphs is top-
bottom and then left-right, or vice versa.

7.3.8 XY Unit

This lets the user determine the XY units on each graph if a lateral resolution is
specified in each file. This would allow the graph XY axes to be shown in physical units
instead of pixels.

7.3.9 Header Image File
This allows the user to choose a header image to go at the top of each page.
7.3.10 Generate Report...

Once all settings have been selected, the user can select generate report, which
brings up a dialog in which to name and save the new report in *.pdf format. An example
report is shown in Figure 7.12.
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Figure 7.12 Example Report with 6 images per page
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8 Troubleshooting

As with any measurement system software, the Surface Analysis program has its
limitations. These limitations exist mainly because the analysis software is sensitive to
patterns it was not designed to interpret, which is typical of any software using pattern
recognition.

8.1 Failure to Correctly Interpret the Phase Image

After acquiring a phase image, a procedure called “unwrapping” is applied to the
phase data (See Akrometrix Optical Technigues and Analyses 101). The unwrapping
process removes the 2w discontinuity by examining the nearest neighbors’ pixel phase
values starting at the center pixel. With the sequential dependent nature of the
unwrapping process, the height at all the pixels in an entire image can be related to one
origin pixel. Conversion from the unwrapped phase image to vertical displacement is
simply multiplication of each pixel phase value by the calibration factor.

Problems arise when an error occurs at one point in the unwrapping process, either
by incorrectly identifying a phase discontinuity or missing a discontinuity that has
occurred. Once a problem occurs, all pixels downstream of the error point are offset from
their correct value by the same increment of one full fringe cycle.

8.1.1 Symptoms

Unwrapping errors are propagated downstream of the error point. These errors
appear in the 3D surface plots as ridges, troughs, or plateaus in the displacement surface.
Two examples of such cases are shown in Figure 8.1, where the error originates from a
step condition on the sample surface.

8.1.2 Cause

Unwrapping errors can occur at steps (i.e. vertical discontinuities in the sample
surface). A step may be defined as a region where fringes are so closely spaced that they
cannot be resolved by the video camera due to a rapid height change on the sample
surface. Typically, fringes less than 5 pixels in width cannot be resolved. The Surface
Analysis program is unable to determine the height at a step larger than approximately
half a fringe height since the relative order of the fringes on the two surfaces cannot be
determined. Unwrapping errors can also occur in regions where there is poor fringe
information or at the transition from such regions to regions of good phase information;
including holes, shadows, pieces of tape, etc.

8.1.3 Solutions

1. The simplest solution is to exclude error-causing features from the ROI. Adjust the
position and size of the ROI to exclude these features.

2. Use the filtering option to help eliminate some unwrapping errors. Filtering
smoothes the phase image before unwrapping. Because filtering can smear out
fine detail in the displacement surface, it should be applied to the analysis only to
the extent necessary to eliminate extended phase unwrapping defects.
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3. Apply a mask to the data analysis and eliminate unwrapping errors by excluding
problematic areas from being analyzed. Follow the directions given in Section 3.2.

Figure 8.1 Surface Plots with Unwrapping Errors

Page 70 of 72 30-50SW-0001 Ver. 8.0



< akrometrix

Surface Analysis User Manual

Appendix A Miscellaneous Information

A.1 File Formats

Akrometrix Surface Analysis loads and saves data with the *.akx_* extension. For a
more detailed breakdown of Surface Analysis specific formats please see the table
below. Image export formats are exclusively *.png with varying filename postfixes to
further denote their origins.

Extension Contents

*.akx_phase A single phase image with associated metadata. May optionally contain cropped
versions of supporting data: intensity, and/or reference displacement

*.akx_disp A single displacement data matrix with associated metadata. May optionally
contain cropped versions of supporting data: phase, intensity, and/or reference
displacement

*.akx_partition Partition file (standard XML format)
*.akx_3Dconfig Configuration file for 3D plot

*.akx_2Dconfig Configuration file for 2D plot

*.akx_chordset Chord set (standard XML format)

*.akx_recipe Stores batch processing settings for recall later.

A.1.1 Metadata Fields

Metadata fields embedded in *.akx_phase or *.akx_disp objects can be used in
building filenames, output paths, and report labels in various places in Akrometrix Studio
applications. Some of the more commonly used metadata fields are described below.

<RoiName> User defined when adding ROIs to the Camera Window in Surface
Measurement. Also defined when partitioning in Surface Analysis.

<Lotld> User defined in the Metadata settings dialog in Surface Measurement or
Thermal Profiler

<Testld> User defined in the Metadata settings dialog in Surface Measurement or
Thermal Profiler

<Operatorld> User defined in the Metadata settings dialog in Surface Measurement or
Thermal Profiler

<Productld> User defined in the Metadata settings dialog in Surface Measurement or
Thermal Profiler

<TemperatureNominal> User defined when creating a profile in Profiler Generator

<TemperatureReading> Any thermocouple data for the acquisition (can include up to 16

temperatures in the case of a CRE measurement). With no suffix, this
metadata tag will provide TC1 data, but a two digit numerical suffix, such
as “02” will provide the data for the corresponding thermocouple.

<TemperatureSetpoint> User defined when creating a profile in Profile Generator

<ProfileSecondsAndTemp> | Time/temperature when a phase/disp file was acquired.
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Other metadata fields such as Pin 1 Location, Equipment Model, etc. are available in
the Properties window of any phase or displacement image (Figure 2.4). Any entry in this
list can be surrounded by “<” “>” symbols to indicate to the application to use that
metadata field in populating the corresponding text entry area. In addition, any gauge
value can be added in the same way.

A.2 Keyboard Shortcuts

Shortcut Command Action
Main Window Shortcuts
Ctrl+O File>Open Open a new *.akx_phase or *akx_disp file
Alt+F+X File>Exit Exit the Surface Analysis program
F1 Help>User Manual Open the User Manual
Phase Window Shortcuts
Ctrl+C Copy (Mask or Partition Region) Copy Mask or Partition Region
Ctrl+V Paste (Mask or Partition Region) Paste Mask or Partition Region
1-4 Advanced->View->Intensity 1-4 Show Intensity Images 1-4
P Advanced->View->Phase Image Show Phase Image
S Advanced->View->Surface Image Show Surface Image
Ctrl+ Zoom in to phase image
Ctrl- Zoom out of phase image
Ctrl+M Advanced>Mask—->New Create a new mask
Ctrl+R Advanced->Partition>New Create a new partition
Ctrl+K Advanced->Chord->New Chord Create a new chord
Ctri+G Advanced->Chord>New Set Create a new chord set
Shift+1-9 Advanced->Chord->1-9 Show Chord Sets 1-9
Shift+T Create a chord along top edge of the image
Shift+B Create a chord along bottom edge of the image
Shift+L Create a chord along left edge of the image
Shift+R Create a chord along right edge of the image
Shift+D Create downward diagonal chord (upper left to lower right corner) on the image
Shift+U Create upward diagonal chord (lower left to upper right corner) on the image
Shift+H Create a chord along the horizontal centerline of the image
Shift+V Create a chord along the vertical centerline of the image

3D Window Shortcuts
Copies the current display window viewing angle and magnification to

CLLRS ST IES the Clipboard.
Cirl+V Paste View Applies the viewing angle and magnification saved to the C_Ilpboard to
the current display window (only appears after Copy View is used).
Batch Processing Window Shortcuts
F5 Edit>Refresh Source Allows the user to update the list of source files since the
Folder folder was originally selected
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